SQL Server 主页

 入门

SQL Server 联机丛书

Microsoft Data Access Component (MDAC) 2.6 和 Extensible Markup Language (XML) 2.6 文档

查看 MDAC 和 XML 文档，请单击此图标

技术支持

  • Microsoft 产品支持服务 (PSS)
  • Microsoft SQL Server 技术支持
  • 知识库 (KB) 搜索
  • Microsoft Technet
  • Microsoft Windows 硬件兼容列表
  • 疑难解答

Microsoft Accessibility Web 站点

SQL Server 印刷文档

白皮书

反馈

示例

Web 链接

  • Microsoft SQL Server 产品 Web 站点
  • Microsoft SQL Server 开发人员中心
  • SQL Server 专业协会
  • SQL Server 杂志
  • Microsoft 新闻组
  • MSDN Online
  • Microsoft SQL Server Web 站点，English Query 页
  • Microsoft SQL Server Web 站点，Analysis Services 页
  • XML 开发人员中心


SQL Server 联机丛书入门

使用下表快速访问 Microsoft® SQL Server™ 2000 文档。

若要了解 | 请参见
SQL Server 构架 | 关系数据库组件 数据库构架 管理构架 复制构架 应用程序开发构架 Analysis Services 构架 Meta Data Services 构架
SQL Server 2000 的新特性 | Microsoft SQL Server 2000 新特性
安装、升级和运行 SQL Server 2000 | 安装 SQL Server 2000 概述 升级到 SQL Server 2000：概述 安装 Analysis Services 安装 English Query 从早期版本升级
计划和设计新数据库 | 创建和维护数据库概述
执行管理任务 | 导入和导出数据 备份和还原数据库 自动化管理任务 安全管理 安全性和身份验证 监视服务器性能和活动 命令提示实用工具入门 管理 Analysis Services PivotTable 服务 MDX
数据仓库和联机分析处理 (OLAP) | DTS 概述 数据仓库和 OLAP 数据仓库
开发应用程序 | Transact-SQL 语法元素 ADO SQL Server 应用程序设计 OLE DB SQL Server 应用程序设计 开发 SQL-DMO 应用程序 复制程序设计入门 DTS 应用程序设计 编写扩展存储过程 用于 C 语言的嵌入式 SQL 程序设计 DB-Library for C 入门 决策支持对象 加载项 PivotTable 服务 Meta Data Services 应用程序设计
计划和设计数据多维数据集 | 多维数据集
性能 | 监视服务器性能和活动 数据库性能优化概述 分析和优化性能 优化知识库性能
疑难解答 | Transact-SQL 窍门 疑难解答概述 Analysis Services 疑难解答

提供此文档仅用于参考。Microsoft 对此文档没有任何明示或暗示保证。有关完整的版权通告，请参见该页底部的链接。有关完整的版权通告，请参见本书开始处的信息。


文档规范

下列规范用于在 SQL Server 联机丛书中区分文本元素。

规范 | 用于
大写 | Transact-SQL 关键字和 SQL 元素。
首字母大写 | 路径和文件名。
加粗 | 数据库名称、表名称、列名称、存储过程、命令提示实用工具、菜单、命令、对话框选项、程序设计元素和必须精确键入的文本。
斜体 | 用户提供的变量、关系和句式。
等宽字体 | 代码示例、示例、显示文本和错误信息。
纯英文文本 | 对在 pubs、Northwind 和 Foodmart 数据库中包含的数据的引用，或对示例中使用的其它数据的引用。

请参见

DB-Library for C 语法规则

复制语法规则

SQL-DMO 语法规则

Transact-SQL 语法规则


在 SQL Server 联机丛书中显示信息

若要在 SQL Server 联机丛书中显示信息，请使用下列文档功能：

展开文本

由加号 (+) 表示的展开文本功能，用于提供某个主题的附加信息。若要查看信息，请单击加号，会出现一个新文本窗口。若要关闭窗口，请单击减号 (-)。打印某个主题时，也会打印展开的文本。

词汇表术语

词汇表术语显示为带下划线的彩色文本。单击词汇表术语查看其定义。若要关闭定义窗口，请在屏幕的任何位置单击。在打印主题时，不会打印术语的定义。SQL Server 联机丛书中的词汇表术语不包括《Microsoft 计算机辞典第四版》中的词汇表术语。

键盘快捷键图标

键盘快捷键图标位于每个主题顶部显示的工具栏上。单击图标后会看到可用的快捷键。

"参阅"图标

"参阅"图标显示在包含相关主题的那些主题的顶部。单击图标后会看到相关主题的列表。

子集

SQL Server 联机丛书允许用户定义整个 SQL Server 联机丛书的子集并对子集执行搜索。用户可以定义自己的子集；不过还需提供一组默认的子集。子集面向特定的用户，并且每个子集涵盖多个主题。子集通过将搜索点击次数减到最少，使搜索与活动有关的信息变得更容易。

缩略图

某些图例以最小化（缩略图）视图显示。若要放大图例，请单击"放大关系图"按钮。图例会显示在右窗格中并放大为实际大小。若要返回主题，请单击工具栏上的"返回"按钮。若要打印图例，请单击包含该图例的窗口顶部的"打印"图标。当打印某个主题时，会按其实际大小打印图例。

链接到执行任务的过程

在 Microsoft® SQL Server™ 2000 中，可使用一种或更多的工具或过程来执行管理任务，不过，并非所有的工具和过程都能用于所有的任务。工具和过程由后面带有标签的加号 (+) 指定。

例如，若要启动 SQL Server 的默认实例，请单击与想要使用的工具或过程相对应的加号文本。

启动 SQL Server 的默认实例

企业管理器

服务管理器

命令提示符

SQL-DMO

下列是可用的工具和过程。

客户端实用工具 | 事件探查器
命令提示符 | 查询分析器
企业管理器 | 服务管理器
故障转移 | SQL 安装
网络实用工具 | SQL-DMO
ODBC | Transact-SQL
OLE DB | Windows
性能监视器 | 向导