选择分发服务器

分发服务器是包含分发数据库并存储元数据、历史数据和/或事务的服务器。分发服务器可以与发布服务器分开的服务器（远程分发服务器），也可以是与发布服务器相同的服务器（本地分发服务器）。分发服务器的角色因所执行的复制类型而异，一般情况下，其作为快照复制和事务复制的角色远远多于合并复制的角色。

分发服务器使用其所在服务器上的以下附加资源：

  • 用于存储发布快照文件的附加磁盘空间。

  • 用于存储分发数据库的附加磁盘空间。

  • 由在分发服务器上运行的复制代理程序使用的附加处理器时间。（如有必要可使用远程代理程序激活，以卸载代理程序的处理负荷。）

选作分发服务器的服务器应有足够的磁盘空间和处理器速度，以支持基于该服务器的复制和任何其它活动。

选择"使服务器成为自己的分发服务器；SQL Server 将创建分发数据库和日志"使本地服务器成为分发服务器。选择"使用下列服务器（选定的服务器必须已配置为分发服务器）"然后单击服务器名，使远程服务器成为分发服务器。

若要将远程服务器用作分发服务器，应确保远程服务器已配置为分发服务器，并且本地服务器已在该分发服务器上启用为发布服务器。如果要用作分发服务器的服务器没有列出，单击"添加服务器"在 SQL Server 企业管理器中注册它，并将其添加到可用分发服务器列表。

请参见

发布服务器、分发服务器和订阅服务器

远程代理程序激活


指定管理密码

在将该发布服务器连接到分发服务器时，分发服务器要求使用密码。此处输入的密码必须与在分发服务器上设置的管理链接密码相同。

可在"发布服务器和分发服务器的属性"对话框的"分发服务器"选项卡中更改密码。

请参见

连接到分发服务器

复制属性


指定快照文件夹

"指定快照文件夹"对话框出现在配置发布和分发向导以及创建发布向导中。

当在配置发布和分发向导中指定快照文件夹时，指定的路径将用作默认的快照文件夹，以便在该向导中启用所有发布服务器（默认快照文件夹不应用到以后使用发布服务器和分发服务器属性启用的发布服务器中）。

当在创建发布向导中指定快照文件夹时，指定的路径将用作正在其上创建发布的发布服务器的快照文件夹。

如果在分发服务器上使用的文件夹位置要求登录有管理特权（例如，文件夹位于 C$ 上），则在其它计算机上运行的代理程序（如用于请求订阅的代理程序）可能不能访问共享。在执行复制之前，测试复制代理程序能否通过在代理程序要使用的安全帐户下登录的方式连接到快照文件夹，然后尝试访问快照文件夹。

输入路径或使用浏览按钮（"..."）指定要存储快照文件的位置。

请参见

备用快照位置

应用初始快照


提供分发数据库信息

键入分发数据库的名称。名称最多可以有 128 个字符，但不能包含 ~'!%@^&*()+-={}[]|\:;"<>,.?/。分发数据库的默认名称为"分发"。

使用配置发布和分发向导只能指定一个分发数据库。不过，在完成该向导后，可在"发布服务器和分发服务器的属性"对话框中指定附加的分发数据库。

输入分发数据库文件和分发数据库日志文件的路径和文件夹。路径必须指向分发服务器的本地磁盘，并以本地驱动器号和冒号（如 C：）开头。映射驱动器号和网络路径无效。

通过将分发日志与分发数据库放在不同的磁盘驱动器上，可减少写入事务的时间并提高复制的性能。

请参见

发布服务器、分发服务器和订阅服务器

复制属性

复制类型


启用发布服务器

可授予其它发布服务器使用分发服务器的权限。选择允许其使用该分发服务器的已注册服务器。单击发布服务器旁的属性按钮（"..."）以设置安全选项、登录信息和快照文件夹。

选作发布服务器的服务器将使用该向导创建的分发数据库。若要使用不同于向导所创建的分发数据库，则不要在此时启用发布服务器。而是在完成配置发布和分发向导后，使用"发布服务器和分发服务器的属性"对话框添加发布服务器。

如果分发服务器运行的是 Microsoft® Windows NT® 4.0 或 Microsoft Windows® 2000，并且要启用发布服务器未列出的服务器，则单击"新建"按钮在 SQL Server 企业管理器中注册该服务器，并将其添加到可用发布服务器列表。运行 Microsoft Windows 95 或 Windows 98 的分发服务器不能作为其它发布服务器的分发服务器。

使发布服务器能够将该服务器作为它的分发服务器，并不能使该服务器成为发布服务器。必须连接到发布服务器，配置其用于发布并选择该服务器作为分发服务器。

请参见

发布服务器、分发服务器和订阅服务器

复制属性


启用发布数据库

选择为发布快照、事务发布和/或合并发布而启用的数据库。

必须是 sysadmin 固定服务器角色成员才能启用发布数据库。启用数据库后，数据库所有者可基于该数据库创建发布。而系统管理员可在不事先启用发布数据库的情况下创建发布。

若要基于数据库创建快照或事务发布，需启用事务复制数据库。快照复制是完全按照数据和数据库对象出现时的状态对其进行复制和分发的过程。快照复制不需要对更改进行连续的监视，因为对已发布数据所做的更改不会增量传播到订阅服务器。

事务复制将数据的初始快照传播到订阅服务器，然后，当发布服务器上发生数据修改时，捕获个别的事务并传播到订阅服务器。

若要创建合并发布，需启用合并复制数据库。合并复制使各站点得以独立工作（联机或脱机），并且过一段时间后将多个站点上的更新合并为一个统一的结果。首先在订阅服务器上应用初始快照，然后 SQL Server 2000 在发布服务器和订阅服务器上跟踪已发布数据的更改。数据在调度时间或需要时在服务器之间进行同步。由于多个服务器上的更新相互独立（不提交协议），同一数据可能由发布服务器或多个订阅服务器更新。于是，合并更新时就可能出现冲突。

请参见

发布服务器、分发服务器和订阅服务器

复制类型


启用订阅服务器

选择可从该发布服务器接收发布的订阅服务器。在该向导中只能启用运行 Microsoft® SQL Server™ 的订阅服务器。单击订阅服务器名称旁的属性按钮（"..."）设置安全选项和默认代理程序调度。

完成"配置发布和分发向导"后，可在"发布服务器和分发服务器的属性"对话框中配置异类订阅服务器。

如果要启用不是作为订阅服务器列出的服务器，则单击"新建"按钮在 SQL Server 企业管理器中注册该服务器，并将其添加到已注册服务器列表。

请参见

发布服务器、分发服务器和订阅服务器

复制属性


发布服务器和分发服务器的属性，分发服务器选项卡（本地分发服务器）

当使用本地分发服务器时，"发布服务器和分发服务器的属性"对话框的"分发服务器"选项卡中有下列可用选项。

选项

名称

查看分发服务器的名称。

数据库

查看分发数据库的名称。

属性

显示选定分发数据库的属性。

新建

添加新的分发数据库。

删除

删除选定的分发数据库。

代理程序配置

显示每种代理程序的配置。

管理链接密码

输入当发布服务器连接到分发服务器时所使用的密码。可将某些发布服务器指定为可信；可信发布服务器连接到分发服务器时不需要密码。如果发布服务器是不可信的，则当配置发布服务器时也必须输入在这里输入的密码。

确认密码

再次输入密码以确认拼写。

请参见

连接到分发服务器

发布服务器、分发服务器和订阅服务器

复制属性


发布服务器和分发服务器的属性，分发服务器选项卡（远程分发服务器）

当使用远程分发服务器时，"发布服务器和分发服务器的属性"对话框的"分发服务器"选项卡中有下列可用选项。

选项

用于发布服务器的分发服务器

查看发布服务器的名称。

分发服务器名称

查看分发数据库所在服务器的名称。

分发数据库

查看分发数据库的名称。

管理链接密码

输入该发布服务器连接到分发服务器时所使用的密码。如果分发服务器已将该发布服务器标识为可信，则对话框中不显示该控件。

确认密码

再次输入密码以确认拼写。如果分发服务器已将该发布服务器标识为可信，则对话框中不显示该控件。

请参见

连接到分发服务器

发布服务器、分发服务器和订阅服务器

复制属性


发布服务器和分发服务器的属性，发布服务器选项卡

"发布服务器和分发服务器的属性"对话框的"发布服务器"选项卡中有下列可用选项。

选项

发布服务器

从已注册服务器的列表中选择要启用的发布服务器。如果 Microsoft® SQL Server™ 2000 个人版正在分发服务器上运行，则只有本地服务器列为可用的发布服务器，并且不管该发布服务器是否被信任。

分发数据库

查看分发数据库的名称。

(...)

显示和修改发布服务器的属性，包括使用的分发数据库、快照文件夹的位置以及复制代理程序连接到发布服务器时所使用的安全连接。

全部启用

使所有列出的发布服务器都能使用该分发服务器。如果已安装了个人版，则不显示该控件。

都不启用

清除所有列出的发布服务器，以禁止其使用分发服务器。如果分发服务器运行的是 SQL Server 2000 个人版，则不显示该控件。

新建

注册没有出现在列表中的服务器。在 SQL Server 企业管理器中注册服务器后，该服务器将作为可用发布服务器出现并可被启用。如果分发服务器运行的是 SQL Server 2000 个人版，则不显示该控件。

请参见

连接到分发服务器

发布服务器、分发服务器和订阅服务器

复制属性


发布服务器和分发服务器的属性，发布数据库选项卡

"发布服务器和分发服务器的属性"对话框的"发布数据库"选项卡中有下列可用选项。

选项

事务

启用用于快照复制或事务复制的数据库。

合并

启用合并复制数据库。

数据库名称

查看数据库的名称。

事务 - 全部启用

启用所有列出的用于快照复制或事务复制的数据库。

事务 - 都不启用

清除所有列出的用于快照复制或事务复制的数据库。

合并 - 全部启用

使所有列出的数据库都能用于合并复制。

合并 - 都不启用

使所有列出的数据库都不能用于合并复制。

双击某个数据库名称将使该数据库可以或不能用于所有类型的复制。

请参见

连接到分发服务器

发布服务器、分发服务器和订阅服务器

复制属性


发布服务器和分发服务器的属性，订阅服务器选项卡

"发布服务器和分发服务器的属性"对话框的"订阅服务器"选项卡中有下列可用选项。

选项

订阅服务器

选择要启用的订阅服务器。然后可为该订阅服务器创建对来自该发布服务器的发布的订阅。

(...)

显示选定订阅服务器的属性，包括复制代理程序连接到订阅服务器和设置分发代理程序或合并代理程序的默认调度时所使用的安全设置。

全部启用

使所有列出的服务器都能接收来自发布服务器的数据。

都不启用

清除所有列出的订阅服务器，以禁止其接收来自该发布服务器的数据。

新建

注册新的订阅服务器，该服务器可以是 SQL Server 安装、Microsoft® Jet 4.0 数据库安装 (Microsoft Access)、Microsoft Exchange 服务器安装（如果该计算机上安装了 Microsoft Exchange 2000）、ODBC 数据源或 OLE DB 数据源。如果新订阅服务器是 SQL Server 安装，则服务器将在 SQL Server 企业管理器中注册。

请参见

发布服务器、分发服务器和订阅服务器

复制属性

订阅发布


分发数据库属性，数据库选项卡（现有数据库）

当查看现有分发数据库属性时，"分发数据库属性"对话框的"数据库"选项卡中有下列可用选项。

选项

数据库名称

查看分发数据库的名称。

下列发布服务器使用该数据库

查看当前使用该分发数据库的发布服务器列表。

事务保持

通过最小化日志历史记录和事务保持所耗费的时间以减少分发服务器上使用的磁盘空间。

存储事务的最短时间

设置事务记录存储在分发数据库中的最短时间。如果时间单位是小时，最小值和最大值分别是 0 和 32767。如果时间单位是天，则最小值和最大值分别是 0 和 1365。存储记录时最小值必须小于最大值。

但不超过

设置事务记录存储在分发数据库中的最长时间。如果时间单位是小时，则最小值和最大值分别是 0 和 32767。如果时间单位是天，则最小值和最大值分别是 0 和 1365。最大值不能小于或等于最小值。

小时

使用小时作为存储事务记录的时间单位。

天

使用天作为存储事务记录的时间单位。

历史记录保持

可通过最小化日志历史和事务保持时间减少分发服务器上使用的磁盘空间。

至少存储复制性能的历史记录

设置复制性能历史记录存储在分发数据库中的最短时间。如果时间单位是小时，最小值和最大值分别是 0 和 32767。如果时间单位是天，则最小值和最大值分别是 0 和 1365。存储性能历史记录时最小值必须小于最大值。

小时

使用小时作为存储复制性能历史记录的时间单位。

天

使用天作为存储复制性能历史记录的时间单位。

请参见

发布服务器、分发服务器和订阅服务器

复制属性

事务复制


分发数据库属性，数据库选项卡（创建新数据库）

当创建新分发数据库时，"分发数据库属性"对话框的"数据库"选项卡中有下列可用选项。

选项

数据库名称

指定新分发数据库的名称。

数据库文件的文件夹

输入分发数据库文件的路径。

(...)

浏览用于存储分发数据库的文件夹。

日志文件的文件夹

输入分发数据库日志文件的路径。

(...)

浏览用于存储分发数据库日志文件的文件夹。

事务保持

通过最小化日志历史记录和事务保持所耗费的间以减少分发服务器上使用的磁盘空间。

存储事务的最短时间

设置事务存储在分发数据库中的最短时间。如果时间单位是小时，最小值和最大值分别是 0 和 32767。如果时间单位是天，则最小值和最大值分别是 0 和 1365。存储记录时最小值必须小于最大值。

但不超过

设置事务存储在分发数据库中的最长时间。如果时间单位是小时，则最小值和最大值分别是 0 和 32767。如果时间单位是天，则最小值和最大值分别是 0 和 1365。最大值不能小于或等于最小值。

小时

使用小时作为存储事务记录的时间单位。

天

使用天作为存储事务记录的时间单位。

历史记录保持

通过最小化日志历史记录和事务保持所耗费的时间以减少分发服务器上使用的磁盘空间。

至少存储复制性能的历史记录

设置复制性能历史记录存储在分发数据库中的最短时间。如果时间单位是小时，最小值和最大值分别是 0 和 32767。如果时间单位是天，则最小值和最大值分别是 0 和 1365。存储性能历史记录时最小值必须小于最大值。

小时

使用小时作为存储复制性能历史记录的时间单位。

天

使用天作为存储复制性能历史记录的时间单位。

请参见

发布服务器、分发服务器和订阅服务器

复制属性

事务复制


发布服务器属性，常规选项卡

对于运行 SQL Server 的发布服务器，"发布服务器属性"对话框的"常规"选项卡中有下列可用选项。

选项

发布服务器

查看发布服务器的名称。

分发数据库

如果正在启用新发布并且分发服务器有多个分发数据库，请选择发布服务器所使用的分发数据库。对于当前启用的发布服务器，请查看该发布服务器所使用的分发数据库。

快照文件夹

输入用于存储来自发布服务器的发布快照的文件夹的路径和名称。

模拟发布服务器上的 SQL Server 代理程序帐户（信任连接）

使用发布服务器上的 SQL Server 代理程序所使用的同一 Windows 身份验证帐户。

使用 SQL Server 身份验证

对指定的登录和密码使用 SQL Server 身份验证。

登录名

输入帐户的登录名。

密码

输入帐户的密码。

确认密码

再次输入帐户密码以确认。

到分发服务器的管理链接

选择"该发布服务器要求输入密码以建立到分发服务器的链接"，可将发布服务器标记为不受分发服务器信任。连接到分发服务器时需要密码，可在"发布服务器和分发服务器的属性"对话框的"分发服务器"选项卡中指定该密码。

只有在不同的服务器上配置发布服务器和分发服务器时才出现该选项。

请参见

发布服务器、分发服务器和订阅服务器

复制属性


发布服务器属性，常规选项卡（异类发布服务器）

对于异类发布服务器，"发布服务器属性"对话框的"常规"选项卡中有下列可用选项。

选项

异类发布服务器

查看异类发布服务器的名称。

分发数据库

查看发布服务器所使用的分发数据库。

快照文件夹

查看用于存储来自发布服务器的发布快照的文件夹的路径和名称。

订阅服务器

选择可接收该发布服务器发布的数据的订阅服务器。

全部启用

使所有列出的订阅服务器都能接收来自该发布服务器的数据。

都不启用

清除所有列出的订阅服务器，以禁止其接收来自该发布服务器的数据。

新订阅服务器

注册新的订阅服务器，该服务器可以是 Microsoft® SQL Server™ 安装、Microsoft Access 安装（Microsoft Jet 4.0 数据库）、ODBC 数据源或 OLE DB 数据源。

请参见

异类发布服务器

发布服务器、分发服务器和订阅服务器

复制属性


订阅服务器属性，常规选项卡

"订阅服务器 属性"对话框的"常规"选项卡中有下列可用选项。

选项

订阅服务器

查看订阅服务器的名称。

类型

查看订阅服务器的类型（SQL Server、Microsoft® Jet 4.0 数据库、Microsoft Exchange 服务器、ODBC 或 OLE DB）。

描述

输入或修改对订阅服务器的描述。

模拟发布服务器上的 SQL Server 代理程序帐户（信任连接）

使用分发服务器上的 SQL Server 代理程序所使用的同一 Windows 身份验证帐户。

使用该帐户的 SQL Server 身份验证

对指定的登录和密码使用 SQL Server 身份验证。

登录名

输入 SQL Server 帐户的登录名。

密码

输入 SQL Server 帐户的密码。

确认密码

再次输入帐户密码以确认。

请参见

发布服务器、分发服务器和订阅服务器

复制属性

订阅发布


订阅服务器属性，调度选项卡

"订阅服务器属性"对话框的"调度"选项卡中有下列可用选项。这些选项可由分发代理程序和合并代理程序使用。

选项

连续地运行

设置在创建新代理程序时，为使该代理程序一直运行而使用的默认调度。

在下列已调度时间运行

设置在创建新代理程序时，为使该代理程序按指定的调度运行而使用的默认调度。

更改

设置代理程序的作业调度。

请参见

发布服务器、分发服务器和订阅服务器

复制属性

订阅发布


创建发布向导，欢迎

创建发布向导的"欢迎"页包括对创建发布向导的描述，以及一个可在向导中选择高级选项的选项。

若已启用"显示本向导中的高级选项"并创建快照或事务发布，则可启用发布执行下列操作：

  • 启用即时更新和/或排队更新的可更新订阅选项。

  • 使用数据转换服务 (DTS) 在发布时转换数据。

当创建合并发布时，将看到所有可用选项无论是否启用了"显示本向导中的高级选项"复选框。

可更新的订阅

一般情况下，复制数据是只读的。然而在 Microsoft® SQL Server™ 2000 中，能够通过在快照复制或事务复制中使用可更新订阅，或通过使用合并复制，修改订阅服务器上的复制数据。若需要使用快照复制或事务复制修改订阅服务器的数据，可选择即时更新、排队更新或以排队更新作为故障转移的即时更新。

转换已发布的数据

转换订阅（可用于快照复制或事务复制）可调节数据转换服务 (DTS) 的数据移动、转换映射和筛选功能。通过在复制拓扑中使用转换订阅，可以基于个别订阅服务器的要求自定义和发送发布的数据。

如何使用转换订阅的示例包括：

  • 基于每个订阅服务器创建发布数据的列和水平分区（自定义数据分区）。

  • 创建数据转换如数据类型映射（例如整数到 real 数据类型）、列操作（例如串联名字列和姓氏列）、字符串操作和函数使用。

请参见

发布数据和数据库对象

复制向导

转换已发布的数据

可更新订阅


选择发布数据库

选择包含要发布的数据和数据库对象的数据库名称。

发布数据库是发布服务器上的数据库，它是要复制的数据和数据库对象的源。sysadmin 服务器角色的成员必须将复制中要用到的每个数据库都启用为发布数据库，方法是：通过使用 sp_replicationdboption 系统存储过程配置发布和分发向导的发布服务器和分发服务器的属性或使用创建发布向导在那个数据库上创建发布。

请参见

发布服务器、分发服务器和订阅服务器

发布数据和数据库对象


选择发布类型

Microsoft® SQL Server™ 2000 提供下列类型的发布：快照、事务和合并。根据所使用的应用程序以及事务和站点独立的不同 ACID 属性（原子性、一致性、隔离性和持久性）级别，每种类型可提供不同的功能。

例如，合并复制使得用户可以自主使用和更新数据，即使没有确定的 ACID 属性。但是，当重新连接服务器时，复制拓扑中的所有站点都汇聚为相同的数据值。

事务复制维护事务的一致性，但其订阅服务器站点的自主性不如合并复制，因为发布服务器和订阅服务器通常应保持不间断的连接，以使更新内容能传播到订阅服务器。

快照复制将数据以特定时刻的当时状态分发，不监视对数据的更新。对于复制不经常更改的数据，或不要求保持大多数数据最新值（低滞后时间）的情况，快照复制是一种最好的数据复制方法。发生同步时，生成完整的快照并发送到订阅服务器。

一个应用程序可以使用多个复制类型和选项。应用程序中的有些数据可能不需要在订阅服务器上更新，有些数据集可能需要偶尔更新，但是这种更新只在一个或几个服务器上进行，而有些数据集可能需要在多个服务器上每天更新。

为应用程序选择何种复制类型取决于分布式数据的因素、数据是否需要在订阅服务器上更新、复制环境，以及被复制数据的需要和要求。

说明 如果运行的 Microsoft SQL Server 2000 个人版，则"事务发布"将变灰。个人版的使用许可不允许创建事务发布。但仍可以订阅事务发布。若要在该服务器上创建事务发布，必须安装 SQL Server 2000 标准版或 SQL Server 2000 企业版。

请参见

为复制制定计划

发布数据和数据库对象

复制类型


可更新订阅，创建发布向导

使用快照复制或事务复制时，默认情况下复制的数据为只读；然而，能够使用可更新订阅在订阅服务器上修改复制的数据。若需要使用快照或事务复制在订阅服务器上修改数据，可根据要求选择以下选项之一。

可更新订阅 | 要求
即时更新 | 必须连接发布服务器和订阅服务器才能更新订阅服务器上的数据。
排队更新 | 不必连接发布服务器和订阅服务器即可更新订阅服务器上的数据。可在脱机状态下进行更新。
在即时更新中将排队更新作为故障转移 | 发布服务器和订阅服务器在大多数时间都相连，但可能偶尔需要脱机更新。

在创建发布向导的"可更新订阅"页上有下列可用选项。

选项

即时更新

启用即时更新。即时更新使数据修改得以在订阅服务器上复制数据。然后将这些更改发送回发布服务器和其它订阅服务器。即时更新确保不存在冲突。使用两阶段提交协议 (2PC) 将数据修改从订阅服务器传播到发布服务器。

排队更新

启用排队更新。排队更新使数据修改得以在订阅服务器上复制数据，而无需连接到发布服务器的活动网络。当通过启用"排队更新"选项来创建发布，且在订阅服务器中的已复制数据上执行 INSERT、UPDATE 或 DELETE 语句时，更改将存储在队列中。当网络连接恢复后，在发布服务器上经过排队的事务将进行异步应用。可以使用 SQL Server 队列（默认）或 Microsoft 消息队列。

选择"即时更新"和"排队更新"启用以排队更新作为故障转移的即时更新。如果预期发布服务器和订阅服务器相互连接，但不希望当由于系统故障导致网络断开连接时丧失在订阅服务器上进行更新的能力，则可以使用以排队更新作为故障转移的即时更新。以排队更新作为故障转移的即时更新使您得以使用即时更新并在需要时切换到排队更新。

创建发布时启用即时更新和/或排队更新后，还需要在对发布创建订阅时指定可更新订阅选项。

说明 通过修改发布属性创建发布后，不能启用或禁用即时更新或排队更新。可更新的订阅和转换已发布的数据是相互排斥的选项。如果选择启用可更新的订阅，则不能启用转换已发布数据（另一个选项可用于快照和事务发布）。

请参见

事务复制

可更新订阅


转换已发布的数据

转换已发布的数据（可用于快照复制或事务复制）可调节数据转换服务 (DTS) 的数据移动、转换映射和筛选功能。通过在复制拓扑中使用转换订阅，可以基于个别订阅服务器的要求自定义和发送发布的数据。

如何使用转换订阅的示例包括：

  • 基于每个订阅服务器创建已发布数据的列和水平分区（自定义数据分区）。

  • 创建数据转换如数据类型映射（例如整数到 real 数据类型）、列操作（例如串联名字列和姓氏列）、字符串操作和函数使用。

创建发布向导的"转换已发布的数据"页上有下列可用选项。

选项

是，转换数据

启用转换已发布的数据。转换已发布数据使您得以将 DTS 包附加到订阅服务器，以便发布数据时转换数据。

否，所有的订阅服务器均直接接收数据

禁用转换已发布的数据。

启用转换已发布的数据后，可用转换已发布数据向导生成复制 DTS 包。将需要将 DTS 包作为订阅进程的一部分附加。Microsoft® SQL Server™ 2000 和 OLE DB 订阅服务器支持转换已发布数据（不支持 ODBC 订阅服务器）。

说明 通过修改发布属性创建发布后，不能启用或禁用转换已发布的数据。

请参见

事务复制

转换已发布的数据


指定订阅服务器的类型

订阅服务器是接收复制数据的服务器。订阅服务器订阅发布而非发布中的个别项目，而且它们只订阅所需要的发布而非发布服务器上可用的所有发布。

订阅是对发布到指定订阅服务器的数据或数据库对象的请求。一个订阅服务器可以有向不同发布请求的多个订阅。

订阅服务器可以是运行 Microsoft® SQL Server™ 2000、SQL Server 早期版本或异类数据源的服务器。对于合并复制，订阅服务器还可以是运行 Windows® CE 版的 Microsoft SQL Server 的设备。

创建发布向导的"指定订阅服务器类型"页上有下列可用选项。

选项

选择一个或多个将订阅该发布的订阅服务器类型。

运行 SQL Server 2000 的服务器

运行 SQL Server 2000 的订阅服务器可以订阅该发布。

运行 SQL Server 7.0 版的服务器

运行 SQL Server 7.0 版的订阅服务器可以订阅该发布。如果选择该选项，则将在和 SQL Server 7.0 订阅服务器兼容的向导中只看到发布属性。

运行 SQL Server CE 的设备

运行 Microsoft SQL Server 2000 Windows CE 版 (SQL Server CE) 的设备可以使用匿名订阅以订阅合并发布。如果启用该类型的订阅服务器，则匿名订阅也将启用服务器而且不能禁用。该选项只有当创建合并发布时才可用。

异类数据源，例如 Oracle 或 Microsoft Access

运行异类数据源或者运行 SQL Server 7.0 版或更早版本的订阅服务器可以订阅该发布。运行 SQL Server 7.0 版或更早版本的订阅服务器可以订阅快照或事务发布，但是不能订阅合并发布。运行 Oracle、Microsoft Access 和其它异类数据源的订阅服务器可以订阅快照或事务发布。运行 Microsoft Access 的订阅服务器可以订阅合并发布。

订阅服务器对发布的版本要求由发布的属性决定，而不是由在该页上选定的订阅服务器类型决定。例如，如果运行 SQL Server 2000 的服务器是选定的唯一选项，但是没启用任何要求订阅服务器运行 SQL Server 2000 的新属性，则运行 SQL Server 7.0 的订阅服务器仍然能够订阅该发布。

请参见

发布服务器、分发服务器和订阅服务器

订阅发布


指定项目

选择要作为项目发布的对象。项目可以是表的所有或已筛选的分区，也可以是数据库对象，如存储过程、视图和用户定义函数。

基于正使用的复制类型和特定项目的要求确定要在发布中包括的项目。如果正在发布引用了其它数据库对象的某个数据库对象，则必须将此对象引用的所有对象一起发布。例如，Northwind 数据库中的 Products Above Average Price（超过平均价格的产品）视图从 PRODUCTS 表检索数据。如果发布此视图，则必须同时发布 PRODUCTS 表。

若要筛选表中的数据，在创建发布向导中继续，将能够水平或垂直筛选任何类型的发布。对于合并发布，可以创建动态筛选和/或链接筛选。

如果正创建合并发布且指示订阅服务器运行 SQL Server 7.0 版或更早版本，则时钟图标将出现在包含 timestamp 列的所有表上。在 SQL Server 7.0 版或更早版本中不能将 timestamp 列作为合并复制的一部分发布，而且，在订阅服务器运行 SQL Server 7.0 版或更早版本时，它们只能使用那个版本的功能。必须先删除 timestamp 列才能从这些表中发布数据。

不能同时在合并发布和允许可更新订阅的快照或事务发布中发布项目。如果已指定合并发布的项目且正创建允许可更新订阅的快照或事务发布，则合并图标将在指定项目页的表名旁出现，表示该项目不能包括在新发布中。

如果已指定允许可更新订阅的快照或事务发布的项目且正创建合并发布，则带有斜杠的红色圆圈将在指定项目页上的表旁出现，表示该项目不能包括在新发布中。

表必须有主键才能作为事务发布的一部分发布。如果正创建事务发布，则在其上有 X 的键图标将在没有主键的表旁出现。带有该图标的表不能包括在新发布中。

默认项目属性的最佳用途是在创建任何该类型的项目前为对象类型设置默认值。如果先创建项目，然后更改默认值，则将提示是否更新以前发布的项目的属性。SQL Server 将重写在以前发布的项目中含有默认值的所有属性。这可能会影响比预期的更多的属性。所设置的默认属性在该向导之外将不再持续。因此，当打开发布属性时，默认值可能和在该向导中定义的不同。

请参见

筛选已发布数据

为各种类型的复制制定计划

发布服务器、分发服务器和订阅服务器

发布数据和数据库对象

在不同版本的 SQL Server 之间进行复制


项目问题

在选择要发布的项目后，可能会收到声明有项目问题的消息。此类消息声明已发现的情况和 Microsoft® SQL Server™ 2000 可能执行的操作。

项目问题 | 详细信息
将向表中添加 uniqueidentifier 列。 | SQL Server 要求所有的合并项目都包含 uniqueidentifier 列，该列具有唯一索引和 ROWGUIDCOL 属性。当生成第一个快照时，SQL Server 将为没有 uniqueidentifier 列的已发布表添加一个 uniqueidentifier 列。有关更多信息，请参见合并复制。
将向表中添加 timestamp 列。（用于运行 SQL Server 7.0 的发布）。 | SQL Server 要求允许可更新订阅的发布中所有项目都包含 timestamp 列，以便跟踪对复制数据的更改。SQL Server 将为没有 timestamp 列的已发布表添加 timestamp 列。有关更多信息，请参见即时更新。
将向表中添加 uniqueidentifier 列。 | SQL Server 要求允许可更新订阅的发布中的所有项目都包含名为"MSrepl_tran_version"的 uniqueidentifier 列，用以跟踪对复制数据的更改。SQL Server 将为没有上述列的已发布表添加该列。有关更多信息，请参见可更新订阅。
IDENTITY 列需要 NOT FOR REPLICATION 选项。 | SQL Server 要求所有 IDENTITY 列都使用 NOT FOR REPLICATION 选项。如果已发布的 IDENTITY 列没有使用该选项，则 INSERT 命令可能不能正确复制。有关更多信息，请参见使用 NOT FOR REPLICATION。
IDENTITY 属性未传输到订阅服务器。 | 因为该发布不允许可更新订阅，当 IDENTITY 列传输到订阅服务器时，将不传输 IDENTITY 属性。（例如，在发布服务器中定义为 INT IDENTITY 的列将在订阅服务器中定义为 INT。）有关更多信息，请参见在复制中使用 IDENTITY 值。
要求视图所引用的表。 | SQL Server 要求由发布视图和索引视图引用的所有表在订阅服务器上都可用。如果没有将被引用的表发布为该发布中的项目，则必须在订阅服务器上手动创建这些表。有关更多信息，请参见发布数据和数据库对象。
需要存储过程引用的对象。 | SQL Server 要求由发布的存储过程引用的所有对象（如表和用户定义函数）在订阅服务器上都可用。如果没有将被引用的对象发布为该发布中的项目，则必须在订阅服务器上手动创建这些对象。有关更多信息，请参见发布数据和数据库对象。
只有 SQL Server 2000 企业版支持索引视图项目。 | 仅在 Microsoft SQL Server 2000 企业版中才支持索引视图。已在订阅服务器上发布了一个或更多创建索引视图的索引视图项目。对于运行 Microsoft SQL Server 的订阅服务器，只有运行 SQL Server 2000 企业版的服务器才能订阅该发布。有关更多信息，请参见发布数据和数据库对象。
异类订阅服务器可能不支持 BIGINT IDENTITY 列。 | 已为一个或更多包含 BIGINT IDENTITY 列的已发布表启用了标识范围管理。有些异类订阅服务器可能不支持 IDENTITY 属性或该列的自动 IDENTITY 值管理。这些订阅服务器可能允许使用会导致重复键侵犯或其它同步冲突的 IDENTITY 列值。有关更多信息，请参见管理标识值。


自定义发布的属性

可以选择接受发布的默认属性，也可以选择定义属性，如筛选数据、启用匿名订阅和设置快照代理程序的调度。

接受发布的默认属性是完成向导和创建发布的最快方法。但是，在创建发布后，将无法更改某些选项。

若想执行下列操作，请选择"是，我将定义数据筛选，启用匿名订阅或自定义其它属性"：

  • 仅发布表中的某些行或列。

  • 允许匿名订阅。

  • 指定是否使快照始终可用于立即同步新订阅。


筛选数据

选择是否要垂直筛选发布（通过限制发布的列）或水平筛选发布（通过限制发布的行）。为了能够在创建发布时（使用该向导）进行筛选，需要在此启用筛选。

启用水平筛选包括能创建动态筛选和联接用于合并发布的筛选。

通过筛选已发布数据，可以：

  • 将网络上发送的数据量减到最少。

  • 减少订阅服务器上需要的存储空间量。

  • 根据个别订阅服务器的要求，自定义发布和应用程序。

  • 由于不同的数据分区可以发送到不同的订阅服务器（不同的订阅服务器不会同时更新同一个数据值），因此可避免或减少冲突。

完全复制的数据库设计将所有的数据库表都发布到远程位置。然而，若要优化应用程序性能和减少所需的远程存储量，或限制可由特定订阅服务器使用的某些数据，应只发布所需的最少数据量。发布中既可以包含未筛选的表，也可以包含已筛选的表。例如，可包含公司产品的完整（未筛选）表和经过筛选的特定区域的客户表。

可根据特定的特性筛选项目以限制发布的数据集。例如，当复制拓扑中的站点或区域只需要访问数据库中的某些行时，建议筛选表中的行。若创建快照发布或事务发布，建议当网络容量有限时，或者当订阅服务器存储大文本或 image 列的容量有限时，筛选表中的列。合并发布不支持筛选表中的列。

说明 如果在创建发布向导的此页上没有对该发布启用筛选，则将不能在该向导中筛选表项目。

请参见

筛选已发布数据


筛选表的列

列筛选限制要包含在快照发布、事务发布或合并发布中的列。列筛选可以减少将数据更新传播到订阅服务器所需的时间，减少订阅服务器上所需的存储空间，以及限制发布中的数据为各个订阅服务器所需的数据。

选择将在发布中包含的列。在项目中列的列表内，可选中或清除列名左侧的框，以表明在项目中是包含还是排除该列。

不能从发布中排除作为表的主键一部分的列（由钥匙键图标而非复选框表示）。

如果是合并发布，或者如果快照或事务发布允许即时更新或排队更新订阅，则不能从发布中排除 timestamp 列（复选框将由时钟图标取代）。

不能排除下列列：

列类型 		发布和/或选项的类型 列旁显示的图标
主键 | 事务发布 | 主键
timestamp | 允许即时更新和/或排队更新的快照或事务发布 | 时钟
uniqueidentifier 列。 | 合并发布 | 禁用的复选框
msrepl_tran_version | 允许即时更新和/或排队更新的快照或事务发布 | 禁用的复选框
不允许 NULL 且没有默认值的列
  • 合并发布

  • 允许即时更新和/或排队更新的快照或事务发布
 禁用的复选框

请参见

列筛选


启用动态筛选

通过在表项目上设置动态筛选，可根据各订阅服务器的要求调整给其发送的数据子集。动态筛选检查订阅服务器的特性，然后按筛选中的定义转发适当的数据。这使您得以创建单个发布，并通过该发布为不同的订阅服务器或订阅服务器组提供不同的数据集。

必须使用 SUSER_SNAME() 这样的函数手动创建动态筛选，以确定传播到特定的订阅服务器的特定数据。

动态快照为应用动态筛选过的合并发布快照带来了性能上的好处。通过使用 Microsoft® SQL Server™ 2000 大容量复制文件将数据应用到特定的订阅服务器（而非一系列 INSERT 语句），可以提高应用动态筛选过的合并发布的初始快照的性能。有关更多信息，请参见动态快照。

选择"是，启用动态筛选"可使发布能够使用动态筛选。创建发布后将无法更改"发布属性"对话框中的该属性。

请参见

动态筛选


自动生成筛选

若要在表中定义静态筛选，请在数据库中标识至少包含一个要筛选的特性列的表。

若要定义动态筛选，请在数据库中标识至少包含一个要筛选的主机名列和一个主机特性列的表。例如，下表中一列包含主机名，一列包含主机的区域。

主机名 | 区域
Smith | 5
Smith | 6
Jones | 2
Green | 1

该表是主机名筛选的起点，并且可自动扩展以筛选相关的表。在此例中，应用一个仅返回 Smith 的行的筛选，这使 Microsoft® SQL Server™ 2000 还包含区域 5 和 6 在任何相关表中的行。如果数据库中没有合适的表，则必须创建一个。

无论是动态筛选还是静态筛选，请从列表中选择数据库中包含第一个筛选所使用的数据列的表。然后输入用于将第一个筛选扩展到表中其它数据列的条件。仅输入要在筛选中使用的条件。不要输入整个 SELECT 语句，也不要输入 WHERE 关键字。例如，仅输入：

sales.rep = SUSER_SNAME()

而不要输入

WHERE sales.rep = SUSUER_SNAME()

完成该向导页后，SQL Server 将生成一个临时 JOIN 筛选列表，将在下一个向导对话框中显示。

请参见

筛选已发布数据


筛选表的行

可以筛选某个表中的行以减少所发布的数据量。筛选语句必须仅引用那个表中的列和值。筛选不能引用其它表中的数据来确定是包含还是排除表中的行。

单击属性按钮（"..."）以输入用作筛选的 WHERE 子句。

使用行筛选可以指定要发布的表中行的子集。当只需要将特定行传播到订阅服务器时，可以使用行筛选，以消除用户不需要看到的行（如包含敏感或保密信息的行），或创建发送到不同订阅服务器的不同数据分区。对于可以将不同数据分区发布到不同订阅服务器的应用程序，这样做还有助于避免由多个订阅服务器更新相同的数据值导致的冲突。

如果要创建合并发布，可以通过创建联接筛选将筛选扩展到相关的表，或者如果已启用了发布的动态筛选，则可以指定行筛选的用户定义函数或系统函数。

指定合并发布的动态筛选

  • 单击属性按钮（"..."）输入 WHERE 子句并使用系统函数（如 SUSER_SNAME()）或用户定义函数（如筛选的条件）。

指定合并发布的联接筛选

  1. 通过单击属性按钮（"..."）输入作为筛选的 WHERE 子句来筛选表中的行。

  2. 单击"已筛选的表"列下的"创建 JOIN"语句。行筛选中正被筛选的表名显示为行。

  3. 在"要筛选的表"下单击并从下拉框中选择要筛选的表。

  4. 单击 JOIN 筛选子句下的属性按钮（"..."）并输入用于联接筛选的 WHERE 子句。

请参见

动态筛选

联接筛选

行筛选


指定筛选

仅输入要在筛选中使用的条件。已提供 SELECT * FROM . . . WHERE 语句且不能修改。例如，仅输入：

sales.rep = SUSER_SNAME()

请参见

行筛选


指定筛选（<<TABLE>> 关键字）

仅输入要在筛选中使用的条件。已提供 SELECT <published columns> FROM <<TABLE>> WHERE 语句且不能修改。在 WHERE 子句中添加必要的筛选。如果在 WHERE 子句中使用表名，则必须使用 <<TABLE>> 而非表名。例如，仅输入：

<<TABLE>>.salesrep = SUSER_SNAME()

请参见

行筛选


指定联接筛选

仅输入要在筛选中使用的条件。已提供 SELECT*FROM . . . ON 语句且不能修改。例如，仅输入：

CUSTOMER.CUST_ID = ORDERS.CUST_ID

任何在两个表中相同并因此可解析到其中一个表的列名都应由表名限定。

请参见

联接筛选


验证订阅服务器信息，创建发布向导

通过合并复制动态筛选，可以使用引用订阅服务器信息的函数。Microsoft® SQL Server™ 2000 在每个合并之前基于该函数验证订阅服务器信息。从而确保每个合并分区信息的一致。

例如，当使用函数 SUSER_SNAME() 动态筛选某个发布时，合并代理程序基于对 SUSER_SNAME() 表达式有效的数据，将初始快照应用于每个订阅服务器。

当订阅服务器重新连接到发布服务器以进行下一次同步处理时，合并代理程序将验证订阅服务器上的信息，确保对与原先作为初始快照的一部分发送的分区相同的分区进行同步处理。

若想在每个合并中验证订阅服务器信息，请选择"是，验证订阅服务器的信息"。然后为该发布输入用于动态筛选的所有函数。

若不想在每个合并中验证订阅服务器信息，请选择"否，不验证订阅服务器的信息"。

创建发布后，无法在"发布属性"对话框中更改该属性。

请参见

验证订阅服务器信息


优化同步

当确定最近的更改是否已导致某行移入或移出订阅服务器的分区时，在合并复制过程中优化同步使您可以将网络传输量减到最小。在合并复制中提供一个选项，可以在发布服务器上存储更多信息，而不是通过网络将该信息传输到订阅服务器。虽然该选项可能会在发布服务器上产生较大的数据库，但是它可以使筛选评估更有效并将慢速链接上的网络流量减到最小，从而提高同步性能。但是，将有更多信息存储在发布服务器上，因而将需要额外的存储空间。

如果未使用优化同步设置，一个分区中的更改将导致合并进程再次验证发送到所有订阅服务器的数据的分区内容，即使更改只影响其中的一个或几个订阅服务器。

若想在发布服务器上存储更多信息而不将其通过网络发送到订阅服务器，请选择"是，最小化数据量"。

若想将信息通过网络发送到订阅服务器，请选择"否，不要最小化数据量"。

请参见

优化同步


允许匿名订阅

匿名订阅是请求订阅的一种类型，有关匿名订阅的订阅和订阅服务器的详细信息不予保存。如果匿名订阅发自订阅服务器，则由订阅服务器负责进行同步处理。

选择"是，允许匿名订阅"以允许发布服务器未知的订阅服务器订阅该发布。创建发布后将不能在发布属性中更改该属性。

如果在创建发布向导的"订阅服务器类型"页上启用了"运行 SQL Server CE 的设备"，则不能对匿名订阅禁用该选项。运行 SQL Server CE 的订阅服务器必须使用匿名订阅。

请参见

匿名订阅


项目属性，常规选项卡（快照或事务发布）

"项目属性"对话框的"常规"选项卡中有下列可用选项。

选项

名称

如果创建新选项，则输入项目的名称。如果已创建了项目，则查看项目的名称。

描述

输入或更改对项目的描述。

源表所有者

查看项目所基于的表所有者的名称。

源表名

查看项目所基于的表名。

目的表所有者

如果创建新项目，则输入表所有者的名称。如果已创建了项目，则查看表所有者的名称。

目的表名

如果创建新项目，则输入表名。如果已创建了项目，则查看表名。

支持由 DTS 转换脚本创建的水平分区。

启用发布以使用水平 DTS 分区。使用可转换订阅和水平分区数据，可以对订阅服务器上的某些行逐台排除。仅当发布允许转换已发布的数据时该选项才出现。

请参见

发布数据和数据库对象


项目属性，常规选项卡（合并发布）

"项目属性"对话框的"常规"选项卡中有下列可用选项。

选项

名称

如果创建新选项，则输入项目的名称。如果已创建了项目，则查看项目的名称。

描述

输入或更改对项目的描述。

源表所有者

查看项目所基于的表所有者的名称。

源表名

查看项目所基于的表名。

目的表所有者

如果创建新项目，则输入表所有者的名称。如果已创建了项目，则查看表所有者的名称。

对相同行的更改视为冲突

将两个站点同时更改同一行定义为冲突。

对相同列的更改视为冲突（将合并对相同行中不同列的更改）。

将两个站点同时更改同一行的同一列定义为冲突。

请参见

发布数据和数据库对象


项目属性，快照选项卡

"项目属性"对话框的"快照"选项卡中有下列可用选项。

选项

保持现有表不变

保留与目的表同名的订阅服务器表中的所有现有数据和架构。

除去现有表并重新创建它

删除与目的表同名的订阅服务器表，并在本地创建与发布服务器上的表相同的新表。

删除现有表中与行筛选语句相匹配的数据

在与目的表同名的订阅服务器表中，删除与要从发布服务器中复制的数据相匹配的数据。本地表中与要复制的数据不匹配的数据在本地表中保持不变。

删除现有表中所有的数据

删除所有数据，但保留与目的表同名的订阅服务器表中的表架构。

包含已声明的引用完整性

如果发布服务器的源表有主键约束、引用约束和唯一约束，则将它们全部复制到目的表。

聚集索引

如果发布服务器上的源表有聚集索引，则将它们复制到目的表。

非聚集索引

如果发布服务器上的源表有非聚集索引，则将它们复制到目的表。

用户触发器

如果发布服务器的源表有用户触发器，则将它们复制到目的表。

扩展属性

如果发布服务器的源表有扩展属性，则将它们复制到目的表。

排序规则

如果发布服务器的源表有排序规则规范，则将它们复制到目的数据库。

将用户定义数据类型转换为基本数据类型

将用户定义数据类型转换为其所基于的原始数据类型（如果发布服务器上的源表中有用户定义数据类型）。将用户定义数据类型转换为基本数据类型可能会更改数据的格式和其它特性。

请参见

应用初始快照

发布数据和数据库对象


项目属性，命令选项卡

"项目属性"对话框的"命令"选项卡中有下列可用选项。对于快照或合并发布，或对于允许即时更新或排队更新订阅的事务发布或者允许转换已发布的数据的事务发布，不显示该选项卡。

选项

用该存储过程调用替换 INSERT 命令

使用每个订阅服务器上的自定义存储过程代替发布服务器发布的 INSERT 命令。可以使用自动命名和自动创建的存储过程，或可以使用自己指定的自定义存储过程。如果指定所有的订阅服务器均运行 SQL Server，则自动选定该选项。如果包括异类订阅服务器，则必须清除用于异类订阅服务器的此选项以接收 INSERT 命令。

用该存储过程调用替换 UPDATE 命令

用每个订阅服务器上的自定义存储过程代替发布服务器发布的 UPDATE 命令。可以使用自动命名和自动创建的存储过程，或可以使用自己指定的自定义存储过程。必须用 M 调用指定自定义存储过程。如果指定所有的订阅服务器均运行 SQL Server，则自动选定该选项。如果包括异类订阅服务器，则必须清除用于异类订阅服务器的此选项以接收 UPDATE 命令。

用该存储过程调用替换 DELETE 命令

用每个订阅服务器上的自定义存储过程代替发布服务器发布的 DELETE 命令。可以使用自动命名和自动创建的存储过程，或可以使用自己指定的自定义存储过程。如果指定所有的订阅服务器均运行 SQL Server，则自动选定该选项。如果包括异类订阅服务器，则必须清除用于异类订阅服务器的此选项以接收 DELETE 命令。

在订阅服务器的初始同步过程中创建上面指定的存储过程

在订阅服务器上自动创建存储过程，因为在那里不存在存储过程。可以使用自动命名和自动创建的存储过程，或可以使用自己指定的自定义存储过程。

以二进制格式发送参数

以最有效的格式发送存储过程。

在不会被存储过程替换的命令中使用列名

在所有的 SQL 语句中使用表列名。

请参见

事务复制

使用项目中的自定义存储过程


项目属性，冲突解决程序选项卡

"项目属性"对话框的"冲突解决程序"选项卡中有下列可用选项。该选项卡在合并发布的项目属性上显示。

选项

使用默认的冲突解决程序

使随 Microsoft® SQL Server™ 2000 提供的冲突解决程序在合并进程中处理检测到的冲突。

使用此自定义的冲突解决程序（已在分发服务器上注册）

使自定义的冲突解决程序处理在合并进程中检测到的冲突。选择要用于该项目的自定义冲突解决程序。在 SQL Server 2000 中有十二个可用的自定义冲突解决程序。

在进行合并之前要求数字签名验证

复制签名验证常数用于指定在合并复制中使用冲突解决程序前是否验证数字签名。

输入冲突解决程序所需的信息

输入当使用存储过程冲突解决程序时调用的存储过程名，并输入该程序所需的任何参数或其它信息。也可以输入其它自定义冲突解决程序所需的信息。

允许订阅服务器在按需同步时交互式地解决冲突

运行时激活后，该交互式冲突解决程序显示每个存在冲突的行的数据，并提供选项供查看和编辑冲突数据以及逐个解决冲突。如果允许交互式地解决冲突，则必须还指定创建订阅时是否交互式地解决冲突。

请参见

合并复制冲突的检测和解决


项目属性，标识范围选项卡

在发布中包含标识列和订阅服务器处可插入新行的复制拓扑结构中，可能需要额外配置以避免出现重复标识值或违反约束。

"标识范围"选项卡使您得以指定 SQL Server™ 2000 将通过将标识值范围分配给发布服务器和所有的订阅服务器来自动指派和管理标识列。

"项目属性"对话框的"标识范围"选项卡上有下列可用选项。

选项

自动为每份订阅指派并维护唯一的标识范围

SQL Server 将为发布服务器和该项目的每个订阅指派标识范围。

最大标识值

查看将要为该复制的表中的行输入的最大标识值。

下一个范围的起始值

查看下一个可用的起始标识值。

标识增量

查看生成标识值的增量。

发布服务器的范围大小

输入为在发布服务器上生成的 INSERT 保留的标识范围大小。

订阅服务器的范围大小

输入为在订阅服务器上生成的 INSERT 保留的标识范围大小。

当使用此百分比值时指派新的范围

该项目上的 INSERT 值达到现有的标识范围的此百分比时，SQL Server 将指派新的标识范围。

说明 更改该对话框上的值将影响基于该表的所有项目。所有基于该表的发布中的所有项目都使用相同的标识范围属性。

请参见

带有即时更新和排队更新的标识范围

管理标识值

发布数据和数据库对象


项目属性，合并更改选项卡

SQL Server™ 2000 提供了验证订阅服务器权限的选项，以将数据更改上载到发布服务器。这将验证合并代理程序登录是否具有权限，以在发布数据库上执行 INSERT、UPDATE 和 DELETE 命令。验证权限要求合并代理程序必须是在发布数据库中具有适当权限的有效用户。

除了验证在订阅服务器上所用的登录是否在发布访问列表 (PAL) 中之外，还要进行这种权限验证。

如果在已经生成初始快照后设置检查权限选项，则必须在订阅服务器上生成并重新应用新的快照，以便在合并数据更改时验证权限。

在"项目属性"对话框的"合并更改"选项卡上有下列选项可用。

选项

INSERT

选择使 SQL Server 验证合并代理程序登录有权限执行 INSERT 命令。

UPDATE

选择使 SQL Server 验证合并代理程序登录有权限执行 UPDATE 命令。

DELETE

选择使 SQL Server 验证合并代理程序登录有权限执行 DELETE 命令。

多列更新

启用 SQL Server 对同一行中多列值所做的所有更改生成一个 UPDATE 语句。如果打开创建发布向导中"合并更改"选项卡中的项目属性，则可以修改该选项。如果在创建发布后打开发布属性中"合并更改"选项卡的项目属性，将能够查看该选项，但是不能修改它。

请参见

合并复制

合并复制冲突的检测和解决


存储过程项目属性，常规选项卡

"存储过程项目属性"对话框的"常规"选项卡中有下列可用选项。

还应发布或在每个订阅服务器上手动创建由存储过程引用的任何对象（如表或函数）。

当发布这些对象时，其定义作为应用于订阅服务器的初始快照的一部分进行复制。对这些对象的定义的后续更改不自动复制到订阅服务器。

选项

名称

如果创建新存储过程项目，则输入项目的名称。如果已创建了项目，则查看项目的名称。

源存储过程所有者

查看要发布的源存储过程所有者。

源存储过程名称

查看要发布的源存储过程名称。

目的存储过程所有者

在将复制的存储过程发布到订阅服务器后输入或查看其所有者。

目的存储过程名称

在将复制的存储过程发布到订阅服务器后查看其名称。

描述

输入对存储过程项目的描述。

请参见

发布数据和数据库对象


存储过程项目属性，其它选项卡

"存储过程项目属性"对话框的"其它"选项卡中有下列可用选项。

选项

保留现有存储过程

如果订阅服务器上已存在存储过程，则在订阅服务器上保留现有存储过程但不发布该存储过程。

除去现有存储过程

如果订阅服务器上已存在存储过程，则在订阅服务器上除去现有存储过程并发布该存储过程。

对于不允许可更新订阅的事务发布中的存储过程项目，除发布存储过程的架构外还可以发布存储过程的执行。有关更多信息，请参见发布存储过程执行。

从不，仅复制架构

不复制存储过程的执行。

每次执行该存储过程时

总是复制存储过程的执行。

仅在可串行事务内部执行该存储过程时

仅在可串行事务内部执行该存储过程时复制它。

扩展属性

发布所有与该存储过程项目共存的扩展属性。

请参见

发布数据和数据库对象


视图项目属性，常规选项卡

创建视图后，它们将作为对象显示在"指定项目"对话框的创建发布向导的中。

当复制这些对象时，其定义作为应用于订阅服务器的初始快照的一部分进行复制。对这些对象的定义的后续更改不自动复制到订阅服务器。但是，对这些对象的定义进行复制可提供方便的机制，以向订阅服务器部署应用程序的这些组件。

还应发布或在每个订阅服务器上手动创建由视图引用的任何对象（如表或函数）。

"视图项目属性"对话框的"常规"选项卡中有下列可用选项。

选项

名称

如果创建新视图项目，则输入项目的名称。如果已创建了项目，则查看项目的名称。

源视图所有者

查看要发布的视图的所有者。

源视图名称

查看要发布的视图的名称。

目的视图所有者

在将复制的视图发布到订阅服务器后输入或查看其所有者。

目的视图名称

在将复制的视图发布到订阅服务器后查看其名称。

描述

输入对视图项目的描述。

请参见

发布数据和数据库对象


视图项目属性，快照选项卡

"视图项目属性"对话框的"快照"选项卡中有下列可用选项。

选项

保留现有视图

如果订阅服务器上已存在具有相同名称的视图，则在订阅服务器上保留现有视图且不发布该视图。

除去现有视图

如果订阅服务器上已存在具有相同名称的视图，则在订阅服务器上除去此视图并发布该视图。

扩展属性

发布所有与该视图项目共存的扩展属性。

用户触发器

发布所有与该视图项目共存的用户触发器。

请参见

发布数据和数据库对象


用户定义函数项目属性，常规选项卡

在数据库中创建视图、用户定义的函数和存储过程定义之后，它们将作为对象显示在"指定项目"对话框上的创建发布向导中。

当复制这些对象时，其定义作为应用于订阅服务器的初始快照的一部分进行复制。对这些对象的定义的后续更改不自动复制到订阅服务器。但是，对这些对象的定义进行复制可提供方便的机制，以向订阅服务器部署应用程序的这些组件。

还应该发布或在每个订阅服务器中手动创建所有函数引用的对象。

"用户定义函数项目属性"对话框的"常规"选项卡上有下列可用选项。

选项

名称

如果创建新用户定义函数项目，则输入项目的名称。如果已创建了项目，则查看项目的名称。

源用户定义函数所有者

查看要发布的用户定义函数的所有者。

源用户定义函数名

查看要发布的用户定义函数的名称。

目的用户定义函数所有者

在复制用户定义函数发布到订阅服务器后输入或查看其所有者。

目的用户定义函数名

在复制用户定义函数发布到订阅服务器后查看其名称。

描述

输入对用户定义函数项目的描述。

请参见

发布数据和数据库对象

用户定义函数

用户定义函数和动态筛选


用户定义函数项目属性，快照选项卡

在"用户定义函数项目属性"对话框的"快照"选项卡上有下列选项可用。

选项

保留现有用户定义函数

如果订阅服务器上已存在具有相同名称的用户定义函数，则在订阅服务器上保留现有用户定义函数且不发布该用户定义函数。

除去现有用户定义函数

如果订阅服务器上已存在具有相同名称的用户定义函数，则在订阅服务器上除去用户定义函数并发布该用户定义函数。

扩展属性

发布所有与该用户定义函数项目共存的扩展属性。

请参见

发布数据和数据库对象

用户定义函数


索引视图项目属性，常规选项卡

创建索引视图后，它们将作为对象显示在"指定项目"对话框的创建发布向导的中。

当复制这些对象时，其定义作为应用于订阅服务器的初始快照的一部分进行复制。对这些对象的定义的后续更改不自动复制到订阅服务器。但是，对这些对象的定义进行复制可提供方便的机制，以向订阅服务器部署应用程序的这些组件。

当为快照复制或事务复制发布非只架构项目的索引视图时，不必将视图以表的形式进行复制。当视图发布到订阅服务器时，订阅服务器上将创建一个表，其中包含视图所基于的数据。在订阅服务器上将视图作为一个表进行索引是复制视图内容的一种方便的方式，它不要求组成视图定义的每个表也加以复制。

还应该发布或在每个订阅服务器中手动创建所有索引视图引用的对象（如表或函数）。

"索引视图项目属性"对话框的"常规"选项卡中有下列可用选项。

选项

名称

如果创建新索引视图项目，则输入项目的名称。如果已创建了项目，则查看项目的名称。

源视图所有者

查看要发布的索引视图的所有者。

源视图名称

查看要发布的索引视图的名称。

目的视图所有者

在复制的对象发布到订阅服务器后输入或查看其所有者。

目的视图名称

在复制的对象发布到订阅服务器后查看其名称。

描述

输入对索引视图项目的描述。

在不允许可更新订阅的快照和事务发布中，可以指定索引视图项目在订阅服务器上是创建索引视图还是创建表。合并发布中的索引视图项目总是在订阅服务器上创建索引视图。

索引视图

在订阅服务器上创建索引视图。合并发布时不显示该选项。

源索引视图定义的表

在订阅服务器上创建表，该订阅服务器包含索引视图所定义的发布服务器中的数据。合并发布时不显示该选项。

请参见

发布数据和数据库对象


索引视图项目属性，快照选项卡

"索引视图项目属性"对话框的"快照"选项卡中有下列可用选项。

选项

保留现有视图

如果订阅服务器上已存在与目的对象具有相同名称的对象，则在订阅服务器上保留现有对象且不发布该对象。

除去现有视图

如果订阅服务器上已存在对象，则在订阅服务器上除去索引视图并发布该索引视图。

非聚集索引

发布所有与该索引视图项目共存的非聚集索引。如果目的对象是索引视图，则要求该选项。

扩展属性

发布所有与该索引视图项目共存的扩展属性。

用户触发器

发布所有与该索引视图项目共存的用户触发器。

请参见

发布数据和数据库对象


强制订阅向导，欢迎

"创建强制订阅向导"的"欢迎"页包含对"创建强制订阅向导"的描述，以及一个可在向导中选择高级选项的选项。

若已启用"显示本向导中的高级选项"并创建快照或事务发布的强制订阅，则将能够配置订阅用于：

  • 即时更新和/或排队更新的可更新订阅选项。

  • 在分发服务器以外的位置运行代理程序。

当创建合并发布的强制订阅时，将看到所有选项都可用不管是否选定了"显示本向导中的高级选项"复选框。

可更新的订阅

一般情况下，复制的数据是只读的。然而在 SQL Server™ 2000 中，能够通过在快照复制或事务复制中使用可更新订阅，或通过使用合并复制，修改订阅服务器上的复制数据。若需要使用快照复制或事务复制修改订阅服务器的数据，可选择即时更新、排队更新或在即时更新中将排队更新作为故障转移。

有关更多信息，请参见可更新订阅。

远程代理程序激活

远程代理程序激活通过在另一台计算机上运行分发代理程序或合并代理程序，然后使用分布式组件对象模型 (DCOM) 远程激活该代理程序，这允许减少分发服务器或订阅服务器上处理的数量。

可以在强制订阅或请求订阅上实施远程代理程序激活。对于每种订阅类型，需要执行以下任务：

  • 表示代理程序在强制订阅或请求订阅向导中运行的位置。

  • 配置 DCOM 以远程激活代理程序。

  • 配置或创建订阅以表示代理程序应该运行的位置。

请参见

强制订阅

远程代理程序激活

复制向导

订阅发布


选择订阅服务器

选择将订阅该发布的数据源。可按住 CTRL 键以选择多个数据源。选择一个组名将会选定该组中的所有服务器。

已启用的订阅服务器组包含以前作为订阅服务器启用的所有订阅服务器（Microsoft® SQL Server™ 和异类数据源）。如果列表中缺少某个订阅服务器，则取消该向导，然后使用"发布服务器和分发服务器"属性（在企业管理器中，右击"复制"文件夹并单击"配置发布、订阅服务器和分发"）中的"订阅服务器"选项卡以启用它。

说明 如果要发布到异类订阅服务器或运行 SQL Server 7.0 版或更早版本的订阅服务器，则快照格式必须设置为字符模式。


设置合并/分发代理程序位置

创建强制订阅时，默认情况下合并代理程序（用于合并发布）或分发代理程序（用于快照和事务发布）运行在分发服务器上。

可以在将代理程序处理卸载到另一个服务器的同时在发布服务器和分发服务器上维持管理控制。只有 Microsoft Windows® 2000 或 Windows NT® 4.0 中的订阅服务器支持卸载代理程序处理。

若不想卸载代理程序处理，请选择"在分发服务器上运行该代理程序"。

若想卸载代理程序处理，请选择"在订阅服务器上执行该代理程序（仅在 Windows 2000 和 Windows NT 订阅服务器上受支持）"。然后验证或输入订阅服务器的计算机名称。

请参见

远程代理程序激活


初始化订阅

若想 Microsoft® SQL Server™ 初始化订阅，请选择"是，初始化架构和数据"。创建订阅后，分发服务器代理程序或合并代理程序将运行并将快照文件应用到订阅服务器。

如果在订阅服务器上手工装载架构和数据，例如使用备份磁带，则不需要初始化订阅。若不想 SQL Server 应用快照，请选择"否，该订阅服务器已经具有架构和数据"。

如果启用立即同步发布属性，且快照代理程序没运行，或发布没设置为立即同步，则选择"启动快照代理程序立即初始化订阅"启动快照代理程序。如果合并代理程序或分发代理程序没设置为持续运行，则该代理程序根据它的调度运行时，将应用快照。

如果启用立即同步发布属性，且没有为发布生成快照，该选项表示在快照可用后，必须启动合并代理程序或分发代理程序。

如果启用立即同步发布属性，且已为发布生成快照，合并代理程序或分发代理程序设置为持续运行，则不显示"启动快照代理程序立即初始化订阅"复选框。

请参见

应用初始快照


设置订阅优先级

创建订阅时，可以指派给其优先级值，也可以在解决冲突时使用发布服务器作为订阅服务器的代理服务器。

具有优先级值的订阅称为全局订阅；使用发布服务器优先级值的订阅称为本地订阅。下表概括了每种订阅类型的主要区别和用途。

类型 | 优先级值 | 已使用
全局。 | 由用户指定。 | 当希望不同的订阅服务器具有不同的优先级时使用。
本地（包括匿名）。 | 0.00，但是发布服务器在订阅服务器和发布服务器同步后作为数据更改的代理服务器。 | 当希望所有的订阅服务器都具有相同的优先级，并且第一个与发布服务器合并的订阅服务器在冲突解决中入选时使用。 希望有大量的订阅，并且不想在发布服务器/订阅服务器上对其进行跟踪时，匿名订阅对此有所帮助。

当在全局订阅中更改一行时，将为该更改在元数据中存储订阅优先级。当更改的行与其它订阅服务器上的更改合并时，该订阅优先级将跟随此行。这确保由较高优先级订阅所进行的更改不会丢失由较低优先级订阅所进行的更改。

如果在本地订阅中更改一行，则不为该更改指定优先级，直到此行与发布服务器上的其它更改合并。在发布服务器上的合并进程中，来自订阅服务器的更改被指定发布服务器的优先级，并且，当此更改与其它发布服务器和订阅服务器上的更改合并时，将随该优先级更改。从某种意义上，发布服务器采用更改的作者身份。

全局订阅比本地订阅提供了更多的选项，并且可执行更复杂的冲突解决方案。使用全局订阅可确保在整个企业范围内保持优先级值。

对于该发布，还可以指定全局订阅作为订阅的可选同步伙伴。（在"发布属性"对话框中指定可选同步伙伴）。

本地订阅也适于在分层拓扑结构中使用（一般是要求的），这时订阅服务器是叶节点。在这些拓扑中，要再次发布数据的所有节点都必须是全局订阅服务器；本地订阅服务器只能用作叶节点。

若想要它成为本地订阅，则选择"解决冲突时使用发布服务器作为订阅服务器的代理服务器"。

选择"使用下列优先级 . . ."然后，若想要它成为全局订阅，则输入订阅的优先级号。

请参见

合并复制的冲突检测和解决

订阅类型和冲突


可更新订阅，订阅向导

使用快照复制或事务复制时，默认情况下复制的数据为只读；然而，能够使用可更新订阅在订阅服务器上修改复制的数据。若需要使用快照或事务复制在订阅服务器上修改数据，可根据要求选择以下选项之一。

可更新订阅 | 要求
即时更新 | 必须连接发布服务器和订阅服务器才能更新订阅服务器上的数据。
排队更新 | 不必连接发布服务器和订阅服务器即可更新订阅服务器上的数据。可在脱机状态下进行更新。
在即时更新中将排队更新作为故障转移 | 发布服务器和订阅服务器在大多数时间都相连，但可能偶尔需要脱机更新。

选项

无 – 不复制更改内容

在订阅服务器上修改的复制数据不传播到发布服务器或其它订阅服务器。

即时更新

配置该订阅使用即时更新。即时更新允许在订阅服务器上对复制数据进行数据修改。然后，将这些更改发送回发布服务器和其它订阅服务器。即时更新确保不存在冲突。使用两阶段提交协议 (2PC) 将数据修改从订阅服务器传播到发布服务器。

排队更新

配置该订阅使用排队更新。排队更新使数据修改得以在订阅服务器上复制数据，而不需要与发布服务器的活动网络连接。当通过启用排队更新选项来创建发布，且在订阅服务器对已复制数据执行 INSERT、UPDATE 或 DELETE 语句时，更改将存储在一个队列中。当网络连接恢复后，在发布服务器上经过排队的事务将进行异步应用。可以使用 SQL Server 队列（默认）或 Microsoft 消息队列。

即时更新并用排队更新作为备用以防失败

为将排队更新作为故障转移的即时更新配置订阅。如果预期发布服务器和订阅服务器相互连接，但不希望当由于系统故障导致网络断开连接时丧失在订阅服务器上进行数据修改的能力，则可以使用以排队更新作为故障转移的即时更新。以排队更新作为故障转移的即时更新使您得以使用即时更新并在需要时切换到排队更新。

说明 通过修改强制订阅属性或请求订阅属性创建订阅后，不能配置即时更新或排队更新。

请参见

事务复制

可更新订阅


指定 DTS 包

如果在发布中启用转换已发布的数据，则必须指定要和该订阅一起使用的 DTS 包。

下列是在创建强制订阅向导的指定 DTS 包页上的可用选项。

选项

分发服务器

如果 DTS 包位于分发服务器上则选择该选项。

订阅服务器

如果 DTS 包位于订阅服务器上则选择该选项。

列出包

如果选择该订阅服务器选项且该订阅服务器正运行 SQL Server，则可以单击"列出包"按钮。这将连接到订阅服务器并检索要和复制一起使用而创建的包列表。可以手工或使用已发布的数据向导的定义转换创建这样的包。

包名称

输入要和该订阅一起使用的 DTS 包名称。

所有者密码（如果要求）

如果要求则输入 DTS 包的所有者密码。

请参见

转换已发布的数据


启动要求的服务

必须运行向导页上列出的服务，才能使 Microsoft® SQL Server™ 对更改进行同步。所有的发布都需要 SQL Server 代理程序。允许可更新的订阅（即时更新和/或排队更新）的事务和快照发布需要 MS DTC。允许排队更新订阅的事务和快照发布需要 Microsoft 消息队列并使用 Microsoft 消息队列对在订阅服务器上所做的数据修改进行排队。

在服务前的"SQL Server 代理程序"图标、"MS DTC"图标或"Message 消息队列"图标表示服务当前是否正运行或停止。如果图标是灰色的，则服务的状态为未知。

如果必需的服务当前没有运行，可以选择该服务并让 SQL Server 在该向导结束时自动启动该服务，或者以后手工启动该服务。


请求订阅向导，欢迎

"创建请求订阅向导"的"欢迎"页包含对"创建请求订阅向导"的描述，以及一个可在向导中选择高级选项的选项。

若已启用"显示本向导中的高级选项"并创建快照或事务发布的请求订阅，则将能够配置该订阅用于：

  • 即时更新和/或排队更新的可更新订阅选项。

当创建合并发布的请求订阅时，将看到所有选项都可用，不管是否选定了"显示本向导中的高级选项"复选框。

可更新的订阅

一般情况下，复制的数据是只读的。然而在 SQL Server 2000 中，能够通过在快照复制或事务复制中使用可更新订阅，或通过使用合并复制，修改订阅服务器上的复制数据。若需要使用快照复制或事务复制修改订阅服务器的数据，可选择即时更新、排队更新或在即时更新中将排队更新作为故障转移。

有关更多信息，请参见可更新订阅。

请参见

请求订阅

复制向导

订阅发布


选择发布

当展开发布服务器时，SQL Server 企业管理器显示满足下列要求的发布：

  • 您的当前登录包含在该发布的发布访问列表中。

  • 当前服务器是在发布服务器上启用的订阅服务器，或者该发布允许匿名订阅。

如果要订阅的发布不在列表中，则将在订阅服务器中使用的登录添加到用于发布的发布访问列表。将登录添加到 PAL：

  1. 单击"取消"退出"创建请求订阅向导"。

  2. 在企业管理器中，连接到发布服务器并右击要订阅的发布。

  3. 单击"属性"，然后在"发布访问列表"选项卡上添加在订阅服务器上使用的登录。

如果没有将当前服务器作为发布服务器上的订阅服务器启用，则请添加订阅服务器。添加该发布服务器的订阅服务器：

  1. 单击"取消"退出"创建请求订阅向导"。

  2. 在企业管理器中，连接到发布服务器并右击"Replication"文件夹，然后单击"配置发布、订阅服务器和分发"。

  3. 在"订阅服务器"选项卡上，选择订阅服务器名称左侧的框。如果没有列出订阅服务器，则单击"新订阅服务器"，并单击要注册的订阅服务器类型，然后输入服务器和连接信息。

如果发布不允许匿名订阅，则更改该属性。启用匿名订阅：

  1. 单击"取消"退出"创建请求订阅向导"。

  2. 在企业管理器中，连接到发布服务器并右击要允许匿名订阅的发布，然后单击"属性"。

  3. 在"订阅选项"选项卡上，选择"允许匿名订阅"。

请参见

匿名订阅

请求订阅

订阅发布


查找发布

创建请求订阅向导的查找发布页上有下列可用选项。

选项

查看已注册服务器所作的发布

选择该选项查看在已注册服务器所作的发布。

查看 Active Directory 中的发布或指定发布信息

选择该选项查看列在 Microsoft® Active Directory™ 中列出的发布。如果允许，将能够订阅列在 Active Directory 中列出的发布。该选项用于运行 SQL Server 2000 的发布服务器。

请参见

Active Directory 服务


指定发布

"创建请求订阅向导"的"指定发布"页上有下列可用选项。

选项

发布服务器

输入发布服务器的计算机名称。

浏览（"..."）

选择以浏览 Microsoft® Active Directory™ 中的发布服务器信息。

发布数据库

输入发布数据库的名称。

发布

输入发布的名称。

使用 Windows 身份验证进行连接

选择以使用 Windows 身份验证连接到发布服务器。

使用 SQL Server 身份验证进行连接

选择以使用 SQL Server 身份验证连接到发布服务器。

登录

键入 SQL Server 帐户的登录。

密码

键入 SQL Server 帐户的密码。

请参见

Active Directory 服务


指定更新订阅登录

发布访问列表确定哪些登录有权更新发布中的数据。确报指定的登录包含在该发布的发布访问列表中。

请参见

发布访问列表

订阅发布


快照传送

所订阅的发布允许订阅服务器使用备用快照位置或文件传输协议 (FTP) 通过 Internet 下载快照文件。如果订阅服务器在初始化订阅时无法直接通过网络访问快照文件，则 Microsoft® SQL Server™ 可以使用 FTP 在 Internet 上复制快照文件。

选择"使用该发布的默认快照文件夹中的快照文件"以访问该发布服务器默认位置中的快照文件。

选择"使用下列文件夹中的快照文件"指定另一个订阅服务器可以访问的快照文件所在的位置。

请参见

备用快照位置

应用初始快照


设置分发代理程序调度

指定为该订阅运行的分发代理程序的调度。选择"连续地运行"以保证数据修改将在发布服务器和订阅服务器之间即时传播。

选择"使用下列调度"，按每小时（默认）、每天、每周或每月运行分发代理程序。但是，选择"连续地运行"以外的频率将增加订阅服务器和发布服务器之间的滞后时间。

选择"仅按需"，以便只在特别请求时才运行分发代理程序。该选项还使订阅服务器能使用 Microsoft Windows 同步管理器。

请参见

分发代理程序

复制代理程序

Windows 同步管理器


设置合并代理程序调度

指定要为该订阅运行的合并代理程序的调度。选择"连续地运行"以保证数据修改将在发布服务器和订阅服务器之间即时传播。

选择"使用下列调度"，按每小时（默认）、每天、每周或每月运行合并代理程序。但是，选择"连续地运行"以外的频率将增加订阅服务器和发布服务器之间的滞后时间。

选择"仅按需"只在特别请求时才运行合并代理程序。该选项还使订阅服务器能使用 Microsoft Windows 同步管理器。

请参见

合并代理程序

复制代理程序

Windows 同步管理器


允许匿名订阅

匿名订阅是请求订阅的一种，有关订阅和订户的详细信息不予保存。如果匿名订阅发自订阅服务器，则由订阅服务器负责进行同步处理。

选择"是，生成匿名订阅"生成该匿名订阅。

选择"否，这是署名订阅"生成该请求订阅以存储详细信息。

请参见

匿名订阅

请求订阅

订阅发布


指定订阅服务器的安全性

该订阅服务器已注册在企业管理器中，用户在连接到该订阅服务器时需要输入密码。选择将由复制代理程序使用的连接信息。选择"通过模拟服务器上的 SQL Server 代理程序帐户"，以使用服务器上的 SQL Server 代理程序所使用的同一 Windows 身份验证帐户。选择"使用该帐户的 SQL Server 身份验证"，以使用指定帐户的 SQL Server 身份验证。

可以以后在"请求订阅属性"的"安全性"选项卡上更改密码。

请参见

复制属性

复制安全性

订阅发布


发布 属性，常规选项卡

"发布 属性"对话框的"常规"选项卡中有下列可用选项。

选项

名称

查看发布的名称。

数据库

查看包含发布的数据库名称。

描述

输入或更改对发布的描述。

类型

查看发布类型（快照、事务或合并）。

在 Active Directory 中列出该发布

选择以启用 Microsoft Windows 2000 的 Microsoft® Windows® Active Directory™ 服务中的发布。这将使订阅服务器中的用户得以查看发布和订阅该发布（如果允许）。

订阅到期后，如果在以下的小时数/天数内不进行同步处理，则会被除去

设置快照和事务发布的小时数或合并发布的天数。这是需要进行同步的小时或天数，否则将除去订阅。

订阅从不到期

允许订阅存在，即使它们没同步。对于快照和事务发布，将停用订阅，除非对其进行重新初始化。

请参见

订阅停用和到期

发布数据和数据库对象


发布属性，项目选项卡

"发布属性"对话框的"项目"选项卡中有下列可用选项。

选项

（复选框）

将选定对象作为项目启用。

对象类型

发布数据库中可以作为项目发布的对象类型。

显示

单击该复选框以显示项目列表中该类型的对象。

全部发布

选择该复选框以发布可以作为该发布中的项目发布的所有该类型对象。（不能发布某些对象。例如，没有主键列的表不能作为事务发布的一部分发布，所以选择该选项将发布所有有主键的表）。

所有者

查看对象所有者的名称。

对象

查看项目基于的表、存储过程、视图、用户定义函数或索引视图的名称。

(...)

显示项目的属性。

项目默认值

基于选定的对象类型设置新项目的默认属性。

显示未发布的对象

显示发布中没有标记为发布的对象。

请参见

发布数据和数据库对象


发布属性，筛选列选项卡

"发布属性"对话框的"筛选列"选项卡上有下列可用选项。

选项

所有者

查看表所有者的名称。

表

查看项目所基于的表名。

项目

查看项目的名称。

（复选框）

将表列包含在选定的项目中或从其中排除。不能从项目中排除作为表的主键组成部分的列，这些列中有一个钥匙图标。

不能从发布中排除下列列。

列类型 | 发布类型和选项 | 图标
主键 | 事务发布 | 主键
Timestamp | 允许可更新订阅的快照或事务发布 | 时钟
uniqueidentifier | 合并发布 | 禁用的复选框
msrepl_tran_version | 允许可更新订阅的快照或事务发布 | 禁用的复选框
不允许 NULL 值且没有默认值的列 | 合并发布 允许可更新订阅的快照或事务发布 | 禁用的复选框

列名

查看列的名称。

数据类型（基类型）

查看列的数据类型。如果数据类型基于另一个数据类型，则基本数据类型显示在括号中。

将列添加到表

使您得以在发布表中添加列以包括在发布中。

除去所选列

使您得以从发布和从发布表中除去列。

请参见

列筛选

筛选已发布数据

发布数据库上的架构更改


发布属性，筛选行选项卡

"发布属性"对话框的"筛选行"选项卡上有下列可用选项。

选项

所有者

查看表所有者的名称。

表

查看项目所基于的表名。

项目

查看项目的名称。

筛选子句

查看用于筛选项目中包含的行的子句。

(...)

输入或修改筛选子句。

请参见

筛选已发布数据

行筛选


发布属性，筛选行选项卡（合并发布）

"发布属性"对话框的"筛选行"选项卡上有下列可用选项。

选项

所有者

查看表所有者的名称。

表

查看项目所基于的表名。

项目

查看项目的名称。

筛选子句

查看用于筛选项目中包含的行的子句。

(...)

输入或修改筛选子句。

已筛选的表

选择已筛选的表名。只有经过 JOIN 筛选过其中一行或全部行的表才显示在该列中。选择"删除 JOIN"可删除现有的 JOIN。

要筛选的表

选择要将筛选扩展到的表名。

JOIN 筛选子句

查看用于将筛选从"已筛选的表"扩展到"要筛选的表"的 JOIN 子句。

(...)

输入或修改 JOIN 子句。

请参见

动态筛选

筛选已发布数据

联接筛选

行筛选


发布属性，订阅选项卡

"发布属性"对话框的"订阅"选项卡中有下列可用选项。

选项

订阅名称

查看订阅的名称。

类型

查看订阅类型（强制或请求）。

优先级

查看订阅的优先级。只有合并发布时才显示该选项。优先级为 0 表示订阅服务器解决数据冲突时使用发布服务器作为更改的代理服务器。只有合并发布时才显示该选项。

全部项目

查看该订阅是否包含发布中的所有项目。只有快照和事务发布时才显示该选项。

强制新建

为该发布创建新强制订阅。

属性

显示选定订阅的属性。

删除

删除选定的订阅。

重新初始化

重新初始化选定的订阅。

全部重新初始化

重新初始化所有列出的订阅。

查看冲突

查看选定订阅的同步冲突。只有合并发布及使用可更新订阅的快照和事务发布时才显示该选项。该选项不用于异类发布。

转换

启动转换已发布数据向导，它将有助于创建 DTS 包以在发布时转换数据。只有允许转换已发布数据的快照和事务发布时才显示该选项。该选项不用于异类发布。

动态快照

启动创建动态快照作业向导。只有允许动态筛选的合并发布时才显示该选项。该选项不用于异类发布。

将并发合并进程的数目限制为

将可以同时运行的合并进程数目限制为指定的数目。只有合并发布时才显示该选项。该选项不用于异类发布。

请参见

订阅发布


发布属性，订阅选项选项卡（快照或事务发布）

"发布属性"对话框的"订阅选项"选项卡上有下列可用选项。

选项

使用独立于该数据库的其它发布的分发代理程序

选择发布是否使用独立的分发代理程序，或者对来自该发布数据库的发布和对同一订阅服务器和订阅数据库的多个强制订阅是否共享一个分发代理程序。共享同一分发代理程序减少了资源要求并增加了分发服务器的性能。若想有该发布的匿名订阅或使用可连接的订阅数据库，则必须使用独立分发代理程序。

始终可以使用快照文件初始化新订阅

选择是否不间断地维护发布的当前快照，以便新订阅一经创建即被初始化。若想允许匿名订阅或可连接的订阅数据库，则必须选择该选项。

允许匿名请求订阅

选择以允许该发布的匿名订阅。

允许通过附加一个订阅数据库的复本来创建新订阅

选择是否允许通过附加一个订阅数据库的复本来创建新订阅。

允许请求订阅

选择是否允许已特别启用的订阅服务器创建对发布的请求订阅。在"发布服务器和分发服务器的属性"对话框的"订阅服务器"选项卡中启用订阅服务器。

数据转换服务

查看 DTS 在发布时是否可以用于转换数据。

请参见

复制代理程序

订阅发布

转换已发布的数据


发布属性，订阅选项选项卡（合并发布）

"发布属性"对话框的"订阅选项"选项卡上有下列可用选项。

选项

允许请求订阅

选择是否允许已特别启用的订阅服务器创建对发布的请求订阅。在"发布服务器和分发服务器的属性"对话框的"订阅服务器"选项卡中，启用订阅服务器创建请求订阅。

允许匿名订阅

选择以允许该发布的匿名订阅。

允许通过附加一个订阅数据库的复本来创建新订阅

选择是否允许通过附加一个订阅数据库的复本来创建新订阅。

集中发布服务器上的冲突报表

选择是否在布服务器上报告发所有数据冲突，或是否在发布服务器或订阅服务器上冲突发生的位置报告冲突。

允许通过动态筛选分区

指定合并发布是否允许动态筛选。

通过增加发布服务器的存储要求使网络流量最小

选择以优化同步，以便决定最新更改是否导致行移到或移出订阅服务器的分区时使网络流量最小。

请参见

动态筛选

合并复制

优化同步


发布属性，订阅选项选项卡（SQL Server 7.0 事务发布）

"发布属性"对话框的"订阅选项"选项卡上有下列可用选项。

选项

使用独立于该数据库的其它发布的分发代理程序

选择发布是否使用单独的分发代理程序。如果让发布服务器上的所有发布使用同一个分发代理程序，则可以减少分发服务器上的资源需求并提高性能。但是，如果应用程序需要即时同步或允许匿名订阅，则该发布必须有单独的分发代理程序。

始终可以使用快照文件来立即初始化新订阅

选择是否不间断地维护发布的当前快照，以便新订阅一经创建即被初始化。

允许匿名订阅服务器创建请求订阅

选择是否允许匿名订阅服务器创建对发布的请求订阅。

允许已启用的订阅服务器创建请求订阅

选择是否允许已特别启用的订阅服务器创建对发布的请求订阅。在"发布服务器和分发服务器的属性"对话框的"订阅服务器"选项卡中启用订阅服务器。

允许使用 FTP（文件传输协议）下载快照

选择已启用的订阅服务器或匿名订阅服务器是否可以使用文件传输协议 (FTP) 通过 Internet 下载快照文件。

允许即时更新订阅

查看订阅服务器是否可以修改订阅数据并将更改复制到发布服务器。


发布属性，可更新选项卡

使用快照复制或事务复制时，默认情况下复制的数据为只读；然而，能够使用可更新订阅在订阅服务器上修改复制的数据。若需要使用快照或事务复制在订阅服务器上修改数据，可根据要求选择以下选项之一。

"发布属性"对话框的"可更新"选项卡中有下列可用选项。

选项

允许即时更新订阅

查看该发布是否允许在订阅服务器上所做的数据修改立即传播到发布服务器，然后传播到其它订阅服务器。创建该发布后不能更改此属性。如果需要更改此属性，则必须删除发布并重新创建它。

允许排队更新订阅

查看该发布是否允许在订阅服务器上所做的数据修改存储在队列中并以后传播到发布服务器。创建该发布后不能更改此属性。如果需要更改此属性，则必须删除发布并重新创建它。

仅报告发布服务器上发生冲突数据的更改

指定只在发布服务器上进行冲突报告。如果清除该选项，则在发布服务器和订阅服务器上都进行冲突报告。

保留发布服务器上所做的更改

选择以指定冲突发生时，在发布服务器上所做的数据更改为冲突中的首选。

保留订阅服务器上所做的更改

选择以指定冲突发生时，在订阅服务器上生成的数据更改为冲突中的首选。

重新初始化订阅

选择以指定冲突发生时，将重新初始化订阅。

在 SQL Server 数据库中

选择以指定在订阅服务器所做的数据修改将存储在 SQL Server 数据库中。仅当启用了排队更新时，该选项才可用。

使用 Microsoft 消息队列

选择以指定在订阅服务器所做的数据修改将使用 Microsoft 消息队列存储。仅当启用了排队更新时，该选项才可用。

请参见

为复制选项制定计划

排队更新冲突检测和解决

可更新订阅


发布属性，快照选项卡

"发布属性"对话框的"快照"选项卡中有下列可用选项。

选项

本地 SQL Server 格式 – 所有订阅服务器均必须运行 SQL Server

指定快照文件将会是本地 SQL Server 格式。

字符模式格式 — 支持异类订阅服务器和使用 DTS 进行数据转换

指定快照文件将会是字符模式格式。

在生成快照的过程中不要锁定表。所有的订阅服务器均必须运行 SQL Server 7.0 版或更高版本。

选择该选项以启用并发快照处理。该选项仅对事务复制显示。生成快照时不锁定发布表。

应用快照之前执行该脚本

输入要在应用快照前执行的脚本的网络路径。

应用快照之后执行该脚本

输入要在应用快照后执行的脚本的网络路径。

(...)

浏览需要执行的脚本的位置。

请参见

应用初始快照

在应用快照之前和之后执行脚本

事务复制工作机制


发布属性，快照位置选项卡

备用快照位置使您得以将快照文件存储在默认位置以外的位置，默认位置常常位于分发服务器上。备用位置可以在另一个服务器上、网络驱动器上或可移动介质（如光盘或可移动的磁盘）上。

"发布属性"对话框的"快照位置"选项卡上有下列可用选项。

选项

在常用快照文件夹中生成快照

指定快照文件将存储在该发布服务器的默认快照文件夹中。若要修改该发布服务器的快照文件夹（影响该发布服务器上的所有发布），则连接到分发服务器，打开"发布服务器和分发服务器属性"对话框，单击"发布服务器"选项卡，选择该发布服务器，然后单击浏览按钮（"..."）。

在下列位置中生成快照

输入想要存储快照文件的文件夹位置。

(...)

浏览想要存储快照文件的文件夹位置。

压缩此文件夹中的快照文件

指定在创建快照文件时将对它们进行压缩。

订阅服务器可以使用 FTP（文件传输协议）访问该文件夹

指定可以使用 FTP 访问快照文件夹。启用该选项将使分发代理程序或合并代理程序得以使用 FTP 访问快照文件，但是必须确保指定的文件夹在分发服务器的 FTP 主目录下。

FTP 服务器名

输入 FTP 站点的服务器名。

端口

输入 FTP 站点的端口号。

从 FTP 根到该文件夹的客户机路径

输入来自 FTP 主目录的路径。该文件夹由订阅服务器上的分发代理程序或合并代理程序使用，以在连接到 FTP 服务器的根文件夹后访问快照文件夹。

登录名

输入帐户的登录名。

密码

输入帐户的密码。

确认密码

再次输入帐户的密码以确认拼写。

请参见

应用初始快照

备用快照位置

压缩快照文件

传输快照


发布属性，发布访问列表选项卡

"发布属性"对话框的"发布访问列表"选项卡上有下列可用选项。

选项

登录名

查看帐户的登录名。

类型

查看用户帐户的类型。

添加

将新登录添加到列表。只能添加在发布服务器和分发服务器上都定义了的登录名。

删除

从列表中删除选定的登录。

全部删除

从列表中删除所有登录。

说明 在已启用的订阅服务器可以连接到发布服务器之前，订阅服务器的登录必须存在于发布服务器的发布访问列表中。

请参见

发布访问列表


发布属性，状态选项卡

"发布属性"对话框的"状态"选项卡中有下列可用选项。

选项

上一次运行

查看上一次运行快照代理程序的日期和时间。

立即运行代理程序

在需要时立即运行快照代理程序。

下一次运行

查看调度快照代理程序下一次运行的日期和时间。

代理程序属性

查看快照代理程序作业的属性。

浏览快照

启动该发布服务器快照文件夹中的 Windows Explorer 以便可以查看、复制或移动当前快照文件。

服务

查看在指定服务器上运行所需的服务。

状态

查看服务的状态（已停止、正在启动或已启动）。

启动服务

在指定服务器上启动选定的服务。

刷新状态

刷新选定服务的状态。

请参见

管理和监视复制

快照代理程序


发布属性，同步伙伴选项卡

要合并发布的订阅服务器可与订阅起源所在的发布服务器以外的其它服务器进行同步。与备用伙伴进行同步为订阅服务器提供这样的能力：即便主发布服务器不可用，也可同步数据。当移动订户可以访问与可选同步伙伴的更快或更可靠的网络连接时，该功能也十分有用。

说明 若要启用和使用可选同步伙伴，则订阅服务器必须运行 SQL Server® 2000。如果指定的订阅服务器类型不运行 SQL Server 2000，则警告将订阅服务器类型选项更改为运行 SQL Server 2000 的服务器并且其中不满足该要求的现有订阅将无效。

潜在的同步伙伴可以是该发布的原始发布者、对该发布的全局订阅服务器（解决数据冲突时不使用发布服务器作为代理程序）和该发布的再次发布者。

"发布属性"对话框的"同步伙伴"选项卡上有下列可用选项。

选项

允许订阅服务器与创建订阅的发布服务器之外的其它方来进行同步

启用使用可选同步伙伴。

（复选框）

选择启用哪个潜在可选同步伙伴用于该发布中。不能禁用该发布的原始发布者。

伙伴

标识为该发布的可选同步伙伴的服务器名。

发布数据库

含有该发布的必要数据的可选同步伙伴上的发布数据库。

发布

可选同步伙伴上的发布名。

请参见

可选同步伙伴

可选同步伙伴的工作方式

合并复制


异类发布属性，常规选项卡

"异类发布属性"对话框的"常规"选项卡中有下列可用选项。

选项

发布名称

查看发布的名称。

数据库名称

查看数据库的名称。

描述

查看对发布的描述。

发布类型

查看发布类型（快照或事务）。

发布服务器名称

查看发布服务器的名称。

供应商名称

查看创建发布的供应商的名称。

分发数据库

查看发布的分发数据库的名称。

说明 只能通过编程方式创建异类发布服务器和发布的属性，而不能通过 Microsoft® SQL Server™ 用户界面设置这些属性。

请参见

异类发布服务器


异类发布属性，订阅选项选项卡

"发布属性"对话框的"订阅选项"选项卡上有下列可用选项。

选项

只允许已启用的订阅服务器创建请求订阅

查看是否允许已特别启用的订阅服务器创建对发布的请求订阅。

既允许匿名订阅服务器也允许已启用的订阅服务器创建请求订阅

查看是否允许已特别启用的订阅服务器和任何匿名订阅服务器创建对发布的请求订阅。

使用独立于该数据库的其它发布的分发代理程序

查看发布是否使用单独的分发代理程序。如果让发布服务器上的所有发布使用同一个分发代理程序，则可以减少分发服务器上的资源需求并提高性能。但是，如果应用程序需要即时同步或允许匿名订阅，则该发布必须有单独的分发代理程序。

始终可以使用快照文件来立即初始化新订阅

查看是否可以通过分发服务器上存储的快照立即初始化新订阅。

允许将 Internet 用于创建和同步订阅

查看订阅服务器是否可以在 Internet 上创建和同步其订阅。

请参见

异类发布服务器


异类发布属性，订阅选项卡

"异类发布属性"对话框的"订阅"选项卡中有下列可用选项。

选项

订阅名称

查看订阅的名称。

类型

查看订阅类型（强制或请求）。

全部项目

查看该订阅是否包含发布中的所有项目。只有快照和事务发布时才显示该选项。

新强制订阅

在一个或多个订阅服务器上创建新的强制订阅。

属性

显示订阅的属性。

删除

删除订阅。

请参见

异类发布服务器


选择目的，定义已发布数据的转换向导

"定义已发布数据的转换向导"对话框的"选择目的"选项卡上有下列可用选项。

选项

目的

选择与目的数据存储格式相匹配的数据专用驱动程序。

服务器

选择将接收转换数据的服务器名。

文件名

指定存储导入数据的路径和文件名（例如，C:\MyData.xls, \\Sales\Database\Northwind.mdb）。如果选定 Microsoft Jet 4.0 数据库作为目的，则该选项可用。

(...)

单击以浏览 Jet .mdb 数据库文件。如果选定 Microsoft Jet 4.0 数据库作为目的，则该选项可用。

使用 Windows 身份验证

选择以使用 Windows 身份验证连接到目的。该选项可用于 SQL Server 目的数据库。

使用 SQL Server 身份验证

选择以使用 SQL Server 身份验证连接到目的。该选项可用于 SQL Server 目的数据库。

登录

输入帐户的登录名。该选项可用于 SQL Server 目的数据库。

密码

输入帐户的密码。该选项可用于 SQL Server 目的数据库。

数据库

选择目的数据库。该选项只用于 SQL Server 目的数据库。

刷新

单击以刷新数据库列表。该选项只用于 SQL Server 目的数据库。

高级连接属性

显示可用的高级属性，具体取决于目的数据源。

请参见

DTS 基础

转换已发布的数据


定义转换

"定义已发布数据的转换向导"对话框的"定义转换"选项卡上有下列可用选项。

选项

源表（发布服务器）

查看发布服务器上的源表名。

表名（订阅服务器）

查看订阅服务器上的目的表名。

转换 (...)

单击转换按钮（"..."）以基于脚本创建列映射或转换。

请参见

DTS 基础

转换已发布的数据


列映射和转换

该页使您得以定义在发布数据时将进行的列映射和转换脚本。

列映射选项卡

使用该选项卡指定如何处理目的表，并指定任何新创建的表上的列特性。

选项

除去现有表并重新创建它

将数据移动到目的表之前，除去该目的表并重新创建该表。将破坏所有目的表中现有数据和全部索引。

保持现有表不变

保持目的表并且不更改它。

删除现有表中的所有数据

除去目的表中的数据。

映射

编辑表中的单元格。该表不列出目的列将出现的顺序，而在所映射的每个源列旁列出每个目的列。

对于"映射"表中的每一列，可以设置下列属性：

源
选择要向目的复制的源表的列名。在源列名上单击"<忽略>"按钮，将某个新表的目的列设置为 NULL。如果该表已存在，允许的情况下数据将为 NULL，或者如果已定义了默认值，则设置为默认值。如果将目的定义为 NOT NULL，但没有为目的列指定默认值，那么当执行包时，在源列中单击"<忽略>"按钮将导致错误。

如果复制定义为标识列的源列，则只有选定"启用标识插入"复选框才能复制数据。

如果将定义为用户定义数据类型的源列复制到新表中，则目的列的数据类型是与用户定义数据类型相对应的系统定义数据类型。

只有在创建新目的表时，才可以更改下列属性。

目的
选择目的表的列名以接收源数据。单击"<忽略>"按钮以防创建新表时在目的表中创建源列。如果要从现有表中删除列，则必须在目的列中单击"<忽略>"按钮，但还要在此对话框中选择"除去并重新创建目的表"复选框。这将重新创建含有指定列的表。该表中的现有数据和索引将丢失。
类型
为目的列选择数据类型。默认设置将目的列的数据类型与源进行匹配。
可为空
指定目的是否允许空值。
大小
按与数据类型对应的单位指定"目的"列的长度。该值仅可用于 char、varchar、nchar、nvarchar、binary 和 varbinary 数据类型。指定的大小小于源的长度会导致数据截断。
精度
输入十进制最大位数，该数字可以安置在小数点的左侧和右侧。该选项仅适用于 decimal 和 numeric 数据类型。
小数位数
输入小数点右边存储的十进制最大位数。该数字必须小于或等于"精度"列中的数字。该选项仅适用于 decimal 和 numeric 数据类型。
转换选项卡

使用此选项卡指定是否必须写入唯一转换代码。文本区域中显示的代码反映了在"列映射"选项卡中设置的列映射。

选项

直接复制源列

将源列复制到目的表，而不更改数据或源和目的映射。

使用以下脚本转换数据

在文本区域编辑脚本，以便在将列从源复制到目的之前自定义这些列。对于复杂的转换，可考虑使用 DTS 设计器，它支持 Microsoft ActiveX® 脚本。

高级

显示"高级转换属性"对话框，在其中可以设置转换标志。这些标志为防止转换和数据损失提供多种保护级别。

请参见

DTS 基础

转换已发布的数据


DTS 包的位置

"定义已发布数据的转换向导"的"DTS 包位置"页上有下列可用选项。

选项

在分发服务器上

选择以在分发服务器上保存 DTS 包。

在订阅服务器上

选择以在订阅服务器上保存 DTS 包。

使用 Windows 身份验证

选择以使用 Windows 身份验证连接到选定的服务器。该选项可用于 SQL Server 目的数据库。

使用 SQL Server 身份验证

选择以使用 SQL Server 身份验证连接到选定的服务器。该选项可用于 SQL Server 目的数据库。

登录

输入帐户的登录名。该选项可用于 SQL Server 目的数据库。

密码

输入帐户的密码。该选项可用于 SQL Server 目的数据库。

请参见

DTS 基础

转换已发布的数据


DTS 包的标识

"定义已发布数据的转换向导"的"DTS 包标识"页上有下列可用选项。

选项

包名称

指定 DTS 包的名称。

描述

为 DTS 包输入描述。

所有者密码（允许编辑和执行）

输入该 DTS 包的所有者密码。使用该密码时，可以编辑和执行 DTS 包。

用户密码（允许执行）。

输入该 DTS 包的所有者密码。使用该密码时，可以执行 DTS 包但不能对其进行编辑。

请参见

DTS 基础

转换已发布的数据


指定筛选值

"创建动态快照作业向导"的"指定筛选值"页上有下列可用选项。

选项

HOST_NAME() 的值

如果系统函数 HOST_NAME() 用于动态筛选合并发布，则输入其值。该值将识别动态快照的数据分区。

suser_sname() 的值，订阅服务器与发布服务器进行连接时使用的登录名

如果系统函数 SUSER_SNAME() 用于动态筛选合并发布，则输入其值。该值将识别动态快照的数据分区。

请参见

动态筛选

动态快照


指定快照文件位置

在"指定快照文件位置"页中，键入要保存快照文件的文件夹路径，或者单击浏览按钮（"..."），浏览文件夹位置。通过使用备用的快照位置功能，您可以在网络、可移动介质或 FTP 服务器上指定快照文件夹位置。

"创建动态快照作业向导"的"指定快照文件位置"页上有下列可用选项。

选项

快照文件夹的网络路径

输入该路径和快照文件夹的位置。不指定用于其它快照的文件夹。

(...)

浏览以指定快照文件夹位置。

请参见

动态筛选

动态快照


设置作业调度

在"设置作业调度"页上，选择"按下列调度运行作业"，然后选择"更改"以指定生成动态快照时间的调度，或选择"只在需要时运行作业"以手工控制动态快照代理程序作业。

选中"立即创建第一个快照"复选框以便立即生成动态快照。

请参见

动态筛选

动态快照


请求订阅属性，常规选项卡

"请求订阅属性"对话框的"常规"选项卡中有下列可用选项。

选项

订阅到发布

查看发布的名称。

发布服务器

查看发布服务器的名称。

发布服务器数据库

查看发布服务器数据库的名称。

描述

查看对发布的描述。

匿名

查看订阅是否为匿名。

即时更新订阅

查看订阅是否允许在订阅服务器进行即时更新。合并发布时不显示该选项。

排队更新订阅

查看订阅是否在订阅服务器允许进行排队更新，或是否在即时更新失败时将排队更新用作故障转移。合并发布时不显示该选项。

解决数据冲突时的优先级

查看解决冲突时的优先级值（"使用发布服务器的优先级"或数值）。只有合并发布时才显示该选项。快照或事务发布时不显示该选项。

请参见

请求订阅

订阅发布


请求订阅属性，同步选项卡（快照或事务发布）

"请求订阅属性"对话框的"同步"选项卡中有下列可用选项。

选项

上次更新时间

上次同步的时间和日期

分发代理程序属性

查看或修改分发代理程序属性

使用 Windows 同步管理器进行同步

使您得以使用 Windows 同步管理器对该请求订阅进行同步。

在订阅服务器上运行该代理程序

若想在订阅服务器上运行该代理程序，则启用。对于请求订阅，默认情况下选定该选项。还可以将代理程序处理卸载到分发服务器，但是仍然在订阅服务器上保持代理程序管理。

在分发服务器上运行该代理程序

若想在分发服务器上运行该代理程序，则启用。选择该选项将卸载代理程序处理，但是在订阅服务器执行代理程序管理。

分发服务器的网络计算机名

如果正在将代理程序处理卸载到分发服务器，则验证或输入分发服务器的网络计算机名。

验证代理程序

单击以验证代理程序在分发服务器上运行。

即时更新（使用 MSDTC）

选择以唤醒调用该订阅的即时更新。只有快照或事务发布和配置为使用即时更新和排队更新的订阅时才显示该选项。

排队更新（使用 Microsoft 消息队列或 SQL Server 队列）

选择以唤醒调用该订阅的排队更新。如果将发布和订阅配置为使用即时更新和排队更新，则显示该选项。

请参见

远程代理程序激活

可更新订阅

Windows 同步管理器


请求订阅属性，同步选项卡（合并发布）

"请求订阅属性"对话框的"同步"选项卡中有下列可用选项。

选项

代理程序属性

查看或修改分发或合并代理程序的属性。

查看冲突

查看订阅服务器上的冲突。

使用 Windows 同步管理器进行同步

使您得以使用 Windows 同步管理器对该请求订阅进行同步。

自动解决冲突

指定 Microsoft® SQL Server™ 2000 将根据创建发布时选择的冲突解决方法解决在合并复制同步中遇到的冲突。

交互式解决冲突（项目必须支持交互式解决）

若想使用交互式冲突解决程序解决在合并复制同步中遇到的冲突，则选择该选项。

在订阅服务器上运行该代理程序

若想在订阅服务器上运行该代理程序，则启用。对于请求订阅，默认情况下选定该选项。还可以将代理程序处理卸载到分发服务器，但是仍然在订阅服务器上保持代理程序管理。

在分发服务器上运行该代理程序

若想在分发服务器上运行该代理程序，则启用。对于请求订阅，默认情况下选定该选项。选择该选项将卸载代理程序处理，但是在订阅服务器执行代理程序管理。

分发服务器的网络计算机名

如果正在将代理程序处理卸载到分发服务器，则验证或输入分发服务器的网络计算机名。

验证代理程序

单击以验证代理程序在分发服务器上运行。

请参见

交互式冲突解决程序

合并复制冲突的检测和解决

远程代理程序激活

Windows 同步管理器


请求订阅属性，安全性选项卡

"请求订阅属性"对话框的"安全性"选项卡上有下列可用选项。

选项

模拟服务器上的 SQL Server 代理帐户

使用订阅服务器上的 SQL Server 代理程序所使用的同一 Windows 身份验证帐户。

使用该帐户的 SQL Server 身份验证

使用指定帐户的 SQL Server 身份验证登录到订阅服务器。

登录名

输入帐户的登录名。

密码

输入帐户的密码。

确认密码

再次输入帐户的密码以确认拼写。

使用与分发服务器相同的登录

使用登录到分发服务器时所使用的同一帐户登录到发布服务器。合并发布时该选项才可用。

使用预定义的链接服务器登录或远程服务器登录

指定将使用预定义的链接服务器登录或远程服务器登录。只有允许可更新订阅的快照和事务发布时才显示该选项。

模拟服务器上的 SQL Server 代理帐户

使用发布服务器上的 SQL Server 代理程序所使用的同一 Windows 身份验证帐户。只有合并发布时才显示该选项。

使用该帐户的 SQL Server 身份验证

使用指定帐户的 SQL Server 身份验证登录到发布服务器。

登录名

输入帐户的登录名。

密码

输入帐户的密码。

确认密码

再次输入帐户的密码以确认拼写。

请参见

连接到分发服务器

复制安全性


请求订阅属性，快照位置选项卡

"请求订阅属性"对话框的"快照位置"选项卡上有下列可用选项。

选项

从发布服务器的常用快照文件夹中获得快照

从默认快照文件夹位置检索快照。

从下列文件夹中获得快照

输入存储快照的文件夹。

这是用于对发布进行动态筛选的快照

指定正被检索的快照是动态快照。快照或事务发布时不显示该选项。

使用 FTP（文件传输协议）下载快照

使用 FTP 而不是常规协议将文件下载到该服务器。

临时工作文件夹

输入要用作临时工作文件夹的文件夹。若要使用 Windows 临时文件夹，请保持该选项空白。

请参见

备用快照位置

应用初始快照


请求订阅属性，快照传送选项卡 (SQL Server 7.0)

"请求订阅属性"对话框的"快照传送"选项卡上有下列可用选项。

选项

从发布服务器的常用快照文件夹中获得快照

从默认快照文件夹位置检索快照。

从下列文件夹中获得快照

输入存储快照的文件夹。

使用下列属性来用 FTP（文件传输协议）下载快照：

使用 FTP 而不是常规协议将文件下载到该服务器。

分发服务器的服务器地址

输入分发服务器上的 FTP 服务的网络地址。

登录

输入用于连接到 FTP 服务的用户名。

端口

输入分发服务器上的 FTP 服务的端口号。

密码

输入用于连接到 FTP 服务的用户密码。

确认密码

再次输入密码以确认拼写。


生成 SQL 脚本，常规选项卡

"生成 SQL 脚本"对话框的"常规"选项卡中有下列可用选项。

选项

分发服务器属性

创建分发服务器的配置脚本。如果服务器既是发布服务器也是分发服务器，则该脚本包含所有配置。如果服务器只是发布服务器，则该脚本只包含指向分发服务器的指针。

下列数据库中的发布

创建选定数据库中的发布脚本。

下列选定数据库中的请求订阅

编写选定数据库中的请求订阅脚本。

全部

选择列表中的所有数据库。

无

清除列表中的所有数据库。

启用或创建选定组件

编写在选定的数据库中启用或创建组件的步骤的脚本。如果选择了分发服务器，则还将添加分发服务器。

禁用或除去选定组件

编写在选定的数据库中禁用或除去组件的步骤的脚本。如果选择了分发服务器，则还将除去分发服务器。编写这些步骤脚本将不会除去发布或请求订阅或禁用分发服务器。

复制作业脚本创建

如果选定，则 SQL Server 企业管理器将试图创建复制作业的脚本，及分发服务器的配置、发布或请求订阅（如果指示）。但是，无权使用 msdb.dbo.sp_help_job 查看作业，SQL Server 企业管理器可能将不能创建作业脚本。通常，sysadmin 固定服务器角色的成员或作业的所有者都有权使用 msdb.dbo.sp_help_job 查看作业。该选项不用于运行 SQL Server 7.0 或更早版本的服务器。

预览

在保存脚本之前预览并对其进行修改。如果修改了预览脚本，则必须单击"预览"对话框中的"另存为"命令保存更改。


生成 SQL 脚本，文件选项选项卡

"生成 SQL 脚本"对话框的"文件选项"选项卡上有下列可用选项。

选项

MS-DOS 文本

使用 OEM 字符集创建脚本。

Windows 文本

使用 ANSI 字符集创建脚本。

国际化文本

使用 Unicode 字符集创建脚本。

将脚本追加到文件中

将脚本添加到指定文件的末尾。


代理程序配置

"代理程序配置"对话框上有下列可用选项。

选项

默认值

选择要在创建指定类型的新代理程序时使用的配置。仅当查看发布服务器和分发服务器属性的默认代理程序配置对话框时才显示该选项。

使用

选择要用于该代理程序的配置。仅当查看现有的代理程序的代理程序配置时才显示该选项。

配置文件名

查看代理程序配置的名称。

类型

查看代理程序配置的类型（用户或系统）。

描述

查看对配置的描述。

查看详细信息

显示选定配置的参数。只有当选择了系统配置时才显示该选项。

修改配置

显示用于修改选定配置的对话框。只有当选择了现有用户配置时才显示该选项。

新建配置文件

显示一个对话框用以基于选定配置创建新配置。参数的起始值是任何选定配置的值。新配置不会自动成为要使用的配置。

删除

从列表中删除选定的用户配置。不能删除系统配置。

将全部的现有 ... 代理程序更改为使用选定的配置

将所有指定类型的代理程序更改为使用默认配置。必须停止持续运行的代理程序并在使用新配置前重新启动它。仅当查看发布服务器和分发服务器属性的默认代理程序配置对话框时才显示该选项。


刷新速率和设置，常规选项卡

"刷新速率和设置"对话框的"常规"选项卡上有下列可用选项。

选项

刷新结果窗格

定期更新由复制监视器显示的详细视图。设置刷新之间相隔的秒数。

刷新服务器树

定期更新显示在服务器树中的复制监视器下的项目。设置刷新之间相隔的秒数。

不活动阈值

设置分钟数，在该时间内代理程序不记录任何活动便认为它不起作用。

匿名订阅

选择是否想要该订阅的匿名订阅和代理程序在复制监视器中显示。


刷新速率和设置，性能监视器选项卡

"刷新速率和设置"对话框的"性能监视器"选项卡上有下列可用选项。

选项

性能监视器设置的路径

为复制代理程序指定包含 Windows 性能监视器设置的文件的路径和名称。该文件必须已存在，而且复制监视器需要该文件以使用 Windows 性能监视器。


复制监视器 - 选择列，快照代理程序选项卡

 复制向导帮助

复制监视器 – 选择列，快照代理程序选项卡

"复制监视器 — 选定列"对话框的"快照代理程序"选项卡上有下列可用选项。

选项 | 描述
（复选框） | 在结果窗格中显示选定的列。
发布服务器 | 创建发布的发布服务器。
发布数据库 | 发布数据库的名称。
状态 | 代理程序上次动作的状态。
上次动作 | 上次采取的动作。
动作时间 | 采取动作的时间。
开始时间 | 此会话开始的时间。
持续时间 | 代理程序会话的持续时间。
传送速率（命令/秒） | 已传送的命令与代理程序持续时间的比率。如果代理程序仍在运行，则该值反映了自会话开始后累积的计数。
转换数 | 传送到分发服务器的事务数。
命令数 | 传送到分发服务器的命令数。
上移 | 将选定的列在列表中上移。还在结果窗格中将该列左移。
下移 | 将选定的列在列表中下移。还在结果窗格中将该列右移。
重置 | 选定所有的列并按默认顺序将其列出。


复制监视器 - 选择列，日志读取器代理程序选项卡

 复制向导帮助

复制监视器 – 选择列，日志读取器代理程序选项卡

"复制监视器 — 选定列"对话框的"日志读取器代理程序"选项卡上有下列可用选项。

选项 | 描述
（复选框） | 在结果窗格中显示选定的列。
数据库 | 发布服务器数据库名。
状态 | 代理程序上次动作的状态。
上次动作 | 上次采取的动作。
动作时间 | 采取动作的时间。
开始时间 | 此会话开始的时间。
持续时间 | 代理程序会话的持续时间。
传送速率（命令/秒） | 已传送的命令与代理程序持续时间的比率。如果代理程序仍在运行，则该值反映了自会话开始后累积的计数。
滞后时间（毫秒） | 从事务应用于发布服务器起截止到被传送到分发服务器所经过的时间（以毫秒为单位）。
命令数 | 传送到分发服务器的命令数。
转换数 | 传送到分发服务器的事务数。
命令个数的平均值 | 会话中传送到分发服务器的每个事务的平均命令数。
上移 | 将选定的列在列表中上移。还在结果窗格中将该列左移。
下移 | 将选定的列在列表中下移。还在结果窗格中将该列右移。
重置 | 选定所有的列并按默认顺序将其列出。


复制监视器 - 选择列，分发代理程序选项卡

 复制向导帮助

复制监视器 – 选择列，分发代理程序选项卡

"复制监视器 — 选定列"对话框的"分发代理程序"选项卡上有下列可用选项。

选项 | 描述
（复选框） | 在结果窗格中显示选定的列。
发布服务器 | 创建发布的发布服务器。
发布服务器 DB | 发布服务器数据库名。
订阅 | 订阅名。
类型 | 订阅类型。
状态 | 代理程序上次动作的状态。
上次动作 | 上次采取的动作。
动作时间 | 采取动作的时间。
开始时间 | 此会话开始的时间。
持续时间 | 代理程序会话的持续时间。
传送速率（命令/秒） | 已传送的命令与代理程序持续时间的比率。如果代理程序仍在运行，则该值反映了自会话开始后累积的计数。
滞后时间（毫秒） | 从将事务传送到分发服务器到将它们应用于订阅服务器，当前所经过的时间（以毫秒为单位）。
转换数 | 传送到订阅服务器的事务数。
命令数 | 传送到订阅服务器的命令数。
命令个数的平均值 | 会话中传送到订阅服务器的每个事务的平均命令数。
上移 | 将选定的列在列表中上移。还在结果窗格中将该列左移。
下移 | 将选定的列在列表中下移。还在结果窗格中将该列右移。
重置 | 选定所有的列并按默认顺序将其列出。


复制监视器 - 选择列，合并代理程序选项卡

 复制向导帮助

复制监视器 – 选择列，合并代理程序选项卡

"复制监视器 — 选定列"对话框的"合并代理程序"选项卡上有下列可用选项。

选项 | 描述
（复选框） | 在结果窗格中显示选定的列。
发布服务器 | 创建发布的发布服务器。
发布数据库 | 发布数据库的名称。
订阅 | 订阅名。
类型 | 订阅类型。
状态 | 代理程序上次动作的状态。
上次动作 | 上次采取的动作。
动作时间 | 采取动作的时间。
开始时间 | 此会话开始的时间。
持续时间 | 代理程序会话的持续时间。
传送速率（行/秒） | 已传送的行与代理程序持续时间的比率。如果代理程序仍在运行，则该值反映了自会话开始后累积的计数。
发布服务器上的插入 | 在发布服务器上应用的 INSERT 命令数。
发布服务器上的更新 | 在发布服务器上应用的 UPDATE 命令数。
发布服务器上的删除 | 在发布服务器上应用的 DELETE 命令数。
发布服务器上的冲突 | 合并过程中在发布服务器上发生的冲突数。
订阅服务器上的插入 | 在订阅服务器上应用的 INSERT 命令数。
订阅服务器上的更新 | 在订阅服务器上应用的 UPDATE 命令数。
订阅服务器上的删除 | 在订阅服务器上应用的 DELETE 命令数。
订阅服务器上的冲突 | 合并过程中在订阅服务器上发生的冲突数。
上移 | 将选定的列在列表中上移。还在结果窗格中将该列左移。
下移 | 将选定的列在列表中下移。还在结果窗格中将该列右移。
重置 | 选定所有的列并按默认顺序将其列出。


复制监视器 - 选择列，事务发布视图选项卡

 复制向导帮助

复制监视器 – 选择列，事务发布视图选项卡

"复制监视器 — 选定列"对话框的"事务发布视图"选项卡上有下列可用选项。

选项 | 描述
（复选框） | 在结果窗格中显示选定的列。
类型 | 订阅类型。
状态 | 代理程序上次动作的状态。
上次动作 | 上次采取的动作。
动作时间 | 采取动作的时间。
开始时间 | 此会话开始的时间。
持续时间 | 代理程序会话的持续时间。
传送速率（命令/秒） | 已传送的命令与代理程序持续时间的比率。如果代理程序仍在运行，则该值反映了自会话开始后累积的计数。
滞后时间（毫秒） | 对于快照或日志读取器代理程序，这是从事务应用于发布服务器起截止到传送到分发服务器所经过的时间（以毫秒为单位）。 对于订阅，这是从事务传送到分发服务器到将它们应用于订阅服务器所经过的当前时间（以毫秒为单位）。
转换数 | 对于快照或日志读取器代理程序，这是传送到分发服务器的事务数。 对于订阅，这是传送到订阅服务器的事务数。
命令数 | 对于快照或日志读取器代理程序，这是传送到分发服务器的命令数。 对于订阅，这是传送到订阅服务器的命令数。
命令个数的平均值 | 对于快照或日志读取器代理程序，这是会话中传送到分发服务器的每个事务的平均命令数。 对于订阅，这是会话中传送到订阅服务器的每个事务的平均命令数。
上移 | 将选定的列在列表中上移。还在结果窗格中将该列左移。
下移 | 将选定的列在列表中下移。还在结果窗格中将该列右移。
重置 | 选定所有的列并按默认顺序将其列出。


复制监视器 - 选择列，合并发布视图选项卡

 复制向导帮助

复制监视器 – 选择列，合并发布视图选项卡

"复制监视器 — 选定列"对话框的"合并发布视图"选项卡上有下列可用选项。

选项 | 描述
（复选框） | 在结果窗格中显示选定的列。
类型 | 订阅类型。
状态 | 代理程序上次动作的状态。
上次动作 | 上次采取的动作。
动作时间 | 采取动作的时间。
开始时间 | 此会话开始的时间。
持续时间 | 代理程序会话的持续时间。
传送速率（行/秒） | 已传送的行与代理程序持续时间的比率。如果代理程序仍在运行，则该值反映了自会话开始后累积的计数。
发布服务器上的插入 | 在发布服务器上应用的 INSERT 命令数。
发布服务器上的更新 | 在发布服务器上应用的 UPDATE 命令数。
发布服务器上的删除 | 在发布服务器上应用的 DELETE 命令数。
发布服务器上的冲突 | 合并过程中在发布服务器上发生的冲突数。
订阅服务器上的插入 | 在订阅服务器上应用的 INSERT 命令数。
订阅服务器上的更新 | 在订阅服务器上应用的 UPDATE 命令数。
订阅服务器上的删除 | 在订阅服务器上应用的 DELETE 命令数。
订阅服务器上的冲突 | 合并过程中在订阅服务器上发生的冲突数。
上移 | 将选定的列在列表中上移。还在结果窗格中将该列左移。
下移 | 将选定的列在列表中下移。还在结果窗格中将该列右移。
重置 | 选定所有的列并按默认顺序将其列出。


复制监视器 - 选择列，杂项代理程序选项卡

 复制向导帮助

复制监视器 – 选择列，杂项代理程序选项卡

"复制监视器 — 选定列"对话框的"杂项代理程序"选项卡上有下列可用选项。

选项 | 描述
（复选框） | 在结果窗格中显示选定的列。
类型 | 杂项代理程序的类型。
状态 | 代理程序上次动作的状态。
上次动作 | 上次采取的动作。
开始时间 | 此会话开始的时间。
持续时间 | 代理程序会话的持续时间。
上移 | 将选定的列在列表中上移。还在结果窗格中将该列左移。
下移 | 将选定的列在列表中下移。还在结果窗格中将该列右移。
重置 | 选定所有的列并按默认顺序将其列出。


复制监视器 - 选择列，队列读取器代理程序选项卡

 复制向导帮助

复制监视器 – 选择列，队列读取器代理程序选项卡

"复制监视器 — 选定列"对话框的"队列读取器代理程序"选项卡上有下列可用选项。

选项 | 描述
（复选框） | 在结果窗格中显示选定的列。
状态 | 代理程序上次动作的状态。
上次动作 | 上次采取的动作。
动作时间 | 采取动作的时间。
开始时间 | 会话启动的时间。
持续时间 | 代理程序会话的持续时间。
传送速率（命令/秒） | 已传送的命令与代理程序持续时间的比率。如果代理程序仍在运行，则该值反映了自会话开始后累积的计数。
滞后时间（毫秒） | 事务输入队列和在发布服务器上应用之间的滞后时间（以毫秒为单位）。
命令数 | 在会话中处理的累计命令数。
转换数 | 在会话中处理的累计事务数。
命令个数的平均值 | 命令的平均数。
上移 | 将选定的列在列表中上移。还在结果窗格中将该列左移。
下移 | 将选定的列在列表中下移。还在结果窗格中将该列右移。
重置 | 选择所有的列并按默认顺序将其列出。


将列添加到复制的表

"将列添加到复制的表"对话框上有下列可用选项。

选项

表

查看要添加列的表名。

列名

输入新列的名称。

列定义（不包括列名）

输入定义列的 SQL 语法，包括数据类型、约束和属性。列必须允许 NULL 值或有指定的默认值。

下列发布中包含该列

选择要在其中自动添加列的发布。

说明 如果正在为允许数据转换的快照或事务发布向发布表添加或除去列，则架构更改不会自动传播到订阅服务器。需要手工更新架构并重新生成复制 DTS 包；否则分发代理程序应用随后的修改时可能会失败。对于快照发布，如果 pre_creation_cmd 是 TRUNCATE 或 DELETE，而不是 DROP，则只需更新架构。

请参见

发布数据库上的架构更改


验证所有订阅

合并发布的"验证所有订阅"对话框上有下列可用选项。

选项

仅验证行计数

通过计算发布服务器上的行计数，然后将该值和订阅服务器计算的行计数比较来验证数据。

验证行计数并比较校验值以验证行数据

通过计算发布服务器上的行计数和校验值，然后将它们和订阅服务器计算的行计数和校验值比较来验证数据。因为校验值在验证大型数据集时需要大量处理器资源，所以可能需要调度验证在服务器用于复制的活动最少时进行。

验证行计数并比较二进制校验值以验证行数据（所有的订阅服务器都运行 SQL Server 2000）

通过计算发布服务器上的二进制校验值，然后将该值和在订阅服务器计算的二进制校验值比较来验证数据。

请参见

验证已复制的数据


验证订阅

事务发布的"验证订阅"对话框上有下列可用选项。

选项

验证全部的订阅

选择以验证对该发布的所有订阅。

验证下列订阅

只选择那些要对其验证数据的订阅。

验证选项

单击以查看更多的验证选项，包括是否计算行计数或校验值。

请参见

验证已复制的数据


订阅验证选项

事务发布的"订阅验证选项"对话框上有下列可用选项。

选项

根据高速缓存的表信息计算快速行计数

通过计算发布服务器上的行计数，然后将该值和在订阅服务器计算的行计数比较来验证数据。行计数基于高速缓存表信息而非直接查询表。

通过直接查询表来计算实际行计数

通过计算发布服务器上的行计数，然后将该值和在订阅服务器计算的行计数比较，并直接查询每台服务器上的表来验证数据。

计算快速行计数；如果发现差异，则计算实际行计数

通过基于高速缓存表信息计算快速行计数验证数据。如果发现更改，则通过直接查询表计算实际的行计数。

比较校验值以验证行数据

通过计算发布服务器上的校验值，然后将该值和在订阅服务器计算的校验值比较来验证数据。

该订阅服务器运行 SQL Server 2000，使用二进制校验值

通过计算在发布服务器上的二进制校验值，然后将该值和在订阅服务器计算的二进制校验值比较来验证数据。

在完成验证后停止分发代理程序

完成任何种类的验证后都停止分发代理程序。


启用订阅服务器 -- ODBC 数据源

复制向导帮助

启用订阅服务器 — ODBC 数据源

在 ODBC 数据源名称列表中选择数据源名称。"启用订阅服务器 – ODBC 数据源"对话框上有下列可用选项。

选项

登录名

输入该订阅服务器帐户的登录名（如果要求）。

密码

输入该订阅服务器帐户的密码（如果要求）。

确认密码

输入该订阅服务器帐户的密码以确认密码。

请参见

异类订阅服务器


启用订阅服务器 -- OLE DB 数据源

复制向导帮助

启用订阅服务器 — OLE DB 数据源

"启用订阅服务器 – OLE DB 数据源"对话框上有下列可用选项。

选项

添加

选择以将运行 OLE DB 数据源的服务器注册为链接服务器。

登录名

输入该订阅服务器帐户的登录名（如果要求）。

密码

输入该订阅服务器帐户的密码（如果要求）。

确认密码

输入该订阅服务器帐户的密码以确认密码。

请参见

异类订阅服务器


兼容性级别警告

"兼容级别警告"对话框对更改订阅服务器要求的兼容级别发出警告。更改订阅服务器的兼容级别能导致停用某些订阅；将需要重新初始化这些订阅。

例如，假设创建发布并指定将发布到运行 Microsoft® SQL Server™ 2000 的订阅服务器或运行 SQL Server 7.0 的订阅服务器，然后用其中的一个表项目创建发布。后来，打开发布属性并选择要作为发布的一部分发布的视图项目。

只能在运行 SQL Server 2000 的订阅服务器中发布视图项目。如果有来自运行 SQL Server 7.0 的订阅服务器中的活动订阅，且选择通过发布视图更改兼容属性，则对 SQL Server 7.0 订阅服务器的订阅将变成非活动的。

选择"不再就更改该属性进行警告"以在将来进行影响兼容性的更改时禁用兼容级别警告。

选择"不再就更改任何发布属性进行警告"以禁用在"发布属性"中的更改所产生的所有警告。


将分发服务器添加到监视器

复制监视器是 SQL Server 企业管理器的一个组件，被设计用来查看复制代理程序的状态和解决分发服务器上的潜在问题。当服务器作为分发服务器启用，且用户是 sysadmin 固定服务器角色中的一个成员时，该复制监视器将显示为 SQL Server 企业管理器中的一个节点。

可以使用复制监视器执行以下任务：

  • 查看发布服务器列表、发布以及对分发服务器支持的发布的订阅。

  • 查看已调度的复制代理程序，并监视每个代理程序的实时状态和历史记录。

  • 设置并监视与复制事件相关的警报。

  • 管理代理程序和订阅，包括启动和停止代理程序以及重新初始化订阅。

已注册的服务器

选择要添加到复制监视器的服务器。按住 CTRL 键或 Shift 键选择多个服务器。

注册服务器

单击以指定要在企业管理器中注册的服务器。


在订阅服务器上运行代理程序

"在订阅服务器上运行代理程序"对话框上有下列可用选项。

选项

订阅服务器的网络名

输入代理程序将运行的订阅服务器名。

验证订阅服务器

单击以验证该订阅服务器已准备好运行卸载的代理程序。

请参见

远程代理程序激活


附加订阅数据库

使用"附加订阅数据库"对话框以指定要附加的数据库文件。将为该订阅服务器自动创建该数据库中的订阅。

如果正在本地服务器上附加订阅数据库，则能够指定订阅数据库文件，要创建的数据库名和要创建的新数据库文件的位置。

如果正在远程服务器上附加订阅数据库，则能够指定订阅数据库文件和要创建的数据库名。将在远程服务器的默认位置自动创建数据库文件。

请参见

可连接的订阅数据库