附加订阅

可连接的订阅数据库功能使您可以在订阅服务器之间传输带有已发布数据和订阅的数据库。在数据库附加到新的订阅服务器后，新订阅服务器上的数据库将自动地接收其自身对那些发布服务器上的发布所作的请求订阅。发布必须使对订阅数据库的复制被复制和附加到另一台订阅服务器上。

在 Windows 同步管理器的"附加订阅"选项卡中，有下列可用选项。

选项

订阅数据库文件：

输入要附加到该订阅服务器的 .msf 订阅数据库文件的路径和文件名。

（"..."）

浏览要附加到该订阅服务器的 .msf 订阅数据库文件。

订阅服务器

输入订阅服务器的计算机名称。

数据库

输入将接收复制数据的订阅数据库名。

使用当前用户帐户的 Windows 身份验证

如果要使用 Windows 身份验证连接订阅服务器，请选择该选项。

使用 SQL Server 身份验证

如果要使用带有登录和密码的 SQL Server 身份验证连接订阅服务器，请选择该选项。

登录

输入与订阅服务器连接时所使用的登录。

密码

输入与订阅服务器连接时所使用的密码。

确认密码

输入密码以确认拼写。


创建匿名订阅

匿名订阅是请求订阅的一种，有关匿名订阅的订阅和订户的详细信息不予保存。如果匿名订阅发自订阅服务器，则由订阅服务器负责进行同步处理。

在 Windows 同步管理器的"创建匿名订阅"选项卡中，有下列可用选项。

选项

显示名称

输入匿名订阅的名称。

订阅服务器

输入订阅服务器的计算机名称。

数据库

输入将接收已复制数据的订阅数据库名称。

发布服务器

输入发布服务器的计算机名称。

数据库

输入作为已发布数据的源的发布数据库。

发布

输入该订阅将订阅的发布的名称。

类型

单击下拉箭头并选择发布类型（快照发布、事务性发布或合并发布）。

分发服务器

输入分发服务器的计算机名称。


创建匿名订阅（浏览 Active Directory）

匿名订阅是请求订阅的一种，有关匿名订阅的订阅和订户的详细信息不予保存。如果匿名订阅发自订阅服务器，则由订阅服务器负责进行同步处理。使用 Microsoft® Windows® 2000 Active Directory™ 服务，可查看复制对象（如发布）并订阅此发布（若允许的话）。

在 Windows 同步管理器的"创建匿名订阅"选项卡中，有下列可用选项。

选项

发布

查看在 Active Directory 中列出的发布名。

浏览（"..."）

单击以浏览在 Active Directory 中列出的发布名。

订阅服务器

输入订阅服务器的计算机名称。

数据库

输入将接收已复制数据的订阅数据库的名称。

使用当前用户帐户的 Windows 身份验证

如果要使用 Windows 身份验证连接订阅服务器，请选择该选项。

使用 SQL Server 身份验证

如果要使用带有登录和密码的 SQL Server 身份验证连接订阅服务器，请选择该选项。

登录

输入与订阅服务器连接时所使用的登录。

密码

输入与订阅服务器连接时所使用的密码。

确认密码

输入密码以确认拼写。


SQL Server 订阅属性、标识选项卡

该选项卡允许更改订阅名、为合并发布选择可选同步伙伴以及重新初始化或删除订阅。

在 Windows 同步管理器的"标识选项卡"中的"SQL Server 订阅属性"中，有下列可用选项。

选项

显示名

查看或输入匿名订阅名。

订阅服务器

查看订阅服务器的计算机名称。

订阅数据库

查看将接收已复制数据的订阅数据库的名称。

发布服务器

选择同步此订阅的发布服务器的计算机名。要合并发布的订阅服务器可与订阅起源所在的发布服务器以外的其它服务器进行同步。与备用伙伴进行同步为订阅服务器提供这样的能力：即便主发布服务器不可用，也可同步数据。当移动的订阅服务器具有访问更快或更可靠且具有可选同步伙伴的网络连接的权限时，该功能也很有用。可选同步伙伴必须具有订阅所要求的数据和架构。建议创建于备用服务器的发布是创建于起始发布服务器的发布的克隆。发布属性必须指定订阅服务器可以与其它发布服务器同步。

发布数据库

查看作为已发布数据的源的发布数据库。

发布名称

查看该订阅将订阅的发布名。

分发服务器

查看分发服务器的计算机名称。

发布类型

查看发布类型（快照发布、事务性发布或合并发布）。


SQL Server 订阅属性、其它选项卡

在 Windows 同步管理器的"其它"选项卡中的"SQL Server 订阅属性"中，有下列可用选项。

选项

登录超时

指定在超时前等待连接的时间量。

查询超时

指定在超时前查询能进行处理的时间量。

交互式地解决冲突（仅适用于支持交互式解决的项目）

选择交互式地解决冲突。Microsoft SQL Server 复制提供了一个交互式冲突解决程序，使您得以在进行按需同步时手工解决冲突。运行时激活后，该交互式冲突解决程序显示每个存在冲突的行的数据，并提供选项供查看和编辑冲突数据以及逐个解决冲突。必须启用该项目才能支持交互式解决。只对合并发布的订阅显示该选项。

自动解决冲突

选择此选项使 SQL Server 基于发布的冲突解决方法自动解决冲突。只对合并发布的订阅显示该选项。

订阅服务器更新模式

选择即时更新或排队更新作为将订阅服务器中的数据修改传播给发布服务器的方法。只对允许即时更新将排队更新作为故障转移的快照或事务发布的订阅显示该选项。如果预期发布服务器和订阅服务器相互连接，但不希望当由于系统故障导致网络断开连接时丧失在订阅服务器上进行更新的能力，则可以使用以排队更新作为故障转移的即时更新。以排队更新作为故障转移的即时更新使您得以使用即时更新并在需要时转移到排队更新。