Microsoft 复制冲突查看器，合并发布

复制冲突查看器帮助查看和解决在复制同步期间可能发生的冲突。在两个不同的服务器（例如，在发布服务器和订阅服务器上，或在两个不同的订阅服务器上）同时更改相同的数据时会发生冲突。可能会发生下列冲突：

  • 更新和插入冲突。当在两个位置更改相同的数据时发生此冲突。一个更改"入选"，而另一个"落选"。对于上述冲突，可以选择保留现有数据（入选的数据）或用冲突数据（落选的数据）重写现有数据。如果保留现有数据，则现有数据仍留在入选的副本中，并且 Microsoft 复制冲突查看器将其添加到更新或插入操作最初落选的副本中。如果用冲突数据重写现有数据，则将更改副本以包括最初落选的数据。

  • 删除冲突。此冲突在一个位置删除某行而在另一个位置更改该行时发生。

冲突由最初在创建项目时选定的冲突解决程序自动解决。当在同步期间解决冲突时，落选行的数据被写入冲突表。复制冲突查看器允许复查这些冲突记录，可能的话还可以修改数据。

使用复制冲突查看器解决冲突时，可选择接受原始解决方法或基于入选行或落选行提交数据更新。每个实例中，记录的冲突行被从冲突表中删除。其后，应当定期复查冲突以帮助减小冲突跟踪表的大小。

说明 每当使用可更新订阅（立即更新或排队更新）时，复制冲突查看器都显示可能作为合并复制的一部分而发生的冲突，或者作为快照复制或事务复制的一部分而发生的冲突。在使用可更新订阅的快照和事务发布情况中，能够使用复制冲突查看器观察冲突，但不能在合并复制同步期间发生冲突时修改解决方法。

在"复制冲突查看器"对话框中，下列选项可用于合并发布。

出现的具体选项取决于所发生的冲突类型。并非所有选项都出现在所有对话框中。日期以 ISO 日期时间格式而非本地格式显示。

选项

冲突原因

查看冲突原因（包括发生数据修改的位置）。

只显示有冲突的列

选择该选项将只显示发生数据修改冲突的列。

显示所有列

选择该选项将显示所有列，不论是否存在冲突。

显示

选择"冲突入选方"或"冲突落选方"以查看引起冲突的入选方或落选方所做的数据修改。

显示或编辑解决方法

选择"冲突入选方"或"冲突落选方"以查看或编辑入选方或落选方所做的数据修改。

保留入选更改

选择该选项将保留入选更改。将忽视落选更改，而入选更改将传播到复制拓扑中的其它服务器。

用此数据解决

选择该选项将用列出的数据解决冲突。接受这些数据并将其传播到复制拓扑中的其它服务器。

延期解决

推迟解决冲突并对该表关闭复制冲突查看器。

记录本冲突详细内容以便以后参考

在系统表中记录冲突的详细内容。


Microsoft 复制交互式冲突解决程序

交互式冲突解决程序使您得以查看、比较、编辑并选择结果数据。不能在交互式冲突解决程序中编辑的数据（例如 rowguid 数据）以只读方式显示，并且此时窗口为阴影显示。描述冲突原因的信息（例如，同时在发布服务器和订阅服务器上更新了同一行）在"冲突原因"框中显示。

冲突数据在两个对应列中显示（"显示"列和"显示或编辑解决方法"列），订阅服务器数据显示在左边的"显示"列下，而建议解决数据则显示在右边的"显示或编辑解决方法"列下。"用此数据解决"按钮始终指向显示在右侧列中的数据。

如果冲突发生在已更新数据和已删除数据之间，则冲突中已删除的数据可能无法显示。在此情况下，交互式冲突解决程序在其中一列中显示一条消息，指出该行在一个地点已删除，而在另一地点已更新，并指示建议的解决方法（冲突入选方）。

选项

冲突原因

查看冲突原因（包括发生数据修改的位置）。

只显示有冲突的列

选择该选项将只显示发生数据修改冲突的列。

显示所有列

选择该选项将显示所有列，不论是否存在冲突。

显示

选择发布服务器数据或订阅服务器数据以查看引起冲突的入选方或落选方所做的数据修改。"显示"下拉表中的起始选择基于将发布服务器数据与建议的解决方法进行比较。如果行不同，则显示发布服务器数据。如果行相同，则显示订阅服务器数据。

显示或编辑解决方法

选择发布服务器数据、订阅服务器数据或建议的解决方法以查看或编辑由发布服务器或订阅服务器所做的修改，或查看或编辑交互式冲突解决程序建议的解决方法。

用此数据解决

选择该选项将用列出的数据解决冲突。接受这些数据并将其传播到复制拓扑中的其它服务器。

用默认值解决

推迟解决冲突并对该表关闭复制冲突查看器。

用默认值解决一切冲突

推迟解决冲突并对该表关闭复制冲突查看器。

记录本冲突详细内容以便以后参考

在系统表中记录冲突的详细内容。

请参见

交互式冲突解决程序

合并复制冲突的检测和解决


Microsoft 复制冲突查看器，可更新订阅

复制冲突查看器帮助查看和解决在复制同步期间可能发生的冲突。在两个不同的服务器（例如，在发布服务器和订阅服务器上，或在两个不同的订阅服务器上）同时更改相同的数据时会发生冲突。可能会发生下列冲突：

  • 更新和插入冲突。当在两个位置更改相同的数据时发生此冲突。一个更改"入选"，而另一个"落选"。对于上述冲突，可以选择保留现有数据（入选的数据）或用冲突数据（落选的数据）重写现有数据。如果保留现有数据，则现有数据仍留在入选的副本中，并且 Microsoft 复制冲突查看器将其添加到更新或插入操作最初落选的副本中。如果用冲突数据重写现有数据，则将更改副本以包括最初落选的数据。

  • 删除冲突。此冲突在一个位置删除某行而在另一个位置更改该行时发生。

冲突由最初在创建项目时选定的冲突解决程序自动解决。当在同步期间解决冲突时，落选行的数据被写入冲突表。复制冲突查看器允许复查这些冲突记录并且可能的话修改数据。

排队更新订阅的冲突解决程序选择为：

  • 发布服务器入选并重新初始化订阅

  • 发布服务器入选

  • 订阅服务器入选

说明 每当使用可更新订阅（立即更新或排队更新）时，复制冲突查看器都显示可能作为合并复制的一部分而发生的冲突，或者作为快照复制或事务复制的一部分而发生的冲突。在使用可更新订阅的快照或事务发布的情况中，能够使用复制冲突查看器观察冲突，但不能在合并复制同步期间发生冲突时修改解决方法。

在"复制冲突查看器"对话框中，下列选项可用于合并发布。

出现的具体选项取决于所发生的冲突类型。并非所有选项都出现在所有对话框中。日期以 ISO 日期时间格式而不是以本地格式显示。

选项

冲突原因

查看

只显示有冲突的列

如果创建新存储过程项目，则输入项目的名称。如果已创建了项目，则查看项目的名称。

显示所有列

如果创建新存储过程项目，则输入项目的名称。如果已创建了项目，则查看项目的名称。

显示

如果创建新存储过程项目，则输入项目的名称。如果已创建了项目，则查看项目的名称。

显示或编辑解决方法

如果创建新存储过程项目，则输入项目的名称。如果已创建了项目，则查看项目的名称。

保留入选更改

如果创建新存储过程项目，则输入项目的名称。如果已创建了项目，则查看项目的名称。

用此数据解决

如果创建新存储过程项目，则输入项目的名称。如果已创建了项目，则查看项目的名称。

延期解决

如果创建新存储过程项目，则输入项目的名称。如果已创建了项目，则查看项目的名称。

记录本冲突详细内容以便以后参考

如果创建新存储过程项目，则输入项目的名称。如果已创建了项目，则查看项目的名称。