SQL 查询分析器概述

Microsoft® SQL Server™ 2000 SQL 查询分析器是一种图形工具，您可以使用它进行以下操作：

  • 创建查询和其它 SQL 脚本，并针对 SQL Server 数据库执行它们。（"查询"窗口）

  • 由预定义脚本快速创建常用数据库对象。（模板）

  • 快速复制现有数据库对象。（对象浏览器脚本功能）

  • 在参数未知的情况下执行存储过程。（对象浏览器过程执行功能）

  • 调试存储过程。（T-SQL 调试程序）

  • 调试查询性能问题。（显示执行计划、显示服务器跟踪、显示客户统计、索引优化向导）

  • 在数据库内定位对象（对象搜索功能），或查看和使用对象。（对象浏览器）

  • 快速插入、更新或删除表中的行。（"打开表"窗口）

  • 为常用查询创建键盘快捷方式。（自定义查询快捷方式功能）

  • 向"工具"菜单添加常用命令。（自定义"工具"菜单功能）

可以从"启动"菜单直接运行 SQL 查询分析器，或从 SQL Server 企业管理器内运行它。还可以通过执行 isqlw 实用工具从命令提示符运行 SQL 查询分析器。


使用 isqlw

可以使用 isqlw 实用工具来从命令提示符运行 SQL 查询分析器。提供一些选项用于指定服务器名称、数据库名称、登录信息、输入和输出文件及其它信息。这些选项使您得以启动预配置的 SQL 查询分析器。

请参见

isqlw 实用工具


连接 SQL Server

连接某个 Microsoft® SQL Server™ 实例以打开 SQL 查询分析器中的一个查询窗口。如果通过 SQL Server 企业管理器中的连接访问 SQL 查询分析器，则自动打开一个查询窗口。

如果未建立连接而访问 SQL 查询分析器，则显示"连接到 SQL Server"对话框，使您可以指定数据库服务器。该对话框还可从工具栏和从"文件"菜单上的"连接"命令进行访问。

连接到 SQL Server

  1. 在"连接到 SQL Server"对话框中，在"SQL Server"框中输入数据库服务器的名称。

    若要选择本地服务器，请选择"（本地）"。

    若要指定另一个服务器或该服务器的另一个实例，请在"SQL Server"框中输入该服务器名称。单击浏览（"..."）按钮以显示活动服务器的列表。服务器使用 servername\instancename 的格式列出。

  2. 单击"Windows NT 身份验证"以使用 Windows NT 身份验证进行连接。

    -或-

    单击"SQL Server 身份验证"以使用 SQL Server 身份验证进行连接。

在连接到 SQL Server 实例后，可以通过"连接到 SQL Server"对话框建立其它连接，或打开新查询。在后一种情况下，不显示"连接到 SQL Server"对话框。

在某些情况下，试图连接到运行于 SQL 查询分析器和 SQL Server 2000 所在的同一计算机上的 SQL Server 7.0 版实例时可能会失败。为避免出现该问题，请确保在试图连接前禁用 SQL Server 客户端网络实用工具中的"共享内存协议"选项。有关更多信息，请参见如何启动客户端网络实用工具 (Windows)。


使用 SQL 查询分析器窗口

SQL 查询分析器提供以下几个工作窗口：

  • "查询"窗口

  • "T-SQL 调试程序"窗口

  • "打开表"窗口
查询窗口

查询窗口的标题栏显示数据库服务器的名称、当前数据库的名称、当前登录名称和查询名称。如果已将查询保存到文件，则显示此文件的完整路径。

查询窗口由多个窗格组成。编辑器窗格是一个文本编辑器，可以在这里输入 Transact-SQL 语句。结果窗格显示返回的结果集。消息窗格显示错误信息。执行计划窗格显示执行计划的图形表示。跟踪窗格显示服务器跟踪信息。统计窗格显示统计信息。

单击某个窗格可使其成为活动窗格。此外，按 SHIFT+F6 键可在各窗格间移动。

T-SQL 调试程序窗口

"Transact-SQL 调试程序"窗口由多个窗格组成。代码窗格显示正在调试的 SQL 语句。此外，Transact-SQL 调试程序分别为局部和全局变量以及查询输出（结果集）提供独立的输出窗口。注意，对于名称以 @@ 开头的 Transact-SQL 内置函数，全局变量是传统术语。

打开表窗口

"打开表"窗口在表格中显示来自表的列和行。可以修改表格中的数据。还可以插入和删除行。

在某些情况下，试图插入、删除或更新计算列所引用的列时可能会失败。如果计算列上存在索引，则在默认情况下在编辑被引用的列之前必须启用 ARITHABORT 用户选项。若要启用 ARITHABORT，请在服务器上执行下列命令：

sp_configure 'user options', 64
RECONFIGURE
GO


SQL 查询分析器图标

下表列出"SQL 查询分析器"工具栏中显示的图标。

图标 | 描述
 | 打开一个新建的查询窗口。
 | 打开查询文件。
 | 将查询存为文件。
 | 插入模板。
{ | 剪切。
 | 复制。
 | 粘贴。
 | 清除编辑器窗格。
 | 查找。
 | 撤消。
 | 结果目标选择器。此选项有四种状态：结果为文本（显示执行计划关闭），结果为文本（显示执行计划打开），结果为表格（显示执行计划关闭），结果为表格（显示执行计划打开）。
 | 只检查语法。
 | 执行查询。
 | 取消查询。
 | 更改数据库。
 | 在 SQL 查询分析器中显示对象浏览器。
 | 显示估计的执行计划。
 | 显示"对象搜索"对话框。
 | 显示连接属性。
 | 显示/隐藏结果窗格。
 | 显示"连接到 SQL Server"对话框。
 | 管理 Windows。
 | 层叠。
 | 断开连接。
 | 断开所有连接。
 | 水平平铺。
 | 索引优化向导
 | 替换模板
 | 重复搜索。
 | T-SQL 帮助。
 | 垂直平铺。

配置工具栏

可以自定义配置工具栏。

配置工具栏

  1. 右击工具栏。

  2. 在"自定义工具栏"对话框中，添加或删除将在工具栏上显示的按钮和分隔符。使用"上移"按钮和"下移"按钮，重新排列图标次序。

将工具栏还原为默认配置

  • 单击"重置"按钮。


Transact-SQL 调试程序图标

下表列出"Transact-SQL 调试程序"工具栏中显示的图标。

图标 | 描述
 | 开始
 | 切换断点
 | 删除所有断点
 | 步入
 | 跨过
 | 异步
 | 运行至游标
 | 重新启动
 | 停止调试
 | 监视
 | 调用栈
 | 自动回滚
 | 帮助


状态栏信息

SQL 查询分析器有五个状态栏，它们提供有关"SQL 查询分析器"窗口中的活动和连接的信息。

"SQL 查询分析器"窗口 —"SQL 查询分析器"应用程序窗口状态栏显示：

  • 有关窗口中活动的常规信息，包括对所选菜单命令的描述。

  • 当前用户使用的连接总数。

  • CAPS Lock 设置。

  • NUM Lock 设置。

  • 插入/重写模式设置。

"查询"窗口 —"查询"窗口状态栏显示：

  • 当前操作的状态。

  • 当前数据库服务器名称。

  • 当前用户和服务器进程标识符 (ID)。

  • 当前数据库的名称。

  • 上一个查询或当前正在执行的查询的总的执行时间。

  • 返回的行数。当结果以表格显示并且结果窗格为活动窗格时，还显示格数。

  • 窗口内插入光标的当前位置。当结果以表格显示并且结果窗格为活动窗格时，显示当前表格单元的位置。

"对象搜索"—"对象搜索"窗口状态栏显示：

  • 当前操作的状态。

  • 当前数据库服务器名称。

  • 当前用户和服务器进程 ID。

  • 上一个搜索或当前正在执行的搜索的总的搜索时间。

  • 搜索结果中的行数。

"打开表"窗口 —"打开表"窗口状态栏显示：

  • 当前数据库服务器名称。

  • 当前用户和服务器进程 ID。

  • 当前数据库的名称。

  • 返回的行数。

  • 当前表格单元的位置。

"T-SQL 调试程序"—"Transact-SQL 调试程序"窗口状态栏显示：

  • 当前操作的状态。

  • 已连接。

  • 事务的自动回滚。

  • 窗口内插入光标的当前位置。


SQL 查询分析器的颜色代码

编辑器窗格中输入的代码按分类以不同颜色显示。下表列出默认颜色以及它们代表的分类。

颜色 | 分类
红色 | 字符串
暗红色 | 存储过程
绿色 | 系统表
暗绿色 | 注释
洋红色 | 系统函数
蓝色 | 关键字
灰色 | 运算符

说明 可以通过选择"选项"对话框上的"字体"选项卡来更改这些默认颜色。


SQL 查询分析器键盘快捷方式

下表列出 SQL Server 查询分析器提供的所有键盘快捷方式。

活动 | 快捷方式
书签：清除所有书签。 | CTRL-SHIFT-F2
书签：插入或删除书签（切换）。 | CTRL+F2
书签：移动到下一个书签。 | F2 功能键
书签：移动到上一个书签。 | SHIFT+F2
取消查询。 | ALT+BREAK
连接：连接。 | CTRL+O
连接：断开连接。 | CTRL+F4
连接：断开连接并关闭子窗口。 | CTRL+F4
数据库对象信息。 | ALT+F1
编辑：清除活动的编辑器窗格。 | CTRL+SHIFT+DEL
编辑：注释代码。 | CTRL+SHIFT+C
编辑：复制。还可以使用 CTRL+INSERT。 | CTRL+C
编辑：剪切。还可以使用 SHIFT+DEL。 | CTRL+X
编辑：减小缩进。 | SHIFT+TAB
编辑：在编辑器窗格中删除至行尾。 | CTRL+DEL
编辑：查找。 | CTRL+F
编辑：转到行号。 | CTRL+G
编辑：增大缩进。 | TAB
编辑：使选定内容为小写。 | CTRL+SHIFT+L
编辑：使选定内容为大写。 | CTRL+SHIFT+U
编辑：粘贴。还可以使用 SHIFT+INSERT。 | CTRL+V
编辑：删除注释。 | CTRL+SHIFT+R
编辑：重复上次搜索或查找下一个。 | F3 功能键
编辑：替换。 | CTRL+H
编辑：全选。 | CTRL+A
编辑：撤消。 | CTRL+Z
执行查询。还可以使用 CTRL+E （针对向后兼容性）。 | F5 功能键
SQL 查询分析器帮助。 | F1 功能键
对所选 Transact-SQL 语句的帮助。 | SHIFT+F1
浏览：在查询窗格和结果窗格之间切换。 | F6 功能键
浏览：切换窗格。 | Shift+F6
浏览：窗口选择器。 | CTRL+W
"新建查询"窗口。 | CTRL+N
对象浏览器（显示/隐藏）。 | F8 功能键
对象搜索。 | F4 功能键
分析查询并检查语法。 | CTRL+F5
打印。 | CTRL+P
结果：以表格格式显示结果。 | CTRL+D
结果：以文本格式显示结果。 | CTRL+T
结果：移动拆分器。 | CTRL+B
结果：将结果保存为文件。 | CTRL+SHIFT+F
结果：显示结果窗格（切换）。 | CTRL+R
保存。 | CTRL+S
模板：插入模板。 | CTRL+SHIFT+INSERT
模板：替换模板参数。 | CTRL+SHIFT+M
优化：显示预估执行计划。 | CTRL+L
优化：显示执行计划（切换开/关）。 | CTRL+K
优化：索引优化向导。 | CTRL+I
优化：显示客户统计 | CTRL+SHIFT+S
优化：显示服务器跟踪。 | CTRL+SHIFT+T
使用数据库。 | CTRL+U


管理 SQL 查询分析器窗口

在 SQL 查询分析器中，可自定义窗口并控制编辑器窗格和结果窗格的行为。也可指定要使用的字体，并操作结果窗格相对于编辑器窗格的大小。

指定输入和输出选项

可以通过"选项"对话框控制"查询"窗口的外观和行为，该对话框可从"工具"菜单访问。

若要自定义编辑器窗格，请使用"选项"对话框中的编辑器选项卡：

  • 设置撤消缓冲区的最大个数以及所有撤消缓冲区的最大累计大小。

  • 设置制表符大小（以空格为单位）。

  • 控制将制表符保存为制表字符还是空格。

  • 启用和禁用编辑器窗格中的文本拖动。

  • 指定默认的非 Unicode 文件的打开格式。

  • 指定结果窗格是在"查询"窗口中显示在一个单独的选项卡上（带选项卡模式），还是显示在编辑器窗格的下方（拆分器模式）。如果选择了选项卡模式，则还可以控制"结果"选项卡是否在查询执行后自动出现，以及"查询"窗口选项卡显示在窗口的顶部还是底部。

若要自定义结果窗格，请使用"选项"对话框中的"结果"选项卡：

  • 指定结果的默认目的。选项为"结果显示为文本"、"结果显示为表格"和"结果保存为文件"。

  • 指定结果集格式。

  • 指定结果集列的最大宽度。

  • 指定输出是否包含列标题，以及数字是否右对齐。

  • 指定是否随接收结果而滚动结果窗格。

  • 控制执行完成时的各种操作，如废弃结果或播放声音。
指定字体

可以指定编辑器窗格、结果文本窗格、结果表格窗格、"打开表"窗口、执行计划窗格、语句配置文件、统计窗格以及对象浏览器中的文本使用的字体。使用"选项"对话框（可从"工具"菜单访问）的"字体"选项卡来指定要使用的字体。还可以右击这些窗格，然后从上下文菜单中选择"字体"命令。

移动拆分器

当"查询"窗口被拆分时，可以更改编辑器窗格和结果窗格的相对大小，方法是将鼠标置于拆分条上并向上或向下拖动。

若要使指针置于拆分条上，请按 CTRL+B。

显示/隐藏结果窗格

如果"查询"窗口处于拆分模式，则可以通过单击工具栏上的"显示结果窗格"按钮来切换结果窗格的显示。


管理 SQL 查询分析器中的选项

可以控制当前连接及所有新建连接的 SET 选项的值。还可以为所有新建连接设置超时设置之类的常规连接选项。设置连接选项：

  • 从"查询"菜单选择"当前连接属性"命令以控制当前连接的 SET 选项。

  • 从"工具"菜单选择"选项"命令，并使用"连接属性"选项卡以控制所有新建连接的 SET 选项。

  • 从"工具"菜单选择"选项"命令，并使用"连接"选项卡以设置常规连接选项。

请参见

使用 SQL 查询分析器的 SET 选项

指定常规连接操作


使用 SQL 查询分析器中的 SET 选项

使用 SET 语句指定连接级别的选项。以下是 SQL 查询分析器中 SET 选项的默认设置。

选项 | 默认设置
Set nocount | OFF
Set noexec | OFF
Set parseonly | OFF
Set concat_null_yields_null | ON
Set rowcount | 0
Set ansi_defaults | ON
Set arithabort | ON
Set showplant_text | OFF
Set statistics time | OFF
Set statistics 10 | OFF
Set ansi_nulls | ON
Set ansi_null_dflt_on | ON
Set ansi_padding | ON
Set ansi_warnings | ON
Set cursor_close_on_commit | OFF
Set implicit_transactions | OFF
Set quoted_identifier | ON

重要 SQL 查询分析器中 Set ansi_defaults、Set arithabort 和 Set quoted_identifier 的默认设置与 Microsoft® SQL Server™ 早期版本的默认设置不同。

使用"当前连接属性"对话框指定当前连接的设置。使用"选项"对话框的"连接属性"选项卡指定所有新建连接的设置。


指定常规连接操作

可以指定常规操作的默认设置，如超时值和网络包大小。还可以指定操作的默认行为，如是否使用区域设置来显示货币、数字、日期和时间，或每次查询后是否断开连接。

使用"选项"对话框的"连接"选项卡来定义这些默认设置。


使用编辑器窗格

SQL 查询分析器中的编辑器窗格是一个文本编辑窗口，用于输入和执行 SQL 语句。若要输入代码，可以：

  • 将 SQL 语句直接键入编辑器窗格。

  • 打开某个保存的 SQL 脚本。其内容显示在编辑器窗格中以供编辑。

  • 打开模板文件。其内容显示在编辑器窗格中以供编辑。

  • 使用对象浏览器的脚本功能来将所选数据库对象的 SQL 语句复制到编辑器窗格中。


编辑 SQL 语句

SQL 查询分析器的编辑器窗格提供各种工具以帮助您创建和编辑 SQL 语句，包括标准编辑命令："撤消"、"剪切"、"复制"、"粘贴"和"全选"。

还可以查找和替换文本，将输入光标移动到特定行，插入和删除缩进，强制大小写以及插入和删除注释标记。

此外，可以从"Microsoft SQL Server 联机丛书"查看 Transact-SQL 参考主题，并将语法复制到编辑器窗格中。


移动和复制文本

该过程描述如何在编辑器窗格中移动或复制文本。

移动或复制文本

  1. 选择要移动或复制的文本。单击"全选"按钮以选择编辑器窗格中的全部文本。

  2. 单击"剪切"按钮以移动文本，或"复制"按钮以复制文本。

  3. 单击新位置以标记文本的插入点。

  4. 单击"粘贴"按钮。

或者，可以选择要移动的文本并将其拖动到新位置。

说明 可以在一个窗格内、从一个窗格到另一个窗格之间甚至从 SQL 查询分析器到其它应用程序之间进行拖放操作。此外，数据库对象可以从对象浏览器和"对象搜索"对话框拖放到查询窗口中。


撤消错误操作

该过程描述如何在编辑器窗格中撤消错误操作。

撤消错误操作

  • 单击"撤消"按钮或按 CTRL+Z 键。

每次单击"撤消"按钮，将撤消上一次操作。撤消操作的最大数目为 20。


清除编辑器窗格

该过程描述如何从编辑器窗格删除全部文本。

从编辑器窗格中删除全部文本

  • 单击"清除查询窗口"或按 CTRL+SHIFT+DEL。


查找和替换文本

这些过程描述如何在编辑器窗格中查找和替换文本。

查找文本

  1. 从"查询"菜单选择"查找"命令。

  2. 输入要查找的文本。

  3. 指定搜索方向。

  4. 对于区分大小写的搜索，选择"区分大小写"复选框。

替换文本

  1. 从"查询"菜单选择"替换"命令。

  2. 输入要查找的文本。

  3. 输入替换文本。

  4. 指定搜索方向。

  5. 对于区分大小写的搜索，选择"区分大小写"复选框。

  6. 通过单击"查找下一个"按钮，然后单击"替换"按钮来逐个替换出现所搜索文本的位置。

    -或-

    通过单击"全部替换"按钮来替换出现所搜索文本的全部位置。


转到行号

本过程描述如何在编辑器窗格中转到某个行号。

转到行号

  1. 从"编辑"菜单单击"转到行"命令。

  2. 在"转到"对话框中输入行号。

如果所指定行号大于可用的总行数，则目的将为窗口的底部。


使用书签

可以在编辑器窗格的左侧插入书签以帮助在代码中定位行。

插入或删除书签

  • 若要在当前行插入书签，请按 CTRL+F2。

    -或-

    若要在当前行删除书签，请按 CTRL+F2。

  • 若要删除所有书签，请按 CTRL+SHIFT+F2。

在书签之间移动

  • 按 F2 移动到下一个书签。

    -或-

    按 SHIFT+F2 移回到上一个书签。


强制文本的大小写

本过程描述如何在编辑器窗格中强制文本的大小写。

强制文本的大小写

  1. 选择要更改其大小写的文本。

  2. 若要使所选文本为小写，请按 CTRL+SHIFT+L。

    -或-

    若要使所选文本为大写，请按 CTRL+SHIFT+U。


添加和删除缩进

这些过程描述如何在编辑器窗格中更改缩进。

缩进一行文本

  1. 在要缩进文本的左边设置插入点。

  2. 按 TAB。

从一行文本删除缩进

  1. 在文本的左边设置插入点。

  2. 按 SHIFT+TAB。

为文本块添加或删除缩进

  1. 选择文本。

  2. 按 TAB 以缩进整块文本。

    -或-

    按 SHIFT+TAB 删除整块文本的缩进。


添加和删除注释

这些过程描述如何在编辑器窗格中添加和删除注释。

注释文本

  1. 选择要注释的文本。

  2. 按 CTRL+SHIFT+C。

删除注释标记

  1. 选择要从中删除注释标记的文本。

  2. 按 CTRL+SHIFT+R。


查看 Transact-SQL 帮助

该过程描述如何查看 Transact-SQL 帮助。

查看 Transact-SQL 帮助

  • 在编辑器窗格内，选择 Transact-SQL 语句、函数、存储过程或者其它 Transact-SQL 元素，并按 SHIFT+F1 查看有关选定文本的信息。


使用 SQL 文件

可以保存查询定义和其它 SQL 脚本以便再次使用。这些文件的默认扩展名为 .sql。

还可以创建模板，它们是用于在数据库中创建对象的样本脚本。模板文件的扩展名是 .tql。


打开 SQL 文件

该过程描述如何在编辑器窗格中打开 SQL 脚本并显示代码。

在编辑器窗格中打开脚本并显示代码

  1. 打开一个"查询"窗口

  2. 单击工具栏上的"加载 SQL 脚本"按钮。

  3. 在"打开查询文件"对话框中，指定要打开文件的位置和名称。

  4. 如有必要，指定文件格式。如果指定"自动"，则自动使用适当的文件格式。


将 SQL 语句保存到文件

该过程描述如何将编辑器窗格的内容保存到文件。

将编辑器窗格的内容保存到文件

  1. 使编辑器窗格成为活动窗格。

  2. 单击工具栏上的"保存"命令。

  3. 如果文件从未保存过，则显示"保存查询"对话框。指定位置、文件名、文件扩展名和文件格式。

还可以将结果集保存到文件，方法是：在保存以前使结果窗格成为活动窗格，或在执行查询以前从"查询"菜单选择"结果保存为文件"命令。


在 SQL 查询分析器中使用模板

模板是包含 SQL 脚本的样本文件，帮助您在数据库中创建对象。Microsoft® SQL Server™ 2000 在 Templates\SQL Query Analyzer 目录中提供各种模板。所提供的模板包括创建数据库、表、视图、索引、存储过程、触发器、统计和函数的模板。此外，还有一些模板帮助管理扩展属性、链接服务器、登录、角色和用户，以及帮助声明和使用游标。

与 SQL 查询分析器一起提供的模板脚本包含一些参数以帮助您自定义代码。模板参数定义使用以下格式：

<parameter_name, data_type, value>

其中

  • parameter_name 是脚本中参数的名称。

  • data_type 是参数的数据类型。

  • value 是要替换脚本中参数每次出现时的值。

使用"替换模板参数"对话框以将值插入到脚本中。

说明 任何时候代码中使用了参数定义，都可以使用"替换模板参数"对话框指定值。比如，当执行来自对象浏览器的函数时，写入编辑器窗格的函数包含函数中所有参数的参数定义。因此，可以使用"替换模板参数"对话框以指定参数值。

使用模板

  1. 打开"查询"窗口。

  2. 单击工具栏上的"插入模板"按钮。

  3. 在"插入模板"对话框中，指定要打开的模板。根据默认，模板文件具有扩展名 .tql。

  4. 当编辑器窗格中显示该模板时，从"编辑"菜单选择"替换模板参数"命令。

  5. 在"替换模板参数"对话框中，指定参数值。

  6. 若要将指定值插入到编辑器窗格中的脚本中，请单击"全部替换"按钮。

  7. 使用另一个名称保存文件。


在 SQL 查询分析器中运行查询

在 SQL 查询分析器中运行查询的方式有多种。可以执行输入或加载到编辑器窗格中的 SQL 语句，或使用执行存储过程的各种可用方法。

在 SQL 查询分析器中执行 SQL 语句

在 SQL 查询分析器中执行存储过程

取消运行时间过长的查询

在 SQL 查询分析器中解决错误

在 SQL 查询分析器中返回结果集


在 SQL 查询分析器中执行 SQL 语句

可以在 SQL 查询分析器中执行完整脚本或只执行选定的 SQL 语句。

  • 通过在编辑器窗格中创建或打开脚本并按 F5 来执行完整的脚本。

  • 通过突出显示编辑器窗格中的代码行并按 F5 来只执行选定的 SQL 语句。

还可以方便地执行包含内置函数的 SELECT 语句。右击对象浏览器中的函数，选择"在新窗口中编写对象脚本"命令，并选择"执行"命令。包含该函数的 SELECT 语句显示在新的编辑器窗格中。如果函数包含参数，则它们以模板参数格式显示。按 CTRL+SHIFT+M 以显示"替换模板参数"对话框并为函数参数提供值。按 F5 执行 SELECT 语句。


在 SQL 查询分析器中执行存储过程

SQL 查询分析器提供多种方式以执行存储过程。

  • 可以在编辑器窗格中直接输入要执行存储过程的语句并按 F5 键。如果执行存储过程的语句为批处理中的第一项，则可以省略 EXECUTE（或 EXEC）语句；否则需要 EXECUTE 语句。

  • 可以右击对象浏览器或"对象搜索"对话框中的存储过程，然后选择"打开"命令以调用"执行过程"对话框。该对话框列出所有参数，并提供一个文本框，在其内指定参数值。


取消运行时间过长的查询

  • 单击"查询"菜单中的"取消执行查询"命令，或按 ALT+BREAK。取消提示出现在状态栏中的消息窗格内。


在 SQL 查询分析器中解决错误

SQL 查询分析器提供多种工具以帮助您防止和解决错误。

  • 使用编辑器窗格中的颜色代码以帮助消除错误。

    以默认颜色为例，如果键入一个关键字，而它不以蓝色显示，则该关键字可能拼错了。如果许多代码都以红色显示，那么可能遗漏了字符串右边的引号。

  • 若要在不执行代码的情况下分析语法，请单击"分析"按钮。

  • 如果发生了错误，请双击错误信息以在代码中定位包含该错误的行。

  • 若要调试存储过程，请使用 Transact-SQL 调试程序。


在 SQL 查询分析器中返回结果集

SQL 查询分析器提供多种方式来返回结果集。

  • 在"查询"窗口内，可以选择结果窗格应显示在编辑器窗格下方，还是显示在独立的"结果"选项卡上。

  • 可以控制结果窗格显示为文本还是一个或多个表格。

  • 可以选择将结果保存到文件。

  • 如果在对象浏览器中或从"对象搜索"对话框打开一个表，则结果将显示在"打开表"窗口中。可以在"打开表"窗口中执行插入、更新和删除操作。


在 SQL 查询分析器中输入数据

除"查询"窗口的编辑器窗格（可以在该窗格内键入 INSERT、UPDATE 和 DELETE 语句）外，SQL 查询分析器还提供"打开表"窗口，它是用于查看或修改数据的一个图形界面。

从对象浏览器或"对象搜索"对话框，右击包含要更新数据的表，并从上下文菜单选择"打开"命令。

插入行

  1. 右击"打开表"窗口，然后从上下文菜单选择"添加"命令。

    窗口底部插入一个空行。

  2. 在新行的各列中填入数据。

更新行

  1. 定位要修改的行并输入更改内容。如果右击正在编辑的单元，则可以使用上下文菜单中的"撤消"、"剪切"、"复制"、"粘贴"、"删除"和"全选"命令。

  2. 离开该行以保存更改。

删除行

  • 右击要删除的行并从上下文菜单选择"删除"命令。


在 SQL 查询分析器中打印

可以打印编辑器窗格的内容，或者结果窗格的内容（如果指定了文本输出的话）。

在 SQL 查询分析器中打印

  • 单击要打印的窗格并从"文件"菜单中选择"打印"命令。


分析查询

SQL 查询分析器最重要的功能是那些帮助分析查询以获得优化性能的工具。这些工具包括：

  • 显示查询执行计划。

  • 显示估计的执行计划。

  • 显示服务器跟踪。

  • 显示客户统计。

  • 索引优化向导。

请参见

查看查询执行计划

查看估计的查询执行计划

查看服务器跟踪信息

查看客户统计信息

优化索引


查看查询执行计划

  1. 如果查询窗格中无查询，请打开一个保存的查询或创建一个新查询。

  2. 在"查询"菜单上，单击"显示执行计划"命令或按 CTRL+K 以将其切换为打开。

    说明 该选项仅当连接到 Microsoft® SQL Server™ 7.0 版或更高版本的实例时才可用。

  3. 通过按 F5 或在"查询"菜单上单击"查询执行"命令来执行查询。

  4. 将光标放置在图形元素上以显示其它执行计划信息。


查看估计的查询执行计划

  1. 如果查询窗格中无查询，请打开一个保存的查询或创建一个新查询。

  2. 在"查询"菜单上，单击"显示预计执行计划"或按 CTRL+L。

  3. 如果有引用的临时对象，则不显示任何估计的查询执行计划。

    说明 该选项仅当连接到 Microsoft® SQL Server™ 7.0 版或更高版本的实例时才可用。

  4. 将光标放置在图形元素上以显示其它执行计划信息。


查看服务器跟踪信息

  1. 在查询窗格中打开一个保存的查询或创建一个新查询。

  2. 在"查询"菜单上单击"显示服务器跟踪"命令。

  3. 通过按 F5 或从菜单单击"查询执行"命令来执行查询。

  4. 单击"跟踪"选项卡以显示跟踪信息。

有关事件的更多信息，请参见使用 SQL 事件探查器事件种类进行监视。


查看客户统计信息

  1. 在查询窗格中打开一个保存的查询或创建一个新查询。

  2. 在"查询"菜单上单击"显示客户统计"命令。

  3. 按 F5 键或在"查询"菜单中单击"查询执行"命令以执行查询。

  4. 单击"统计"选项卡以显示统计信息。

请参见

查询窗口统计窗格


优化索引

  1. 如果查询窗格中无查询，请打开一个保存的查询或创建一个新查询。

  2. 选择要优化的查询文本。

  3. 在"查询"菜单上，单击"索引优化向导"命令或按 CTRL+I。若要执行索引优化，您必须是 sysadmin 固定服务器角色的成员之一。

    说明 该选项仅当连接到 Microsoft® SQL Server™ 7.0 版或更高版本的实例时才起作用。

  4. 按照"索引优化向导"中的指导进行操作。在"指定工作负荷"页上，选择"查询分析器选择"以在"查询"窗口中优化查询。继续在向导页中进行操作。该向导为查询推荐最优的索引配置。

  5. 当完成优化索引所需的步骤后，可以立即应用推荐、调度作业以在特定的时间应用推荐，或以 Transact-SQL 脚本的形式将推荐保存到文件。


使用对象浏览器

对象浏览器是一种基于树的工具，用于浏览数据库中的对象。除浏览外，对象浏览器还提供对象脚本、存储过程执行以及对表和视图对象的访问。

对象浏览器由两个窗格组成：

  • 对象窗格，列出数据库内的对象和公用对象，如内置函数和基本数据类型。

  • 模板窗格，提供对 Templates 目录的访问。

请参见

从对象浏览器向代码添加对象

从对象浏览器查询

从对象浏览器运行存储过程

从对象浏览器编辑对象

使用对象浏览器中的脚本功能

从对象浏览器设置扩展属性


从对象浏览器向代码添加对象

可以使用对象浏览器的拖放功能向编辑器窗格中的代码添加对象。

添加一个对象

  1. 在对象浏览器中展开一个服务器，再展开一个数据库。

  2. 展开一个文件夹，单击对象，然后将对象拖至编辑器窗格内。

比如，若要生成一个查询，此查询要在 Categories 表中选定 CategoryID 列，则请在编辑器窗格内键入 SELECT，并打开 Northwind 数据库的文件夹。将 CategoryID 列拖到编辑器窗格内 SELECT 语句的后面。

添加文件夹中的所有对象

  1. 在对象浏览器中展开一个服务器，再展开一个数据库。

  2. 单击文件夹，然后将文件夹拖至编辑器窗格。

比如，若要生成一个选择列表，此列表要包含 Category 表的全部列，则请从 Category 表中将 Columns 文件夹拖到编辑器窗格。


从对象浏览器查询

可以使用对象浏览器在 SQL 查询分析器中执行 SELECT * 查询。

从对象浏览器执行查询

  1. 在对象浏览器中展开一个服务器，再展开一个数据库。

  2. 展开一个文件夹，右击表，然后单击"打开"命令。

查询结果将显示在一个独立的结果窗口中。


从对象浏览器运行存储过程

使用对象浏览器运行存储过程并获得输入参数的提示。

运行存储过程

  1. 在对象浏览器中展开一个服务器，再展开一个数据库。

  2. 展开 Stored Procedures 文件夹，右击存储过程，然后单击"打开"命令以显示"执行过程"对话框。

  3. 单击"参数"列表中的一个参数，然后在"值"框中键入一个值。用此方法为要使用的每个参数输入值。

  4. 单击"执行"按钮。

此存储过程的 EXECUTE 语句将在编辑器窗格中显示，结果将在结果窗格中显示。


从对象浏览器编辑对象

可以使用对象浏览器改变数据库中的对象。

从对象浏览器编辑一个对象

  1. 在对象浏览器中展开一个服务器，再展开一个数据库。

  2. 右击对象，然后单击"编辑"命令。

    在编辑器窗格内会显示选定对象的 ALTER 语句。比如，如果选定对象是一个存储过程，那么将提供一条 ALTER PROCEDURE 语句。

  3. 使用 ALTER 语句来指定更改内容。

  4. 执行 ALTER 语句。

从对象浏览器删除对象

  • 右击对象，然后单击"删除"命令。

与"编辑"命令不一样，"删除"命令不会显示用来进行修改和执行的 DROP 语句。相反，要求确认是否确实要删除对象。如果单击"确认"按钮，对象即被删除。


使用对象浏览器中的脚本功能

对象浏览器许多所显示的对象提供了脚本功能。所支持的操作根据对象的类型而变化。比如，表对象能够生成包含 SELECT 语句、数据定义语句（如：CREATE）或者数据操作语句（如：INSERT）的脚本。视图则只能生成 SELECT 语句或者数据定义语句。

有关脚本的目的，共有 3 个选项：

  • 在新窗口中编写对象脚本

  • 在文件中编写对象脚本

  • 在剪贴板中编写对象脚本

对任脚本目的可指定下列这些操作。

操作 | 描述
创建 | 为对象生成一个 CREATE 语句。
更改 | 生成一个 ALTER 语句。
除去 | 生成一个 DROP 语句。
选择 | 生成一个包含选择列表中的所有表列 SELECT 语句。
插入 | 生成一个 INSERT 语句，并为要插入的值提供占位符。
更新 | 生成一个 UPDATE 语句，并且为值和搜索条件提供占位符。
删除 | 生成一个 DELETE 语句，并且为搜索条件提供占位符。
执行 | 为存储过程生成一个 EXECUTE 语句。


从对象浏览器设置扩展属性

扩展属性是可在数据库中的各种对象上进行定义的属性。对象浏览器提供了对"扩展属性"对话框的访问。通过此对话框，可以查看选定对象的现有属性，或者定义新的属性。

查看或定义对象的扩展属性

  1. 在对象浏览器中展开一个服务器，再展开一个数据库。

  2. 右击对象，然后单击"扩展属性"命令。

若要定义一个新属性，请在"名称"框内输入属性的名称，在"值"框内输入属性值。


使用对象搜索

使用对象搜索功能来查找当前数据库服务器中的对象。可通过工具栏上的按钮和"工具"菜单中的"对象搜索"命令使用对象搜索。

重要 当与 SQL Server 6.5 实例相连时，对象搜索功能不可用。

查找对象

  1. 单击"对象搜索"按钮以显示"对象搜索"对话框。

  2. 在"对象名称"框中，键入要查找对象的名称，或使用"全部"以查找指定对象类型的所有对象。

  3. 对于区分大小写的搜索，选择"区分大小写"复选框。区分大小写的搜索仅当数据库服务器区分大小写时才有效。

  4. 在"数据库"列表中，单击特定数据库的名称或单击"全部"。

  5. 在"命中限制"对话框中，输入搜索命中的最大个数。

  6. 在"对象类型"复选框中，选择要查找的一个或多个对象类型。

  7. 若要定位与选定对象类型相关的扩展属性，请选择"扩展属性"。
    • 可以搜索所有属性名称或某个特定名称。

    • 可以搜索所有属性值或某个特定值。
  8. 单击"开始查找"以执行搜索。

结果显示在对话框的下部。

说明 可以将结果中的一个或多个对象拖动到"查询"窗口中。也可以右击结果以显示上下文菜单，从而使您得以在"打开表"窗口中打开选定的对象，或执行各种编辑和脚本编写活动。


使用快捷方式

SQL 查询分析器提供各种快捷方式以获得信息和自定义工作环境。可以快速检索有关当前数据库中的对象的信息，创建频繁运行的查询或存储过程的自定义快捷方式，以及向"工具"菜单添加命令。

请参见

获取数据库对象信息

定义自定义快捷方式

自定义工具菜单


获取数据库对象信息

在"帮助"菜单上，单击"数据库对象信息"命令以查看当前数据库的 sp_help 信息。

查看数据库中特定对象的信息

  1. 在查询窗格中键入对象名称并将其突出显示。

  2. 在"帮助"菜单上单击"数据库对象信息"命令。

信息显示在结果窗格中。


定义自定义快捷方式

SQL 查询分析器支持可自定义键盘快捷方式，以用于执行 Transact-SQL 语句。不能修改下列预定义的键组合：

组合键 | 定义
ALT+F1 | sp_help
CTRL+1 | sp_who
CTRL+2 | sp_lock

定义查询快捷方式

  1. 单击"工具"菜单的"自定义"命令。

  2. 在"自定义"对话框中单击"自定义"选项卡。

  3. 在组合键旁边的列内键入要执行的 Transact-SQL 语句。语句长度的最大值可为 1024 个字符。

    比如，以下代码执行 sp_autostats 存储过程，为 Northwind 数据库中的 Customers 表启用自动统计。

    USE Northwind EXEC sp_autostats 'Customers', 'ON'

    本示例对 Customers 表执行 SELECT 语句。

    SELECT * from Northwind..Customers

删除所有可修改的快捷方式

  • 单击"全部重置"按钮。


自定义工具菜单

可以通过向"工具"菜单添加命令来自定义 SQL 查询分析器。比如，可以添加"记事本"或 osql 之类的可执行文件或文档的名称。

向"工具"菜单添加命令

  1. 单击"工具"菜单的"自定义"命令。

  2. 在"自定义"对话框中单击"工具"选项卡。

  3. 单击"添加"按钮。在"菜单内容"列表中，输入将出现在"工具"菜单上的名称。可为可执行文件名称或者要打开文档的名称。使用向上和向下箭头在菜单中放置名称。

  4. 在"命令"框中，输入要执行文件的名称和位置。可以使用浏览（"..."）按钮查找该文件所驻留的目录。

    比如，要执行 osql，请输入：

    C:\Program Files\Microsoft SQL Server\80\Tools\Binn\osql.exe

    如果使用的是 Microsoft® Windows NT® 并希望指定记事本，请输入：

    C:\WINNT\Notepad.exe
  5. 在"参数"框中输入命令的任何参数。比如，如果命令是 osql，可以指定选项 -Usa。

    如果命令是"记事本"并且希望菜单命令调用一个新建文档，则保留该框为空。如果希望在"记事本"中打开某个特定文档，则在这里指定文档的名称。

  6. 在"初始目录"框中，输入命令自哪个位置开始执行。


使用 Transact-SQL 调试程序

SQL 查询分析器附带 Transact-SQL 调试程序，使您可以控制和监视存储过程的执行。该调试程序支持传统功能，如设置断点、定义监视表达式和单步执行过程。

SQL 查询分析器中的 Transact-SQL 调试程序支持对 Microsoft® SQL Server™ 2000、SQL Server 7.0 版和 SQL Server 6.5 版 Service Pack 2 进行调试。

说明 建议不要在生成服务器上使用 Transact-SQL 调试程序。在步骤执行模式下，调试程序会锁定其它进程所需的某些系统资源。

请参见

Transact-SQL 调试程序

Transact-SQL 调试程序图标


启动调试程序

T-SQL 调试程序只能在 SQL 查询分析器内运行。一旦启动，调试界面将占据该应用程序内的一个窗口。

启动调试程序

启动调试程序有两种方法。每种方法都要求目标过程创建和存储于 SQL Server 数据库中。第一种方法使用对象浏览器。第二种方法依靠对象搜索工具。

从对象浏览器启动调试程序

  1. 在"工具"菜单上单击"对象浏览器"命令。

  2. 在"对象浏览器"对话框中，单击"对象"选项卡。

  3. 双击以打开在其中存储该过程的数据库。

  4. 双击以打开 Stored Procedures 文件夹。

  5. 右击要调试的存储过程。出现一个上下文菜单。

  6. 从上下文菜单中选择"调试"命令。

从对象搜索启动调试程序

  1. 在"工具"菜单上单击"对象搜索"命令。

  2. 在"对象搜索"窗口中，输入所需的适当搜索参数以定位所查找的过程。单击"开始查找"按钮以显示相匹配的过程。

  3. 在"对象搜索"窗口的结果窗格中，右击希望调试的存储过程的名称。出现一个上下文菜单。

  4. 从上下文菜单中选择"调试"命令。

一旦启动了 Transact-SQL 调试程序，将出现一个对话框，提示您设置输入参数变量的值。并非强制在此时设置这些值。还可以在调试程序界面出现时对这些值进行修改。在该对话框中，单击"执行"可继续会话。

说明 SQL 查询分析器不支持调试程序的多个实例。试图调试第二个存储过程时，系统将提示您取消当前活动的调试会话。

由于连接限制，调试程序窗口在前台时不能创建新的查询。若要创建新的查询，必须将某个现有查询窗口调到前台或打开到数据库的新连接。


界面组件

Transact-SQL 调试程序界面由工具栏、状态栏和一系列窗口窗格组成。很多组件都具有双重用途，既作为控件又作为监视机制。

过程完成或终止以后，某些组件只有有限的功能可以使用。比如，当过程未运行时不能在任何一个变量窗口中设置断点或在条目间滚动。

工具栏

工具栏位于调试程序界面的顶部。它由一系列按钮组成，可用于控制执行过程的启动、停止和增量进展。

源代码窗口

源代码窗口显示来自当前在作用域中的过程的代码。黄色箭头指出要执行的下一条语句。红色项目符号标记的语句前设置了断点。

参数变量窗口

参数变量窗口显示当前过程的各个输入和输出变量的名称、值和类型。当运行中的过程设置或修改其变量时，这里显示的值进行相应的更改。

参数变量可以在过程执行的任何时候进行手工修改。单击某个值以更改和键入替换文本。

局部变量窗口

局部变量窗口的行为与参数变量窗口相似。默认情况下，该窗口只包含当前作用域内定义的变量。

当在嵌套过程调用内执行时，仍可能访问更高级别过程的作用域。单击调用堆栈窗口中列出的任意过程名称以查看或修改调用中的过程的元素。

调用堆栈窗口

调用堆栈窗口显示活动的或未完成的过程调用的列表。列表内的顶部条目称为当前过程。该过程决定了局部和参数变量窗口中的变量的作用域。

当存储过程执行一系列嵌套过程调用时，调用堆栈窗口帮助跟踪该存储过程的操作。比如，第一个过程可以调用第二个过程，而该过程又可以依次调用第三个过程。这样的嵌套调用会使调试过程变得复杂。调用堆栈窗口记录以前的调用和当前的过程。

当前执行过程可由源代码窗口中的黄色箭头标识。为查看父过程调用当前过程的点，请单击调用堆栈窗口中当前过程下方列出的名称。这样源代码窗口将显示父过程的源代码，且有一个绿色箭头指向调用当前过程的代码行。

结果文本窗口

结果文本窗口用于显示存储过程的任何输出。该区域还用于显示服务器错误信息。

状态栏

状态栏位于调试程序界面的底部，包含有关当前会话的只读信息。它列出执行的当前状态（运行中、已完成或已终止）、调试程序所连接到的主机、作为什么用户登录以及光标在源代码窗口内的位置。


SQL 查询分析器对话框和窗口

本节提供有关"SQL 查询分析器"对话框的信息：

  • 连接到 SQL Server

  • 新建索引

  • 创建统计

  • 当前连接属性

  • 自定义

  • 自定义工具栏

  • 编辑现有索引

  • 编辑 Transact-SQL 脚本

  • 执行过程

  • 管理索引

  • 管理统计

  • 新建

  • 对象搜索

  • 选项

  • 选择数据库

  • T-SQL 调试程序

  • 模板参数值

  • 更新统计

  • 窗口选择器


连接到 SQL Server 对话框

使用"连接到 SQL Server"对话框连接到 Microsoft® SQL Server™ 数据库。

选项

SQL Server

指定要连接的 SQL Server 实例的名称。在 Microsoft Windows NT® 中，必须具有要求的系统权限和权利，才能在本地或远程启动 SQL Server。在运行 Microsoft Windows® 95 或 Windows 98 操作系统的计算机上，每个用户可在本地启动 SQL Server。操作系统能防止用户远程启动 SQL Server。

启动 SQL Server（如果它是停止的）

启动 SQL Server 的一个实例（如果它是停止的）。

（...）

显示网络中活动 SQL Server 数据库服务器列表。此列表只显示运行于 Windows NT 平台的 SQL Server 实例。该功能不适用于运行 Microsoft Windows 95 或 Windows 98 操作系统的计算机。

通过下列方式连接：

指定在连接到数据库服务器时，所采用的身份验证方式。

Windows NT 身份验证 | 指定 SQL Server 使用 Windows NT 用户信息来验证用户身份。此选项只有连接到运行于 Windows NT 的 SQL Server 实例时才可用。客户必须属于 Windows NT 域或者工作组的一部分。用户须经 Windows NT 用户身份验证后才能被授予访问权。
SQL Server 身份验证 | 指定使用标准 SQL Server 安全验证。对于 Microsoft Windows 95 或 Windows 98 操作系统上的 SQL Server 实例，该选项是默认值且是唯一的可用选项。对于 Windows NT 上的 SQL Server 实例，该选项是可选选项。用户只有在向 SQL Server 注册登录资料后，才能进行登录。
登录名 | 指定 SQL Server 认可的登录。
密码 | 指定登录名所用的密码。


创建缺少的统计对话框

使用"创建缺少的统计"对话框创建缺少的统计。SQL 查询分析器建议对非索引列使用附加索引和统计，这将改善查询优化器的性能，以高效处理查询。特别地，SQL 查询分析器显示缺少的统计，以便创建这些统计。

选项

统计名称

查看选定列中缺少的统计名称。

列名

查看缺少指定统计的列。

列类型

查看缺少指定统计的列类型。

要采样的数据量

指定要为统计采样的数据量。

默认值 | 为选定统计选择要采样的默认数据量。
采样所有数据 | 为选定统计指定采样所有数据。
采样 % 的数据 | 为选定统计指定要进行采样的数据采样率。

不自动重新计算统计

指定不自动重新计算统计。不推荐使用本选项。

编辑 SQL

打开"编辑 Transact-SQL 脚本"对话框，从中可编辑 CREATE STATISTICS 语句。


创建统计对话框

使用"创建统计"对话框在"管理统计"对话框中所指定的数据库和表中定义统计。

选项

名称

指定要创建统计的名称。

列

指定要在新建统计中包括的列。

数据类型

查看列的数据类型。

要采样的数据量

指定要为统计采样的数据量。

默认值 | 选择要为统计采样的默认数据量。
采样 % 的数据 | 指定要为统计进行采样的数据采样率。
采样所有数据 | 指定要为统计采样所有数据。

不自动重新计算统计

指定不自动重新计算统计。不推荐使用本选项。

编辑 SQL

打开"编辑 Transact-SQL 脚本"对话框，从中可编辑 CREATE STATISTICS 语句。


当前连接属性对话框

使用"当前连接选项"对话框指定当前连接的设置。

说明 若要为所有新建连接指定连接属性，请使用"选项"对话框上的"连接属性"选项卡。

选项

Set nocount

限制行消息。本设置反映在查询或存储过程中设置的 SET NOCOUNT ON/OFF 选项状态。有关更多信息，请参见 SQL Server 联机丛书中的 SET NOCOUNT。默认设置为 OFF。

Set noexec

编译但不执行语句。此设置可用于验证语法和对象名称。同时，还可用于调试大批处理语句的一部分。默认设置为 OFF。

Set parseonly

分析语法但不编译或执行语句。此选项不验证对象名称。此设置默认情况下为 OFF。

Set concat_null_yields_null

如果串联操作中任何操作数为 NULL，则返回 NULL。

Set rowcount

返回指定的行数并且停止查询。默认 (0) 设置返回全部行。

Set arithabort

在查询执行过程中出现溢出或"被零除"等错误时，中止查询。

Set showplan_text

显示执行信息但不执行。

Set statistics time

显示分析、编译和执行语句所需的时间（以毫秒计）。默认设置为 OFF。

Set statistics IO

显示磁盘活动信息。此信息包括查询所使用的表名称，执行扫描的次数，从数据高速缓存和磁盘读取的页数，以及写入高速缓存的页数。默认设置为 OFF。

Show stats I/O

指定显示每条查询语句产生的有关磁盘活动信息。

Set ansi_defaults

将本组中的选项设置符合 SQL-92 标准。

Set ansi nulls | 如果比较运算符具有任何空表达式，则返回 UNKNOWN。此选项将 ANSI_NULLS 选项设置为打开。在任何空比较中必须使用 ANSI 语法"IS NULL"或者"IS NOT NULL"。如果 ANSI_NULLS 选项为关闭，那么在数据值为 NULL 的情况下，所有数据与此数据的比较将取值为 TRUE。
Set ansi_null_dflt_on | 替代新建列的默认为空性。
Set ansi_padding | 不自动截断尾随空格和尾随零。此选项将 ANSI_PADDING 选项设置成打开。varchar 值的尾随空格和 varbinary 值的尾随零不会自动截断。
Set ansi_warnings | 在出现某些错误情况时发出警告。此选项将 ANSI_WARNINGS 选项设置成打开。在违犯 ANSI 规则，但未违犯 Transact-SQL 规则的情况下，SQL Server 会发出警告消息。
Set cursor_close_on_commit | 当事务提交时关闭游标。
Set implicit_transactions | 自动启动事务，勿需明确的 BEGIN TRANSACTION 语句。
Set quoted_identifier | 将双引号中的字符解释为标识符。在 SQL Server ODBC 驱动程序连接时，此选项将 QUOTED_IDENTIFIERS 选项设置成打开。此设置默认情况下为 OFF。有关更多信息，请参见 SET QUOTED_IDENTIFIERS。

全部重置

将所有连接属性恢复成各自初始设置。


自定义对话框

使用此对话框上的选项卡定义键盘快捷方式或向"工具"菜单添加命令。

  • 自定义对话框中的自定义选项卡

  • 自定义对话框中的工具选项卡


自定义对话框中的自定义选项卡

使用"自定义"对话框的"自定义"选项卡最多可以定义 12 组存储过程键盘快捷方式。

选项

快捷方式

是用于运行存储过程或者执行 SQL 语句的组合键。

存储过程

指定使用这些快捷方式时所要运行的存储过程或者 SQL 语句。默认值定义 sp_help、sp_who 和 sp_lock。

全部重置

删除所有可修改的快捷方式。


自定义对话框中的工具选项卡

使用"自定义"对话框的"工具"选项卡向"工具"菜单添加命令。

选项

菜单内容

指定在"工具"菜单中显示的文本。可为可执行文件名称或者要打开文档的名称。

"添加菜单项"按钮

将选定项添加至"工具"菜单。

"删除菜单项"按钮

将选定项从"工具"菜单中删除。

向上箭头和向下箭头

改变选定项在"工具"菜单中的位置。

命令

指定要执行文件的名称和位置。比如，若要执行 osql，请输入：

C:\Program Files\Microsoft SQL Server\80\Tools\Binn\osql.exe

参数

指定命令的任何参数。比如，如果命令是 osql，可以指定参数选项 -Usa –P。

初始目录

指定执行命令的起始位置。


自定义工具栏对话框

使用"自定义工具栏"对话框指定显示于工具栏的按钮。

可用工具栏按钮

列出所有能置于工具栏的按钮。

当前工具栏按钮

列出工具栏上的按钮。

添加

将"可用工具栏按钮"列表中的选定按钮移至"当前工具栏按钮"列表。

删除

将"当前工具栏按钮"列表中的选定按钮移回"可用工具栏按钮"列表。

重置

将工具栏恢复为初始状态。


编辑 Transact-SQL 脚本对话框

使用"编辑 Transact-SQL 脚本"对话框编辑由索引管理和统计管理功能生成的 SQL 语句。

选项

分析

分析但不执行文本框内的 SQL 语句。

执行

执行文本框内的 SQL 语句。


调试过程对话框

使用"调试过程"对话框指定参数值并调试存储过程。

选项

过程

选择要调试的存储过程。

参数

列出为存储过程定义的参数。

数据类型

显示选定参数的数据类型。

方向

显示选定参数是输入参数还是输出参数。

值

指定选定参数的值。

设为空值

为选定参数指定一个空值。

自动回滚

使过程执行期间完成的所有工作自动回滚。

执行

使用指定值调试存储过程。


执行过程对话框

使用"执行过程"对话框指定参数值并执行存储过程。

选项

过程

选定要执行的存储过程。

参数

列出为存储过程定义的参数。

数据类型

显示选定参数的数据类型。

方向

显示选定参数是输入参数还是输出参数。

Value

指定选定参数的值。

设为空值

为选定参数指定一个空值。

执行

使用指定值执行存储过程。

复制

使用指定的值生成用于唤醒调用存储过程的 Transact-SQL 语句，并将这些语句复制到剪贴板。


扩展属性对话框

使用"扩展属性"对话框定义数据库中对象的扩展属性。这些扩展属性可用于存储与对象有关的应用程序特有或站点特有的信息。

选项

对象名

是对象名。

名称

指定一个属性的名称。

Value

指定一个属性的值。

"添加"按钮

向列表添加一个属性。

"删除"按钮

从属性列表删除一个属性。

应用

将所显示的扩展属性应用于对象。

刷新

废弃未应用的属性和值。

请参见

在数据库对象上使用扩展属性


索引对话框

使用"创建新索引"和"编辑现有索引"对话框定义和修改"管理索引"对话框中指定的数据库和表索引。

选项

索引名

指定要创建或编辑的索引名称。

列

指定或更改选定索引的列。

排序次序

指定或更改列的排列顺序。默认次序为降序。

数据类型

查看列的数据类型。

长度

显示选定列的长度。

可以为空

显示选定列是否可为空。

精度

显示选定列的精度。

小数位数

显示选定列的小数位数。

改变列序

更改索引中列的位置。

上移 | "上移"将选定列向上移动一列。
下移 | "下移"选定列向下移动一列。

索引选项

指定索引类型和其它索引选项。

聚集索引 | 指定一个聚集索引。
唯一值 | 指定用唯一值建立列的索引。
忽略重复值 | 指定忽略重复值。
不自动重新计算统计（不推荐使用） | 指定不重新计算索引统计。不推荐使用本选项。
文件组 | 指定索引的文件组。
填充索引 | 指定填充索引。填充索引在索引的每个内部节点上留出空格。
除去现有索引 | 指定在创建新索引之前删除任何现有的同名索引。
填充因子 | 指定 SQL Server 在创建索引过程中，对各索引页的叶级所进行填充的程度。

编辑 SQL

打开"编辑 Transact-SQL 脚本"对话框，在此可编辑 CREATE INDEX 或 ALTER INDEX 语句。


管理索引对话框

使用"管理索引"对话框选择所要创建、编辑或删除其中索引的数据库和表或者视图。

选项

数据库

指定数据库。

表/视图

指定索引的表或视图。

包含系统对象

指定在表和视图中包含系统对象。

索引

指定选定数据库和表或者视图中的一个现有索引。

聚集

表示现有索引是否为聚集索引。

列

表示索引所基于的列。

新建

打开"创建新索引"对话框在选定的数据库和表中定义一个新索引。

编辑

在"编辑现有索引"对话框中编辑选定索引。

删除

在选定的数据库和表中除去选定索引。


管理统计对话框

使用"管理统计"对话框选择所要创建、编辑或者删除统计的数据库和表或者视图。

选项

数据库

指定数据库。

表/视图

指定要为其创建、编辑或者删除统计的表或者视图。

包含系统对象

指定在表和视图中包含系统对象。

名称

列出现有统计的名称。

列

显示现有统计所基于的列。

新建

打开"创建统计"对话框定义一个新统计。

更新

在"更新统计"对话框内更新选定统计。

删除

删除选定统计。


新建对话框

使用"新建"对话框中的"常规"选项卡打开模板或空白的查询窗口。使用下列选项控制该对话框中的模板文件夹和文件的显示。

选项

向上一个级别

显示当前级别的上一级文件夹的内容。

大图标

将模板文件夹和文件显示为大图标。

列表

在多列列表中显示模板文件夹和文件。

详细信息

以列表的形式显示模板文件夹和文件，列表中提供了诸如修改日期和大小之类的详细信息。


对象搜索对话框

使用"对象搜索"对话框查找当前数据库服务器中的对象。

选项

对象名

指定要查找的对象名称。

区分大小写

指定区分大小写的搜索，勿需考虑数据库服务器的区分大小写设置。

数据库

指定要搜索的数据库或者指定全部数据库。

命中限制

指定要返回的最大项目数。

所有对象类型

在执行搜索时考虑全部对象类型。

系统表

搜索系统表。

用户表

搜索用户表。

视图

搜索视图。

存储过程

搜索存储过程。

用户定义函数

搜索用户定义函数。

列

搜索列。

索引

搜索索引。

触发器

搜索触发器。

扩展过程

搜索扩展存储过程。

DRI 约束

搜索声明索引完整性约束。

扩展属性搜索

搜索扩展属性。

属性名称 | 指定要查找的属性名称。
属性值 | 指定要查找的属性值。

开始查找

开始搜索操作。搜索结果显示在窗口的下部。

说明 右击结果以显示上下文菜单，它使您可以在"打开表"窗口中打开选定对象，或执行各种编辑和编写脚本活动。

新建搜索

清除选定项以指定新搜索条件。


选项对话框

使用"选项"对话框上的选项卡指定文件位置和其它配置设置，配置编辑器窗格和结果窗格，指定常规连接选项，指定 SET 选项，以及指定所用字体。

  • 选项对话框上的常规选项卡

  • 选项对话框上的编辑器选项卡

  • 选项对话框上的结果选项卡

  • 选项对话框上的连接选项卡

  • 选项对话框上的连接属性选项卡

  • 选项对话框上的字体选项卡

  • 选项对话框上的脚本选项卡


选项对话框上的常规选项卡

使用"选项"对话框的"常规"选项卡指定文件位置、文件扩展名和其它配置设置。

选项

查询文件目录

指定查询文件的默认位置。

结果文件目录

指定结果文件的默认位置。

模板文件目录

指定模板文件的默认位置。

查询文件扩展名

指定查询文件的默认扩展名。

结果文件扩展名

指定结果文件的默认扩展名。

模板文件扩展名

指定模板文件的默认扩展名。

将 SQL Server 查询分析器标记为查询文件扩展名默认编辑器

指定 SQL 查询分析器为查询文件的默认编辑器。

在关闭时不提示有未保存文件

指定在关闭文件时不提问是否应该保存文件。

装载

装载含有配置设置的文件。

保存

保存当前配置文件设置，用作备份目的或用于传输至另一台计算机。


选项对话框上的编辑器选项卡

使用"选项"对话框的"编辑器"选项卡配置编辑器窗格。

选项

撤消缓冲区的数目

指定可执行的撤消操作次数。

最大撤消缓冲区大小

指定全部撤消缓冲区的总大小。

撤消缓冲区限制处理

指定如何处理撤消缓冲区限制。

制表符大小（以空格计）

指定使用 Tab 键时缩进的空格数。

将制表符存为空格

指定是将制表符存为空格，还是存为制表字符。

在编辑器内禁用拖放文本

控制是否可在编辑器窗格内拖放文本。

默认（非 Unicode）文件打开格式

指定默认文件格式。

带选项卡模式（对应于拆分模式）

指定查询结果是显示在独立的选项卡上（选项卡模式），还是全部显示于"查询"窗口下半部分中。

执行查询后切换到"结果"选项卡

指定在查询执行后，是否自动显示"结果"选项卡。如果启用此选项，则必须手动选择"结果"选项卡。

在顶部显示选项卡

指定是将窗口选项卡显示在窗口顶部还是底部。


选项对话框上的结果选项卡

使用"选项"对话框的"结果"选项卡配置结果窗格。星号 (*) 表示该选项无法将结果应用于网格功能。

选项

默认结果目标

指定结果输出的默认类型。

结果输出格式

指定结果格式："列对齐"、"逗号分隔 (CSV)"、"制表符分隔"、"空格分隔"、"其它分隔符"。

分隔符

在选定"其它分隔符"选项时，指定分隔符字符。

每列最大字符个数 (*)

指定输出列中返回的最大字符个数。该设置还影响"Transact-SQL 调试程序"窗口的行为。

打印列标题

指定输出中是否包含列标题。

输出查询

指定每条查询的前三行在结果窗格内显示。此设置默认情况下为 OFF。

废弃结果

指定废弃查询结果。

收到时滚动结果 (*)

指定应在返回结果时滚动结果。

右对齐数字 (*)

指定应该右对齐数字。

在完成一次批查询后：

指定在一个查询批处理完成执行时应发出信号。

播放 Windows 声音提示消息

指定在批处理完成时播放 Windows 声音提示消息。

播放此 WAV 文件

指定在批处理完成时播放此 .wav 文件。


选项对话框上的连接选项卡

使用"选项"对话框的"连接"选项卡配置常规连接设置。

选项

登录超时（秒）

指定在超时前等待连接的时间量。连接超时仅适用于查询分析器在网络上的每台计算机中搜索了请求服务器之后。

网络包大小（字节）

指定网络包的大小。

查询超时（秒）

指定在超时前查询能进行处理的时间量。

锁定超时（毫秒）

指定在超时前等待锁定的时间量。

批处理分隔符

指定用作分隔批处理的英文单词或字符。

分析 ODBC 消息前缀

指定应分析 ODBC 前缀。

执行字符数据转换

指定应执行字符数据转换。

在显示货币、号码、日期和时间时使用区域设置

指定应对货币、数字、日期和时间使用区域设置。

查询执行后断开连接

指定应在查询执行后断开连接。

分析 ODBC 消息前缀

指定要分析 ODBC 消息前缀。当选定此选项后，[Microsoft][ODBC SQL Server Driver][SQL Server] 等前缀将从 ODBC 错误信息中删除。如果此选项为 OFF，则出现错误信息。此设置默认情况下为 ON。

说明 该选项仅当连接到 SQL Server 4.21a 版或更高版本的实例时才可用。

T-SQL 批处理分隔符

指定用于分隔批处理的 Transact-SQL 命令。此设置默认情况下为 GO。

说明 该选项仅当连接到 SQL Server 4.21a 版或更高版本的实例时才可用。

查询超时（秒）

指定在返回到应用程序前，等候完成连接中任何请求的时间量（以秒计）。当超出该时间时，客户端将提示用户继续等待。默认值为零，表示无限等待或者没有超时。

说明 该选项仅当连接到 SQL Server 4.21a 版或更高版本的实例时才可用。

将 SQL Server 使用的系统消息语言更改为

指定由 SQL Server 向客户端发送系统消息所用的语言。此处列表是在假定服务器上可能使用语言的实际列表。但是，只有在连接到 Microsoft® SQL Server™ 7.0 或更高版本时，才提供更广泛的语言列表。SQL Server 6.5 和早期版本仅支持英语、法语、德语和日语。

说明 该选项仅当连接到 SQL Server 4.21a 版或更高版本的实例时才可用。

执行字符数据转换

指定要执行字符数据转换。打开此设置将导致 ODBC 驱动程序在客户端与服务器代码页间交换数据时转换字符。此属性只影响存储于 SQL Server 中的 char、 varchar 和 text 类型列。当转换选项为 OFF 时，驱动程序不会在客户端与服务器交换字符数据时将字符从一个代码页转换到另一个代码页。驱动程序自动配置字符转换，决定在正由客户端使用的服务器上安装的代码页。此设置默认情况下为 ON。

说明 该选项仅当连接到 SQL Server 4.21a 版或更高版本的实例时才可用。

输出货币、数字、日期和时间时使用区域设置

指定在将数字、日期、时间和货币转换成字符串时使用区域设置。将该设置切换到 ON 将导致 ODBC 驱动程序在将数字、日期、时间和货币值转换成字符串时遵守本地客户端设置。此转换仅将 SQL Server 本机数据类型转换成字符串。当此设置为 OFF 时，驱动程序不将数字、日期、时间和货币数据转换为使用客户端区域设置的字符串。此转换设置仅适用于输出转换，并且仅在将货币、数字、日期或者时间值转换为字符串时可见（查询分析器常为此类情况）。此设置默认情况下为 OFF。

说明 该选项仅当连接到 SQL Server 4.21a 版或更高版本的实例时才可用。


选项对话框上的连接属性选项卡

使用"选项"对话框的"连接属性"选项卡指定所有新建连接的 SET 选项。

说明 在"选项"对话框中"连接属性"选项卡的选项与"当前连接属性"对话框的选项完全一致。但是，"选项"对话框中设置的连接属性影响新建连接。"当前连接属性"对话框中设置的连接属性只影响当前连接。

选项

Set nocount

限制行消息。本设置反映在查询或存储过程中设置的 SET NOCOUNT ON/OFF 选项状态。有关更多信息，请参见 SQL Server 联机丛书中的 SET NOCOUNT。默认设置为 OFF。

Set noexec

编译但不执行语句。此设置可用于验证语法和对象名称。同时，还可用于调试大批处理语句的一部分。默认设置为 OFF。

Set parseonly

分析语法但不编译或执行语句。此选项不验证对象名称。此设置默认情况下为 OFF。

Set concat_null_yields_null

如果串联操作中任何操作数为 NULL，则返回 NULL。

Set rowcount

返回指定的行数并且停止查询。默认 (0) 设置返回全部行。

Set arithabort

在查询执行过程中出现溢出或"被零除"等错误时，中止查询。

Set showplan_text

显示执行信息但不执行。

Set statistics time

显示分析、编译和执行语句所需的时间（以毫秒计）。默认设置为 OFF。

Set statistics IO

显示磁盘活动信息。此信息包括为查询所在使用的表名称，执行扫描的次数，从数据高速缓存和磁盘读取的页数，以及写入高速缓存的页数。默认设置为 OFF。

Show stats I/O

指定显示每条查询语句产生的有关磁盘活动信息。

Set ansi_defaults

将本组中的选项设置符合 SQL-92 标准。

Set ansi nulls | 如果比较运算符具有任何空表达式，则返回 UNKNOWN。此选项将 ANSI_NULLS 选项设置为打开。在任何空比较中必须使用 ANSI 语法"IS NULL"或者"IS NOT NULL"。如果 ANSI_NULLS 选项为关闭，那么在数据值为 NULL 的情况下，所有数据与此数据的比较将取值为 TRUE。
Set ansi_null_dflt_on | 替代新建列的默认为空性。
Set ansi_padding | 不自动截断尾随空格和尾随零。此选项将 ANSI_PADDING 选项设置成打开。varchar 值的尾随空格和 varbinary 值的尾随零不会自动截断。
Set ansi_warnings | 在出现某些错误情况时发出警告。此选项将 ANSI_WARNINGS 选项设置成打开。在违犯 ANSI 规则，但未违犯 Transact-SQL 规则的情况下，SQL Server 会发出警告消息。
Set cursor_close_on_commit | 当事务提交时关闭游标。
Set implicit_transactions | 自动启动事务，勿需明确的 BEGIN TRANSACTION 语句。
Set quoted_identifier | 将双引号中的字符解释为标识符。在 SQL Server ODBC 驱动程序连接时，此选项将 QUOTED_IDENTIFIERS 选项设置成打开。此设置默认情况下为 OFF。有关更多信息，请参见 SQL Server 联机丛书中的 SET QUOTED_IDENTIFIERS。

全部重置

将所有连接属性恢复成各自初始设置。


选项对话框上的字体选项卡

使用"选项"对话框中的"字体"选项卡控制 SQL 查询分析器元素中所用的字体。这些元素包括：

  • 编辑器

  • 结果文本

  • 结果表格/打开表

  • 显示计划

  • 语句事件探查

  • 客户统计

  • 对象浏览器

可为 SQL 查询分析器中的所有组件指定要使用的字体及其大小。另外，还可为编辑器窗格中出现的各种类型的文本指定不同的颜色。

选项

文本（查询字符）

指定字母文本的格式。

文本选择（查询字符）

指定选定查询文本时查询文本的格式。

关键字（查询字符）

指定 Transact-SQL 关键字的格式。

存储过程（查询字符）

指定存储过程的格式。

系统表格（查询字符）

指定系统表的格式。

全局变量（查询字符）

指定全局变量的格式。

注释（查询字符）

指定在 Transact-SQL 脚本中注释的格式。

数字（查询字符）

指定数字文本的格式。

字符串（查询字符）

指定单引号所包含字母数字文本的格式。

运算符（查询字符）

指定用于执行列间或者变量间数学计算或比较所用符号的格式。运算符可分为算术运算符、位运算符、比较运算符或联接运算符。

前景

在"颜色"框中为选定内容类型指定前景字符颜色。

后台

在"颜色"框中为选定内容类型指定背景颜色。

字体

为"颜色"框中选定的内容类型指定字体。

大小

在"颜色"框中为选定内容类型指定字号。

示例

以选定格式显示查询字符。

全部重置

将所有选项重置成各自的初始默认值。


选项对话框上的脚本选项卡

在对象浏览器中，可编写对象的创建脚本。使用"选项"对话框上的"脚本"选项卡设置脚本选项并调整已编写脚本的输出。可供选择的选项包括：

脚本格式选项

在脚本中包含描述性标题。

将用 /*...*/ 分隔的注释添加到脚本输出中。注释包括对象的全名和脚本的创建时间。

给脚本加上检查是否存在的前缀。当执行脚本时，仅当组件不存在时才创建它。

将检查对象是否存在的语句添加到脚本中。如果对象存在，脚本就不创建该对象。

标识符分隔符

允许调整脚本标识符的格式，使其与 Microsoft® SQL Server™ 6.5版、SQL Server 7.0 或 SQL Server 2000 兼容。这些选项包括：

  • 版本相关默认设置

  • 无

  • [ ] -- 7.0 版兼容的被引用的标识符

  • "" -- 6.5 版兼容的被引用的标识符

不要使用命令终止符。

从脚本输出中省略 "GO" 终止符。如果未选择该选项，每个 Transact-SQL 语句将随 "GO" 命令终止。

仅对与 7.0 兼容的功能编写脚本。

在脚本输出中仅包括与 SQL Server 7.0 版兼容的选项。

如果源为 SQL Server 7.0 或更高版本的实例，则不要为排序规则子句编写脚本。

如果源为 SQL Server 7.0 或更高版本的实例，则不要为排序规则子句编写脚本。

生成 Transact-SQL 以删除引用的组件。在尝试删除组件前脚本测试其是否存在。

将测试组件是否存在的语句添加到脚本中,并在重新创建前有条件地删除该组件。

将扩展属性脚本作为对象脚本的一部分。

如果对象具有关联的扩展属性，将在脚本的最后追加对 sp_addextendedproperty 的适当调用以还原任何先前相关的扩展属性。

"不要包括指示使用文件组的 ""ON <filegroup>"" 子句。"

"不要包括指示使用文件组的 ""ON <filegroup>"" 子句。"

编写对象脚本 — 级别权限。

将还原与对象相关的任何专有权利的语句添加到脚本中。

表脚本选项

按对象的所有者限定对象名。

将当前的所有者名称添加到对象名语法中。（例如，syscomments 变成 dbo.syscomments）。

将用户定义数据类型的规范转换为正确的 SQL Server 基本数据类型。

将用户定义数据类型转换为它所基于的、由 SQL Server 提供的数据类型（例如，decimal、int、char、varchar）。

不要包括可定义声明引用完整性约束的子句。

已编写脚本的输出中不要包括任何可定义声明引用完整性约束的子句。

不包含标识属性、种子和增量的定义。

从表创建命令的列定义中删除 IDENTITY 属性。有关更多信息，请参见 IDENTITY（属性）。

在 CREATE TABLE 语句前，生成 SET ANSI_PADDING ON 和 SET ANSI_PADDING OFF 语句。

在 SET ANSI_PADDING 语句的前面加上表创建命令。有关更多信息，请参见 SET ANSI_PADDING。


选择数据库对话框

使用"选择数据库"对话框指定活动的"查询"窗口的数据库上下文。该对话框提供当前数据库服务器中的数据库的列表。

选项

名称

显示数据库名称。当前数据库显示为蓝色。

兼容级别

标识数据库的当前兼容级别。

状态

显示数据库的当前状态，如数据库是脱机还是处于单用户模式。如果该列为空，则数据库处于正常操作模式。

刷新

刷新列表。


替换模板参数对话框

使用"替换模板参数"对话框指定存储过程或函数中的参数值。

选项

参数

列出存储过程或函数中的参数。

类型

标识模板参数的数据类型。

Value

指定选定参数的值。

全部替换

将指定参数值插入到编辑器窗格的代码中。


更新统计对话框

使用"更新统计"对话框修改在"管理统计"对话框中所指定的数据库和表的统计。

选项

名称

查看要更新的统计名称。

列

查看要包括在选定统计中的列。

要采样的数据量

指定要为统计采样的数据量。

默认值 | 选择要为统计采样的默认数据量。
采样 % 的数据 | 指定要为统计进行采样的数据采样率。
采样所有数据 | 指定要为统计采样所有数据。
示例行 | 指定要为选定统计采样的行数。

更新统计选项

指定其它统计选项。

包含列 | 指定要在选定统计中包含列。
不自动重新计算统计 | 指定不自动重新计算统计。不推荐使用本选项。

编辑 SQL

打开"编辑 Transact-SQL 脚本"对话框，在此可编辑 UPDATE STATISTICS 语句。


窗口选择器对话框

使用"窗口选择器"对话框在 SQL 查询分析器中浏览窗口。

选项

选择窗口

列出 SQL 查询分析器中打开的窗口。当前窗口显示为蓝色。该列表框显示各窗口的以下信息。

列 | 描述
窗口类型 | 窗口的类型，如查询窗口、Transact-SQL 调试程序或对象搜索。
服务器 | 数据库服务器。
数据库 | 窗口的数据库上下文。
用户 | 打开窗口的登录。
描述 | 有关窗口的信息。信息包括未保存窗口的名称、已保存窗口的名称及路径和 Transact-SQL 调试程序中的存储过程的名称。

激活

使选定窗口成为活动窗口，并关闭对话框。

关闭窗口

关闭选定窗口。

保存

将选定窗口的内容保存到文件。


Transact-SQL 调试程序

"Transact-SQL 调试程序"窗口显示将要调试的存储过程文本，并提供下列调试选项。

选项 | 描述
GO | 以调试模式运行存储过程。
切换断点 | 在当前行设置或删除断点。在包含不可执行代码（比如注释、声明语句）的行或者空行中无法设置断点。
删除所有断点 | 清除代码中的所有断点。
步入 | 一次执行一条代码语句。"跟踪"执行当前执行点的语句。如果此语句将调用一个过程，那么下一条显示的语句便是此过程的第一条语句。
跨过 | 一次执行一条代码语句。如果当前语句包含对一个过程的调用，那么单步会将此过程当成一个单元执行，然后再前进至当前过程的下一个语句。因此，无论当前语句是否调用其它过程，显示的下一条语句都是当前过程的下一个语句。
异步 | 执行当前执行点所在函数的剩余行。显示的下一条语句是紧挨着过程调用的语句。执行了位于当前执行点与最后执行点之间的所有代码。
运行至游标 | 在代码内部要让执行停止的位置，指定一条语句。使用此选项避免单步调试大循环。
重新启动 | 从存储过程的开始重新启动执行。
停止调试 | 暂停调试。
监视 | 显示当前监视表达式。
调用栈 | 列出已启动但未完成的过程调用。
自动回滚 | 使过程执行期间完成的所有工作自动回滚。

代码窗格显示了正在调试的 SQL 语句。为局部及全局变量、查询结果集和调用堆栈分别提供了输出窗格。注意，对于名称以 @@ 开头的 Transact-SQL 内置函数，全局变量为传统术语。


查询窗口执行计划窗格

"执行计划"选项以图形方式显示 Microsoft® SQL Server™ 查询优化器所选择的数据检索方法。

执行计划窗格使用图标而不是 SET SHOWPLAN_ALL 或者 SET SHOWPLAN_TEXT 语句所产生的表格表示法表示 SQL Server 中具体语句和查询的执行过程。

图标

使用 SQL Server 查询分析器以图形方式显示执行计划

物理运算符

Assert

Bookmark Lookup

Clustered Index Delete

Clustered Index Insert

Clustered Index Scan

Clustered Index Seek

Clustered Index Update

Collapse

Compute Scalar

Concatenation

Constant Scan

Deleted Scan

Filter (clsColumn)

Hash Match

Hash Match Root

Hash Match Team

Index Delete

Index Insert

Index Scan

Index Seek

Index Spool

Index Update

Inserted Scan

Log Row Scan

Merge Join

Nested Loops

Parallelism

Parameter Table Scan

Remote Delete

Remote Insert

Remote Query

Remote Scan

Remote Update

Row Count Spool

Sequence

Sort

Stream Aggregate

Table Delete

Table Insert

Table Scan

Table Spool

Table Update

Top

游标物理运算符

Dynamic

Fetch Query

Keyset

Population Query

Refresh Query

Snapshot


查询窗口统计窗格

"显示客户端统计"命令提供查询执行的客户端统计详细信息。在统计窗格中显示的输出结果集包含下面这些列。

列名 | 描述
计数器 | 计数器标签。
值 | 计数器值，在每次查询后更新。
平均 | 从连接开始或者上一次手工重置起的运行平均值。

三组统计计数器分别是：

  • 应用程序配置

  • 网络

  • 时间

仅在生成查询结果时才显示这些统计。当选择"分析"、"显示估计的执行计划"或者"索引优化向导"等命令时，不显示这些统计。

应用程序配置统计
计数器 | 描述
计时器分辨率（毫秒） | 服务器时钟时间的最小分辨率（以毫秒计）。此项通常被报告为 0（零），并且只在报告数字较大时，才予以考虑。如果服务器时钟的最小分辨率大于某些基于计时器统计的可能间隔，那么这些统计可能被夸大。
INSERT、UPDATE、DELETE 等语句的数目 | 在 SQL_PERF_START 语句之后，INSERT、UPDATE 或 DELETE 等语句的数目。
受 INSERT、UPDATE、DELETE 等语句影响的行 | 在 SQL_PERF_START 语句之后，受 INSERT、UPDATE 或 DELETE 等语句影响的行。
SELECT 语句的数量 | 在 SQL_PERF_START 之后处理 SELECT 语句的数目。
受 SELECT 语句影响的行 | 在 SQL_PERF_START 之后所选定行的数目。
用户事务数 | 在 SQL_PERF_START 语句之后的用户事务数目，包括回滚。当一个 ODBC 应用程序正和 SQL_AUTOCOMMIT_ON 语句一起运行时，每条命令都将被认为是一个事务。
平均提取时间 | 相当于 SQLFetchTime/SQLFetchCount。
累计提取时间 | 完成提取服务器游标所需的累计时间。
提取数 | 在 SQL_PERF_START 语句后，对服务器游标所执行的提取数。
打开的语句句柄数 | 在驱动程序中所有开放连接中当前打开的语句句柄数。
最大打开的语句句柄数 | 在 SQL_PERF_START 语句之后并发打开的最大打开的语句句柄数。
累计的语句句柄数 | 在 SQL_PERF_START 之后打开的语句句柄的数目。

网络统计信息
计数器 | 描述
服务器往返的次数 | 驱动程序向服务器发送命令并接收答复的次数。
所发送的 TDS 数据包的数量 | 在 SQL_PERF_START 语句之后驱动程序向 SQL Server 发送 TDS 数据包的数目。较大的命令可以获得多个缓冲区。比如，如果一个较大命令被发送至服务器，且填充了 6 个数据包，那么 ServerRndTrips 将增加 1 个，BuffersSent 将增加 6 个。
所接收的 TDS 数据包的数目 | 在应用程序开始使用驱动程序后，驱动程序从 SQL Server 接收到的 TDS 数据包的数目。
所发送的字节数 | 在应用程序开始使用驱动程序后，用 TDS 数据包向 SQL Server 发送的数据字节数。
所接收的字节数 | 在应用程序开始使用驱动程序后，用 TDS 数据包从 SQL Server 接收的数据字节数。

时间统计信息
计数器 | 描述
客户端处理累计时间 | 在 SQL_PERF_START 语句之后，驱动程序进行处理所花费的累计时间量，其中包括驱动程序用于等待服务器答复所用的时间。
服务器应答累计等待时间 | 驱动程序用于等待服务器答复所花费的累计时间量。


查询窗口跟踪窗格

"显示服务器跟踪"命令提供了对信息的访问，此信息用于确定查询对服务器方的影响。

如果"显示服务器跟踪"命令在执行查询时启用，则该命令显示跟踪窗格，此窗格提供有关事件类、子类、整型数据、文本数据、数据库 ID、持续时间、启动时间、读、写以及 CPU 使用的信息。


使用对象浏览器

 SQL 查询分析器帮助

对象浏览器

使用对象浏览器可查找选定数据库服务器的数据库对象。可通过工具栏上的按钮和通过"工具"菜单中的"对象浏览器"命令使用对象浏览器。

"对象"选项卡包含一个树列表，它显示选定的数据库服务器中的数据库。对于每个数据库，对象浏览器列出下列文件夹。

用户表 | 对于每个用户表，对象浏览器列出列、索引、触发器和相关性。
系统表 | 对于每个系统表，对象浏览器列出列、索引和相关性。
视图 | 对于每个视图，对象浏览器列出列和相关性。
存储过程 | 对于每个存储过程，对象浏览器列出参数和相关性。
扩展存储过程 | 对于每个扩展存储过程，对象浏览器列出参数和相关性。 仅对 master 数据库显示扩展存储过程。
函数 | 对于每个用户定义函数，对象浏览器列出参数和相关性。

除数据库外，树列表还显示一个名为 Common Objects 的文件夹，该文件夹包含 Transact-SQL 内置函数和基本数据类型。

"模板"选项卡显示存储于 Templates\SQL Query Analyzer 目录中的模板。