跟踪属性（常规选项卡）

使用此选项卡查看或指定下列选项。

选项

跟踪名

指定跟踪的名称。

跟踪 SQL Server

指定要跟踪的 Microsoft® SQL Server™ 实例。

模板名

从模板目录中选择一个模板。

模板文件名

选择先前用 .tdf 文件扩展名保存的模板。

另存为文件

将跟踪数据捕获到 .trc 文件。如果想保存跟踪数据以便日后查阅与分析，那么这项就非常有用。将跟踪保存到文件，这样也降低了 SQL 事件探查器的内存开销。

如果选择将跟踪数据保存到一个文件，那么必须指定最大跟踪文件的大小。最大是十亿字节 (GB)。

启用文件翻转
指定如果达到最大的文件大小，就打开一个新文件以便接受跟踪数据。新文件名将是原始的 .trc 文件名，后面追加一个数字。例如，当达到最大文件大小时，NewTrace.trc 会变成新的 NewTrace_1.trc、NewTrace_2.trc，等等。将跟踪数据保存到文件中时，默认启用该项。
服务器处理 SQL Server 跟踪数据
指定运行着跟踪的服务器应该处理跟踪数据。如果选定这项，那么在机器压力较大的情况下也不会跳过任何事件。然而，服务器的性能可能会受到影响，这取决于正在跟踪的事件数量。如果清除该复选框，则由客户端应用程序来执行处理，将有可能在压力较大的情况下发生不跟踪某些事件的情况。

另存为表

将跟踪数据捕获到数据库表。如果想保存数据以便日后查阅与分析，那么这项就非常有用。将跟踪数据保存到表，对于正在保存跟踪的服务器来说，会导致很大的开销。

设置最大行（以千计）
指定保存数据的最大行数。最大值是 9,999,000 行。

启用跟踪停止时间

为跟踪设置日期和时间，以便到时就终止并且关闭它。

请参见

如何创建跟踪（SQL 事件探查器）


跟踪模板属性（常规选项卡）

使用此选项卡查看或指定下列选项。

选项

文件名称

查看跟踪模板的名称。

保存跟踪模板

将当前的跟踪定义保存为另一个名称。

请参见

创建并管理跟踪和模板


跟踪文件属性（常规选项卡）

使用此选项卡查看或指定下列选项。

选项

文件名称

指定跟踪文件的名称和位置。

文件大小 (KB)

以千字节 (KB) 为单位指定文件大小。

创建于

指定创建该文件的日期和时间。

修改时间

指定更新该文件的日期和时间。

请参见

创建并管理跟踪和模板


跟踪表属性（常规选项卡）

使用此选项卡查看或指定下列选项。

选项

表名

指定跟踪表的名称。

服务器名称

指定存储跟踪表的服务器。

行

指定表中包含了多少行。

数据大小（页）

指定数据的大小，以页为单位。

请参见

创建并管理跟踪和模板

如何将跟踪结果保存到表（SQL 事件探查器）


属性（事件选项卡）

使用此选项卡查看或指定下列选项。

选项

可用的事件类

查看可跟踪的所有事件。当查看已保存的跟踪的属性时，不列出事件类。

选定的事件类

对于某个跟踪或跟踪模板，查看所有选定的要进行跟踪的事件。当查看已保存的跟踪的属性时，只会列出被捕获的事件。

添加

将事件类添加到跟踪或跟踪模板。

删除

将事件类从跟踪或跟踪模板中删除。

请参见

如何在跟踪模板或跟踪文件中添加或删除事件（SQL 事件探查器）

使用 SQL 事件探查器监控事件分类


属性（数据列选项卡）

使用此选项卡查看或指定下列选项。

选项

未选定的数据

当选择在跟踪或跟踪模板中将要捕获的数据列时，该选项查看所有未被选定的数据列。

选定的数据

查看所有选定的数据列，将其捕获到跟踪或跟踪模板中。Event Class 和 SPID 是必需的列，不能从"选定的数据"列表中移动。

添加

向"选定的数据"列表添加列，指定用以对跟踪进行分组的列。不能按 StartTime 或 EndTime 数据列分组。

删除

将列从"选定的数据"列表中删除。

向上

沿着选定的列或排列依据列的列表将某个选定的列向上移动。

向下

沿着选定的列或排列依据列的列表将某个选定的列向下移动。

请参见

如何在跟踪模板中添加或删除数据列（SQL 事件探查器）

使用 SQL 事件探查器监控事件分类


属性（筛选器选项卡）

使用此选项卡查看或指定下列选项。

选项

跟踪事件准则

指定跟踪事件准则，这些准则用来限制有关在跟踪中定义的事件的数据集合。若要应用一个筛选，请扩展跟踪标准并进入或修改每个准则下框内的值。

请使用通配符 (%) 和分号来包括任意字符系列。例如 SQL%;MS% 指定跟踪中将包含所有以 SQL 开始的事件以及所有以 MS 开始的事件。

可以使用 Like、Not Like、Equals 及 Not Equals 运算符执行多个筛选。

拒绝系统 Id

通过排除引用大多数系统对象的事件，来捕获更少量的跟踪事件。通常分配给系统对象小于或等于 100 的系统 ID。选择该选项可将对象 Id 设置为大于或等于 100，从而将大多数系统对象从跟踪中消除。这样，因为正访问的系统对象可产生 50-75% 的跟踪事件，所以跟踪有更大的选择性。

请参见

如何筛选跟踪模板中的事件（SQL 事件探查器）

限制跟踪


跟踪选项（常规选项卡）

使用此选项卡查看或指定下列选项。

选项

模板名

选择与 Microsoft® SQL Server™ 一起提供的模板，以便用于新的跟踪。

模板文件名

除非已经进行了另外的指定，否则请指定自定义模板文件名，以便用于新的跟踪。

进行连接后立即启动跟踪

指定只要建立到服务器的连接就开始跟踪。

请参见

如何设置跟踪定义默认值（SQL 事件探查器）


跟踪选项（显示选项卡）

使用此选项卡查看或指定下列选项。

选项

字体名称

指定在 SQL Server 事件探查器跟踪窗口中显示的字体。

字体大小

指定在 SQL Server 事件探查器跟踪窗口中显示的字体大小（从 0 到 24）。

请参见

如何设置跟踪显示默认值（SQL 事件探查器）


源表

使用此对话框查看或指定下列选项。

选项

SQL Server

指定表的服务器目的。

数据库

指定表的数据库目的。

所有者

指定表的数据库所有者。

表

指定表，以使跟踪将数据追加到该表中。

请参见

如何打开跟踪表（SQL 事件探查器）


重播 SQL Server

使用此对话框查看或指定下列选项。

选项

重播 SQL Server

指定所需的服务器，将对该服务器重播跟踪。使用重播来重新创建先前捕获的 Microsoft® SQL Server™ 活动，以此来调试或探查事件，或者向服务器施加压力。

输出文件名称

指定要把重播输出结果保存到其中的文件的名称和位置。保存输出文件以便日后查阅并分析错误和结果。

将事件按跟踪的顺序重播。该选项可启用调试。

指定将事件按跟踪的顺序重播。这允许使用调试方法（单步调试每个跟踪）

重播使用多线程的事件。该选项优化性能并禁用调试。

指定使用多线程重播事件。该项优化性能，但禁用调试。

显示重播结果

指定显示重播结果。这是默认选项。如果重播的跟踪非常大，可以禁用该项来节省磁盘空间。

请参见

如何打开跟踪数据文件（SQL 事件探查器）


目的表

使用此对话框查看或指定下列选项。

选项

SQL Server

指定跟踪表的服务器。

数据库

指定跟踪表的数据库。

所有者

指定表的所有者。

表

指定容纳跟踪结果的表。

请参见

如何将跟踪结果保存到表（SQL 事件探查器）


查找

使用此对话框查看或指定下列选项。

选项

搜索值

指定要搜索的值。

数据列

选择需要在其中搜索的列。

查找下一个

查找下一个与搜索准则相匹配的值。

查找上一个

返回到符合搜索标准的先前值。

请参见

如何在跟踪时查找值或数据列（SQL 事件探查器）