Banyan Vines

使用该对话框查看或指定 Banyan VINES 配置。

选项

项目名

指定用于重命名服务的名称。

默认组

指定服务所属的默认组。

默认单位

指定组所属的默认单位。

请参见

如何编辑服务器网络库配置（网络实用工具）

如何装载已安装的服务器网络库（网络实用工具）


SQL Server 网络实用工具（常规选项卡）

使用该选项卡查看或指定服务器属性，包括协议、加密和代理。

选项

本服务器上的实例

选择希望查看或更改其协议的 Microsoft® SQL Server™ 实例。

禁用的协议

查看选定的 SQL Server 实例中所有禁用的协议。

启用的协议

查看选定的 SQL Server 实例中所有启用的协议。Banyan VINES Net-Library 尚未得到改进，它运行在 SQL Server 7.0 级别的功能上。该 Net-Library 仅用于向后兼容，在命名实例中不被支持。

启用

启用为指定的 SQL Server 实例选定的协议。

禁用

禁用为指定的 SQL Server 实例选定的协议。

属性

查看选定协议的属性。

强制协议加密

启用协议加密。加密是通过将数据更改为不可读形式而使敏感数据得以保密的方法。加密通过对每个人都隐藏信息而确保数据安全，即使有人直接查看加密数据。

若想在故障转移群集中使用加密，必须在故障转移群集中的所有节点上安装具有虚拟服务器的完全合法 DNS 名称的服务器证书。例如，如果有个节点名为 test1.redmond.corp.microsoft.com 和 test2.redmond.corp.microsoft.com 且含有虚拟 SQL Server"Virtsql"的双节点群集，则需要获得"virtsql.redmond.corp.microsoft.com"的证书并在两个节点上都要安装此证书。然后，可在 SQL Server 网络实用工具上选中"强制协议加密"复选框以配置加密的故障转移群集。

启用 WinSock 代理

设置 SQL Server 在通过 TCP/IP 套接字使用 Microsoft Proxy Server 的代理服务器上监听。

WinSock 代理服务器地址

指定 WinSock 代理服务器地址。

WinSock 代理服务器端口

指定 WinSock 代理服务器端口号。

请参见

如何停用服务器网络库配置（网络实用工具）

如何编辑服务器网络库配置（网络实用工具）

如何装载已安装的服务器网络库（网络实用工具）


NWLink IPX/SPX

使用该对话框查看或指定 NWLink IPX/SPX 配置。

选项

默认服务名

指定默认的 Microsoft® Windows NT® 4.0 或 Windows® 2000 计算机名称，Microsoft SQL Server™ 实例在该名称下运行。该信息存储在服务器的平构数据库中。

默认端口

指定默认的 NWLink IPX/SPX 端口，当接受来自 NWLink IPX/SPX 客户端的连接时，服务器将在该端口上监听。默认值为 33854。

隐藏服务器

选择隐藏 SQL Server 实例。如果隐藏了 SQL Server 实例，则将禁止对试图枚举网络上现有的 SQL Server 实例的客户端所发出的广播作出响应。

请参见

如何编辑服务器网络库配置（网络实用工具）

如何加载已安装的服务器网络库（网络实用工具）


多协议

使用该对话框查看或指定服务器处理多个网络连接的方式。

选项

预期的最少连接数

指定预期的最少服务器连接数。默认值为 1。

预期的最多连接数

指定预期的最多服务器连接数。超出这个数字后，将拒绝另外的连接。默认值为 1024。

RPC 协议

为每个支持的多协议指定值。

启用加密

启用协议加密。加密是通过将数据更改为不可读形式而使敏感数据得以保密的方法。加密通过对所有人都隐藏信息来确保数据安全，即使有人直接查看加密数据。

若想在故障转移群集中使用加密，必须在故障转移群集中的所有节点上安装具有虚拟服务器的完全合法 DNS 名称的服务器证书。例如，如果有个节点名为 test1.redmond.corp.microsoft.com 和 test2.redmond.corp.microsoft.com 且含有虚拟 SQL Server"Virtsql"的双节点群集，则需要获得"virtsql.redmond.corp.microsoft.com"的证书并在两个节点上都要安装此证书。然后，可在 SQL Server 网络实用工具上选中"强制协议加密"复选框以配置加密的故障转移群集。

请参见

如何编辑服务器网络库配置（网络实用工具）

如何加载已安装的服务器网络库（网络实用工具）


命名管道

使用该对话框查看或指定命名管道默认值。

选项

默认管道

指定 Microsoft® SQL Server™ 所监听的默认管道。默认情况下，SQL Server 在管道 \\.\pipe\sql\query 上监听。

请参见

如何编辑服务器网络库配置（网络实用工具）

如何加载已安装的服务器网络库（网络实用工具）


VIA

使用该对话框查看或指定虚拟接口构架 (VIA) 配置。VIA 不适用于运行 Microsoft® Windows® 98 的系统。

选项

供应商

选择可以和 VIV 一起使用的硬件供应商，如 Giganet。该值必须是公认的注册表供应商。

监听信息

输入监听信息的值。默认值为 0:1433。

请参见

VIA 客户端

SQL Server 网络实用工具


TCP/IP

使用该对话框查看或指定 TCP/IP 配置。

选项

默认端口

指定默认的 TCP/IP 端口，当接收来自 TCP/IP 套接字客户端的连接时，服务器将在该端口上监听。默认值为 1433。

隐藏服务器

选择隐藏 Microsoft® SQL Server™ 实例。如果隐藏了 SQL Server 实例，则将禁止对试图枚举网络上现有的 SQL Server 实例的客户端所发出的广播作出响应。

请参见

在网络上公布 SQL Server

如何编辑服务器网络库配置（网络实用工具）

如何加载已安装的服务器网络库（网络实用工具）


SQL Server 网络实用工具（网络库选项卡）

使用该选项卡查看或指定网络库属性。

选项

服务器名称

查看正在查看其网络库属性的服务器名称。

服务器网络库

查看安装在这台计算机上的 Microsoft® SQL Server™ 客户端网络库。

库文件名

查看这台计算机上安装的 SQL Server 客户端网络库的位置。

路径

查看这台计算机上安装的服务器网络库的路径。

版本

查看这台计算机上安装的 SQL Server 客户端网络库的版本号。

文件日期

查看这台计算机上安装的 SQL Server 客户端网络库的日期。

大小

查看这台计算机上安装的 SQL Server 客户端网络库的文件大小。

请参见

如何查看已安装的 SQL Server 服务器网络库（网络实用工具）


AppleTalk

使用该对话框查看或指定 AppleTalk 配置。

选项

默认对象名

指定由系统管理员指派的默认服务对象。标准默认值是 Microsoft® SQL Server™ 实例的名称。

请参见

如何编辑服务器网络库配置（网络实用工具）

如何装载已安装的服务器网络库（网络实用工具）