选择服务器和数据库

使用"选择服务器和数据库"对话框选择要优化的 Microsoft® SQL Server™ 2000 数据库。还可以选择保留现有索引、包括索引视图和选择优化模式。

选项

服务器

指定要连接的 SQL Server 实例的名称。

数据库

指定要优化的数据库。

保留所有现有索引

指定在最终的优化建议中保留所有现有索引。如果选择不保留现有索引，则可能会除去或替换索引。

添加索引视图

指定在分析中包括索引视图。建议在支持索引视图的平台上使用索引视图。

优化模式

指定要使用的优化模式。

模式 | 描述 | 限制
快速 | 该模式提供最快的执行时间，但可能无法使总体性能得到最大提高。 | 建议不要使用新的聚集索引。 建议不要使用新的索引视图。 保留所有现有的索引。
适中 | 该模式提供比快速模式更全面的分析和比彻底模式更快的执行时间。这是默认选择。 | 无
彻底 | 该模式执行详尽的查询分析。该模式的执行时间会很长，但可以更好地提高总体性能。 | 无


指定工作负荷

使用"指定工作负荷"对话框指定用作优化输入的工作负荷文件的名称。

选项

我的工作负荷文件

指定工作负荷文件的位置。该文件的格式必须为这些格式之一：.trc（SQL 事件探查器跟踪文件）、.sql（SQL 文件）或 .log（Microsoft® SQL Server™ 2000 6.5 版跟踪文件）。

SQL Server 表

打开"连接到 SQL Server"和"源表"对话框，指定包含用于优化的工作负荷的数据库表。

查询分析器选择

选择在 SQL 查询分析器中分析单个查询或批查询。只有 sysadmin 固定服务器角色成员可以使用 SQL 查询分析器进行索引分析。

高级选项

单击"高级选项"对话框查看或更改索引优化参数。


高级选项

使用"高级选项"对话框查看或更改默认索引优化参数。

选项

当前空间使用

显示数据库的数据大小和索引大小以及可用于增长的空间。不能从索引优化向导中修改该信息。

当前数据大小 (MB)
数据库内表和聚集索引的当前大小。
当前索引大小 (MB)
数据库内所有非聚集索引的当前大小。
可用于增长的空间 (MB)
磁盘上可用于数据库增长的空间。

索引优化参数

修改下列参数以提高索引优化向导的性能。

将要抽样的工作负荷查询的数目限制为
指定要抽样的工作负荷查询的数目。默认值为 200 个查询。从指定的工作负荷文件中随机选取查询。如果设置值超过工作负荷文件中的查询数，则优化所有查询。
用于建议索引的最大空间 (MB)
指定可由建议索引集占用的最大空间（以 MB 为单位）。默认空间大小是当前数据大小的三倍，或是所有附加磁盘驱动器上的最大可用空间，或是两者中较小的那一个。
每个索引的最大列数
指定索引优化向导建议的索引中的最大列数。允许的最大值是 16，这是默认值。


选择要优化的表

使用"选择要优化的表"对话框选择要优化的表。

选项

显示可用于分析的当前表。

表

单击此复选框以指定希望向导优化的表。此外，还可以单击此复选框清除以前选定的表。

实际行

显示表中的当前行数。

计划的行

显示表的计划增长量。默认情况下，该值与"实际行"的值相同。这种表的缩放特性使得能够在更小范围的样本数据库上研究建议的索引。对较小的示例数据库应使用合理的大小（若干百分比、每个表几千行），否则缩放的数据分配直方图可能不准确，而为示例数据库建议的索引集可能不同于为整个数据库建议的索引。

选择所有表

单击该选项选择所有列出的表。

清除所有表

单击该选项清除所有选定的表。


索引建议

使用"索引建议"对话框查看索引优化向导的建议。该对话框

显示建议的索引集。该列表可能包含要使用的当前索引、要除去的当前索引或要创建的新索引。

选项

聚集

表示现有索引是否为聚集索引。

索引名称

显示索引的名称。有一个图标表示索引的状态（现有的、新的或待除去的）。若要查看该图标的定义，请单击该图标。

表/视图名称

显示与索引关联的表或视图。

列名

显示索引使用的列。

分析

单击该选项可打开"报表"对话框。


报表

使用"报表"对话框选择报表类型。可将报表保存到用制表符分隔的文本文件。

选项

报表

显示可用报表类型列表中的选定报表。


调度索引更新作业

使用"调度索引更新作业"对话框调度索引建议的执行。

选项

应用更改

指定执行选项。

现在执行建议

指定立即执行。

调度其它时间执行建议

指定执行索引建议的日期和时间。

保存脚本文件

指定存储脚本文件的文件名和位置。可在稍后手工执行脚本，或在其它服务器上执行脚本。