 IIS 虚拟目录管理实用工具

IIS 虚拟目录管理实用工具

使用"虚拟目录属性"对话框中的下列选项卡指定虚拟根、与其关联的物理目录、数据库、登录信息及其它权限：

  • 虚拟目录属性对话框（常规选项卡）

  • 虚拟目录属性对话框（安全选项卡）

  • 虚拟目录属性对话框（数据源选项卡）

  • 虚拟目录属性对话框（设置选项卡）

  • 虚拟目录属性对话框（虚拟名称选项卡）

  • 虚拟目录属性对话框（高级选项卡）


虚拟目录属性对话框（常规选项卡）

使用此选项卡指定访问数据库所使用的虚拟目录名，以及与该虚拟目录关联的物理目录路径。

物理目录存储可通过虚拟目录访问的文件。通常可以在该目录中存储模板文件或带批注的映射架构文件。

选项

虚拟目录名

输入虚拟目录名，例如 VirtualRoot。

本地路径

输入与虚拟目录关联的物理目录的完整路径，例如 C:\Inetpub\Wwwroot\VirtualRoot。单击"浏览"按钮在本地计算机上查找该目录。在连接到远程计算机时，此浏览按钮是不可用的。


虚拟目录属性对话框（安全性选项卡）

使用此选项卡指定登录身份验证方法。此选项卡上的选项映射到三种 Microsoft® Internet Information 服务器 (IIS) 身份验证方案。

选项

总是用此身份登录

Windows 和 SQL Server 帐户类型映射到 IIS 身份验证安全性的匿名访问方案。使用匿名访问，任何人都可以访问虚拟目录。访问服务器的每个人都使用"用户名"和"密码"中指定的凭据登录。

用户名
指定用于登录的用户名。如果选择 SQL Server 帐户类型，则所指定的帐户名必须是有效的 Microsoft SQL Server™ 2000 登录。如果选择 Windows 帐户类型，则所提供的 Microsoft Windows® 登录将用于所有用户。
密码
指定用于选择的SQL Server 或 Windows 登录的密码。
SQL Server
选择该选项以指定用于访问服务器的 SQL Server 登录名和密码。当指定一个 SQL Server 登录时，虚拟目录中的所有用户都将使用该帐户。
Windows
选择该选项为虚拟目录的所有用户指定一个 Windows 帐户。默认情况下，使用 IUSR_ServerName（Internet Guest 帐户）访问服务器。IUSR_ServerName 是在安装 IIS 时创建的用户。默认情况下，"启用 Windows 帐户同步"是选中的。

使用 Windows 集成身份验证

选择该选项以使用 Windows 登录进行身份验证。

该选项映射到 Microsoft Windows NT® 质询/响应 (Windows NT 4.0) 或 Windows 集成身份验证 (Microsoft Windows 2000) IIS 身份验证方法。具有有效的 Windows NT 4.0 或 Windows 2000 用户帐户的用户经过身份验证并被允许访问虚拟目录。Windows 集成身份验证要求授予 Windows 用户帐户访问 SQL Server 的权限。

使用对 SQL Server 帐户的基本身份验证（明文）

选择该选项，可以通过提示用户输入 SQL Server 登录和密码以进行验证身份。

该选项不同于 IIS 身份验证安全性的基本身份验证方法。选择该选项，系统会提示用户输入 SQL Server 登录和密码。在该身份验证选项中，在 IIS 内启用匿名身份验证。用户所提供的登录必须是有效的 SQL Server 登录。因此，当您试图访问数据库时，ISAPI 会首先尝试匿名访问，而当匿名访问失败时，系统会将一条错误信息发送给浏览器。然后，浏览器显示一个对话框，要求用户输入 SQL Server 的用户名和密码。


虚拟目录属性对话框（数据源选项卡）

使用此选项卡指定包含要连接到的数据库的 Microsoft® SQL Server™ 2000 实例以及数据库名称。

选项

SQL Server

输入所需的服务器（或者是 SQL Server 实例）的名称。单击浏览（"..."）按钮查看网络上运行 SQL Server 的服务器。如果安装了多个 SQL Server 实例，则可以指定服务器名称和实例名称。如果没有指定实例名称，系统会采用默认实例。

数据库

输入服务器上的默认数据库名称，例如 Northwind。虚拟目录映射到该数据库。根据访问权限，可以在虚拟目录映射到的 SQL Server 实例上的其它数据库上执行查询；不过，这里指定的数据库为默认数据库。


虚拟目录属性对话框（设置选项卡）

使用此选项卡指定希望通过虚拟目录提供的 Microsoft® SQL Server™ 2000 访问类型。

说明 可在任何地方存储模板和架构文件。如果虚拟名称是为模板或架构而创建的，则目录路径将指定这些文件的位置。

默认情况下，URL中只允许模板。也可以允许在 URL 上执行 SQL 查询、XPath 查询或 POST 查询（可选）。

选项

允许 URL 查询

在 URL 上直接执行 SQL 查询。出于安全考虑，建议不要使用该选项。

允许模板查询

在 URL 内执行模板。模板是一个有效的 XML 文档，它由一个或多个 SQL 查询组成。默认情况下启用该选项。

允许 XPath 查询

直接在URL上针对批注的映射架构执行 XPath 查询。

允许 POST 查询

允许将数据发布到数据库。默认情况下，用户不能将数据发送到服务器，但可以访问服务器中的数据。

POST 查询的最大大小（以 KB 为单位）

指定每次查询可以发送到服务器的最大数据量（以 KB 为单位）。


虚拟目录属性对话框（虚拟名称选项卡）

使用此选项卡创建虚拟名称，该名称被直接指定为 URL 的一部分，用以执行模板文件、执行针对映射架构文件的 XPath 查询，或者访问数据库对象。因为在 URL 中只包括虚拟名称，所以不表现有关正在执行的内容和文件存储位置的信息。这样又增加了安全性。

选项

定义虚拟名称

指定虚拟名称，通过该名称可以访问资源。例如 VirtualRoot 虚拟目录中的虚拟名称 as 可以以 http://IISServer/VirtualRoot/as/ 方式访问。

类型

指定正在为其创建虚拟名称的查询的类型。

dbobject
表示数据库对象。
schema
表示针对于映射架构的 XPath 查询。
template
表示在模板中的 SQL 查询。

路径

指定模板和映射架构所在位置的目录路径。该路径可以是绝对路径，也可以是相对路径（相对于与虚拟目录相关的物理目录）。如果虚拟名称被创建为 dbobject 类型，则不需要路径。单击浏览（"..."）按钮搜索目录路径。在管理远程计算机时，浏览按钮是不可用的。

在创建模板或架构映射时，这个路径可以是到文件夹的路径，也可以是到文件的路径。如果是到文件夹的路径，则在 URL 中必须包含文件名（例如 http://IISServer/VirtualRoot/as/schema.xml）。如果是到文件的路径，则映射会直接转到该文件，从而只使用该文件。

不允许 URL 路径（用于 SQL Server 的 IIS 虚拟目录管理实用工具不验证路径项）。

新建

单击此处，可以创建新虚拟名称。

删除

单击此处，从定义的映射列表中删除所选的映射。


虚拟目录属性对话框（高级选项卡）

使用此选项卡指定 ISAPI 扩展动态链接库 (DLL)（Microsoft® SQL Server™ 2000 的Sqlisapi.dll）。通过虚拟目录访问 SQL Server 2000 实例时需要该文件。

选项

ISAPI 位置

指定 Sqlisapi.dll 的位置。如果在远程服务器上创建了虚拟目录，则可能必须提供 Sqlisapi.dll 的位置（默认情况下，Sqlisapi.dll 安装在 Program Files\Common Files\System\Ole DB 目录下）。如果将 Sqlisapi.dll 从其默认位置移动，则必须将 Sqlisapi.rll 也移动到同一位置。

其它用户设置

指定其它的可选设置。这些设置未经分析即追加到传递给 OLE DB 的连接字符串。

高速缓存选项

Sqlisapi.dll 有一个高速缓存选项，它在高速缓存内存储将在以后的查询中重新使用的映射架构。

选择"禁用映射架构的高速缓存"以防止高速存储映射架构。每次在映射架构上执行查询时，都重新装载映射架构。