词汇

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z 符号 英文索引表


词汇

A

ActiveX 数据对象 (ActiveX Data Objects)

一种易于使用的应用程序接口 (API)，该接口将 OLE DB 封装以用于 Visual Basic、用于应用程序的 Visual Basic、Active Server Pages 和 Microsoft Internet Explorer Visual Basic 脚本等语言中。

ActiveX 数据对象（多维）(ADO MD) (ActiveX Data Objects (Multidimensional) (ADO MD))

一种高级的、不依赖语言的基于对象的数据访问接口的集合，该集合为多维数据应用程序进行了优化。Visual Basic 及其它一些自动化语言将 ADO MD 用作多维数据存储的数据访问接口。ADO MD 是 ADO 2.0 及更高版本的一部分。

ADO (ADO)

参见定义： ActiveX 数据对象

ADO MD (ADO MD)

参见定义： ActiveX 数据对象（多维）(ADO MD)

安全标识号 (SID) (Security Identifier (SID))

标识登录到安全系统上的用户的唯一值。SID 可以标识一个或一组用户。

暗示性权限 (implied permission)

执行针对角色的活动的权限。暗示性权限不能授权、废除或拒绝。

按位运算 (bitwise operation)

操作单个位或测试某一位是开还是关的运算。

安装程序初始化文件 (Setup initialization file)

使用 Windows .ini 文件格式的一种文本文件，存储允许在不必有用户响应安装程序提示的情况下安装 SQL Server 的配置信息。

ANSI (ANSI)

参见定义： 美国国家标准学会 (ANSI)

ANSI 到 OEM 转换 (ANSI to OEM conversion)

当数据从使用特定代码页存储字符数据的数据库传输到使用不同代码页的计算机上的客户端应用程序时必定发生的字符转换。通常，基于 Windows 的客户端计算机使用 ANSI/ISO 代码页，而一些数据库（出于兼容性原因）可能使用 OEM 代码页，如 MS-DOS 437 代码页或代码页 850。

API (API)

参见定义： 应用程序接口 (API)

API 服务器游标 (API server cursor)

一种服务器游标，用于支持应用程序接口 (API)（如 ODBC、OLE DB、ADO 和 DB-Library）的游标函数。应用程序并不经常直接请求服务器游标，而是调用 API 的游标函数。如果这是支持所请求的游标功能的最佳方式，则该 API 的 SQL Server 接口实现服务器游标。

请参见： 服务器游标

B

半加法度量 (semiadditive measure)

可以沿多维数据集中的一个或多个（但不是全部）维度进行求和的度量值。例如，清单的库存量度量值可以沿地理维度求和以得到所有仓库的库存总量，但不能沿时间维度求和，因为该度量值定期指定快照数量。

绑定 (binding)

在 SQL 应用程序接口 (API) 中，绑定使结果集列或参数与程序变量相关联，以便当提取或更新行时数据自动移入或移出程序变量。

保存点 (savepoint)

使应用程序可以在遇到次要错误时回滚部分事务的标记。应用程序仍必须在事务完成时提交或回滚完整事务。

保存与转发数据库 (store-and-forward database)

参见定义： 分发数据库

bcp 实用工具 (bcp utility)

一种命令提示符大容量复制实用工具，它以用户指定的格式从操作系统文件或向操作系统文件复制 SQL Server 数据。

bcp 文件 (bcp files)

存储由大容量复制实用工具或同步创建的大容量复制数据的文件。

被动语态 (passive voice)

表示动词的主语接受该动词的动作。例如，在句子“该产品已被卖给另外一个客户了”中，主语 该产品 接受动词 卖 的动作。

请参见： 主动语态

备份 (backup)

系统错误后用于恢复数据的数据库、事务日志、文件或文件组的复本。

备份集 (backup set)

单个备份操作的输出。

备份媒体 (backup media)

用于存储备份集的磁带、磁盘或命名管道。

备份设备 (backup device)

备份或还原操作中使用的磁带或磁盘。

备份文件 (backup file)

存储完整或部分数据库、事务日志、文件和/或文件组备份的文件。

备注 (memo)

列的一种，包含长字符串文本，通常多于 255 个字符。这是 SQL Server text 数据类型的 Access 等价物。

本地登录标识 (local login identification)

用户登录到本地服务器时必须使用的标识 (ID)。登录 ID 最多可以有 128 个字符。这些字符可以是字母数字，但第一个字符必须为字母（例如 CHRIS 或 TELLER8）。

本地订阅 (local subscription)

对合并发布的订阅，使用发布服务器的优先级值进行冲突检测和解决。

本地多维数据集 (local cube)

使用 PivotTable 服务在本地计算机上创建和存储的带有 .cub 扩展名的多维数据集。

本地分发服务器 (local Distributor)

同时配置为 SQL Server 复制的发布服务器和分发服务器的服务器。

请参见： 分发服务器, 远程分发服务器

本地服务器 (local server)

SQL Server 2000 连接中，SQL Server 2000 实例与应用程序在同一台计算机上运行。

当在 Transact-SQL 语句中解析对数据库对象的引用时，执行该语句的 SQL Server 2000 实例。

SQL Server 2000 分布式查询中，执行分布式查询的 SQL Server 2000 实例。然后本地服务器访问查询中引用的任何链接服务器。

SQL Server 2000 远程存储过程中，执行引用远程存储过程的 EXEC 语句的 SQL Server 实例。然后本地服务器将执行请求传递给远程存储过程所驻留于的远程服务器。

请参见： 链接服务器, 远程服务器

本地组 (local group)

Windows NT 4.0 或 Windows 2000 中的组，包含来自相应域组和任何信任域的用户帐户和全局组，这些用户和全局组是在该域组中创建的。本地组中不能含有其它本地组。

本机格式 (native format)

大容量复制数据文件，使用与 SQL Server 用来在 SQL Server 数据库中存储数据的相同的内部数据结构在这些文件中存储数据。大容量复制可以快速处理本机模式文件，因为当在 SQL Server 和大容量复制数据文件之间传输数据时不必转换数据。

请参见： 字符格式

比较级 (comparative form)

英文中形容词或副词的一种词形，表示比较或较大的程度。较短的形容词和某些副词通常通过添加 -er 来构成其比较级，如“young”和“younger”。

变量 (variables)

赋以值的定义实体。局部变量使用 DECLARE@localvariable 语句定义，并通过 SELECT 或 SET@localvariable 语句在声明该变量的语句批处理内赋以初始值。

编写复制脚本 (replication scripting)

生成 .sql 脚本以用于配置和禁用复制。

表 (table)

一种二维数据对象，由行和列组成，用于存储关系数据库中的数据。每个表存储有关由数据库建模的一类对象的信息。例如，某个教育数据库将具有一个教师表、一个学生表和一个课程表。

表的列代表建模对象的一个特性（例如名、姓和地址）。每个行代表建模对象的一个发生。例如，Class 表中的一个行将记录有关上午 9:00 进行的代数 1 课程的信息，而另一个表将记录有关上午 10:00 进行的世界历史课程的信息。

表达式 (expression)

SQL 中符号和运算符的组合，它评估为单个数据值。简单的表达式可以是一个常量、变量、列或标量函数。复杂表达式是由运算符连接的一个或多个简单表达式。

表格格式数据流 (TDS) (tabular data stream (TDS))

SQL Server 内部客户端/服务器数据传输协议。TDS 允许客户端和服务器产品通讯，而与操作系统平台、服务器版本或网络传送无关。

表级约束 (table-level constraint)

当定义表或改变表时，允许在一个列上（列级约束）或几个列上（表级约束）定义各种形式的数据完整性的约束。约束支持域完整性、实体完整性、引用完整性以及用户定义的完整性。

标量聚合 (scalar aggregate)

在只包含聚合函数的 SELECT 语句列列表中指定的一种聚合函数（如 MIN()、MAX() 或 AVG()）。当列列表只包含聚合函数时，则结果集只具有一个行给出聚合值，该值由与 WHERE 子句谓词相匹配的源行计算得到。

表扫描 (table scan)

一种数据检索操作，该操作中数据库引擎必须读取表中的所有页以查找符合查询条件的行。

标识符 (identifier)

数据库中对象的名称。标识符可以具有 1 到 128 个字符。

标识列 (identity column)

表中已指派了标识属性的列。标识属性生成唯一数字。

标识属性 (identity property)

生成对表中每个行进行唯一标识的值的属性。当向具有标识列的表中插入行时，SQL Server 自动基于上次使用的标识值和创建列时指定的增量值来生成下一个标识值。

表锁 (table lock)

包括所有数据和索引的表上的锁。

标准安全机制 (standard security)

参见定义： SQL Server 身份验证

别名 (alias)

表达式中表或列的可选名称，常用来简化名称以方便以后在代码中的引用，防止可能的不明确引用，或在查询输出中提供更具描述性的名称。别名还可以是服务器的可选名称。

别名 (nickname)

当用于合并复制系统表时，另一个订阅服务器的名称，已知该订阅服务器已具有更新数据的指定生成。用来避免将更新发送给已接收到那些更改的订阅服务器。

bigint 数据类型 (bigint data type)

一种整型数据类型，其值的范围为从 -2^63 (-9223372036854775808) 到 2^63-1 (9223372036854775807)。

binary 数据类型 (binary data type)

固定长度的二进制数据类型，其最大长度为 8,000 个字节。

并发 (concurrency)

允许多个用户同时访问和更改共享数据的进程。SQL Server 使用锁定以允许多个用户同时访问和更改共享数据而彼此之间不发生冲突。

bit 数据类型 (bit data type)

存放 1 或 0 值的数据类型。

BLOB (BLOB)

参见定义： 二进制大对象

布尔型 (Boolean)

只可以评估为真或假的运算或表达式。

不感知游标 (insensitive cursor)

打开时不反映其他用户对基础数据进行的数据修改的游标。

不规则动词 (irregular verb)

不以通常的方式进行词尾变化的动词。不规则动词的一个例子是不以对原形添加 -ed 来创建过去式和过去分词的动词。不规则动词有几种常见类型，根据其表示过去式和过去分词的方式进行分类：元音变化（begin、began、begun）；添加 -en（beat、beat、beaten）；元音变化（spin、spun、spun）；-d 变化为 -t（lend、lent、lent）；无变化（put、put、put）。

不规则名词 (irregular noun)

不是通过添加 -s 或 -es 而构成的名词复数，如 men 或 women。

不规则形式类型 (irregular form type)

单词所使用的不规则形式的词尾变化（复数、过去式或未知）的类型。例如，单词 woman 具有不规则的复数形式 (women)，因为不按照复数的标准方式（添加 -s 或 -es）构成 woman 的复数。

不规则形式 (irregular form)

英文单词的一种形式，它是词尾变化标准规则的例外。例如，run 的过去式是 ran ，而不是 runned ；同样地，alumnus 的复数是 alumni ，而不是 alumnuses 。

不均衡层次结构 (unbalanced hierarchy)

叶节点距根节点的距离不同的维度层次结构。组件部件和结构图表层次结构通常是不均衡的。

请参见： 不齐整层次结构

不可重复读取 (nonrepeatable read)

当某个事务不止一次读取同一行，并且一个单独的事务在两次（或多次）读取之间修改该行时。因为在同一个事务内的多次读取之间修改了该行，所以每次读取都生成不同值，从而引发不一致问题。

不齐整层次结构 (ragged hierarchy)

一种维度层次结构，其中一个或多个级别在层次结构的一个或多个分支中不包含成员。例如，地理层次结构中的州或省级别对于不具有州或省的国家/地区不包含成员。

请参见： 不均衡层次结构

步骤对象 (step object)

一种数据转换服务 (DTS) 对象，它协调 DTS 包中的控制流和任务的执行。不会执行不具有相关的步骤对象的任务。

C

参照键 (referencing key)

参见定义： 外键 (FK)

操作 (action)

最终用户发起的对选定的多维数据集或多维数据集的一部分进行的操作。该操作可以用所选项目作为参数启动应用程序，也可以检索关于所选项目的信息。

层次结构 (hierarchy)

一种逻辑树结构，它这样组织维度的成员：每个成员都具有一个父成员和零个或多个子成员。

请参见： 级别, 维度层次结构

插入查询 (Insert query)

从一个表将特定列和行复制到另一个表或同一个表的查询。

插入值查询 (Insert Values query)

创建一个新行并在指定列中插入值的查询（SQL 语句）。

查询优化器 (query optimizer)

负责生成 SQL 语句的有效执行计划的 SQL Server 数据库引擎组件。

差异数据库备份 (differential database backup)

仅记录自上次完全数据库备份之后对数据库的更改的数据库备份。差异备份较小，还原比完整备份更快且对性能影响最小。

查找表 (lookup table)

English Query 应用程序中的数据库或硬编码中的表，包含代码及代码所代表的英文字或短语。例如，一个性别查找表包含以下代码和英文描述：

M, Male

常规多维数据集 (regular cube)

基于表并有自己的聚合的多维数据集。

常规维度 (regular dimension)

既不是父子维度又不是虚拟维度的维度。

常量 (constant)

代表特定数据值的一组符号。常量的格式取决于它所表示的值的数据类型。例如，'abc' 是字符串常量，123 是整型常量，'December 16, 1999' 是 datetime 常量，而 0x02FA 是二进制常量。

超大型维度 (very large dimension)

Analysis Services 中包含多于约五百万个成员、少于约一千万个成员的维度。使用特殊技术来处理超大型维度。

请参见： 巨型维度

超文本标记语言 (HTML) (Hypertext Markup Language (HTML))

标记某个文档以便在万维网上发布的系统。以 HTML 格式准备的文档包括引用图形和格式化标记。可以使用 Web 浏览器（如 Microsoft Internet Explorer）来查看这些文档。

char 数据类型 (char data type)

字符数据类型，最多可保存 8,000 个字符。

CHECK 约束 (CHECK constraints)

定义列中可接受的数据值。可以将 CHECK 约束应用于多个列，也可以将多个 CHECK 约束应用于单个列。当除去某个表时，也将除去 CHECK 约束。

成员 (member)

维度中的一个项目，表示数据的一个或多个出现。成员可以是唯一的或非唯一的。例如，1997 和 1998 表示 time 维度的 year 级别的唯一成员，而 January 表示 month 级别中的非唯一成员，因为如果 time 维度包含不止一年的数据的话，则该维度中可以有不止一个 January。

请参见： 虚拟维度

成员变量 (member variable)

由 Analysis Services 内部使用的值，以标识某个维度成员。MemberKeyColumn 属性指定维度的成员变量。例如，1 到 12 之间的某个数字可以是相应于年中的某个月的成员变量。

请参见： 成员键列, 成员名列

成员键列 (member key column)

维度级别的一个属性，指定该级别成员的标识符。该属性的值可以指定包含标识符或评估为标识符的表达式的列。

请参见： 成员名列, 成员变量

成员名列 (member name column)

维度级别的一个属性，指定该级别成员的名称。该属性的值可以指定包含名称或评估为名称的表达式的列。

请参见： 成员键列, 成员变量

成员属性 (member property)

除维度中包含的信息以外的有关维度级别的成员的信息（例如产品的颜色或销售代表的电话号码）。有关成员属性的更多信息，请参见 OLE DB 文档。

请参见： 虚拟维度

成员委派 (member delegation)

一种建模概念，描述接口成员从一个接口到另一个接口的映射方式。

成员组 (member group)

连续维度成员集合的系统生成的父代。

请参见： 维度

持续性 (persistence)

对象定义的保存，以便当前会话结束后对象定义可用。

冲突解决策略 (resolution strategy)

选择对象（该对象存在多个版本且在调用程序中未指定版本信息）时知识库引擎连续评估的一组准则。

触发器 (trigger)

当修改指定表中的数据时执行的存储过程。常常创建触发器以强制不同表中逻辑相关数据的引用完整性或一致性。

处理 (process)

多维数据集中，重建多维数据集的结构、将数据装载到多维结构中、计算汇总以及保存预先计算的聚合的一系列操作。作为动词指用数据和聚合填充多维数据集。它是多维数据集的三个处理选项之一。

维度中，从数据仓库中的维度表将数据装载到为维度定义的级别中并重建维度结构的操作。它是维度的两个处理选项之一。

数据挖掘模型中，从关系数据源或 OLAP 数据源将培训数据检索到为数据挖掘模型定义的结构中，使用数据挖掘算法对它进行统计分析，并将统计数据保存为数据挖掘内容的操作。作为动词指用数据挖掘内容填充数据挖掘模型。

请参见： 增量更新, 刷新数据

初始快照 (initial snapshot)

包括复制所需的架构和数据、约束、扩展属性、索引、触发器以及系统表的文件。当执行复制时将初始快照传输到订阅服务器。

请参见： 同步

初始媒体 (initial media)

每个媒体家族中的第一个媒体。

传递顺序 (pass order)

多维数据集中计算成员、自定义成员、自定义汇总公式和计算单元的评估顺序（从最高计算传递数到最低计算传递数）和计算顺序（从最低计算传递数到最高计算传递数）。传递顺序用于在计算多维数据集中单元的值时在所有计算传递中确定公式优先权。

请参见： 求解次序

串联 (concatenation)

将两个或多个字符串或表达式组合成为单个字符串或表达式，或将两个或多个二进制字符串或表达式组合成为单个二进制字符串或表达式。

垂直分区 (vertical partitioning)

基于选定的列将单个表分段为多个表。多个表中的每一个具有相同的行数，但列数较少。

请参见： 分区, 垂直筛选

垂直筛选 (vertical filtering)

筛选来自表的列。当用作复制的一部分时，创建的表项目只包含来自发布表的选定列。

请参见： 筛选, 垂直分区

磁带备份 (tape backup)

由 Windows NT 4.0 和 Windows 2000 支持的备份到任何磁带设备的备份操作。如果您打算创建磁带备份文件，则必须首先使用 Windows NT 4.0 和 Windows 2000 安装磁带设备。磁带设备必须物理连接到正在备份的 SQL Server。

词性 (parts of speech)

根据词的形式变化及其语法关系划分词的种类。传统的词性有动词、名词、代词、形容词、副词、介词、连词和感叹词。

CLI (CLI)

参见定义： 调用级接口 (CLI)

COM (COM)

参见定义： 组件对象模型 (COM)

COM 结构化存储文件 (COM-structured storage file)

一种组件对象模型 (COM) 复合文件，由数据转换服务 (DTS) 用来存储保存的 DTS 包的版本历史。

CPU 忙 (CPU busy)

一种 SQL Server 统计，报告中央处理器 (CPU) 在 SQL Server 工作上花费的时间（以毫秒为单位）。

存储过程 (stored procedure)

Transact-SQL 语句的预编译集合，这些语句在一个名称下存储并作为一个单元进行处理。SQL Server 提供存储过程以管理 SQL Server 和显示有关数据库和用户的信息。SQL Server 提供的存储过程称为系统存储过程。

存档文件 (archive file)

通过将 Analysis Services 数据库存档而创建的 .cab 文件。

错误日志 (error log)

记录来自 SQL Server 的系统信息的文本文件。

错误状态号 (error state number)

与 SQL Server 2000 消息相关的编号，帮助 Microsoft 支持工程师查找发出该消息的特定代码位置。这对于诊断错误（可能生成自 SQL Server 2000 代码中的多个位置）很有帮助。

cursor 数据类型 (cursor data type)

用于引用游标的特殊数据类型。

D

大级别 (large level)

一种包含大量成员的维度级别，其成员数等于或超过大级别的阈值。该阈值是在 Analysis Manager 的“属性”对话框中设置的一个变量。

代词 (pronoun)

一种词性，它占据名词的位置并起一个名词的作用，如 she、he 和 we。

代码页 (code page)

对于字符和 Unicode 数据的位模式的定义，此模式代表特定字母、数字或符号（例如 0x20 代表一个空格，而 0x74 代表字符“t”）。一些数据类型每个字符使用一个字节；每个字节可以具有 256 个不同的位模式中的一个模式。

单用户模式 (single-user mode)

只有一个用户可以访问某个资源的状态。SQL Server 实例和单独的数据库都可以置于单用户模式。

datetime 数据类型 (datetime data type)

一种 SQL Server 系统数据类型，存储组合的日期和时间值，范围为从 January 1, 1753 到 December 31, 9999，精确度为秒的百分之三（或 3.33 毫秒）。

DBCS (DBCS)

参见定义： 双字节字符集 (DBCS)

DCL (DCL)

参见定义： 数据控制语言 (DCL)

DDL (DDL)

参见定义： 数据定义语言 (DDL)

decimal 数据类型 (decimal data type)

从 -10^38 -1 到 10^38 -1 的固定精度和小数位的数字数据。

登录安全模式 (login security mode)

确定 SQL Server 2000 实例验证登录请求的方式的安全模式。有两种类型的登录安全性：Windows 身份验证和 SQL Server 身份验证。

登录（帐户） (login (account))

给予用户使用 SQL Server 身份验证连接到 SQL Server 2000 的权限的标识符。使用 Windows NT 身份验证连接到 SQL Server 2000 的用户由其 Windows 2000 登录标识，且不需要单独的 SQL Server 2000 登录。

递归分区 (recursive partitioning)

由数据挖掘算法提供程序使用的递归进程，该进程将数据划分为组，直到找不到有用的组为止。

调用级接口 (CLI) (call-level interface (CLI))

由 ODBC 支持的接口，供应用程序使用。

定位更新 (positioned update)

在游标当前位置的行上执行的更新、插入或删除操作。实际更改在用于在游标中生成当前行的基表的行中进行。Transact-SQL 批处理、存储过程和触发器使用 WHERE CURRENT OF 子句执行定位更新。应用程序使用 API 函数（如 ODBC SQLSetPos 函数）执行定位更新。

订阅 (subscribe)

向发布服务器请求数据。

订阅 (subscription)

定义将发布哪些数据、何时发布和发布到哪个订阅服务器的命令。

订阅服务器 (Subscriber)

接收已发布数据的复本的服务器。

订阅服务器 (subscribing server)

存储链接多维数据集的分析服务器。

请参见： 发布服务器, 链接多维数据集

订阅数据库 (subscription database)

订阅服务器上的一个数据库，接收由发布服务器发布的数据和数据库对象。

DML (DML)

参见定义： 数据操作语言 (DML)

动词 (verb)

表示动作、发生或存在的一种词性。一个动词可由一个或多个单词组成。例如，在以下句子中动词以斜体显示：

Employees sell products（职员销售产品）。

Employees will be working late（职员将加班）。

动词句式 (verb phrasing)

以英文表达关系的一种方式，该方式中一个实体是动作中的主语，此动作使用一个动词表达。例如 customers buy products（客户购买产品）。(Customers 是实体，buy 是动词，而 products 是直接对象。）

动态恢复 (dynamic recovery)

检测和/或尝试更正关系数据库管理系统 (RDBMS) 内软件错误或数据完整性损失的进程。

动态快照 (dynamic snapshot)

带有动态筛选的合并发布的快照，使用大容量复制文件应用该快照以改善性能。

动态筛选 (dynamic filter)

基于系统函数或用户定义的函数限制数据的合并复制筛选（用户定义函数的例子：SUSER_SNAME()）。

动态 SQL 语句 (dynamic SQL statements)

在用于 C 语言的嵌入式 SQL 中，在运行时生成和执行的 SQL 语句。

动态锁定 (dynamic locking)

SQL Server 用来确定任意时刻要使用的最划算的锁的进程。

动态游标 (dynamic cursor)

可以在游标打开时反映对基础数据进行的修改的游标。用户所做的更新、删除和插入在动态游标中加以反映。

DRI (DRI)

参见定义： 声明引用完整性 (DRI)

DSN (DSN)

参见定义： 数据源名称 (DSN)

DTS 包 (DTS package)

连接、数据转换服务 (DTS) 任务、DTS 转换以及工作流约束的有组织集合，由 DTS 对象模型定义，并使用 DTS 工具或通过编程进行组合。

DTS 包模板 (DTS package template)

模型数据转换服务 (DTS) 包。该模板用于帮助创建和配置包的特定类型。

独立 (autonomy)

当执行对数据的修改时一个站点所具有的对其它站点的独立性。

度量 (measurement)

English Query 中“形容词句式”对话框中的一个选项。使用它可以指定实体中所表示的某些度量。例如，表达为 the city is some temperature （城市炎热）的关系可能由 Area 实体和 Temperature 实体表示。

度量值 (measure)

在多维数据集内，基于该多维数据集的事实数据表中的某列的一组值，它们通常是数字。度量值是进行聚合和分析的主要值。

请参见： 维度

短语 (phrase)

缺少主语或谓词、或二者都缺少的语法相关的词的序列。

单元 (cell)

多维数据集中属性的集合（包括值），由从每个维度选择一个成员时的交集指定。

单元集 (cellset)

ADO MD 中的一个对象，该对象包含通过多维查询从多维数据集或其它单元集中选择的单元的集合。

队列 (queue)

SQL Server 事件探查器队列提供要捕获的服务器事件的临时存放位置。

对象 (object)

数据库中的下列数据库组件之一：表、索引、触发器、视图、键、约束、默认、规则、用户定义的数据类型或存储过程。

对象变量 (object variable)

包含对某个对象的引用的变量。

对象标识符 (object identifier)

给予对象的唯一名称。

在 Meta Data Services 中，由全局唯一标识符 (GUID) 和内部标识符构造的唯一标识符。所有对象都必须具有对象标识符。

请参见： 内部标识符

对象权限 (object permission)

控制在对象上执行操作的能力的特性。例如，表或视图权限控制哪些用户可以对表或视图执行 SELECT、INSERT、UPDATE 和 DELETE 语句。

对象所有者 (object owner)

控制对象权限的安全帐户，通常是对象的创建者。对象所有者 也称作数据库对象所有者。

对象相关性 (object dependencies)

对其它对象的引用，第一个对象的行为可以由它所引用的对象中的更改影响。例如，如果存储过程引用某个表，则表的更改可以影响存储过程的行为。

多重继承 (multiple inheritance)

一种建模术语，描述某个接口接收不止一个父接口的特征的方式。

多对多关系 (many-to-many relationship)

两个表之间的一种关系，该关系中每个表的行在相关表中具有多个匹配行。多对多关系通过使用第三个表（称作连接表）并向该表添加来自另两个表的主键列加以维护。

多对一关系 (many-to-one relationship)

两个表中的一种关系，该关系中一个表中的一个行可以与另一个表中的许多行相关。

多实例 (multiple instances)

在同一台计算机上运行的 SQL Server 的多个复本。可以有一个默认实例，该实例可以是任意版本的 SQL Server。可以有 SQL Server 2000 的多个命名实例。

请参见： 默认实例, 命名实例

多维表达式 (MDX) (Multidimensional Expressions (MDX))

用于定义多维对象及查询和操作多维数据的语法。

多维结构 (multidimensional structure)

一种数据库范例，它不将数据处理为关系表和列，而处理为包含维度和单元中的汇总数据的信息多维数据集。每个单元通过一组坐标来寻址，这些坐标指定该结构的维度中的某个位置。例如，坐标 {SALES, 1997, WASHINGTON, SOFTWARE} 处的单元将包含 Washington 1997 年的软件销售的汇总。

请参见： 多维数据集

多维 OLAP (MOLAP) (multidimensional OLAP (MOLAP))

一种存储模式，使用专用的多维结构存储分区的事实和聚合或某个维度。一个分区的数据完全包含在多维结构内。

请参见： 关系 OLAP (ROLAP), 混合 OLAP (HOLAP)

多维数据集 (cube)

数据的集合，这些数据组织并汇总到一个由一组维度和度量值所定义的多维结构中。

请参见： 多维结构

多维数据集角色 (cube role)

对一个多维数据集具有相同访问权限的用户和组的集合。当将数据库角色指派给多维数据集时即创建多维数据集角色，且此角色只应用于该多维数据集。

请参见： 自定义规则, 数据库角色

多维数据集文件 (cube file)

参见定义： 本地多维数据集

多线程服务器应用程序 (multithreaded server application)

在单个进程内创建多个线程以同时服务多个用户请求的应用程序。

多用户 (multiuser)

支持许多用户同时操作且又为每个用户提供计算机系统的全部功能的计算机功能。

E

English Query (English Query)

指一种 Microsoft 应用程序开发产品，它使用户可以用英文而不是 SQL 之类的计算机语言提出问题。例如，您可以询问“How many customers bought products last year?”（去年有多少客户购买了产品？），而不用准备等价的 SQL 语句。

English Query 应用程序 (English Query application)

基于关系数据库的一种应用程序，使最终用户可以以英文而不是以 SQL 之类的计算机语言提出问题。

二进制大对象 (binary large object)

具有异常大的尺寸的二进制数据块（如以数字数据存储的图片或乐曲），或足够存放这样的值的任意变量或表列。在 Transact-SQL 中，BLOB 存储在 image 列中。有时术语 BLOB 还适用于较大的字符数据值，如存储在 text 或 ntext 列中的值。

F

发布 (publication)

发布是一个数据库中的一个或多个项目的集合。这种多个项目的分组使得指定想要同时复制的逻辑相关的一组数据和数据库对象变得更容易。

发布保持期 (publication retention period)

预设的时间长度，控制订阅在同步过程中接收更新并在数据库中保持激活状态的时间长度。

发布表 (publishing table)

发布服务器上的表，其内数据已为复制进行标记，是发布的一部分。

发布服务器 (Publisher)

使数据可复制到其它服务器、检测已更改数据和维护有关站点上所有发布的信息的服务器。

发布服务器 (publishing server)

一种分析服务器，存储一个或多个链接的多维数据集的源多维数据集。

请参见： 链接多维数据集, 订阅服务器

发布数据库 (publication database)

发布服务器上的一个数据库，从该数据库标记作为传播到订阅服务器的发布的一部分进行复制的数据和数据库对象。

发生器 (producer)

收集特定事件分类中的事件并将数据发送到 SQL Server 事件探查器队列中。

返回参数 (return parameters)

存储过程输出参数的旧式定义，用在开放式数据服务和 DB-Library API 中。

自反关系 (reflexive relationship)

从表中的一个列或列的组合到同一个表中的其它列的关系。自反关系用于比较同一个表内的行。在查询中，这称作自联接。

范围查询 (range query)

将值的范围指定为搜索条件的一部分的查询，如从 10 到 100 的所有行。

方法 (method)

如在 SQL-DMO、OLE DB 和 ActiveX 数据对象 (ADO) 中那样通过使用 COM 对象执行某操作的函数。

请参见： 组件对象模型 (COM)

废除 (revoke)

删除以前在当前数据库内的用户帐户、角色或组上授予或拒绝的权限。

非聚集索引 (nonclustered index)

一种索引，该索引中索引的逻辑顺序与磁盘上行的物理存储顺序不同。

非叶 (nonleaf)

树结构中，具有一个或多个从属元素的元素。例如 Analysis Services 中具有一个或多个后代的维度成员。SQL Server 索引中，指向其它中间节点或叶节点的中间索引节点。

请参见： 叶

非叶成员 (nonleaf member)

具有一个或多个后代的成员。

分布式查询 (distributed query)

访问多个数据源的数据的单个查询。

分段 (segmentation)

一种数据挖掘技术，分析数据以发现共享类似的特性集的互斥记录集合。分段算法可以使用自学习技术（如聚集）或特定预测字段的监督学习技术。

请参见： 聚集

分发 (distribute)

从发布服务器将事务或数据的快照移动到订阅服务器，在订阅服务器上将它们应用于订阅数据库中的目的表。

分发保持期 (distribution retention period)

分发保持期决定为复制代理程序存储的信息量以及订阅将在分发数据库中保持活动的时间长度。当超出分发保持期时，分发清除代理程序将运行。

分发服务器 (Distributor)

作为分发数据库宿主并存储历史数据和/或事务以及元数据的服务器。

请参见： 本地分发服务器, 远程分发服务器

分发数据库 (distribution database)

分发服务器上的数据库，存储用于复制的数据，包括事务、快照作业、同步状态和复制历史信息。

分隔符 (delimiter)

Transact-SQL 中指出对象名称的开始和结尾的字符，使用双引号 ("") 或方括号 ([])。

分类 (classification)

参见定义： 预测

分区 (partition)

Analysis Services 中一种用于多维数据集的数据和聚合的存储容器。每个多维数据集包含一个或多个分区。对于带有多个分区的多维数据集，每个分区可以单独存储在不同的物理位置。每个分区可以基于不同的数据源。分区对于用户是不可见的；多维数据集看起来为单个对象。

分区 (partitioning)

以多个较小的表替换一个表的进程。每个较小的表都具有与原始表相同的格式，但只具有其数据的一个子集。为每个已分区的表分配行时均基于数据的某些特征（如特定键范围）。定义行分配到哪个表的规则必须明确。例如，将一个表分为两个表。将主键值小于指定值的所有行分配到一个表，而将主键值等于或大于该值的所有行分配到另一个表。分区可以提高应用程序处理速度，并减少多站点更新复制中发生冲突的可能性。可以通过创建视图来提高已分区表的可用性。通过联合所有已分区表上的选择操作而创建的视图，将数据表现为就象全部驻留于单个表中一样。

请参见： 筛选, 垂直分区, 水平分区

分析服务器 (Analysis server)

Analysis Services 的服务器组件，是专为创建和维护多维数据结构并提供多维数据以响应客户端查询而设计的。

FIPS (FIPS)

参见定义： 联邦信息处理标准 (FIPS)

FK (FK)

参见定义： 外键 (FK)

float 数据类型 (float data type)

存放从 -1.79E + 308 到 1.79E + 308 的浮点数字数据的数据类型。float 、double precision 和 float(n) 是 SQL Server 的 float 数据类型。

副词 (adverb)

修饰动词、形容词或其它副词的词性。在 English Query 中，能够正确解释“very”和“recent”这样的副词，但不能解释“rapidly”或“graciously”这样的副词。

父代 (parent)

层次结构中上一个较高级别中与当前成员直接相关的成员。父代的值通常是其所有子代的值的合并。例如，在包含级别 Quarter、Month 和 Day 的 Time 维度中，Qtr1 是 January 的父代。

请参见： Ancestor, 子代, 后代, 兄弟

复述 (restatement)

由 English Query 引擎返回的英文查询，它是对最终用户输入的查询的检查。复述使最终用户可以检查 English Query 引擎是否正确解释了其问题。如果复述准确，则将生成正确的 SQL 语句，因而返回的答案将有效。

服务器名称 (server name)

唯一标识网络上的某台服务器计算机的名称。SQL Server 应用程序可以通过仅指定服务器名称而连接到 SQL Server 的默认实例。SQL Server 应用程序在连接到服务器上的某个命名实例时必须既指定服务器名称又指定实例名称。

服务器游标 (server cursor)

在服务器上实现的游标。游标本身在服务器上生成，且只将应用程序提取的行发送到客户端。

请参见： API 服务器游标

复制 (replication)

从一个数据库将数据和数据库对象复制和分发到另一个数据库，然后使两个数据库之间的信息同步以获得一致性的进程。

复制冲突查看器 (Replication Conflict Viewer)

使用户可以查看和解决合并复制进程中发生的冲突以及检查解决冲突的方式。

复制的数据 (replicated data)

订阅服务器上已从发布服务器接收的数据。

复制监视器 (Replication Monitor)

使用户可以查看和管理负责各种复制任务的复制代理程序以及解决分发服务器上潜在的问题。

复制拓扑 (replication topology)

定义服务器和数据的复本之间的关系，并阐明决定数据在服务器之间的流动方式的逻辑。

G

干扰词 (noise word)

不参与全文查询搜索的词。例如 a、and、the（一个、和、这）等等。

感知游标 (sensitive cursor)

打开时可以反映其他用户对基础数据进行的修改的游标。其他用户进行的更新、删除和插入在感知游标中加以反映。感知游标通常通过省略 DECLARE CURSOR 语句中的 INSENSITIVE 关键字来用在 Transact-SQL 批处理、存储过程和触发器中。

隔离级别 (isolation level)

控制隔离数据以供一个进程使用并防止其它进程干扰的程度的事务属性。设置隔离级别定义了 SQL Server 会话中所有 SELECT 语句的默认锁定行为。

跟踪文件 (trace file)

由 SQL 事件探查器用来记录受监视事件的文件。

更改脚本 (change script)

包含在编辑会话内对数据库进行所有更改的 SQL 语句（按照更改进行的顺序）的文本文件。每个更改脚本保存在单独的文本文件中，带有扩展名 .sql。更改脚本以后可以使用 osql 之类的工具重新将其应用到数据库。

更新 (update)

修改一个或一些现有行中的一个或多个数据值的操作，通常通过使用 UPDATE 语句来进行。有时，术语更新 指任何数据修改，包括插入、更新和删除操作。

更新锁 (update lock)

放置在可更新的资源（如行、页、表）上的锁。更新锁用于防止常见形式的死锁，这类死锁在多个会话锁定资源并且稍后可能更新资源时发生。

更新统计 (update statistics)

重新计算指定索引中的键值分发信息的进程。这些统计由查询优化器用来确定执行查询的最有效方式。

更新查询 (Update query)

更改表中的一个行或多个行的列中的值的查询。

工程 (project)

English Query 中包含关系数据库的结构和语义对象（如实体、关系和字典条目）的定义的文件。其扩展名为 *.eqp。它用于测试 English Query 将英文问题转换为 SQL 语句的方式。以后，可以将它编译到带有 *.eqd 扩展名的可部署的应用程序文件中。

工具 (tool)

带有图形用户界面的 SQL Server 应用程序，用于执行公用任务。

共享锁 (shared lock)

由非更新（读取）操作创建的锁。其他用户可以并发读取数据，但任何事务都不能获取数据上的排它锁，直到已释放所有共享锁。

共享维度 (shared dimension)

在数据库内创建的维度，可以由该数据库内的任意多维数据集使用。

请参见： 专用维度

固定服务器角色 (fixed server role)

存在于服务器级别的预定义角色。该角色的作用域限于其所定义于的 SQL Server 实例。

固定数据库角色 (fixed database role)

每个数据库中都存在的预定义的角色。该角色的作用域限于其所定义于的数据库。

关键字 (keyword)

SQL Server 中的保留字，执行某种特定功能，如定义、操作和访问数据库对象。

关系 (relationship)

表之间的链接，使一个表中的外键引用另一个表中的主键。如果强制表之间的引用完整性，则关系线在数据库关系图中以一根实线表示；如果 INSERT 和 UPDATE 事务不强制引用完整性，则以虚线表示。关系线的终结点显示一个主键符号以表示主键到外键关系，或者显示一个无穷符号以表示一对多关系的外键端。

在 English Query 中，描述实体彼此之间的关系的实体之间的关联。关系可以以英文简明描述为有关实体的简单陈述，例如 customers purchase products （客户购买产品）。可能需要不止一个联接来表示单个关系。

关系 (relationship)

在 Meta Data Services 中，关系是一对对象之间的关联，这里一个对象是起点，另一个对象是目的。该关联对后续的每一对对象重复，以便一个关系的目的成为下一个关系的起点。这样，信息模型中的所有对象通过一个关系链相互关联，该关系链从一个对象延伸到下一个对象，贯穿此信息模型。

关系对象 (relationship object)

表示担任彼此相关的角色的一对对象的对象。

请参见： 顺序关系

关系类型 (relationship type)

两个接口之间的关系的定义，如在信息模型中所定义的一样。关系类型类似于一个类，因为它描述特定实例必须符合的特征。

关系 OLAP (ROLAP) (relational OLAP (ROLAP))

使用关系数据库中的表存储多维结构的存储模式。

请参见： 多维 OLAP (MOLAP), 混合 OLAP (HOLAP)

关系数据库 (relational database)

在表中组织的信息的集合。每个表建立机构感兴趣的一个对象类的模型（例如 Customers 、Parts 、Suppliers ）。表中的每个列建立对象一个特性的模型（例如 LastName 、Price 、Color ）。表中的每一行表示表建立的对象类中的一个实体（例如客户名 John Smith 或部件号 1346）。查询可以使用一个表中的数据来查找其它表中的相关数据。

关系数据库管理系统 (RDBMS) (relational database management system (RDBMS))

将数据组织为相关的行和列的系统。SQL Server 是一个关系数据库管理系统 (RDBMS)。

高速缓存老化数据清除 (cache aging)

高速缓存确定高速缓存行何时过时及必须刷新的机制。

规范化规则 (normalization rules)

一组数据库设计规则，它使数据冗余减到最小，并得到这样一个数据库：数据库引擎和应用程序软件可以在此数据库中方便地强制完整性。

规则 (rule)

绑定到列或用户定义的数据类型并指定列可接受哪些数据值的数据库对象。CHECK 约束提供相同的功能，因为其在 SQL-92 标准中，所以首选使用。

规则 (rule)

在 Analysis Services 中，规则为安全读取和读/写角色权限指定无限制、完全受限或自定义之类的限制。

请参见： 角色

滚动 (scroll)

以除只进以外的方向移动游标的功能。用户可以向上和向下移动游标。

过程缓存 (procedure cache)

SQL Server 内存缓冲池的一部分，用于存储 Transact-SQL 批处理、存储过程和触发器的执行计划。执行计划记录 SQL Server 为生成由包含在批处理、存储过程或触发器中的 Transact-SQL 语句指定的结果而必须采取的步骤。

国际标准化组织 (ISO) (International Organization for Standardization (ISO))

负责发展国际数据通讯标准的两个国际标准团体之一。国际标准化组织 (ISO) 与国际电子技术委员会 (IEC) 紧密合作来定义计算的标准。他们共同发布了 SQL 的 ISO/IEC SQL-92 标准。

国际电子技术委员会 (IEC) (International Electrotechnical Commission (IEC))

负责发展国际数据通讯标准的两个国际标准团体之一。国际电子技术委员会 (IEC) 与国际标准化组织 (ISO) 紧密合作来定义计算的标准。他们共同发布了 SQL 的 ISO/IEC SQL-92 标准。

过适 (overfitting)

某些数据挖掘算法的特性，通过将数据中的随机变化视为重要模式而为其赋以重要性。

H

函数 (function)

作为单个逻辑单元运行的代码块。函数通过名称来调用，接受可选输入参数，并返回一个状态和可选的输出参数。许多编程语言都支持函数，包括 C 语言、Visual Basic 和 Transact-SQL。Transact-SQL 提供内置函数（不能修改），并支持用户定义的函数（可以由用户创建和修改）。

行 (row)

SQL 表中构成表中的水平行的元素集合。表中的每一行代表由该表建模的对象的一个出现，并存储该对象所有特性的值。例如，在 Northwind 示例数据库中，Employees 表建立 Northwind Traders 公司职员的模型。表中的第一行记录职员 ID 为 1 的职员的全部信息（例如姓名和头衔）。

请参见： 列

行集 (rowset)

用于包含结果集的 OLE DB 对象。它还展示基于应用程序设置的行集属性的游标行为。

行聚合函数 (row aggregate function)

生成汇总值的一种函数，这些汇总值在查询结果中作为附加行出现（与作为新列出现的聚合函数结果不同）。这使您得以在一个结果集中看到详细汇总的行。行集合函数（SUM、AVG、MIN、MAX 和 COUNT）在 SELECT 语句中与 COMPUTE 子句一起使用。

行筛选 (row filter)

指定要发布的和当需要将特定行传播到订阅服务器时表中行的一个子集。

行锁 (row lock)

表中单个行上的锁。

合并 (merge)

将两个分区组合为单个分区的操作。

合并复制 (merge replication)

复制的一种，允许站点对已复制数据进行匿名更改，并在晚些时候合并更改和根据需要解决冲突。

请参见： 快照复制, 事务复制

核心 (kernel)

SQL Server 2000 中存储引擎的一个子集，某些错误信息中会引用它。Windows 2000 中操作系统的核心，执行一些基本操作。

HOLAP (HOLAP)

参见定义： 混合 OLAP (HOLAP)

后代 (descendant)

维度层次结构中的一个成员，它与相同维度内的更高级别的成员相关。例如，在包含 Year、Quarter、Month 和 Day 级别的 Time 维度中，January 是 1997 的后代。

请参见： Ancestor, 子代, 父代, 兄弟

候选键 (candidate key)

对于表中的每一行具有唯一值的一个列或一组列。每个候选键值唯一标识表中的一个行。表可以具有多个候选键。表中的一个候选键由数据库设计器指定为表的主键，其它候选键称作备用键。

HTML (HTML)

参见定义： 超文本标记语言 (HTML)

幻像 (phantom)

通过一个任务，在以前由另一个尚未提交其事务的任务读取的行的范围中插入新行或删除现有行。带有未提交事务的任务由于该范围中行数的更改而无法重复其原始读取。如果某个连接设置其事务隔离级别为可串行，则 SQL Server 使用键范围锁定以防止幻像。

恢复间歇 (recovery interval)

数据库引擎恢复一个数据库所需的最大时间量。数据库引擎确保数据库日志的活动部分足够小，以在为恢复间歇指定的时间量内恢复数据库。

恢复日志文件 (redo log file)

参见定义： 备份文件

回滚 (roll back)

删除由一个或多个部分完成的事务执行的更新。为在应用程序、数据库或系统错误后还原数据库的完整性，需要使用回滚。

请参见： 提交

回写 (write back)

更新多维数据集单元值、成员或成员属性值。

请参见： 写启用

会话 (session)

English Query 中由 English Query 引擎执行的操作序列。会话在用户登录时开始，在用户注销时结束。会话期间的所有操作构成一个事务作用域，并受由登录用户名和密码决定的权限的支配。

混合模式 (Mixed Mode)

将 Windows 身份验证和 SQL Server 身份验证相组合。混合模式使用户既可以通过 Windows NT 4.0 或 Windows 2000 用户帐户，又可以通过 SQL Server 登录连接到 SQL Server 的实例。

混合 OLAP (HOLAP) (hybrid OLAP (HOLAP))

使用多维数据结构和关系数据库表的组合来存储多维数据的存储模式。Analysis Services 以多维结构存储 HOLAP 分区的聚合，而以关系数据库存储事实。

请参见： 多维 OLAP (MOLAP), 关系 OLAP (ROLAP)

活动语句 (active statement)

一种 SQL 语句，该语句已执行，但其结果集尚未取消或完全处理。

活锁 (livelock)

由于一系列交叠共享锁不断干扰而被重复拒绝的对排它锁的请求。SQL Server 检测四次拒绝后的状况，并拒绝更多的共享锁。当读事务独占某个表或页（强制写事务无限等待）时也将发生活锁。

请参见： 死锁

I

IEC (IEC)

参见定义： 国际电子技术委员会 (IEC)

image 数据类型 (image data type)

一种 SQL Server 可变长度的二进制数据类型，其最大长度为 2^31 - 1 (2,147,483,647) 个字节。

int (integer) 数据类型 (int (integer) data type)

一种 SQL Server 系统数据类型，存放从 -2^31 (-2,147,483,648) 到 2^31 - 1 (2,147,483,647) 的整数。

IPC (IPC)

参见定义： 进程间通讯 (IPC)

ISO (ISO)

参见定义： 国际标准化组织 (ISO)

ISQL (ISQL)

参见定义： 交互式结构化查询语言 (ISQL)

J

结果 (result)

English Query 中向 English Query 应用程序提出的问题的英文答案。

级 (rank)

对于全文和 SQL Server 联机丛书搜索，表示行或主题与指定的搜索条件接近的程度的值。对于 Meta Data Services 和 Analysis Services，表示元素（如维度成员、层次结构级别或集合中的元组）的相对位置的值。

基本数据类型 (base data type)

任意系统提供的数据类型，例如 char 、varchar 、binary 和 varbinary 。用户定义的数据类型由基本数据类型导出。

请参见： 数据类型, 用户定义的数据类型

基表 (base table)

数据库中永久存储的表。基表由视图、游标、SQL 语句和存储过程引用。

请参见： 基础表

级别 (level)

维度层次结构中成员集合的名称，该集合的所有成员距层次结构的根的距离相同。例如，Time 层次结构可能包含级别 Year、Month 和 Day。

请参见： 维度, 层次结构

级别层次结构 (level hierarchy)

参见定义： 维度层次结构

集成安全性 (integrated security)

参见定义： Windows 身份验证

基础表 (underlying table)

由视图、游标或存储过程引用的表。

请参见： 基表

级联更新 (cascading update)

更新主键值的操作，该值由其它表的现有行中的外键列引用。在级联更新中，更新所有外键值以与新的主键值相匹配。

级联删除 (cascading delete)

删除包含主键值的行的操作，该值由其它表的现有行中的外键列引用。在级联删除中，还删除其外键值引用删除的主键值的所有行。

记录 (record)

视作一个单元的信息的一组相关字段（列）。在 SQL 数据库中记录更经常被称作行。

记录集 (recordset)

用于包含结果集的 ActiveX 数据库对象 (ADO) 对象。它还展示基于应用程序设置的记录集属性的游标行为。ADO 记录集映射到 OLE DB 行集。

机器 DSN (machine DSN)

在系统注册表中存储数据库的连接信息。连接信息由 ODBC 驱动程序管理器用来建立连接的参数和相应的值组成。

即时更新 (immediate updating)

快照复制和事务复制可用的一个选项，允许在订阅服务器上对已复制数据进行数据修改。然后使用两阶段提交协议 (2PC) 将数据修改立即传播到发布服务器。

即时更新订阅 (immediate updating subscriptions)

对快照或事务发布的一种订阅，用户能够在订阅服务器上修改数据。然后使用两阶段提交协议 (2PC) 将数据修改立即传播到发布服务器。

即时更新订阅服务器 (immediate updating Subscribers)

参见定义： 即时更新订阅

计算公式 (calculation formula)

一种多维表达式 (MDX) 的表达式，用于为计算子多维数据集中的单元提供值（依照应用的计算条件）。

请参见： 求解次序

计算列 (calculated column)

表中显示表达式结果而不是存储的数据的列。例如 CalculatedCostColumn = Price * Quantity 。

计算列 (computed column)

表中的虚拟列，其值在运行时计算得到。该列中的值并未存储在表中，而是基于定义该列的表达式计算得到。计算列的定义的一个例子如下：Cost 为 Price * Quantity 。

计算成员 (calculated member)

维度的一个成员，其值是使用表达式在运行时计算的。计算成员的值可能从其它成员的值导出。计算成员是任何非输入成员的成员。例如，计算成员 Profit 可以通过从成员 Sales 的值中减去成员 Cost 的值来确定。

请参见： 输入成员

计算字段 (calculated field)

查询中定义的一种字段，它显示表达式的结果而不是存储的数据。

计算子多维数据集 (calculation subcube)

多维数据集单元的集合，用于创建计算单元定义。单元的集合由多维表达式 (MDX) 集合表达式的组合定义。

请参见： 求解次序

计算传递 (calculation pass)

多维数据集中的一个计算阶段，在该阶段中对适用的计算进行评估。完成全部计算可能需要多个传递。

请参见： 求解次序

计算条件 (calculation condition)

一种多维表达式 (MDX) 的逻辑表达式，用于确定计算公式是否要应用于计算子多维数据集中的某个单元。

请参见： 求解次序

架构 (schema)

SQL-92 标准中数据库对象的一个集合，这些对象由单个用户所有并构成单个命名空间。命名空间是不能具有重复名称的一组对象。例如，仅当两个表位于彼此独立的架构中时才可以具有相同的名称，同一个架构中不可以有名称相同的表。在 Transact-SQL 中，与架构相关联的许多功能均通过数据库用户 ID 实现。在数据库工具中，架构也指描述架构或数据库中的对象的目录信息。在 Analysis Services 中，架构是对多维数据集和维度之类的多维对象的一种描述。

架构行集 (schema rowset)

一种特殊的 OLE DB 或 Analysis Services 行集，报告数据库或多维数据集中对象的目录信息。例如，OLE DB 架构行集 DBSCHEMA_COLUMNS 描述表中的列，而 Analysis Services MDSCHEMA_MEASURES 架构行集描述多维数据集中的度量值。

加密 (encryption)

通过将数据更改为不可读形式而使敏感信息得以保密的方法。

加密触发器 (encrypted trigger)

使用可选加密参数创建的触发器，该参数对定义文本加密且不能解密。加密使得信息不可破译，以保护其不会遭到未授权的查看或使用。

加载项 (add-in)

一种自定义扩展，可以使用支持组件对象模型 (COM) 的任何语言（通常为 Visual Basic）编写，它与 Analysis Manager 交互，并提供特定功能。加载项使用 Analysis 加载项管理器进行注册。它们由 Analysis 加载项管理器调用，以响应用户界面中的用户操作。

键 (key)

唯一标识行 (PRIMARY KEY)、定义两表之间的关系 (FOREIGN KEY) 或用于生成索引的一个列或一组列。

请参见： 键列

检查点 (checkpoint)

一种事件，在该事件中数据库引擎将脏缓冲区页写入磁盘。脏页是已修改但所做修改尚未写入磁盘的页。每个检查点将在上个检查点是脏的且仍未写入磁盘的所有页写入磁盘。检查点基于由数据修改生成的日志记录的数目定期发生，或当用户请求或系统关机时发生。

键范围锁 (key range lock)

用于锁定表中记录之间的范围的锁，以防止记录集中的幻像插入或删除。确保可串行事务。

键集驱动游标 (keyset-driven cursor)

一种游标，打开时显示由其他用户更新其成员行的效果，但不显示插入或删除的效果。

间接宾语 (indirect object)

指称动词的动作所间接影响的一个（或一些）实体的一个（或一些）词。例如“Emily sliced me some cheese”（Emily 为我切了一些干酪），Me 是间接宾语。

键列 (key column)

由主键、外键或索引键引用的列。

请参见： 键

脚本 (script)

用于执行某项操作的 Transact-SQL 语句的集合。Transact-SQL 脚本存储为文件，通常带有 .sql 扩展名。

交叉表查询 (crosstab query)

显示来自某个字段或表的汇总值的数据，然后按照两组事实将它们分组：一个沿数据表的左侧向下，一个沿数据表的顶端向右。

交互式结构化查询语言 (ISQL) (interactive structured query language (ISQL))

SQL Server 提供的交互式命令提示实用工具，使用户可以从服务器或工作站执行 Transact-SQL 语句或批处理并查看返回的结果。

介词 (preposition)

一种词性，它将一个名词或名词替代物与句子中的另一个词链接并联系起来。例如，在句子 """"the dancers leaped across the stage""""（舞者跃过舞台）中，across 便是介词。常用作介词的词有 about 、after 、among 、before 、between 、but 、during 、for 、from 、in 、into 、near 、of 、on 、over 、to 、until 、with 等等。

介词句式 (preposition phrasing)

以英文表达关系的一种方式，该方式中一个实体作为主语，一个实体作为对象，二者由一个介词链接起来。例如，在句子“stories are about subjects”（故事是关于主题的）中，stories 是主语实体，about 是介词，而 subjects 是对象。

结构化查询语言 (SQL) (Structured Query Language (SQL))

用于插入、检索、修改和删除关系数据库中的数据的一种语言。SQL 还包含用于定义和管理数据库中对象的语句。SQL 是大多数关系数据库所支持的语言，且是由国际标准化组织 (ISO) 和美国国家标准学会 (ANSI) 发布的标准的主题。SQL Server 2000 使用称为 Transact-SQL 的 SQL 语言版本。

结构化存储文件 (structured storage file)

参见定义： COM 结构化存储文件

结果集 (result set)

从 SELECT 语句返回的行的集合。结果集中行的格式由 SELECT 语句的列的列表定义。

接口 (interface)

属性、方法和集合的定义集，构成行为和数据的一个逻辑分组。类由其所实现的接口定义。一个接口可能由许多不同的类实现。

接口含义 (interface implication)

如果一个接口暗示另一个接口，则实现第一个接口的任何类也必须实现第二个接口。接口含义用在信息模型中以获取多重继承的某些效果。

进程间通讯 (IPC) (interprocess communication (IPC))

一种机制，操作系统进程和线程通过它交换数据和消息。IPC 包括本地机制（如 Windows 共享内存）或网络机制（如 Windows 套接字）。

近似搜索 (proximity search)

搜索指定的词彼此接近的情况的全文查询。

静态游标 (static cursor)

以游标打开时刻的当时状态显示结果集的游标。静态游标在游标打开时不反映对基础数据进行的更新、删除或插入。有时称它们为快照游标。

警报 (alert)

用户定义的对 SQL Server 事件的响应。警报既可以执行定义的任务，又可以向指定的操作员发送电子邮件和/或呼叫消息。

精度 (precision)

指定小数点左边和右边可以存储的十进制数字的最大总数。

静态 SQL 语句 (static SQL statements)

在用于 C 语言的嵌入式 SQL 中，在编译应用程序时生成的 SQL 语句。当编译应用程序时将它创建为存储过程，而当应用程序运行时执行该存储过程。

镜像 (mirroring)

通过在单独的磁盘上维护数据的完全冗余复本来保护因磁盘错误而引起的数据丢失的进程。镜像可以在下列几个级别上实现：在 SQL Server 2000 中、在操作系统中以及在磁盘控制器硬件中。

局部变量 (local variable)

用户定义的变量，具有已赋的值。局部变量使用 DECLARE 语句定义，使用 SELECT 或 SET 语句赋以初始值，并在声明该变量的语句批或过程内使用。

聚合 (aggregation)

包含预先计算好的多维数据集数据的表或结构。

聚合 (aggregation)

构成整体的各个对象的集合。聚合可以是对象之间整体与部分关系的一个具体的或概念上的集合。

聚合包装 (aggregation wrapper)

将一个 COM 对象封装在另一个 COM 对象中的包装。

聚合查询 (aggregate query)

一种查询（SQL 语句），它通过包含一个聚合函数（如 Sum 或 Avg ）来汇总来自多个行的信息。

聚合函数 (aggregate function)

一种函数，它对一组行中的某个列执行计算，并返回单个值。

聚合前缀 (aggregation prefix)

一个字符串，它与系统定义的 ID 相组合，以便为分区的聚合表创建唯一的名称。

聚集 (clustering)

一种数据挖掘技术，它对数据进行分析，根据记录在多维特性空间中的位置对记录进行分组。聚集是一种自学习技术。

请参见： 分段

聚集索引 (clustered index)

一种索引，该索引中键值的逻辑顺序决定了表中相应行的物理顺序。

拒绝 (deny)

从某用户帐户删除权限并防止该帐户通过权限内的组或角色的成员资格获取权限。

句式 (phrasing)

以英文表达某种关系的一种方式。句式的类型包括名称句式、形容词句式、子集句式、介词句式、动词句式和特征句式。例如，department names are names of departments （部门名称是部门的名称）是名称句式的一个例子。

巨型维度 (huge dimension)

Analysis Services 中包含的成员数多于约一千万的维度。巨型维度必须使用关系 OLAP (ROLAP) 存储模式。

请参见： 超大型维度

决策树 (decision tree)

由某些数据挖掘方法生成的数据的树状模型。决策树可用于预测。

请参见： 预测

角色 (role)

一种 SQL Server 安全帐户，它是管理权限时可以视为单个单元的其它安全帐户的集合。角色可以包含 SQL Server 登录、其它角色以及 Windows 登录或组。

角色 (role)

在 Analysis Services 中，角色使用 Windows 安全帐户来限制用户访问数据库、多维数据集、维度和数据挖掘模型时的访问的作用域和权限。

请参见： 规则

决策支持 (decision support)

为支持发现业务趋势所需的复杂分析而设计的系统。从这些系统检索的信息使管理者得以根据对业务趋势的及时准确的分析作出经营决策。

均衡层次结构 (balanced hierarchy)

一种维度层次结构，其中所有的叶节点与根节点的距离相同。

K

开放式数据服务 (ODS) (Open Data Services (ODS))

SQL Server 数据库引擎层，该引擎层将客户端请求传输到数据库引擎中的适当函数。开放式数据服务表现扩展的存储过程 API，该 API 用于编写可以从 Transact-SQL 语句调用的 DLL 函数。

开放式数据库连接 (ODBC) (Open Database Connectivity (ODBC))

一种数据访问应用程序接口 (API)，支持对可使用 ODBC 驱动程序的任何数据源的访问。ODBC 与美国国家标准学会 (ANSI) 和国际标准化组织 (ISO) 的用于数据库调用级接口 (CLI) 的标准一致。

开放信息模型 (OIM) (Open Information Model (OIM))

由元数据合并 (MDC) 发布并由软件供应商广泛支持的一种信息模型。OIM 是对由主题区组织的元数据结构的正式描述。

可串行 (serializable)

最高事务隔离级别。可串行事务锁定其读取或修改的所有行，以确保事务在与其它任务完全隔离的情况下完成。这保证一系列可串行事务在按照相同的序列运行时将始终生成相同的结果。

可更改维度 (changing dimension)

具有可变的成员结构的维度。可更改维度旨在支持对结构和数据的频繁更改。

客户端应用程序 (client application)

一种应用程序，它从分析服务器检索数据，并在本地对来自关系数据库或多维数据库的数据进行分析和展示。客户端应用程序通过 PivotTable 服务组件连接到分析服务器。

客户端游标 (client cursor)

在客户端实现的游标。整个结果集首先传输到客户端，接着客户端应用程序接口 (API) 软件从这个已被缓存的结果集实现游标功能。

可再次使用的书签 (reusable bookmark)

可以从给定表的某个行集使用并用在同一个表的不同行集上以定位到相应行的书签。

可支持 Internet 的 (Internet-enabled)

启用到 Internet 订阅服务器的复制的发布设置。

可转换订阅 (transformable subscription)

允许复制期间的数据转换服务 (DTS) 的数据移动、转换映射和筛选功能的订阅。

空闲时间 (idle time)

一种 SQL Server 2000 代理程序条件，定义构成空闲状态的 SQL Server 2000 数据库引擎对 CPU 的占用程度。然后可以创建 SQL Server 2000 代理程序作业，以便每当数据库引擎 CPU 的占用程度降至空闲时间定义中定义的等级以下时，运行这些作业。这使得 SQL Server 代理作业对其它访问数据库的任务可能造成的影响减到最小。

控制流语言 (control-of-flow language)

控制触发器、存储过程和批处理中的 SQL 语句和语句块的执行流的 Transact-SQL 关键字。

控制中断报表 (control-break report)

以用户定义的组或分割方式汇总数据的报表。当遇到不同的数据时将触发一个新组。

库 (library)

Analysis Services 中包含共享对象（如共享维度）的文件夹，可以由数据库内的多个对象使用。

块 (blocks)

在 BEGIN 和 END 之间的一系列 Transact-SQL 语句。可以将 BEGIN...END 块嵌套于其它 BEGIN...END 块内。

快照代理程序 (Snapshot Agent)

准备快照文件，其中包含已发布表的架构和数据，然后将这些文件存储在快照文件夹中，并在发布数据库中插入同步作业。

快照代理程序实用工具 (Snapshot Agent utility)

配置和触发快照代理程序，该代理程序准备快照文件，其内包含已发布表和数据库对象的架构和数据。

快照复制 (snapshot replication)

一种复制类型，将数据以特定时刻的当时状态分发，不监视对数据的修改。

请参见： 合并复制, 事务复制

快照游标 (snapshot cursor)

参见定义： 静态游标

扩展盘区 (extent)

每当 SQL Server 对象（如表或索引）需要更多空间时分配给该对象的空间所属的单元。在 SQL Server 2000 中，一个扩展是八个邻接的页。

扩展存储过程 (extended stored procedure)

动态链接库 (DLL) 中的一种函数，它使用 SQL Server 2000 扩展存储过程 API 进行编码。然后可以使用与用于执行 Transact-SQL 存储过程的相同的语句从 Transact-SQL 调用该函数。可以生成扩展存储过程来实现用 Transact-SQL 存储过程无法实现的功能。

L

来宾 (guest)

所有 SQL Server 2000 数据库中均提供的一种特殊用户帐户，它不能从任何数据库中删除。如果使用未指派给数据库中的某个用户帐户的登录来进行连接，并且该连接引用此数据库中的对象，那么它仅具有指派给该数据库中的 guest 帐户的权限。

LCID (LCID)

参见定义： 区域设置标识符 (LCID)

粒度 (granularity)

数据元素中包含的信息的确切性程度。具有细粒度的事实数据表包含许多离散的事实，如各个销售事务。具有粗粒度的表存储的事实是各个元素的汇总，如每天的销售合计。

联邦信息处理标准 (FIPS) (Federal Information Processing Standard (FIPS))

适用于美国政府购买的计算机系统的标准。每个 FIPS 标准均由国家标准与技术学会 (NIST) 定义。SQL 产品的当前标准是 FIPS 127-2，它基于 ANSI SQL-92 标准。ANSI SQL-92 与 ISO/IEC SQL-92 一致。

连词 (conjunction)

一种词性（如 and 或 although），用于连接单词、短语、子句或句子。并列连词（and、but、or、nor、for、so、yet）连接并说明具有相同语法分类的词和词组的关系。

联合查询 (Union query)

通过执行等同于将一个表追加到另一个表的操作来组合两个表的查询。

联接 (join)

作为动词，是指组合两个或多个表的内容，并生成合并了每个表的行和列的结果集。通常使用各个表共有的数据联接这些表。作为名词，是指联接表的进程或结果，就象在术语“内联接”中指联接表的一种特定方法一样。

请参见： 联接列

联机重做日志 (online redo log)

参见定义： 事务日志

联机分析处理 (OLAP) (online analytical processing (OLAP))

使用多维结构为分析提供对数据的快速访问的技术。OLAP 的源数据通常存储在关系数据库的数据仓库中。

联机事务处理 (OLTP) (online transaction processing (OLTP))

为在机构的全部业务事务发生时进行记录而设计的数据处理系统。OLTP 系统的特征是许多并发用户动态地添加和修改数据。

连接 (connection)

在 SQL Server 2000 应用程序和 SQL Server 2000 实例之间建立的进程间通讯 (IPC) 链接。如果应用程序位于与 SQL Server 2000 实例不同的计算机上，则该连接是网络链接。如果应用程序和 SQL Server 2000 实例在同一台计算机上，则链接通过本地 IPC 机制构成，如共享内存。应用程序使用 IPC 链接将 Transact-SQL 语句发送到 SQL Server，并从 SQL Server 接收结果集、错误和消息。

联接表 (join table)

参见定义： 连接表

连接表 (junction table)

建立其它表之间的关系的表。连接表包含引用构成该关系的表的外键。例如，OrderParts 连接表可以通过具有 Orders 表和 Parts 表的外键来展示每个订单运送的部件。

链接表 (linked table)

由 OLE DB 数据源表现的 OLE DB 行集，已定义为链接服务器以供在 SQL Server 2000 分布式查询中使用。由链接服务器表现的行集可以在分布式查询中作为表加以引用。

链接表 (linking table)

已与其它两个表相关联并间接用作这两个表之间的关联的表。

链接多维数据集 (linked cube)

基于在另一台分析服务器上定义的多维数据集的多维数据集。

请参见： 发布服务器, 源多维数据集, 订阅服务器

链接服务器 (linked server)

由 SQL Server 2000 分布式查询使用的 OLE DB 数据源的定义。链接服务器定义指定访问数据所需的 OLE DB 提供程序，并包括足够的寻址信息以供 OLE DB 提供程序用来连接数据。然后由 OLE DB 数据源表现的任意行集可以在 SQL Server 2000 分布式查询中作为表（称为链接表）加以引用。

请参见： 本地服务器

联接列 (join column)

联接条件中引用的列。

请参见： 联接

联接路径 (join path)

指出两个表的联系方式的一系列联接。例如 Sales.SalesRepIDSalesReps.ID、SalesReps.BranchIDBranches.ID。

联接筛选 (join filter)

合并复制中使用的一种行筛选，它定义两个表之间的关系，该关系将在同步过程中加以强制，这与指定两个表之间的联接类似。

联接条件 (join condition)

指定表根据其联接列而联系起来的方式的比较子句。

联接运算符 (join operator)

联接条件中的一种比较运算符，确定条件两侧的评估方式以及返回哪些行。

联接字段 (join field)

参见定义： 联接列

两阶段提交 (two-phase commit)

确保应用于不止一个服务器的事务在所有的服务器上都完成或都未完成的进程。

列 (column)

SQL 表中每一行中的区域，存储用该表制作模型的某个对象特性的数据值。例如，Northwind 示例数据库中的 Employees 表建立 Northwind Traders 公司职员的模型。Employees 表的每个行中的 LastName 列存储该行所代表的职员的姓氏，就象窗口或表单中的 Last Name 字段包含姓氏一样。

请参见： 行

列级排序规则 (column-level collation)

SQL Server 2000 支持在单个实例中采用多个排序规则。数据库可以具有与实例的默认排序规则不同的默认排序规则。可以为单个列和变量指派与实例或数据库的默认排序规则不同的排序规则。表中的每个列可具有不同的排序规则。

列级约束 (column-level constraint)

当表创建或改变时在列定义内指定的约束定义。该约束只应用于相关的列。

请参见： 约束

列筛选 (column filter)

列筛选限制要包含在快照发布、事务发布或合并发布中的列。

临时表 (temporary table)

放置在临时数据库 tempdb 中的表，在会话结束时清除该表。

临时存储过程 (temporary stored procedure)

放置在临时数据库 tempdb 中的一个过程，在会话结束时清除该过程。

浏览模式 (browse mode)

一种函数，使您可以扫描数据库行并逐行更新其值。一些浏览模式函数返回的信息可供应用程序用来检查复杂特殊查询的结构。

流水游标 (firehose cursor)

默认结果集的一个过时的术语。

流水游标 (firehose cursors)

默认结果集的过时的术语。

请参见： 默认结果集

逻辑名称 (logical name)

SQL Server 用来标识文件的名称。文件的逻辑名称必须符合标识符的规则，且最多可以具有 30 个字符（例如 ACCOUNTING 或 LIBRARY）。

逻辑运算符 (logical operators)

运算符 AND、OR 和 NOT。用于连接 WHERE 子句中的搜索条件。

M

MAPI (MAPI)

参见定义： 消息应用程序接口 (MAPI)

master 数据库 (master database)

控制 SQL Server 的各个实例的操作的数据库。它自动与 SQL Server 的各个实例一起安装，并跟踪用户帐户、远程用户帐户及每个实例可与之交互的远程服务器。它还跟踪正在进行的进程、可配置的环境变量、系统错误信息、系统上可用的磁带和磁盘以及活动锁。

MDX (MDX)

参见定义： 多维表达式 (MDX)

枚举 (enumeration)

属性的一种数据类型。它指定属性值应支持不变的字符串或整型值的固定集合。

媒体集 (media set)

备份操作中涉及的所有媒体。

请参见： 媒体描述, 媒体家族

媒体家族 (media family)

由单个设备写入的集合中的所有媒体（例如一个初始媒体和全部延续媒体，如果有的话）。

请参见： 媒体集

媒体描述 (media description)

描述媒体集的文本。

请参见： 媒体集

媒体名称 (media name)

整个备份媒体集的描述性名称。

媒体首部 (media header)

提供有关备份媒体的信息。

密度 (density)

多维结构中包含数据的单元所占的百分比。Analysis Services 只存储包含数据的单元。密集的多维数据集比结构设计相同的稀疏的多维数据集需要更多的存储空间。

请参见： 数据爆炸, 稀疏度

美国国家标准学会 (ANSI) (American National Standards Institute (ANSI))

为美国建立商业和通讯标准的美国工商团体组织。ANSI 利用其在国际标准化组织 (ISO) 和国际电子技术委员会 (IEC) 的成员资格，在美国标准与相应的国际标准之间起协调作用。

名称句式 (name phrasing)

某种关系的英文描述，该关系中一个实体是另一个实体的名称。例如，在句子“Custnames are the names of Customers”（Custnames 是客户的名称）中，Custnames 和 Customers 都是实体。

名词 (noun)

一种词性，它为人、地点、事物、想法、动物、质量或动作命名。英文中名词通常变化形式以表示复数和所有格。

命令关系 (command relationship)

使用自然语言问题或命令向硬件发布指令。例如“Play the album with song XXX on it.”（播放带有歌曲 XXX 的曲集。）

命名别名 (aliasing)

允许对象、属性或关系的名称在新的上下文中重新使用，而同时保持其它特性不变。

命名管道 (named pipe)

一种进程间通讯 (IPC) 机制，SQL Server 用它来提供客户端和服务器之间的通讯。命名管道允许对共享网络资源的访问。

命名关系 (naming relationship)

一种命名规则，根据名称标识该关系的目的对象。

命名集 (named set)

维度成员集或为重复使用而创建的集合表达式，例如多维表达式 (MDX) 查询。

命名实例 (named instance)

SQL Server 2000 的一个安装，给予它一个名称以与其它命名实例及同一台计算机上的默认实例区分。命名实例由计算机名和实例名标识。

请参见： 默认实例, 多实例

模块 (module)

工程中的一组对象。可以在工程中的模块之间移动对象，从而为分散开发环境组织这些对象。

默认成员 (default member)

当未对维度指定成员时查询中所使用的维度成员。如果存在“（全部）”级别则维度的默认成员是“全部”成员，否则是最高级别的任意一个成员。还可以在维度安全性的自定义规则中设置各个角色的默认成员。

请参见： “全部”成员

默认结果集 (default result set)

SQL Server 用来将结果集返回到客户端的默认模式。行按照其放置在结果集中的顺序发送到客户端，且应用程序必须按此顺序对行进行处理。在执行连接中的某 SQL 语句之后，应用程序除了检索结果集中的行以外不能在连接上执行任何其它操作，直到已检索了所有的行。在结果集检索结束之前应用程序可以执行的唯一的其它操作是取消结果集的剩余部分。这是客户端从 SQL Server 获取行的最快方法。

请参见： 流水游标

默认实例 (default instance)

SQL Server 的复本，使用其所安装于的计算机的名称作为自己的名称。

请参见： 命名实例, 多实例

默认数据库 (default database)

用户登录到 SQL Server 后立即连接到的数据库。

默认语言 (default language)

用户未指定语言时 SQL Server 2000 用于错误和消息的语言。每个 SQL Server 2000 登录都具有一种默认语言。

默认约束 (DEFAULT constraint)

为表列定义的属性，指定将一个常量用作该列的默认值。如果任何后续的 INSERT 或 UPDATE 语句将该列指定为 NULL 值，或未指定该列的值，则将 DEFAULT 约束中定义的常量值放置在该列内。

默认 (default)

当用户未指定时由系统自动指派的数据值、选项设置、排序规则或名称。当用户未指定某些事件发生后要采取的操作时所自动采取的操作。

模型 (model)

在 English Query 中，模型是在 English Query 应用程序中已知的有关这些对象的所有信息的集合。该信息包括：指定的数据库对象（如表、字段和联接）、语义对象（如实体、实体间的关系、附加字典条目）和全局域默认选项。

模型相关性 (model dependency)

两个或多个模型之间的关系，该关系中一个模型依赖另一个模型的信息。

model 数据库 (model database)

与 SQL Server 一起安装的数据库，为新的用户数据库提供模板。SQL Server 2000 通过复制 model 数据库中的内容，然后将它扩充到所请求的大小来创建新数据库。

MOLAP (MOLAP)

参见定义： 多维 OLAP (MOLAP)

money 数据类型 (money data type)

一种 SQL Server 系统数据类型，存储从 -2^63 (-922,337,203,685,477.5808) 到 2^63 - 1 (+922,337,203,685,477.5807) 之间的货币值，精度为货币单位的千分之十。

目的对象 (destination object)

知识库中的对象，它参与一种关系，是这种关系的目的。例如，组件 是关系工程拥有组件 中的目的对象。

请参见： 起始对象

目标对象 (target object)

参见定义： 源和目标

目标分区 (target partition)

一种 Analysis Services 分区，将另一个分区合并到该分区中，且合并之后包含两个分区的数据。

请参见： 源分区

N

nchar 数据类型 (nchar data type)

固定长度的 Unicode 数据类型，最大长度为 4,000 个字符。Unicode 字符每个字符使用两个字节，并支持所有国际化字符。

内部标识符 (internal identifier)

知识库中对象标识符的更精简形式。内部标识符只保证在单个知识库中唯一。

请参见： 对象标识符

内联接 (inner join)

通过比较源表间共享的列的值从多个源表检索行的操作。内联接排除来自不具有与其它源表中的行匹配的行的源表的行。

内置函数 (built-in functions)

一组预定义的函数，这些函数作为 Transact-SQL 和多维表达式 (MDX) 语言的部分而提供。

Net-Library (Net-Library)

一种 SQL Server 通讯组件，它将 SQL Server 客户端软件和数据库引擎与网络 API 隔离。SQL Server 客户端软件和数据库引擎向 Net-Library 发送常规网络请求，Net-Library 将请求转换为用户所选协议的特定网络命令。

匿名订阅 (anonymous subscription)

匿名订阅是请求订阅的一种，有关该订阅和订户的详细信息将不进行保存。

niladic 函数 (niladic functions)

没有输入参数的函数。大多数 niladic SQL Server 函数返回系统信息。

ntext 数据类型 (ntext data type)

一种可变长度 Unicode 数据类型，最多可以存放 2^30 - 1 (1,073,741,823) 个字符。ntext 列在数据行中存储一个 16 位的指针，而数据单独存储。

NULL (NULL)

没有显式赋给的值的条目。NULL 不等于零或空格。NULL 值不视作大于、小于或等于任何其它值，包括另一个 NULL 值。

nvarchar 数据类型 (nvarchar data type)

一种可变长度 Unicode 数据类型，最多可有 4,000 个字符。Unicode 字符每个字符使用两个字节，并支持所有国际化字符。sysname 是一种系统提供的用户定义的数据类型，该类型是 nvarchar(128) 的同义词，用于引用数据库对象名。

O

ODBC (ODBC)

参见定义： 开放式数据库连接 (ODBC)

ODBC 驱动程序 (ODBC driver)

一种动态链接库 (DLL)，支持 ODBC 的应用程序（如 Excel）可以用它来访问 ODBC 数据源。每个 ODBC 驱动程序针对一个数据库管理系统 (DBMS)，如 SQL Server、Access 等等。

ODBC 数据源 (ODBC data source)

一组数据的位置，可以使用 ODBC 驱动程序访问该位置。也是一种存储的定义，包含 ODBC 应用程序连接到数据源所需的全部连接信息。

请参见： 数据源

ODS (ODS)

参见定义： 开放式数据服务 (ODS)

OIM (OIM)

参见定义： 开放信息模型 (OIM)

OLAP (OLAP)

参见定义： 联机分析处理 (OLAP)

OLE DB (OLE DB)

用于访问数据的基于 COM 的应用程序接口 (API)。对于以可使用 OLE DB 提供程序的任意格式（数据库、电子表格、文本文件等等）存储的数据，OLE DB 都支持对其进行访问。

请参见： 用于 OLAP 的 OLE DB

OLE DB 使用者 (OLE DB consumer)

调用和使用 OLE DB 应用程序接口 (API) 的任何软件。

OLE DB? 提供程序 (OLE DB provider)

表现 OLE DB 接口的软件组件。每个 OLE DB 提供程序表现来自特定类型的数据源（例如 SQL Server 数据库、Access 数据库或 Excel 电子表格）的数据。

OLE 自动化对象 (OLE Automation objects)

提供可兼容自动化的接口的组件对象模型 (COM) 对象。

OLE 自动化服务器 (OLE Automation server)

向其它应用程序（称为“自动化客户端”）表现可编程自动化对象的应用程序。表现可编程对象使客户端可以通过直接访问这些对象并使用因它们而可用的服务“自动处理”某些函数。例如，字处理器可以表现其拼写检查功能以便其它程序可以使用该功能。

OLE 自动化控制器 (OLE Automation controller)

可以驱动自动化对象的编程环境（如 Visual Basic）。

OLTP (OLTP)

参见定义： 联机事务处理 (OLTP)

P

排它锁 (exclusive lock)

一种锁，它防止任何其它事务获取资源上的锁，直到在事务的末尾将资源上的原始锁释放为止。在更新操作（INSERT、UPDATE 或 DELETE）过程中始终应用排它锁。

排序次序 (sort order)

排序规则中规则的集合，定义字符在比较运算中评估的方式和其排序顺序。

排序规则 (collation)

一组规则，决定数据比较、排序和表现的方式。字符数据使用排序规则信息（包括区域设置、排序次序和区分大小写）进行排序。

请参见： 区域设置, SQL 排序规则

培训数据集 (training data set)

一组已知的和可预测的数据，用于培训数据挖掘模型。

请参见： 挖掘模型培训

批处理 (batch)

一组 SQL 语句，它们作为一个组一起提交并加以执行。脚本通常是逐个提交的一系列批处理。

批注属性 (annotational property)

由 Meta Data Services 作为字符串数据进行维护的属性，该字符串数据可以附加到表现 IAnnotationalProps 接口的任意知识库对象。

平展行集 (flattened rowset)

表现为二维行集的多维数据集，其中多个维度的元素的唯一组合在一个轴上进行组合。有关更多信息，请参见 OLE DB 文档。

平展界面 (flattened interface)

创建来组合多个界面的成员的界面。

PK (PK)

参见定义： 主键 (PK)

pubs 数据库 (pubs database)

与 SQL Server 一起提供的一个示例数据库。

Q

起始对象 (origin object)

知识库中作为定向关系起点的对象。例如，工程 是关系工程具有组件 中的起始对象。

请参见： 目的对象, 顺序关系

前滚 (roll forward)

应用数据库或日志备份中的全部已完成事务，以将数据库恢复到某个时间点或错误点（例如在磁盘丢失之类的事件之后）。

嵌套表 (nested table)

一种数据挖掘模型配置，该配置中某个表的一个列包含一个表。

嵌套查询 (nested query)

包含一个或多个子查询或者子查询的另一个术语的 SELECT 语句。

前缀长度 (prefix length)

bcp 本机格式数据文件中每个非字符字段前的前缀字符的数目。

前缀搜索 (prefix search)

搜索列的全文查询，这些列中指定的基于字符的文字、词或短语是前缀。当使用短语时，该短语内的每个单词都被看作是一个前缀。例如，指定短语“sport fish*”与“sport fishing”、“sportsman fishing supplies”等相匹配的前缀搜索。

前缀字符 (prefix characters)

1 到 4 个字节的集合，为本机格式大容量复制数据文件中的每个数据字段加上前缀。前缀字符记录字段中数据值的长度，当值为 NULL 时则为 -1。

强制订阅 (push subscription)

在发布服务器上创建和管理的订阅。存储有关发布和订阅服务器的信息。

请参见： 请求订阅

切片 (slice)

多维数据集中数据的一个子集，由维度的成员限制一个或多个维度来指定。例如，特定年份的事实构成多年数据的一个切片。

请参见： 轴

请求订阅 (pull subscription)

在订阅服务器上创建和管理的订阅。存储有关发布和订阅服务器的信息。

请参见： 强制订阅

求解次序 (solve order)

多维数据集的单个计算传递中的计算成员、自定义成员、自定义汇总公式和计算单元的评估次序（从最高求解次序到最低求解次序）和计算次序（从最低求解次序到最高求解次序）。求解次序用于在计算多维数据集中的单元的值时确定公式优先级，但这只在单个计算传递内。

请参见： 传递顺序, 计算子多维数据集, 计算传递, 计算条件, 计算公式

区域设置 (locale)

定义与语言有关的某些行为的 Windows 操作系统特性。区域设置定义用于存储字符数据的代码页或位模式，以及字符排序的顺序。它还定义语言特定的项目，如用于日期和时间的格式以及用于分隔数字中的小数的字符。每个区域设置由一个唯一的数字标识，称为区域设置标识符或 LCID。SQL Server 2000 排序规则与区域设置类似，因为排序规则定义 SQL Server 2000 实例的语言特定的行为类型。

请参见： 排序规则, 区域设置标识符 (LCID)

区域设置标识符 (LCID) (locale identifier (LCID))

标识基于 Windows 的区域设置的编号。

请参见： 区域设置

全局变量 (global variable)

SQL Server 中可以由多个数据转换服务 (DTS) 任务引用的变量。在 SQL Server 的早期版本中，该术语指那些名称以两个 at 符号 (@@) 开始的 Transact-SQL 系统函数。

全局订阅 (global subscriptions)

对合并发布的订阅，该发布带有一个赋给的优先级值以用于冲突检测和解决。

全局规则 (global rule)

为特定数据库定义而由不同表的列共享的规则。

全局默认值 (global default)

为特定数据库定义而由不同表的列共享的默认值。

全局属性 (global properties)

English Query 应用程序的常规属性，如默认年份设置或财政年度的起始日期。

全文查询 (full-text query)

与 SELECT 语句一样在基于字符的列（数据类型为 char 、varchar 、text 、ntext 、nchar 或 nvarchar ）内搜索词、短语或者词或短语的多个形式的查询。SELECT 语句返回满足搜索条件的行。

全文服务 (full-text service)

执行全文查询的 SQL Server 组件。

全文目录 (full-text catalog)

存储数据库内表的全部全文索引。

全文启用 (full-text enabling)

允许当前数据库上发生全文查询的进程。

全文索引 (full-text index)

存储给定表的所有全文词及其位置的全文目录部分。

R

RDBMS (RDBMS)

参见定义： 关系数据库管理系统 (RDBMS)

real 数据类型 (real data type)

一种 SQL Server 系统数据类型，具有 7 个数字的精度。从 -3.40E + 38 到 3.40E + 38 之间的浮点精度数字数据。存储大小为 4 个字节。

任务 (task)

参见定义： 作业

任务对象 (task object)

一种数据转换服务 (DTS) 对象，定义要作为数据转换进程的一部分执行的工作块。例如，任务可以执行一条 SQL 语句或使用 DTS 数据抽取从 OLE DB 源将异类数据移动和转换到 OLE DB 目的。

RI (RI)

参见定义： 引用完整性 (RI)

日志文件 (log file)

包含数据库中所进行修改的记录的文件或文件集合。

请参见： 数据文件

ROLAP (ROLAP)

参见定义： 关系 OLAP (ROLAP)

RTIM (RTIM)

参见定义： 知识库类型信息模型 (RTIM)

S

SELECT (SELECT)

用于将数据返回给应用程序或另一个 Transact-SQL 语句、或者用以填充游标的 Transact-SQL 语句。SELECT 语句返回一个表格格式的结果集，它通常由从一个或多个表中析取的数据组成。结果集只包含与 WHERE 或 HAVING 子句中指定的搜索条件匹配的行中的数据。

SELECT (SELECT)

在 Analysis Services 中，用于查询多维数据集并返回多维数据的记录集的多维表达式 (MDX) 语句。

筛选 (filter)

控制作为结果集返回的记录集合的一组准则。筛选还可以定义行以怎样的序列返回。

筛选 (filtering)

基于 SQL 语句的 WHERE 子句中设置的准则限制数据的功能。对于复制，筛选发生在发布中定义的表项目上。结果是可以发布到订阅服务器的数据分区。

请参见： 分区, 垂直筛选

删除查询 (Delete query)

从一个或多个表删除行的查询（SQL 语句）。

设备 (device)

参见定义： 文件

深化/浅化 (drill down/drill up)

用于浏览各种级别的数据的一种技术，数据范围为从最概要的（浅化）到最详细的（深化）。例如，当查看根据年份的销售数据的详细信息时，用户可以深化以显示根据季度的销售数据，以及进一步深化以显示根据月份的数据。

身份验证 (authentication)

验证试图连接到 SQL Server 的用户是否有权进行连接操作的进程。

请参见： SQL Server 身份验证

生成表查询 (Make Table query)

创建一个新表然后通过从现有表复制行来在新表中创建行的查询（SQL 语句）。

声明引用完整性 (DRI) (declarative referential integrity (DRI))

作为表定义的一部分定义的 FOREIGN KEY 约束，在表间实施正确的关系。这些约束确保当 DELETE、INSERT 和 UPDATE 语句删除、添加或修改主键或外键值时进行正确的操作。由 FOREIGN KEY 约束强制的 DRI 操作，可以通过表上的触发器中定义的其它引用完整性逻辑加以补充。

使非规范化 (denormalize)

将冗余引入表中，以从相关表合并数据。然后可以消除相关表。非规范化可以通过降低数据仓库架构中的复杂性来提高效率和性能。

请参见： 星型架构

时间维度 (time dimension)

将时间划分为 Year、Quarter、Month 和 Day 之类的级别的维度。Analysis Services 中从日期/时间列创建的一种特殊维度。

事例 (case)

数据挖掘中由特性和与其它事例的关系描绘的数据的摘要视图。事例是事例集的独立成员，且一个事例可以是多个事例集的成员。

请参见： 事例键, 事例集, 特性

实例 (instance)

计算机上运行的 SQL Server 的复本。一台计算机可以运行 SQL Server 2000 的多个实例。但只可以运行 SQL Server 7.0 版或更早版本的一个实例，尽管在某些情况下它还可以运行 SQL Server 2000 的多个实例。

事例集 (case set)

数据挖掘中事例的集合。

请参见： 事例

事例键 (case key)

数据挖掘中事例的元素，通过它在事例集内引用该事例。

请参见： 事例

示例数据 (sample data)

当在处理多维数据集之前对其进行查询时，代替实际数据而提供的人工生成的数据。示例数据使您可以查看修改多维数据集时结构更改的效果。

事实 (fact)

数据仓库内事实数据表中的一行。事实包含定义数据事件（如销售事务）的值。

事实数据表 (fact table)

数据仓库架构中的中央表，它包含联系事实与维度表的数字度量值和键。事实数据表包含描述业务（如银行事务或产品销售）内特定事件的数据。

请参见： 数据仓库, 维度表, 星型架构, 星型联接

实体 (entity)

在 English Query 中，实体是现实世界的对象，是由名词（人、地点、事物或想法）指代的人、产品、货物、城市等等。实体是语义对象。

实体完整性 (entity integrity)

这样一种状态：数据库中的所有行都具有一个非空的主键值，所有表都具有主键，且没有具有重复的主键值的表。这确保数据库中所代表的任何事物均不存在重复的条目。

视图 (view)

可以使用与表相同的方式在 SQL 语句中引用的数据库对象。视图使用 SELECT 语句定义，类似于包含该语句的结果集的对象。

视图生成 (view generation)

用于创建基于类、接口和信息模型中的关系的关系视图的知识库引擎功能。

事务 (transaction)

组合到工作的一个逻辑单元中的一组数据库操作，或者完全提交，或者回滚。事务是原子的、一致的、隔离的和持久的。

事务处理 (transaction processing)

用于有效记录某机构感兴趣的业务活动（称为事务）的数据处理（例如销售、供货的定购或货币传输）。通常，联机事务处理 (OLTP) 系统执行大量的相对较小的事务。

事务回滚 (transaction rollback)

将用户指定的事务回滚到事务内上一个保存点或事务的起始。

事务日志 (transaction log)

记录对数据库的所有更改的数据库文件。它由 SQL Server 在自动恢复过程中使用。

实用工具 (utility)

从命令提示符运行以执行公用任务的 SQL Server 应用程序。

授权 (authorization)

验证授权给用户的权限和访问权的操作。

授权 (grant)

将权限应用于用户帐户，以允许帐户执行某项活动或使用数据。

数据爆炸 (data explosion)

由于聚合数据的存储而引起的多维结构（如多维数据集）大小的指数级增长。

请参见： 密度, 稀疏度

数据仓库 (data warehouse)

为查询和分析特别构造的数据库。数据仓库通常包含代表某机构业务历史的数据。

请参见： 事实数据表, 数据集市

数据操作语言 (DML) (data manipulation language (DML))

SQL 语句的子集，用于检索和操作数据。

数据成员 (data member)

为父子维度中的非叶成员生成的子成员。数据成员包含与非叶成员直接相关的值，该值独立于由该成员的后代计算得到的汇总值。例如，数据成员可以包含某个经理的薪水，以便既可以显示单份薪水又可以显示汇总的薪水。

数据抽取 (data pump)

一种 OLE DB 服务提供程序，它提供一种基本结构，以便可以使用数据转换服务 (DTS) 在异类数据存储之间导入、导出和转换数据。

数据定义 (data definition)

指定数据库中的特性、属性和对象。

数据定义查询 (data-definition query)

包含数据定义语言 (DDL) 语句的 SQL 查询。有一些语句使您可以创建或改变数据库中的对象（如表、索引、视图等等）以及从 Microsoft Access 迁移数据库对象。

数据定义语言 (DDL) (data definition language (DDL))

一种语言，通常是数据库管理系统的一部分，用于定义数据库的所有特性和属性，尤其是行布局、列定义、键列（有时是选键方法）、文件位置和存储策略。

数据关系图 (database diagram)

数据库中对象的图形表示。数据库关系图可以是数据库结构的整体或部分图片；它包括表的对象、表所包含的列和它们之间的关系。

数据集 (dataset)

用于 OLAP 的 OLE DB 中的多维数据集合，是执行多维表达式 (MDX) 的 SELECT 语句后得到的结果。有关数据集的更多信息，请参见 OLE DB 文档。

数据集市 (data mart)

数据仓库内容的子集。数据集市往往包含针对部门级或特定业务领域的数据。

请参见： 数据仓库

数据控制语言 (DCL) (Data Control Language (DCL))

用于控制对数据库对象的权限的 SQL 语句的子集。使用 GRANT 和 REVOKE 语句来控制权限。

数据库 (database)

为特定目的（如搜索、排序和重新组织数据）而组织和提供的信息、表和其它对象的集合。数据库存储在文件中。

数据库语言 (database language)

用于访问、查询、更新和管理关系数据库系统中的数据的语言。SQL 是一种广泛使用的数据库语言。SQL 的 Microsoft SQL Server 实现称为 Transact-SQL。

数据库对象 (database object)

一种数据库组件。数据库中的表、索引、触发器、视图、键、约束、默认、规则、用户定义的数据类型或存储过程。也可能指的是数据库。

数据库对象 (database object)

用于 English Query 应用程序中以响应查询的对象（表、字段和联接）。

数据库架构 (database schema)

数据库的表名、字段、数据类型、主键和外键。也称作数据库结构。

数据库工程 (database project)

一个或多个数据连接（数据库以及访问该数据库所需的信息）的集合。当创建数据库工程时，可以通过 ODBC 连接到一个或多个数据库并通过可视用户界面（带有用于设计和创建数据库的数据库设计器，以及用于为遵从 ODBC 的任意数据库创建 SQL 语句的查询设计器）查看它们的组件。

数据库脚本 (database script)

用于创建数据库对象的语句的集合。Transact-SQL 脚本保存为文件，文件名通常以 .sql 结尾。

数据库角色 (database role)

对某个 Analysis Services 数据库具有相同访问权限的用户和组的集合。可以将数据库角色指派给数据库中的多个多维数据集，从而将该角色的用户访问权限授予这些多维数据集。

请参见： 多维数据集角色, 自定义规则

数据库目录 (database catalog)

包含数据库中所有对象的定义以及数据库的定义的数据库部分。

请参见： 系统目录

数据库所有者 (database owner)

数据库的数据库管理员角色的成员。只有一个数据库所有者。所有者拥有数据库中的全部权限，并决定提供给其他用户的访问权限和功能。

数据库文件 (database file)

构成数据库的物理文件之一。

数据块 (data block)

在 text 、ntext 和 image 数据中，数据块是应用程序和 SQL Server 2000 实例之间一次传输的数据单元。该术语还适用于这些数据类型的存储单元。在磁带备份文件中，数据块是物理 I/O 的单元。

数据类型 (data type)

指定哪种类型的信息可以存储在列、参数或变量中的特性。SQL Server 提供系统提供的数据类型；还可以创建用户定义的数据类型。

请参见： 基本数据类型

数据连接 (data connection)

访问特定数据库所需要的信息的集合。该集合包括数据源名称和登录信息。数据连接存储在工程中，当用户执行需要访问数据库的操作时这些连接被激活。例如，SQL Server 数据库的数据连接由数据库的名称、数据库所驻留于的服务器的位置、用于访问该服务器的网络信息以及用户 ID 和密码组成。

数据清理 (data scrubbing)

用来自多个联机事务处理 (OLTP) 系统的数据生成数据仓库的进程的一部分。该进程必须解决不正确的拼写、两个系统之间冲突的拼写规则和冲突的数据（如对于相同的部分具有两个编号）之类的错误。

数据透视 (pivot)

在交叉表格式数据浏览器中将行旋转为列和将列旋转为行。

从多维数据结构中的可用维度集合中选择维度以在交叉表格式结构的行和列中显示。

数据完整性 (data integrity)

存储在数据库中的所有数据值均正确的状态。如果数据库中存储有不正确的数据值，则该数据库称为已丧失数据完整性。

数据文件 (data file)

在大容量复制操作中，将数据从向外大容量复制操作传输到向内大容量复制操作的文件。在 SQL Server 2000 数据库中，数据文件存放着在数据库中存储的数据。每个 SQL Server 2000 数据库至少有一个主要数据文件，可以有多个次要数据文件以存放不适合在主要数据文件中放置的数据。

请参见： 日志文件

数据修改 (data modification)

使用 INSERT、DELETE 和 UPDATE 之类的 Transact-SQL 语句在数据库中添加、删除或更改信息的操作。

数据沿袭 (data lineage)

由数据转换服务 (DTS) 与 Meta Data Services 一起使用的信息，记录每块数据的包执行和数据转换的历史。

数据源 (data source)

ADO 和 OLE DB 中 OLE DB 提供程序所表现的数据源的位置。

请参见： ODBC 数据源

数据源 (data source)

多维数据集或维度等对象的数据的源。它还是访问源数据所必要的信息规范。有时它指 ClassType clsDataSource 的一个对象。

数据字典视图 (data dictionary view)

一种系统表。

数据字典 (data dictionary)

存储在目录中的一组系统表，包括数据库结构和相关信息的定义（如权限）。

输入成员 (input member)

值直接从数据源装载而不是由其它数据计算得到的成员。

请参见： 计算成员

输入集 (input set)

提供给多维表达式 (MDX) 值表达式的数据的集合，表达式在这些数据上运行。有关设置值表达式的更多信息，请参见 OLE DB 文档。

输入源 (input source)

用作查询的信息源的任何表、视图或架构关系图。

事务复制 (transactional replication)

复制的一种类型，在订阅服务器上应用数据的初始快照，然后当发布服务器上发生数据修改时，捕获个别的事务并传播到订阅服务器。

请参见： 合并复制, 快照复制

属性 (property)

控件、字段或数据库对象的一种命名特性，设置该特性以定义对象的特性之一（如大小、颜色或屏幕位置）或其行为的一个方面（如是否隐藏）。

属性页 (property pages)

一个具有选项卡的对话框，在该对话框中标识表、关系、索引、约束和键的特性。数据库关系图中的每个对象都具有一组属性，它们确定数据库对象的定义。每组选项卡只显示针对所选对象的属性。如果选择了多个对象，则属性页显示所选的第一个对象的属性。

数值表达式 (numeric expression)

评估为数字的任意表达式。该表达式可以是变量、常量、函数和运算符的任意组合。

刷新数据 (refresh data)

清除多维数据集中的数据、用来自数据仓库的新数据装载多维数据集以及计算聚合的一系列操作。当数据仓库中的多维数据集的基础数据变化但多维数据集的结构和聚合定义保持不变时使用刷新数据。多维数据集的三个处理选项之一。

请参见： 增量更新, 处理

双字节字符集 (DBCS) (double-byte character set (DBCS))

一般使用两个字节代表一个字符的字符集，允许代表的字符多于 256 个。DBCS 通常用于使用表意书写系统（如日文、韩文和中文）的环境中。

水平分区 (horizontal partitioning)

将单个表基于选定的行分段为多个表。多个表中的每一个都具有相同的列，但具有的行较少。

请参见： 分区

数据源名称 (DSN) (data source name (DSN))

指派给 ODBC 数据源的名称。应用程序可以使用 DSN 来请求与系统 ODBC 数据源的连接，此连接指定了计算机名称和（可选）DSN 映射到的数据库。

顺序关系 (sequenced relationship)

知识库中的一种关系，指定目的对象集合内的每个目的对象的显式位置。

请参见： 关系对象, 起始对象, 顺序集合

顺序集合 (sequenced collection)

顺序关系对象的目的对象的集合。

请参见： 顺序关系

死锁 (deadlock)

当各自拥有一块数据上的锁的两个用户试图获取对方数据块上的锁时的情况。每个用户都将无限期地等待另一个用户释放锁，除非用户进程之一终止。SQL Server 检测死锁并终止其中一个用户进程。

请参见： 活锁

SID (SID)

参见定义： 安全标识号 (SID)

smalldatetime 数据类型 (smalldatetime data type)

从 1900 年 1 月 1 日到 2079 年 6 月 6 日的日期和时间数据，精确到分钟。

smallint 数据类型 (smallint data type)

从 -2^15 (-32,768) 到 2^15 - 1 (32,767) 的 SQL Server 系统整型数据。

smallmoney 数据类型 (smallmoney data type)

一种 SQL Server 系统数据类型，存储从 -214,748.3648 到 +214,748.3647 的货币值，精确到货币单位的千分之十。存储大小为 4 个字节。当显示 smallmoney 值时，将其舍入成两位。

搜索条件 (search condition)

WHERE 或 HAVING 子句中指定源行要包括在 SQL 语句中而必须满足的条件的谓词。例如，语句 SELECT * FROM Employees WHERE Title = 'Sales Representative' 只返回与以下搜索条件匹配的行：Title = 'Sales Representative'。

SQL (SQL)

参见定义： 结构化查询语言 (SQL)

SQL 表达式 (SQL expression)

评估为单个值的运算符、常量、字面值、函数、表名称与字段名称的任意组合。例如，使用表达式来定义查询中的计算字段。

SQL 查询 (SQL query)

一条 SQL 语句，如 SELECT、INSERT、UPDATE、DELETE 或 CREATE TABLE。

SQL 排序规则 (SQL collation)

一组 SQL Server 2000 排序规则，其特性与 SQL Server 早期版本的常用代码页和排序次序组合的特性相匹配。SQL 排序规则是使站点可以选择与其早期系统的行为相匹配的排序规则的兼容功能。

请参见： 排序规则

SQL Server 登录 (SQL Server login)

SQL Server 中存储的帐户，使用户可以连接到 SQL Server。

SQL Server 角色 (SQL Server role)

参见定义： 角色

SQL Server 身份验证 (SQL Server Authentication)

验证连接到 SQL Server 实例的尝试的两种机制之一。用户连接时必须指定一个 SQL Server 登录 ID 和密码。SQL Server 实例确保登录 ID 和密码组合有效才允许连接成功。Windows 身份验证是首选的身份验证机制。

请参见： 身份验证, Windows 身份验证

SQL Server 事件转发服务器 (SQL Server Event Forwarding Server)

SQL Server 的中央实例，管理由其它实例转发给它的 SQL Server 代理事件。启用 SQL Server 事件的集中管理。

SQL Server 用户 (SQL Server user)

参见定义： 用户（帐户）

SQL 数据库 (SQL database)

基于结构化查询语言 (SQL) 的数据库。

SQL 邮件 (SQL Mail)

SQL Server 的一个组件，使 SQL Server 可以通过内置的 Windows NT 或 Windows 2000 消息应用程序接口 (MAPI) 发送和接收邮件。邮件可以由短文本字符串、查询的输出或附件组成。

SQL 语句 (SQL statement)

对数据执行某操作的 SQL 或 Transact-SQL 命令（如 SELECT 或 DELETE）。

sql_variant 数据类型 (sql_variant data type)

存储各种 SQL Server 支持的数据类型（text 、ntext 、timestamp 和 sql_variant 除外）的值的数据类型。

SQL-92 (SQL-92)

1992 年发布的 SQL 标准的版本。国际标准是 ISO/IEC 9075:1992 数据库语言 SQL。美国国家标准学会 (ANSI) 也发布了相应的标准（数据语言 SQL X3.135-1192），因此在美国有时称 SQL-92 为 ANSI SQL。

碎片 (fragmentation)

发生在进行数据修改时。可以通过除去和重新创建聚集索引来减少碎片和改善预读性能。

锁 (lock)

对多用户环境中的资源的访问权限的限制。SQL Server 自动将用户锁在特定行、列或文件外，以维护安全性或防止并发数据修改问题。

锁升级 (lock escalation)

将众多细粒度锁转换为较少的粗粒度的锁以削减系统开销的进程。

索引 (index)

关系数据库中基于键值提供对表的行中数据的快速访问的数据库对象。索引还可以在表的行上强制唯一性。SQL Server 支持聚集索引和非聚集索引。对表的主键自动进行索引。在全文检索中，全文索引存储关于重要词和这些词在给定列中的位置的信息。

索引 OR 运算 (index ORing)

一种执行策略，包括使用几个索引查找单个表的行，然后生成结果（通过将各部分结果合并在一起）。通常对应于 WHERE <search_conditions> 中的 OR。例如，使用列 R.a 和 R.b 上的索引的 WHERE R.a = 6 OR R.b = 7。

索引页 (index page)

包含索引行的数据库页。

所有格 (possessive case)

一种语法格，表示所有关系或类似于所有关系的关系，例如 Mary's blood type（Mary 的血型）或 John's movie（John 的电影）。

T

table 数据类型 (table data type)

一种特殊的数据类型，存储供以后处理的结果集。

填充因子 (fill factor)

索引的一个特性，定义该索引每页上的可用空间量。FILLFACTOR 适应以后表数据的扩展并减小了页拆分的可能性。FILLFACTOR 是从 1 到 100 之间的某个值，指定索引页保留为空的百分比。

TDS (TDS)

参见定义： 表格格式数据流 (TDS)

特殊连接器名称 (ad hoc connector name)

查询的 FROM 子句中的 OpenRowset 函数，它允许每当必须访问数据时都发布外部服务器和数据源的所有连接信息。

特性 (attribute)

数据挖掘中事例的单个特性。特性用于提供有关事例的信息。例如，重量可以是涉及运输容器的事例的一个特性。

请参见： 事例

特征 (trait)

描述实体的一个特性。例如，血型是病人的一个特征。

特征句式 (trait phrasing)

以英文描述表达关系的一种方式，该方式中次要实体描述主要实体。例如，在短语“ages of customers”（客户的年龄）中，“ages”是特征（或次要实体），“customers”是主要实体。

tempdb 数据库 (tempdb database)

为临时表、临时存储过程和其它临时工作存储需要提供存储区域的数据库。

text 数据类型 (text data type)

一种 SQL Server 系统数据类型，指定可变长度的非 Unicode 数据，最长可有 2^31 -1 (2,147,483,647) 个字符。text 数据类型不能用于存储过程中的变量或参数。

theta 联接 (theta join)

基于标量值的比较（=、>、>=、<、<=、< >、!<、!>）的联接。

提供程序 (provider)

一种 OLE DB?提供程序。

提供对数据库的访问的一种进程内动态链接库 (DLL)。

提交 (commit)

保存自事务开始时起对数据库、多维数据集或维度进行的所有更改的操作。提交保证事务的所有修改在数据库、多维数据集或维度中都永久有效。提交还释放事务所使用的资源（如锁）。

请参见： 回滚

提取 (fetch)

从游标检索行或行块的操作。Transact-SQL 批处理、存储过程和触发器使用 FETCH 语句从 Transact-SQL 游标进行提取。应用程序使用应用程序接口 (API) 提取函数。

timestamp 数据类型 (timestamp data type)

一种 SQL Server 系统数据类型，它是一个单调增加的计数器，其值在数据库内始终唯一。

tinyint 数据类型 (tinyint data type)

一种 SQL Server 系统数据类型，存放从 0 到 255 的整数。其存储大小为 1 个字节。

同步 (synchronization)

复制中在发布服务器上和订阅服务器上维护相同的架构和数据的进程。

请参见： 初始快照

同等联接 (equijoin)

对所联接的列中的值进行同等性比较的联接，所有列都包括在结果中。

同类数据 (homogeneous data)

来自由相同的软件管理的多个数据源的数据（例如，来自几个 Exchange 电子表格的数据，或来自几个 SQL Server 2000 实例的数据）。如果某 SQL Server 2000 分布式查询的所有数据均来自 SQL Server 2000 实例，则这个查询是同类的。

通配符搜索 (wildcard search)

使用占位符（如 * 或 ?）执行表或字段中的数据搜索。例如，使用 Smith* 搜索数据库中的 Last Name 字段，将找到姓以 Smith 打头的所有记录，包括 Smith、Smithson、Smithlin 等等。

通配符字符 (wildcard characters)

与 LIKE 关键字一起使用以进行模式匹配的字符，包括下划线 (_)、百分比 (%) 和方括号 ([ ])。

同义词 (synonym)

指的是与另一个词所指的相同的事物的词。例如，员工 和职员 是同义词。

Transact-SQL (Transact-SQL)

包含用于管理 SQL Server 实例，创建和管理 SQL Server 实例中的所有对象，以及插入、检索、修改和删除 SQL Server 表中的所有数据的命令的语言。Transact-SQL 是由国际标准化组织 (ISO) 和美国国家标准学会 (ANSI) 发布的 SQL 标准中定义的语言的扩展。

Transact-SQL 游标 (Transact-SQL cursor)

使用 Transact-SQL DECLARE CURSOR 语法定义的服务器游标。Transact-SQL 游标用于 Transact-SQL 批处理、存储过程和触发器中。

U

Unicode (Unicode)

Unicode 定义一组字母、数字和符号，SQL Server 可在 nchar 、nvarchar 和 ntext 数据类型中识别它们。它与字符集相关，但独立于字符集。Unicode 具有 65,000 多个可能值（相比之下字符集只有 256 个值），并且存储空间是字符集的两倍。Unicode 包括大多数语言的字符。

Unicode 格式 (Unicode format)

使用 Unicode 字符存储在大容量复制数据文件中的数据。

Unicode 排序规则 (Unicode collation)

这作为 Unicode 数据的排序次序。它是确定 SQL Server 响应数据库查询而比较、整理和提供 Unicode 数据的方式的规则集合。

UNIQUE 约束 (UNIQUE constraints)

强制非主键上的实体完整性的约束。UNIQUE 约束确保未输入重复值，并创建一个索引以增强性能。

uniqueidentifier 数据类型 (uniqueidentifier data type)

包含以 16 个字节的二进制字符串存储的唯一标识号的数据类型，用于存储全局唯一标识符 (GUID)。

V

varbinary 数据类型 (varbinary data type)

一种 SQL Server 系统数据类型，最多可存放 8,000 个字节的可变长度二进制数据。

varchar 数据类型 (varchar data type)

一种 SQL Server 系统数据类型，存放可变长度的非 Unicode 数据，最多可有 8,000 个字符。

W

挖掘模型 (mining model)

一种对象，其中包含数据挖掘进程的定义和培训活动的结果。例如，数据挖掘模型可以指定输入、输出、算法及进程的其它属性，并存放培训活动中收集的信息（如决策树）。

挖掘模型培训 (mining model training)

数据挖掘模型用以通过评估一组已知的和可预测的数据估计模型参数的进程。也是导致挖掘模型评估培训数据的操作。

请参见： 培训数据集

外表 (foreign table)

包含外键的表。

外键 (FK) (foreign key (FK))

列或列的组合，其值与同一个表或另一个表中的主键 (PK) 或唯一键相匹配。也称作参照键。

外联接 (outer join)

一种联接，包括满足搜索条件的联接表的所有行，甚至包括在所联接的表中没有匹配行的表中的行。对于当一个表中的行与另一个表中的行不匹配时所返回的结果集行，将为解析到没有相应行的表中的所有结果集列提供 NULL 值。

完整外部联接 (full outer join)

外部联接的一种类型，在该联接中包括所有联接的表中的所有行，而无论这些行是否匹配。

完整性约束 (integrity constraint)

表中定义的一个属性，防止可能创建无效数据的数据修改。

谓词 (predicate)

句子的基本语法部分，由对主语的描述组成。例如，在句子“The voters elected the incumbent”（投票人选举了现任者）中，主语是voters ，谓词是elected the incumbent 。

维度 (dimension)

多维数据集的一种结构特性，是描述事实数据表中的数据的类别（级别）的有组织的层次结构。这些类别通常描述相似成员的集合，用户要根据它们进行分析。例如，某个地理维度可能包括国家、地区、州或省以及城市的级别。

请参见： 度量值, 虚拟维度, 级别, 成员组

维度表 (dimension table)

数据仓库中的表，其条目描述事实数据表中的数据。维度表包含创建维度所基于的数据。

请参见： 事实数据表, 主维度表

维度层次结构 (dimension hierarchy)

维度的层次结构之一。

请参见： 层次结构

为空性 (nullability)

列、参数或变量的一种特性，指定其是否允许空数据值。

未强制关系 (unenforced relationship)

表之间的一种链接，一个表中的外键引用另一个表中的主键，且在 INSERT 和 UPDATE 事务中不检查引用完整性。未强制关系在数据库关系图中由虚线表示。

唯一索引 (unique index)

一种索引，不允许具有索引值相同的行，从而禁止重复的索引或键值。系统在创建该索引时检查是否有重复的键值，并在每次使用 INSERT 或 UPDATE 语句添加数据时进行检查。

位置 (position)

游标中处理的当前位置。例如，在某应用程序从游标提取了前 10 行之后，当前位置定位在游标的第十行。数据库 API 还有一些函数（如 ODBC SQLSetPos 函数）允许应用程序在未执行提取的情况下直接移动到游标中的某个特定位置。

文件存储类型 (file storage type)

定义数据文件中使用的存储格式，该文件将数据从向外大容量复制操作传输到向内大容量复制操作。在本机模式文件中，所有数据均使用与 SQL Server 2000 用来在数据库中存储数据的相同的内部结构进行存储。在字符模式文件中，所有数据均转换为字符串。

文件 DSN (file DSN)

在保存在计算机上的文件中存储数据库的连接信息。该文件是带有扩展名 .dsn 的文本文件。连接信息由参数和相应的值组成，ODBC 驱动程序管理器使用它们来建立连接。

文件组 (filegroup)

SQL Server 中一个或多个文件的命名集合，它构成分配或用于数据库管理的单个单元。

问题 (question)

English Query 中查询的英文形式，例如“How many customers bought products last year?”（去年有多少客户购买产品？）问题还可以以陈述的形式向 English Query 应用程序提出，例如“List the customers that bought products last year.”（列出去年购买产品的客户）。

问题模板 (question template)

描述一组问题的一种结构，这些问题可使用某个特定关系或一组关系进行询问。

问题生成器 (Question Builder)

支持用户了解有关域对象的更多信息以构造问题的需要的工具。他们可以查明域对象包含的内容，域中代表了哪些基本关系，以及可以使用哪些英文短语来询问这些关系。

问题文件 (.eqq) (question file (.eqq))

一种 ASCII 文本文件，包含准备使用 English Query 引擎测试的问题（一行一个）。问题文件以 .eqq 扩展名表示。问题可以使用测试工具自动提交给问题文件，或者开发人员可以创建问题列表。

文件 (file)

SQL Server 数据库中数据库存储的基本单元。一个数据库可以存储在几个文件中。SQL Server 使用三种类型的文件：数据文件（存储数据）、日志文件（存储事务日志）和备份文件（存储数据库的备份）。

WHERE 子句 (WHERE clause)

SQL 语句指定要检索哪些记录的部分。

Windows 排序规则 (Windows collation)

确定 SQL Server 对字符数据排序的方式的一组规则。它由 Windows“控制面板”中的名称和在 SQL Server 2000 安装过程中指定。

Windows 身份验证 (Windows Authentication)

验证连接到 SQL Server 实例的尝试的两种机制之一。用户连接时以其 Windows 用户或组标识。Windows 身份验证是连接到 SQL Server 的最安全机制。

请参见： SQL Server 身份验证, 信任连接

无 DSN 连接 (DSN-less connection)

一种数据连接类型，该连接基于数据源名称 (DSN) 创建，但作为工程或应用程序的一部分进行存储。无 DSN 连接对于 Web 应用程序尤其有用，因为它们使您可以将应用程序在服务器间移动而不会在新的服务器上重新创建 DSN。

物理读取 (physical reads)

对数据库页的请求，该请求中 SQL Server 必须将所请求页从磁盘传输到 SQL Server 缓冲区池。所有读取页的尝试都称作逻辑读取。如果该页已在缓冲区中，则不存在由逻辑读取生成的相关物理读取。物理读取的数目从不会超过逻辑读取的数目。在调整良好的 SQL Server 实例中，逻辑读取的数目通常远高于物理读取的数目。

物理名称 (physical name)

文件或镜像文件位于的路径。默认物理名称是 Master.dat 文件的路径缀上文件逻辑名称的前八个字符。例如，如果 Accounting 是逻辑名称，而 Master.dat 文件位于 Sql\Data，则默认物理名称是 Sql\Data\Accounti.dat。对于镜像文件，默认物理名称是 Master.mir 文件的路径缀上镜像文件逻辑名称的前八个字符。例如，如果 Maccount 是镜像文件的名称，而 Master.mir 文件位于 Sql\Data，则默认物理名称是 Sql\Data\Maccount.mir。

X

稀疏度 (sparsity)

不包含数据的多维结构的单元的相对百分比。Analysis Services 只存储包含数据的单元。稀疏的多维数据集比具有相同的结构设计的密集的多维数据集需要的存储要少。

请参见： 数据爆炸, 密度

系统表 (system tables)

构成 SQL Server 的系统目录的内置表。系统表存储 SQL Server 实例的所有元数据，包括实例的配置信息及其所有数据库和数据库对象的定义。用户不应直接修改任何系统表。

系统存储过程 (system stored procedures)

一组 SQL Server 提供的存储过程，可以用于执行一些操作，如从系统目录检索信息或执行管理任务。

系统管理员 (system administrator)

负责管理 SQL Server 的实例的人或一组人。系统管理员具有在 SQL Server 的实例中执行所有操作的全部权限。系统管理员是 sysadmin 固定服务器角色的成员，或是使用 sa 登录 ID 的登录。

系统函数 (system functions)

一组内置函数，对 SQL Server 中的值、对象和设置执行操作，并返回有关它们的信息。

系统目录 (system catalog)

描述 SQL Server 实例的所有功能的一组系统表。系统目录记录元数据（如所有用户、所有数据库、每个数据库中的所有对象的定义）以及系统配置信息（如服务器和数据库选项设置）。

请参见： 数据库目录

系统数据库 (system databases)

SQL Server 的所有实例中都存在的一组四个数据库，用于存储系统信息：

master 数据库存储所有的实例级别元数据，并记录所有其它数据库的位置。

tempdb 数据库存储暂时对象，这些对象只在单个语句或连接期间存在，如工作表和临时的表或存储过程。

model 数据库用作创建所有用户数据库的模板。

msdb 数据库由 SQL Server 代理用来记录有关作业、警报和备份历史的信息。

请参见： 用户数据库

线程 (thread)

一种操作系统组件，允许多用户应用程序的逻辑以几个单独的异步执行路径执行。SQL Server 关系数据库引擎执行多个线程，以利用多个处理器。线程的使用还有助于确保当某些用户连接被阻塞时为其它用户连接执行工作（例如，当等待磁盘读或写操作完成时）。

显示计划 (Showplan)

显示 SQL 语句的执行计划的报表。SET SHOWPLAN_TEXT 和 SET SHOWPLAN_ALL 生成文本化的显示计划输出。SQL Query 分析器和 SQL Server 企业管理器可以将显示计划信息显示为图形树。

显式事务 (explicit transaction)

包围在事务分隔符内的一组 SQL 语句。第一个分隔符必须为 BEGIN TRANSACTION 或 BEGIN DISTRIBUTED TRANSACTION，而结束分隔符必须为下列之一：

COMMIT TRANSACTION

COMMIT WORK

ROLLBACK TRANSACTION

ROLLBACK WORK

SAVE TRANSACTION。

相关子查询 (correlated subquery)

在 outer 语句中引用列的子查询。在 outer 语句中为每个候选行执行内层查询。

相关性 (dependencies)

依靠指定的表或视图的视图和过程。

项目 (article)

为复制指定的对象。项目是发布中的一个组件，可以是一个表、指定的列（使用列筛选）、指定的行（使用行筛选）、存储过程或视图定义、存储过程的执行、视图、索引视图或用户定义函数。

消息编号 (message number)

标识 SQL Server 2000 错误信息的编号。

消息应用程序接口 (MAPI) (Messaging Application Programming Interface (MAPI))

一种电子邮件应用程序接口 (API)。

写启用 (write enable)

更改多维数据集或维度，以便对该多维数据集或维度具有读/写访问权限的多维数据集角色中的用户可以更改其数据。

请参见： 回写

信任连接 (trusted connection)

一种 Windows 网络连接，只能由已通过网络的身份验证的用户打开。用户由其 Windows 登录 ID 标识，且不必输入单独的 SQL Server 登录 ID。

请参见： Windows 身份验证

信息模型 (information model)

一种面向对象的架构，定义用于指定应用程序、进程、组件或软件制品的结构和行为的元数据结构。

星型架构 (star schema)

一种关系数据库结构，该结构中在位于架构中心的单个事实数据表中维护数据，其它维度数据存储在维度表中。每个维度表与事实数据表直接相关，且通常通过一个键列联接到事实数据表。星型架构用在数据仓库中。

请参见： 使非规范化, 事实数据表, 雪花架构

星型联接 (star join)

一个事实数据表（通常为大型事实数据表）和至少两个维度表之间的联接。事实数据表在一个维度键上与每个维度表联接。SQL Server 考虑这些查询中的特殊索引操作策略以使对事实数据表的访问减到最小。

参与星型联接查询的架构的一个例子是一个销售表（包含数百万行的事实数据表）、一个产品表（包含对几百个产品的描述）和一个商店表（包含几十个商店名称）。在本示例中，产品表和商店表是维度表。星型查询优化的一个理想候选方式是选择一小组商店和产品的一个子集（由销售数据库中所没有的特性限制）的销售数据的查询。

请参见： 事实数据表

形容词句式 (adjective phrasing)

一种用英语表达关系的方式，其中一个实体由一个形容词（单个词或包含形容词的另一个实体）描述。例如，在句子“The cities are hot”（城市很炎热）中，“hot”（炎热）是形容词，“cities”（城市）是所描述的实体。

兄弟 (sibling)

维度层次结构中的一个成员，它的父代与指定成员的父代相同。例如，在带有 Year 和 Month 级别的 Time 维度中，成员 January 1997 和 February 1997 为兄弟。

请参见： Ancestor, 子代, 后代, 父代

序列 (sequence)

参见定义： 标识列

虚拟多维数据集 (virtual cube)

基于一个或多个常规多维数据集或链接多维数据集的逻辑多维数据集。

虚拟维度 (virtual dimension)

基于物理维度成员的属性值的逻辑维度。例如，包含红色、绿色和蓝色的虚拟维度可以基于产品维度的 Color 成员属性。

请参见： 成员属性, 维度, 成员

选择查询 (Select query)

将行返回到来自一个或多个表的结果集中的查询。选择查询可以包含要返回的列、要选择的行、放置行的顺序和如何将信息分组（汇总）的规范。

选择列表 (select list)

定义 SELECT 语句返回的结果集的列的 SELECT 语句子句。选择列表是逗号分隔的表达式（如列名、函数或常量）的列表。

雪花架构 (snowflake schema)

星型架构的一个扩展，由多个表定义一个或多个维度。在雪花架构中，只将主维度表与事实数据表联接。其它维度表联接到主维度表。

请参见： 星型架构, 主维度表

Y

延迟 (latency)

数据更改在一个服务器上完成与该更改出现在另一个服务器上之间所用的时间（例如在发布服务器上进行更改和该更改出现在订阅服务器上之间的时间）。

严重级别 (severity level)

表示由 SQL Server 数据库引擎生成的错误的相对重要性的数字。值的范围为从信息 (1) 到严重 (25)。

叶 (leaf)

树结构中没有从属元素的元素。例如，在 Analysis Services 中，叶是不具有后代的维度成员。

请参见： 非叶

页 (page)

虚拟存储系统中固定长度的邻接虚拟地址块，在分页操作中作为一个单元从内存复制到磁盘和从磁盘复制回内存。SQL Server 以页为单位分配数据库空间。在 SQL Server 中，一页的大小为 8 千字节 (KB)。

叶成员 (leaf member)

没有后代的维度成员。

页拆分 (page split)

将已满的数据页或索引页中的行或条目的一半移动到两个新页以便为新的行或索引条目腾出空间的进程。

叶级 (leaf level)

聚集索引或非聚集索引的底部级别。在聚集索引中，叶级包含表的实际数据页。在非聚集索引中，叶级指向数据页或指向聚集索引（如果存在的话），而不是本身包含数据。

业务规则 (business rules)

用于运行业务的逻辑规则。业务规则可以在组成 Windows DNA 系统中间层的 .com 对象中实施，还可以使用触发器、存储对象和约束在 SQL Server 数据库中实施。

已调度备份 (scheduled backup)

当作为作业定义和调度时由 SQL Server 代理完成的自动备份。

一对多关系 (one-to-many relationship)

关系数据库中两个表之间的一种关系，该关系中第一个表中的单个行可以与第二个表中的一个或多个行相关，但第二个表中的一个行只可以与第一个表中的一个行相关。

一对一关系 (one-to-one relationship)

关系数据库中两个表之间的一种关系，该关系中第一个表中的单个行只可以与第二个表中的一个行相关，且第二个表中的一个行也只可以与第一个表中的一个行相关。

已发布数据 (published data)

发布服务器上已复制的数据。

异类数据 (heterogeneous data)

以多种格式存储的数据。例如存储在 SQL Server 数据库、文本文件和 Excel 电子表格中的数据。

取模 (modulo)

一种算术运算符，提供两个整数相除之后的整数余数。

意向锁 (intent lock)

放置在资源层次结构的一个级别上的锁，以保护较低级别资源上的共享或排它锁。例如，在 SQL Server 2000 数据库引擎任务应用表内的共享或排它行锁之前，在该表上放置意向锁。如果另一个任务试图在该表级别上应用共享或排它锁，则受到由第一个任务控制的表级别意向锁的阻塞。第二个任务在锁定该表前不必检查各个页或行锁，而只需检查表上的意向锁。

隐性事务 (implicit transaction)

一种连接选项，该选项下连接执行的每个 SQL 语句都视为单独的事务。

引用键 (referenced key)

由外键引用的主键或唯一键。

引用完整性 (RI) (referential integrity (RI))

数据库中的所有外键值都有效的状态。为使外键有效，它必须包含值 NULL 或来自该外键所引用的主键或唯一键列的现有键值。

应用程序接口 (API) (application programming interface (API))

应用程序（如 ADO）中可用例程的集合，供软件程序员设计应用程序接口时使用。

应用程序角色 (application role)

一种 SQL Server 角色，创建该角色以支持应用程序的安全性需要。

用户定义函数 (user-defined function)

Analysis Services 中，在 Microsoft ActiveX 库中定义、使用组件对象模型 (COM) 自动化语言（如 Visual Basic 或 Visual C++）创建的函数。这类库可以使用 Analysis Services 注册，其函数可以从多维表达式 (MDX) 查询调用。

用户定义函数 (user-defined function)

在 SQL Server 中，由用户定义的 Transact-SQL 函数。函数将频繁执行的逻辑封装到一个命名实体中，该实体可以由 Transact-SQL 语句调用，而不必在每个语句中重新编写该逻辑的代码。

用户定义事件 (user-defined event)

由用户定义的一种消息，可以由 SQL 事件探查器跟踪或用于启动自定义警报。通常，该用户是系统管理员。

用户定义数据类型 (user-defined data type)

由用户创建、用于自定义数据存储、基于 SQL Server 数据类型的一种数据类型。规则和默认值可以绑定到用户定义的数据类型（但不能绑定到系统数据类型）。

请参见： 基本数据类型

用户数据库 (user database)

由 SQL Server 用户创建的数据库，用于存储应用程序数据。连接到 SQL Server 实例的大多数用户只引用用户数据库，而不引用系统数据库。

请参见： 系统数据库

用户（帐户） (user (account))

SQL Server 安全帐户或标识符，表示数据库中的特定用户。每个用户的 Windows 帐户或 SQL Server 登录都映射于数据库中的一个用户帐户。然后，将适当的权限授予用户帐户。每个用户帐户只可以访问已授予使用权限的数据。

用于 OLAP 的 OLE DB (OLE DB for OLAP)

以前指 OLAP 扩展针对 OLE DB 而订的单独规范。从 OLE DB 2.0 开始，OLAP 扩展并入 OLE DB 规范。

请参见： OLE DB

游标 (cursor)

映射结果集并在结果集内的单个行上建立一个位置的实体。在将游标放置到某行之后，可以在该行或从该位置开始的行块上执行操作。最常见的操作是提取（检索）当前行或行块。

游标库 (cursor library)

ODBC 和 DB-Library 应用程序接口 (API) 的一部分，它实现客户端游标。在当前系统中游标库不常用，而使用服务器游标。

优化程序 (optimizer)

参见定义： 查询优化器

优化同步 (optimize synchronization)

一个合并复制选项，当要确定最近的更改是否已导致某行移入或移出发布到订阅服务器的分区时，该选项使您可以将网络数据流量减到最小。

右向外联接 (right outer join)

外联接的一种，在该联接中包括 JOIN 子句中最右边的表中的所有行。当右表中的行与左表中的行不匹配时，来自左表的所有结果集列被赋以值 NULL。

有序集 (ordered set)

按照特定顺序返回的成员的集合。多维表达式 (MDX) 查询中的 ORDER 函数返回一个有序集。

域 (domain)

在 Windows 2000 安全性中，为查看和管理目的将共享一个公用安全数据库的计算机组织在一起所形成的计算机集合。关系数据库中某列允许的有效值的集合。

预测 (prediction)

一种数据挖掘技术，分析现有数据并使用其结果来预测新记录的特性值或现有记录中缺少的特性值。例如，现有的信用卡应用数据可以用于预测新应用的信用风险。

请参见： 决策树

语句权限 (statement permission)

控制用户是否可以执行 CREATE 或 BACKUP 语句的特性。

域完整性 (domain integrity)

强制给定列的条目有效性的完整性机制。CHECK 约束之类的机制可以通过数据类型、格式或允许的值的范围限制可能的数据值。

预写日志 (write-ahead log)

一种事务日志记录方法，该方法中日志总在数据之前写入。

语义对象 (semantic object)

可以由一个数据库对象或其它现实世界的对象表示的对象。例如，实体和关系便是语义对象。

远程表 (remote table)

存储在 OLE DB 数据源中、独立于 SQL Server 的当前实例的表。通过建立链接服务器定义或使用特殊连接器名称来访问该表。

远程存储过程 (remote stored procedure)

位于 SQL Server 的一个实例上、由 SQL Server 的另一个实例上的语句执行的存储过程。在 SQL Server 2000 中支持远程存储过程，但分布式查询提供的功能更好。

远程登录标识 (remote login identification)

指派给用户以访问远程服务器上的远程过程的登录标识（登录 ID）。

远程分发服务器 (remote Distributor)

配置为分发服务器的服务器，且该服务器独立于配置为发布服务器的服务器。

请参见： 分发服务器, 本地分发服务器

远程分区 (remote partition)

其数据存储在非用于存储分区的元数据的分析服务器上的分区。

远程服务器 (remote server)

由远程存储过程调用使用的 SQL Server 实例的定义。SQL Server 2000 仍支持远程服务器，但链接服务器提供的功能更好。

请参见： 本地服务器

远程数据 (remote data)

存储在独立于 SQL Server 的当前实例的 OLE DB 数据源中的数据。该数据通过建立链接服务器定义或使用特殊连接器名称来访问。

源对象 (source object)

特定集合中的所有对象通过关系（全部为相同的关系类型）的方式与其连接的单个对象。对于目的集合，源对象是目的对象。对于起点集合，源对象是起点对象。

源多维数据集 (source cube)

链接多维数据集所基于的多维数据集。

请参见： 链接多维数据集

源分区 (source partition)

一种 Analysis Services 分区，将它合并到另一个分区，并在合并进程结束时将它自动删除。

请参见： 目标分区

源和目标 (source and target)

一种浏览技术，使用源对象检索其目标对象或其关系内的对象。

元数据 (meta data)

有关数据属性的信息，如列中数据的类型（数字、文本等等）或列的长度。它还可以是有关数据结构的信息或指定对象设计的信息（如多维数据集或维度）。

源数据库 (source database)

参见定义： 发布数据库

源数据库 (source database)

数据仓储中，从中析取数据以用于数据仓库的数据库。

原形 (root form)

单词的最基本形式。例如，generating 的原形是 generate。对于其它动词，当定义 English Query 中的字典条目时应使用现在时、不定式形式（使用 run，而不是 ran 或 runs）。对于名词，使用单数形式作为基词，而不是复数形式（animal，而不是 animals）。

延续媒体 (continuation media)

当初始媒体装满时所使用的备份媒体，使备份操作可以延续。

原子的 (atomic)

或者执行全部的事务数据修改，或者全部不执行。

元组 (tuple)

来自不同维度的成员的有序集合。例如，(Boston, [1995]) 是由两个维度的成员组成的元组：Geography 和 Time。单个成员是元组的退化事例，可以作为不带括号的表达式使用。

请参见： 轴

跃点 (hop)

数据通讯中地理分散的网络上的路由器之间的路径的一段。跃点可比拟为旅程（包括出发点和目的地之间的中间车站）的一“段”。那些车站（路由器）彼此之间的距离将是一个通讯跃点。

约束 (constraint)

指派给表列的属性，用于防止将某些类型的无效数据值放置在该列中。例如，UNIQUE 或 PRIMARY KEY 约束防止插入重复的当前值，CHECK 约束防止插入与搜索条件不匹配的值，而 NOT NULL 防止插入 NULL 值。

请参见： 列级约束

Z

再次发布 (republish)

当订阅服务器将接收自发布服务器的数据发布到另一个订阅服务器时。

再次发布者 (republisher)

发布接收自发布服务器的数据的订阅服务器。

脏读 (dirty read)

包含未提交数据的读。例如，事务1 更改了某行。事务2 在事务1 提交更改之前读取已更改的行。如果事务1 回滚更改，则事务2 便读取了逻辑上从未存在过的行。

脏页 (dirty pages)

包含尚未写入磁盘的修改的缓冲区页。

增量更新 (incremental update)

向现有多维数据集或维度添加新成员或向分区添加新数据的操作的集合。多维数据集或分区的三个处理选项之一。维度的两个处理选项之一。

请参见： 刷新数据, 处理

证书 (certificate)

数据的集合，用于不安全的网络（如 Internet）上的身份验证和信息的安全交换。证书将公用加密键安全地绑定到存放相应的专用加密键的实体。证书由证书颁发机构进行数字签名，并可以为用户、计算机或服务进行管理。

整型 (integer)

SQL Server 2000 中的一种数据类型分类，包括 bigint 、int 、smallint 和 tinyint 数据类型。

值表达式 (value expression)

返回一个值的多维表达式 (MDX) 表达式。值表达式可以在集合、元组、成员、级别、数字或字符串上操作。例如，集合值表达式在成员、元组和集合元素上操作以生成其它集合。

自动恢复 (automatic recovery)

每当 SQL Server 重新启动时发生的恢复。自动恢复在发生系统错误时对您的数据库提供保护。

直观合计 (visual total)

维度成员显示、聚合的单元值，它与其显示的子代的显示单元值一致。如果单元的某些子代隐藏，则单元的直观合计可以与实际合计不同。例如，如果聚合函数是 SUM，Spain 的显示单元值是 1000，而 Portugal 的显示单元值是 2000，那么 Iberia 的直观合计是 3000。

直接传递查询 (pass-through query)

不间断的传递给外部服务器以供评估的查询。由直接传递查询返回的结果集可以象普通的基表一样用于查询的 FROM 子句中。

直接传递语句 (pass-through statement)

直接传递给源数据库而没有修改或延迟的 SELECT 语句。在 PivotTable 服务中，PASSTHROUGH 选项是 INSERT INTO 语句的一部分。

直接对象 (direct object)

命名及物动词之后的人或物的名词（连同其修饰成分一起）。例如客户购买产品（产品即是直接对象）。

直接连接 (direct connect)

连接到后端数据库的状态，因而当保存关系图或选择其内项目时对数据库关系图所做的任何更改将自动更新数据库。

直接响应模式 (direct response mode)

SQL Server 统计收集与 SQL Server 统计显示分开的默认模式。数据对于 SQL Server 性能监视器立即可用，但是所显示统计滞后于所检索统计一段时期。

只进游标 (forward-only cursor)

不能滚动的游标；只能按照从第一行到最后一行的次序读取行。

知识库 (repository)

由 Analysis Services 使用的元数据的存储容器。元数据存储在关系数据库的表中，用于定义分析服务器对象的参数和属性。

知识库 (repository)

包含信息模型的数据库，这些信息模型与可执行软件一起管理该数据库。该术语也指 Meta Data Services 的一个安装。

知识库对象 (repository object)

代表存储在知识库类型库中的一种数据结构的 COM 对象。

知识库类型信息模型 (RTIM) (Repository Type Information Model (RTIM))

一种核心对象模型，代表 Meta Data Services 的知识库类型定义。该对象模型由信息模型的实例所基于的抽象类组成。

知识库 SQL 架构 (Repository SQL schema)

一组标准表，由知识库引擎用来管理所有的知识库对象、关系和集合。知识库 SQL 架构将信息模型元素映射到 SQL 架构元素。

知识库引擎 (repository engine)

面向对象的软件，提供对知识库数据库的管理支持和客户访问。

轴 (axis)

元组的集合。每个元组是成员的一个矢量。一组轴定义一个多维数据集的坐标。有关轴的更多信息，请参见 OLE DB 文档。

请参见： 切片, 元组

主表 (primary table)

一对多关系的两个相关表中的一方。主表应具有一个主键，且每个记录都应唯一。主表的一个例子是由 CustomerID 主键字段唯一标识的客户名的表。

主定义位置 (master definition site)

参见定义： 发布服务器

主动语态 (active voice)

表示句子的主语是执行动词所描述的操作的实体。例如，客户购买产品 为主动语态，而产品被客户买走 为被动语态。

请参见： 被动语态

主键 (PK) (primary key (PK))

唯一标识表中的所有行的一个列或一组列。主键不允许空值。不能存在具有相同的主键值的两个行，因此主键值总是唯一标识单个行。表中可以有不止一个键唯一标识行，每个键都称作候选键。只有一个候选键可以选作表的主键，所有其它候选键称作备用键。尽管表不要求具有主键，但定义主键是很好的做法。 在规范化的表中，每行中的所有数据值都完全依赖于主键。例如，在以 EmployeeID 作为主键的规范化的 employee 表中，所有列都应包含与某个特定职员相关的数据。该表不具有 DepartmentName 列，因为部门的名称依赖于部门 ID，而不是职员 ID。

主维度表 (primary dimension table)

数据仓库中的雪花架构中，与事实数据表直接相关并通常联接到事实数据表的维度表。完成维度定义的其它表联接到主维度表，而不联接到事实数据表。

请参见： 维度表, 雪花架构

主位置 (master site)

参见定义： 分发服务器

主文件 (master file)

随 SQL Server 的早期版本一起安装的文件，用于存储 master 、model 和 tempdb 系统数据库和事务日志以及 pubs 示例数据库和事务日志。

祖先 (ancestor)

维度层次结构中较高级别的成员，通过沿袭而与维度层次结构内的当前成员相关。例如，在包含 Quarter、Month 和 Day 级别的 Time 维度中，Qtr1 是 January 1 的祖先。

请参见： 父代, 子代, 后代, 兄弟

主语 (subject)

句子的一个基本语法部分。主语是一个名词或名词子句，是谓词（通常在主语后面）声称或询问的对象。例如，在句子 """"The employee placed the order""""（职员下订单）中，单词 employee 是句子的主语。

转储 (dump)

参见定义： 备份

转储文件 (dump file)

参见定义： 备份文件

转换 (transformation)

数据仓储中，将从数据源系统析取的数据更改为与数据仓库的架构一致的排列和格式的进程。

转义符 (escape character)

用于表示表达式中的另一个字符表示字面意义而不是运算符的字符。例如，在 SQL 中，字符 "%" 用作通配符，以表示 "该位置中任意个数的字符"。但是，如果希望搜索 "10%"（百分之十）之类的字符串，则不能只指定 "10%" 作为搜索字符串，因为 "%" 将解释为 "除 10 以外还有任意个数的字符"。通过指定转义符，可以标记 "%" 特指百分号的实例。例如，如果指定转义符 "#"，则可以指定搜索字符串 "10#%" 表示 "百分之十"。

专用维度 (private dimension)

为特定多维数据集创建并供其使用的维度。与共享维度不同，专用维度只对其所创建于的多维数据集可用。

请参见： 共享维度

专有名词 (proper noun)

英文中大写的名词；特定的名称（如 John Smith）。

子查询 (subquery)

嵌套在另一个 SELECT、INSERT、UPDATE 或 DELETE 语句或者另一个子查询内的 SELECT 语句。

子代 (child)

层次结构中紧邻的较低级别中的成员，与当前成员直接相关。例如，在包含 Quarter、Month 和 Day 级别的 Time 维度中，January 是 Qtr1 的一个子代。

请参见： Ancestor, 父代, 后代, 兄弟

字典条目 (dictionary entry)

English Query 字典中定义的词。可以通过 English Query 域编辑器向字典添加条目，方法是指定词、其词性以及一个可选的不规则形式。

自定义规则 (custom rule)

一种规范，用于限制一个角色中的用户所允许访问的维度成员或多维数据集单元。

请参见： 多维数据集角色, 数据库角色

自定义汇总 (custom rollup)

一种为维度级别或成员自定义的聚合计算，将替代多维数据集的度量值的聚合函数。

字段 (field)

存储单个数据值的窗口或记录中的某个区域。某些数据库（如 Microsoft Access）将字段用作列的同义词。

字段长度 (field length)

大容量复制中，代表大容量复制字符格式数据文件中的一个数据项目所需的最大字符个数。

字段终止符 (field terminator)

大容量复制中标记字段或行的末尾的一个或多个字符，它将数据文件中的字段或行彼此分隔开。

字符串 (string)

一组邻接的字节，包含单个基于字符的数据值或二进制数据值。在字符串中，每个字节或每对字节代表单个字母、特殊字符或数字。在二进制字符串中，整个值视作不具有任何固有模式的单个位流。例如，常量 'I am 32.' 是一个 8 个字节的字符串，而常量 0x0205efa3 是一个 4 个字节的二进制字符串。

字符串函数 (string functions)

在字符或二进制字符串上执行操作的函数。内置的字符串函数返回对字符数据进行操作通常所需的值。

字符集 (character set)

字符集决定了 SQL Server 在 char 、varchar 和 text 数据类型中识别的字符的类型。每个字符集都是一个国家/地区或语言所使用的 256 个字母、数字和符号的集合。前 128 个值的可打印字符对于所有的字符集是相同的。后 128 个字符（有时称作扩展字符）是每个字符集所独有的。字符集与 Unicode 字符相关，但独立于 Unicode 字符。

字符格式 (character format)

使用文字字符存储在大容量复制数据文件中的数据。

请参见： 本机格式

子集 (subset)

表及表之间的关系线的一个选集，它是大型数据库关系图的一部分。该选集可以复制到新的数据库关系图中。这称作对关系图划分子集。

子集句式 (subset phrasing)

以英文表达关系的一种方式，该关系中一个实体或单词是另一个实体的子集。例如，在句子 """"Some mountains are volcanoes""""（一些山是火山）中，volcanoes（火山）是 mountains（山）的子集。

子句 (clause)

在 English Query 中，句子内相关词组成的序列，具有主语和谓词，并作为独立或非独立单元使用。在 Transact-SQL 中，SQL 语句的子单元。子句以关键字开始。

自联接 (self-join)

当联接的字段中有匹配的值时来自一个表的记录与来自同一个表的其它记录组合的联接。自联接可以是内联接或外联接。在数据库关系图中，自联接称为自反关系。

字生成 (word generation)

确定指定的一个（或一些）词的其它形式的进程。Microsoft 搜索服务目前已实现通过词尾变化来生成单词。例如，如果指定单词 swim ，则 SQL Server 也搜索 swim 、swam 和 swimming 。

组合键 (composite key)

由两个或多个列组成的键。

组合索引 (composite index)

使用表中的不止一个列对数据进行索引的索引。

组件对象模型 (COM) (Component Object Model (COM))

用于开发组件软件的一种 Microsoft 规范。一些 SQL Server 和数据库应用程序接口 (API) 即基于 COM，如 SQL-DMO、OLE DB 和 ADO。某些 SQL Server 组件（如 Analysis Services 和 English Query）将对象存储为 COM 对象。

请参见： 方法

钻取 (drill through)

检索详细数据，多维数据集单元中的数据根据它们进行汇总。

最高级 (superlative form)

英文中副词或形容词的一种形式，表示一种比较或最高程度。较短的形容词和一些副词通常通过添加 -est 来构成其最高级，如“youngest”或“strongest”。

左向外联接 (left outer join)

外联接的一个类型，在该联接中包括 JOIN 子句中的最左边的表的所有行。当右表中的行与左表中的行不匹配时，对来自右表的所有结果集列赋以 NULL 值。

作业 (job)

由 SQL Server 代理连续执行的指定的一系列操作（称为步骤）。

符号

“全部”成员 (All member)

“（全部）”级别的单个成员。在默认情况下，“全部”成员的名称由单词 All 后接一个空格再加上维度的名称构成。

请参见： 默认成员

“（全部）”级别 ((All) level)

维度的可选最高级别。“（全部）”级别包含单一成员，该成员是直接从属级别的所有成员的汇总。


(All) level | “（全部）”级别
action | 操作
active statement | 活动语句
active voice | 主动语态
ActiveX Data Objects | ActiveX 数据对象
ActiveX Data Objects (Multidimensional) (ADO MD) | ActiveX 数据对象（多维）(ADO MD)
ad hoc connector name | 特殊连接器名称
add-in | 加载项
adjective phrasing | 形容词句式
ADO | ADO
ADO MD | ADO MD
adverb | 副词
aggregate function | 聚合函数
aggregate query | 聚合查询
aggregation | 聚合
aggregation prefix | 聚合前缀
aggregation wrapper | 聚合包装
alert | 警报
alias | 别名
aliasing | 命名别名
All member | “全部”成员
American National Standards Institute (ANSI) | 美国国家标准学会 (ANSI)
Analysis server | 分析服务器
ancestor | Ancestor
annotational property | 批注属性
anonymous subscription | 匿名订阅
ANSI | ANSI
ANSI to OEM conversion | ANSI 到 OEM 转换
API | API
API server cursor | API 服务器游标
application programming interface (API) | 应用程序接口 (API)
application role | 应用程序角色
archive file | 存档文件
article | 项目
atomic | 原子的
attribute | 特性
authentication | 身份验证
authorization | 授权
automatic recovery | 自动恢复
autonomy | 独立
axis | 轴
backup | 备份
backup device | 备份设备
backup file | 备份文件
backup media | 备份媒体
backup set | 备份集
balanced hierarchy | 均衡层次结构
base data type | 基本数据类型
base table | 基表
batch | 批处理
bcp files | bcp 文件
bcp utility | bcp 实用工具
bigint data type | bigint 数据类型
binary data type | binary 数据类型
binary large object | 二进制大对象
binding | 绑定
bit data type | bit 数据类型
bitwise operation | 按位运算
BLOB | BLOB
blocks | 块
Boolean | 布尔型
browse mode | 浏览模式
built-in functions | 内置函数
business rules | 业务规则
cache aging | 高速缓存老化数据清除
calculated column | 计算列
calculated field | 计算字段
calculated member | 计算成员
calculation condition | 计算条件
calculation formula | 计算公式
calculation pass | 计算传递
calculation subcube | 计算子多维数据集
call-level interface (CLI) | 调用级接口 (CLI)
candidate key | 候选键
cascading delete | 级联删除
cascading update | 级联更新
case | 事例
case key | 事例键
case set | 事例集
cell | 单元
cellset | 单元集
certificate | 证书
change script | 更改脚本
changing dimension | 可更改维度
char data type | char 数据类型
character format | 字符格式
character set | 字符集
CHECK constraints | CHECK 约束
checkpoint | 检查点
child | 子代
classification | 分类
clause | 子句
CLI | CLI
client application | 客户端应用程序
client cursor | 客户端游标
clustered index | 聚集索引
clustering | 聚集
code page | 代码页
collation | 排序规则
column | 列
column filter | 列筛选
column-level collation | 列级排序规则
column-level constraint | 列级约束
COM | COM
command relationship | 命令关系
commit | 提交
comparative form | 比较级
Component Object Model (COM) | 组件对象模型 (COM)
composite index | 组合索引
composite key | 组合键
computed column | 计算列
COM-structured storage file | COM 结构化存储文件
concatenation | 串联
concurrency | 并发
conjunction | 连词
connection | 连接
constant | 常量
constraint | 约束
continuation media | 延续媒体
control-break report | 控制中断报表
control-of-flow language | 控制流语言
correlated subquery | 相关子查询
CPU busy | CPU 忙
crosstab query | 交叉表查询
cube | 多维数据集
cube file | 多维数据集文件
cube role | 多维数据集角色
cursor | 游标
cursor data type | cursor 数据类型
cursor library | 游标库
custom rollup | 自定义汇总
custom rule | 自定义规则
data block | 数据块
data connection | 数据连接
Data Control Language (DCL) | 数据控制语言 (DCL)
data definition | 数据定义
data definition language (DDL) | 数据定义语言 (DDL)
data dictionary | 数据字典
data dictionary view | 数据字典视图
data explosion | 数据爆炸
data file | 数据文件
data integrity | 数据完整性
data lineage | 数据沿袭
data manipulation language (DML) | 数据操作语言 (DML)
data mart | 数据集市
data member | 数据成员
data modification | 数据修改
data pump | 数据抽取
data scrubbing | 数据清理
data source | 数据源
data source name (DSN) | 数据源名称 (DSN)
data type | 数据类型
data warehouse | 数据仓库
database | 数据库
database catalog | 数据库目录
database diagram | 数据关系图
database file | 数据库文件
database language | 数据库语言
database object | 数据库对象
database owner | 数据库所有者
database project | 数据库工程
database role | 数据库角色
database schema | 数据库架构
database script | 数据库脚本
data-definition query | 数据定义查询
dataset | 数据集
datetime data type | datetime 数据类型
DBCS | DBCS
DCL | DCL
DDL | DDL
deadlock | 死锁
decimal data type | decimal 数据类型
decision support | 决策支持
decision tree | 决策树
declarative referential integrity (DRI) | 声明引用完整性 (DRI)
default | 默认值
DEFAULT constraint | 默认约束
default database | 默认数据库
default instance | 默认实例
default language | 默认语言
default member | 默认成员
default result set | 默认结果集
Delete query | 删除查询
delimiter | 分隔符
denormalize | 使非规范化
density | 密度
deny | 拒绝
dependencies | 相关性
descendant | 后代
destination object | 目的对象
device | 设备
dictionary entry | 字典条目
differential database backup | 差异数据库备份
dimension | 维度
dimension hierarchy | 维度层次结构
dimension table | 维度表
direct connect | 直接连接
direct object | 直接对象
direct response mode | 直接响应模式
dirty pages | 脏页
dirty read | 脏读
distribute | 分发
distributed query | 分布式查询
distribution database | 分发数据库
distribution retention period | 分发保持期
Distributor | 分发服务器
DML | DML
domain | 域
domain integrity | 域完整性
double-byte character set (DBCS) | 双字节字符集 (DBCS)
DRI | DRI
drill down/drill up | 深化/浅化
drill through | 钻取
DSN | DSN
DSN-less connection | 无 DSN 连接
DTS package | DTS 包
DTS package template | DTS 包模板
dump | 转储
dump file | 转储文件
dynamic cursor | 动态游标
dynamic filter | 动态筛选
dynamic locking | 动态锁定
dynamic recovery | 动态恢复
dynamic snapshot | 动态快照
dynamic SQL statements | 动态 SQL 语句
encrypted trigger | 加密触发器
encryption | 加密
English Query | English Query
English Query application | English Query 应用程序
entity | 实体
entity integrity | 实体完整性
enumeration | 枚举
equijoin | 同等联接
error log | 错误日志
error state number | 错误状态号
escape character | 转义符
exclusive lock | 排它锁
explicit transaction | 显式事务
expression | 表达式
extended stored procedure | 扩展存储过程
extent | 扩展
fact | 事实
fact table | 事实数据表
Federal Information Processing Standard (FIPS) | 联邦信息处理标准 (FIPS)
fetch | 提取
field | 字段
field length | 字段长度
field terminator | 字段终止符
file | 文件
file DSN | 文件 DSN
file storage type | 文件存储类型
filegroup | 文件组
fill factor | 填充因子
filter | 筛选
filtering | 筛选
FIPS | FIPS
firehose cursor | 流水游标
firehose cursors | 流水游标
fixed database role | 固定数据库角色
fixed server role | 固定服务器角色
FK | FK
flattened interface | 平展界面
flattened rowset | 平展行集
float data type | float 数据类型
foreign key (FK) | 外键 (FK)
foreign table | 外表
forward-only cursor | 只进游标
fragmentation | 碎片
full outer join | 完整外部联接
full-text catalog | 全文目录
full-text enabling | 全文启用
full-text index | 全文索引
full-text query | 全文查询
full-text service | 全文服务
function | 函数
global default | 全局默认值
global properties | 全局属性
global rule | 全局规则
global subscriptions | 全局订阅
global variable | 全局变量
grant | 授权
granularity | 粒度
guest | 来宾
heterogeneous data | 异类数据
hierarchy | 层次结构
HOLAP | HOLAP
homogeneous data | 同类数据
hop | 跃点
horizontal partitioning | 水平分区
HTML | HTML
huge dimension | 巨型维度
hybrid OLAP (HOLAP) | 混合 OLAP (HOLAP)
Hypertext Markup Language (HTML) | 超文本标记语言 (HTML)
identifier | 标识符
identity column | 标识列
identity property | 标识属性
idle time | 空闲时间
IEC | IEC
image data type | image 数据类型
immediate updating | 即时更新
immediate updating Subscribers | 即时更新订阅服务器
immediate updating subscriptions | 即时更新订阅
implicit transaction | 隐性事务
implied permission | 暗示性权限
incremental update | 增量更新
index | 索引
index ORing | 索引 OR 运算
index page | 索引页
indirect object | 间接宾语
information model | 信息模型
initial media | 初始媒体
initial snapshot | 初始快照
inner join | 内联接
input member | 输入成员
input set | 输入集
input source | 输入源
insensitive cursor | 不感知游标
Insert query | 插入查询
Insert Values query | 插入值查询
instance | 实例
int (integer) data type | int (integer) 数据类型
integer | 整型
integrated security | 集成安全性
integrity constraint | 完整性约束
intent lock | 意向锁
interactive structured query language (ISQL) | 交互式结构化查询语言 (ISQL)
interface | 接口
interface implication | 接口含义
internal identifier | 内部标识符
International Electrotechnical Commission (IEC) | 国际电子技术委员会 (IEC)
International Organization for Standardization (ISO) | 国际标准化组织 (ISO)
Internet-enabled | 可支持 Internet 的
interprocess communication (IPC) | 进程间通讯 (IPC)
IPC | IPC
irregular form | 不规则形式
irregular form type | 不规则形式类型
irregular noun | 不规则名词
irregular verb | 不规则动词
ISO | ISO
isolation level | 隔离级别
ISQL | ISQL
job | 作业
join | 联接
join column | 联接列
join condition | 联接条件
join field | 联接字段
join filter | 联接筛选
join operator | 联接运算符
join path | 联接路径
join table | 联接表
junction table | 连接表
kernel | 核心
key | 键
key column | 键列
key range lock | 键范围锁
keyset-driven cursor | 键集驱动游标
keyword | 关键字
large level | 大级别
latency | 延迟
LCID | LCID
leaf | 叶
leaf level | 叶级
leaf member | 叶成员
left outer join | 左向外联接
level | 级别
level hierarchy | 级别层次结构
library | 库
linked cube | 链接多维数据集
linked server | 链接服务器
linked table | 链接表
linking table | 链接表
livelock | 活锁
local cube | 本地多维数据集
local Distributor | 本地分发服务器
local group | 本地组
local login identification | 本地登录标识
local server | 本地服务器
local subscription | 本地订阅
local variable | 局部变量
locale | 区域设置
locale identifier (LCID) | 区域设置标识符 (LCID)
lock | 锁
lock escalation | 锁升级
log file | 日志文件
logical name | 逻辑名称
logical operators | 逻辑运算符
login (account) | 登录（帐户）
login security mode | 登录安全模式
lookup table | 查找表
machine DSN | 机器 DSN
Make Table query | 生成表查询
many-to-many relationship | 多对多关系
many-to-one relationship | 多对一关系
MAPI | MAPI
master database | master 数据库
master definition site | 主定义位置
master file | 主文件
master site | 主位置
MDX | MDX
measure | 度量值
measurement | 度量
media description | 媒体描述
media family | 媒体家族
media header | 媒体首部
media name | 媒体名称
media set | 媒体集
member | 成员
member delegation | 成员委派
member group | 成员组
member key column | 成员键列
member name column | 成员名列
member property | 成员属性
member variable | 成员变量
memo | 备注
merge | 合并
merge replication | 合并复制
message number | 消息编号
Messaging Application Programming Interface (MAPI) | 消息应用程序接口 (MAPI)
meta data | 元数据
method | 方法
mining model | 挖掘模型
mining model training | 挖掘模型培训
mirroring | 镜像
Mixed Mode | 混合模式
model | 模型
model database | model 数据库
model dependency | 模型相关性
module | 模块
modulo | 取模
MOLAP | MOLAP
money data type | money 数据类型
Multidimensional Expressions (MDX) | 多维表达式 (MDX)
multidimensional OLAP (MOLAP) | 多维 OLAP (MOLAP)
multidimensional structure | 多维结构
multiple inheritance | 多重继承
multiple instances | 多实例
multithreaded server application | 多线程服务器应用程序
multiuser | 多用户
name phrasing | 名称句式
named instance | 命名实例
named pipe | 命名管道
named set | 命名集
naming relationship | 命名关系
native format | 本机格式
nchar data type | nchar 数据类型
nested query | 嵌套查询
nested table | 嵌套表
Net-Library | Net-Library
nickname | 别名
niladic functions | niladic 函数
noise word | 干扰词
nonclustered index | 非聚集索引
nonleaf | 非叶
nonleaf member | 非叶成员
nonrepeatable read | 不可重复读取
normalization rules | 规范化规则
noun | 名词
ntext data type | ntext 数据类型
NULL | NULL
nullability | 为空性
numeric expression | 数值表达式
nvarchar data type | nvarchar 数据类型
object | 对象
object dependencies | 对象相关性
object identifier | 对象标识符
object owner | 对象所有者
object permission | 对象权限
object variable | 对象变量
ODBC | ODBC
ODBC data source | ODBC 数据源
ODBC driver | ODBC 驱动程序
ODS | ODS
OIM | OIM
OLAP | OLAP
OLE Automation controller | OLE 自动化控制器
OLE Automation objects | OLE 自动化对象
OLE Automation server | OLE 自动化服务器
OLE DB | OLE DB
OLE DB consumer | OLE DB 使用者
OLE DB for OLAP | 用于 OLAP 的 OLE DB
OLE DB provider | OLE DB? 提供程序
OLTP | OLTP
one-to-many relationship | 一对多关系
one-to-one relationship | 一对一关系
online analytical processing (OLAP) | 联机分析处理 (OLAP)
online redo log | 联机重做日志
online transaction processing (OLTP) | 联机事务处理 (OLTP)
Open Data Services (ODS) | 开放式数据服务 (ODS)
Open Database Connectivity (ODBC) | 开放式数据库连接 (ODBC)
Open Information Model (OIM) | 开放信息模型 (OIM)
optimize synchronization | 优化同步
optimizer | 优化程序
ordered set | 有序集
origin object | 起始对象
outer join | 外联接
overfitting | 过适
page | 页
page split | 页拆分
parent | 父代
partition | 分区
partitioning | 分区
parts of speech | 词性
pass order | 传递顺序
passive voice | 被动语态
pass-through query | 直接传递查询
pass-through statement | 直接传递语句
persistence | 持续性
phantom | 幻像
phrase | 短语
phrasing | 句式
physical name | 物理名称
physical reads | 物理读取
pivot | 数据透视
PK | PK
position | 位置
positioned update | 定位更新
possessive case | 所有格
precision | 精度
predicate | 谓词
prediction | 预测
prefix characters | 前缀字符
prefix length | 前缀长度
prefix search | 前缀搜索
preposition | 介词
preposition phrasing | 介词句式
primary dimension table | 主维度表
primary key (PK) | 主键 (PK)
primary table | 主表
private dimension | 专用维度
procedure cache | 过程缓存
process | 处理
producer | 发生器
project | 工程
pronoun | 代词
proper noun | 专有名词
property | 属性
property pages | 属性页
provider | 提供程序
proximity search | 近似搜索
publication | 发布
publication database | 发布数据库
publication retention period | 发布保持期
published data | 已发布数据
Publisher | 发布服务器
publishing server | 发布服务器
publishing table | 发布表
pubs database | pubs 数据库
pull subscription | 请求订阅
push subscription | 强制订阅
query optimizer | 查询优化器
question | 问题
Question Builder | 问题生成器
question file (.eqq) | 问题文件 (.eqq)
question template | 问题模板
queue | 队列
ragged hierarchy | 不齐整层次结构
range query | 范围查询
rank | 级
RDBMS | RDBMS
real data type | real 数据类型
record | 记录
recordset | 记录集
recovery interval | 恢复间歇
recursive partitioning | 递归分区
redo log file | 恢复日志文件
referenced key | 引用键
referencing key | 参照键
referential integrity (RI) | 引用完整性 (RI)
reflexive relationship | 反身关系
refresh data | 刷新数据
regular cube | 常规多维数据集
regular dimension | 常规维度
relational database | 关系数据库
relational database management system (RDBMS) | 关系数据库管理系统 (RDBMS)
relational OLAP (ROLAP) | 关系 OLAP (ROLAP)
relationship | 关系
relationship object | 关系对象
relationship type | 关系类型
remote data | 远程数据
remote Distributor | 远程分发服务器
remote login identification | 远程登录标识
remote partition | 远程分区
remote server | 远程服务器
remote stored procedure | 远程存储过程
remote table | 远程表
replicated data | 复制的数据
replication | 复制
Replication Conflict Viewer | 复制冲突查看器
Replication Monitor | 复制监视器
replication scripting | 编写复制脚本
replication topology | 复制拓扑
repository | 知识库
repository engine | 知识库引擎
repository object | 知识库对象
Repository SQL schema | 知识库 SQL 架构
Repository Type Information Model (RTIM) | 知识库类型信息模型 (RTIM)
republish | 再次发布
republisher | 再次发布者
resolution strategy | 冲突解决策略
restatement | 复述
result | 结果
result set | 结果集
return parameters | 返回参数
reusable bookmark | 可再次使用的书签
revoke | 废除
RI | RI
right outer join | 右向外联接
ROLAP | ROLAP
role | 角色
roll back | 回滚
roll forward | 前滚
root form | 原形
row | 行
row aggregate function | 行聚合函数
row filter | 行筛选
row lock | 行锁
rowset | 行集
RTIM | RTIM
rule | 规则
sample data | 示例数据
savepoint | 保存点
scalar aggregate | 标量聚合
scheduled backup | 已调度备份
schema | 架构
schema rowset | 架构行集
script | 脚本
scroll | 滚动
search condition | 搜索条件
Security Identifier (SID) | 安全标识号 (SID)
segmentation | 分段
SELECT | SELECT
select list | 选择列表
Select query | 选择查询
self-join | 自联接
semantic object | 语义对象
semiadditive measure | 半加法度量
sensitive cursor | 感知游标
sequence | 序列
sequenced collection | 顺序集合
sequenced relationship | 顺序关系
serializable | 可串行
server cursor | 服务器游标
server name | 服务器名称
session | 会话
Setup initialization file | 安装程序初始化文件
severity level | 严重级别
shared dimension | 共享维度
shared lock | 共享锁
Showplan | 显示计划
sibling | 兄弟
SID | SID
single-user mode | 单用户模式
slice | 切片
smalldatetime data type | smalldatetime 数据类型
smallint data type | smallint 数据类型
smallmoney data type | smallmoney 数据类型
Snapshot Agent | 快照代理程序
Snapshot Agent utility | 快照代理程序实用工具
snapshot cursor | 快照游标
snapshot replication | 快照复制
snowflake schema | 雪花架构
solve order | 求解次序
sort order | 排序次序
source and target | 源和目标
source cube | 源多维数据集
source database | 源数据库
source object | 源对象
source partition | 源分区
sparsity | 稀疏度
SQL | SQL
SQL collation | SQL 排序规则
SQL database | SQL 数据库
SQL expression | SQL 表达式
SQL Mail | SQL 邮件
SQL query | SQL 查询
SQL Server Authentication | SQL Server 身份验证
SQL Server Event Forwarding Server | SQL Server 事件转发服务器
SQL Server login | SQL Server 登录
SQL Server role | SQL Server 角色
SQL Server user | SQL Server 用户
SQL statement | SQL 语句
sql_variant data type | sql_variant 数据类型
SQL-92 | SQL-92
standard security | 标准安全机制
star join | 星型联接
star schema | 星型架构
statement permission | 语句权限
static cursor | 静态游标
static SQL statements | 静态 SQL 语句
step object | 步骤对象
store-and-forward database | 保存与转发数据库
stored procedure | 存储过程
string | 字符串
string functions | 字符串函数
Structured Query Language (SQL) | 结构化查询语言 (SQL)
structured storage file | 结构化存储文件
subject | 主语
subquery | 子查询
subscribe | 订阅
Subscriber | 订阅服务器
subscribing server | 订阅服务器
subscription | 订阅
subscription database | 订阅数据库
subset | 子集
subset phrasing | 子集句式
superlative form | 最高级
synchronization | 同步
synonym | 同义词
system administrator | 系统管理员
system catalog | 系统目录
system databases | 系统数据库
system functions | 系统函数
system stored procedures | 系统存储过程
system tables | 系统表
table | 表
table data type | table 数据类型
table lock | 表锁
table scan | 表扫描
table-level constraint | 表级约束
tabular data stream (TDS) | 表格格式数据流 (TDS)
tape backup | 磁带备份
target object | 目标对象
target partition | 目标分区
task | 任务
task object | 任务对象
TDS | TDS
tempdb database | tempdb 数据库
temporary stored procedure | 临时存储过程
temporary table | 临时表
text data type | text 数据类型
theta join | theta 联接
thread | 线程
time dimension | 时间维度
timestamp data type | timestamp 数据类型
tinyint data type | tinyint 数据类型
tool | 工具
trace file | 跟踪文件
training data set | 培训数据集
trait | 特征
trait phrasing | 特征句式
transaction | 事务
transaction log | 事务日志
transaction processing | 事务处理
transaction rollback | 事务回滚
transactional replication | 事务复制
Transact-SQL | Transact-SQL
Transact-SQL cursor | Transact-SQL 游标
transformable subscription | 可转换订阅
transformation | 转换
trigger | 触发器
trusted connection | 信任连接
tuple | 元组
two-phase commit | 两阶段提交
unbalanced hierarchy | 不均衡层次结构
underlying table | 基础表
unenforced relationship | 未强制关系
Unicode | Unicode
Unicode collation | Unicode 排序规则
Unicode format | Unicode 格式
Union query | 联合查询
UNIQUE constraints | UNIQUE 约束
unique index | 唯一索引
uniqueidentifier data type | uniqueidentifier 数据类型
update | 更新
update lock | 更新锁
Update query | 更新查询
update statistics | 更新统计
user (account) | 用户（帐户）
user database | 用户数据库
user-defined data type | 用户定义的数据类型
user-defined event | 用户定义事件
user-defined function | 用户定义函数
utility | 实用工具
value expression | 值表达式
varbinary data type | varbinary 数据类型
varchar data type | varchar 数据类型
variables | 变量
verb | 动词
verb phrasing | 动词句式
vertical filtering | 垂直筛选
vertical partitioning | 垂直分区
very large dimension | 超大型维度
view | 视图
view generation | 视图生成
virtual cube | 虚拟多维数据集
virtual dimension | 虚拟维度
visual total | 直观合计
WHERE clause | WHERE 子句
wildcard characters | 通配符字符
wildcard search | 通配符搜索
Windows Authentication | Windows 身份验证
Windows collation | Windows 排序规则
word generation | 字生成
write back | 回写
write enable | 写启用
write-ahead log | 预写日志