全文索引、目录和检索

全文索引存储给定表的所有全文词及其位置。全文目录存储数据库的全文索引。全文服务执行全文查询。


全文检索服务属性，常规选项卡

本节说明在"全文检索属性"对话框的"常规"选项卡中可用的选项及其功能。

服务状态

显示全文检索服务的当前状态。单击"刷新"可获得最新状态。

目录文件默认位置

显示全文目录文件的默认目录位置。SQL Server 安装程序决定此位置，并使其具有只读属性。但是，管理员可在创建全文目录时替代此位置。

临时文件位置

显示临时文件的目录位置。这项属性在安装时设置并且是只读的。

错误日志文件位置

显示错误日志文件的目录位置。这项属性在安装时设置并且是只读的。


新建全文目录属性，新建全文目录选项卡

本节说明在"新建全文目录属性"对话框的"新建全文目录"选项卡中可用的选项及其功能。

名称

显示并设置全文目录的显示名称。

位置

显示并替代在安装时设置并显示于"常规"选项卡中的默认全文目录位置。


新建全文目录属性，调度选项卡

用于为当前全文目录创建完全或增量填充调度。每行代表一个完全填充或增量填充。可以为全文目录指派一个或多个完全或增量填充调度，或完全填充次数或增量填充次数的组合。若要修改调度，请双击调度或选择调度并单击"编辑"按钮。若要添加一个调度，请单击"新建调度"若要删除调度，请选择调度并单击"删除"按钮。


全文目录属性，状态选项卡

本节说明在"全文目录属性"对话框的"状态"选项卡中可用的选项及其功能。

名称

显示目录的友好名称。该计数为只读。

位置

显示此目录的根目录的位置。该计数为只读。

物理目录

显示磁盘上的目录名称。该计数为只读。

状态

显示此目录当前的填充状态。单击"刷新"按钮即可更新此显示。该计数为只读。

数值为下列之一：

  • 闲置

  • 正在进行完全填充

  • 已暂停

  • 已中止

  • 正在恢复

  • 关机

  • 正在进行增量填充

  • 正在生成索引

  • 磁盘已满。已暂停

  • 更改跟踪

项目计数

显示此全文目录中编入索引的表和行的数目。该计数为只读。

目录大小

以 MB 为单位显示全文目录的大小。该计数为只读。

唯一键计数

显示全文目录中编入索引的唯一非干扰词计数。该计数为只读。

上次填充的日期

显示此全文目录上次填充的日期和时间。

说明 如果填充在启动后立即停止，则"上次填充的日期"将包含填充的启动日期，即使它没有成功完成也一样。


全文检索目录属性，表选项卡

本节说明在"全文检索目录属性"对话框的"表"选项卡中可用的选项及其功能。

表

显示使用此全文目录为全文索引配置的表。

启用全文索引

显示每个表的全文索引是否是活动的，以及能否对其进行查询。


全文目录属性/全文索引，调度选项卡

用来查看或修改当前全文目录的完全填充或增量填充调度列表。每行代表一个完全填充或增量填充调度。可将一个或多个完全填充或增量填充调度指派给全文目录。若要修改调度，请双击调度或选择调度并单击"编辑"按钮。若要添加一个调度，请单击"新建调度"若要删除调度，请选择调度并单击"删除"按钮。


新建/编辑全文索引调度

可以创建或修改当前全文目录的完全填充或增量填充调度。本节说明在"新建（或编辑）全文索引调度"对话框中可用的选项及其功能。

名称

显示或修改调度名称。

启用

显示或修改所选调度的启用状态。

作业类型（完全/增量）

指定一个完全或增量填充作业类型。完全填充重建全文目录中的所有条目。增量填充为含有带时间戳的行的表更新全文目录中的条目。

启动 SQL Server 代理时自动启动

当 SQL Server 代理启动时，自动启动已调度的填充。

一次

在指定的日期和时间启动一次已调度的填充。

日期

指定想要启动填充的日期。

时间

指定想要启动填充的时间。

反复出现

根据显示的调度信息启动已调度的填充。

更改

更改当前反复出现的作业调度。


表属性，全文索引选项卡

本节说明在"表属性"对话框的"全文索引"选项卡中可用的选项及其功能

全文索引状态

指出此表的全文索引是否是活动的。活动的全文索引支持全文查询。

全文目录

显示包含此表的全文索引的全文目录名称。可在此表数据库的"全文目录"文件夹中找到此全文目录。

全文唯一键列

显示全文索引中用来标识表行的唯一键的列名。

全文唯一键索引

显示在全文索引中用来标识表行的唯一键索引。

全文更改跟踪

指出是否为此表启用全文更改跟踪。

全文更新索引

指出是否为此表启用全文更新索引。

列

显示此表的列。已选取那些被选中参与全文索引的文本化列。