已注册的 SQL Server 属性（常规选项卡）

使用此选项卡查看或指定下列选项。

选项

服务器

查看注册的服务器，该服务器正在运行要编辑的 Microsoft® SQL Server™ 实例。单击搜索（"..."）按钮搜索要查看的服务器。

使用 Windows 身份验证

连接到 SQL Server 实例时使用 Windows 身份验证。为了安全，建议使用该选项，因为通过 Microsoft Windows NT® 4.0 或 Windows® 2000 用户帐户连接的用户可以使用信任连接。信任连接由 Windows NT 4.0 或 Windows 2000 验证的连接。

使用 SQL Server 身份验证

连接服务器时使用 SQL Server 身份验证。

登录名

指定当使用 SQL Server 身份验证连接服务器时使用的登录名。

密码

指定当使用 SQL Server 身份验证连接服务器时使用的密码。

总是提示输入登录名和密码

指定用户使用 SQL Server 身份验证连接到服务器时，SQL Server 必须总是提示需要登录名和密码。

服务器组

选择关联服务器所用的服务器组。单击添加（"..."）按钮将服务器组添加到该列表。

在控制台中显示 SQL Server 的状态

指定在控制台中显示 SQL Server 的状态。

显示系统数据库和系统对象

指定显示的系统数据库和系统对象。

在连接时自动启动 SQL Server

指定在用户连接到服务器时，SQL Server 实例自动启动。

请参见

注册服务器


服务器组（常规选项卡）

使用此选项卡查看或指定下列选项。

选项

名称

指定服务器组的名称。

顶层组

指定组出现在 SQL Server 企业管理器窗口控制台树的顶层。

下面项目的子组

指定组作为某一服务器组的子组出现。

请参见

创建服务器组


SQL Server 企业管理器属性（常规选项卡）

使用此选项卡查看或指定下列选项。

选项

对服务器进行轮询以查找服务器的状态和相关服务

定期对服务器进行轮询并且使用红绿灯图标查看其状态。

服务

选择轮询哪种服务。

轮询间隔（秒）

指定服务器轮询的间隔时间（以秒为单位）。

本地读取/存储

本地读取和存储服务器的注册信息。

与用户无关的读取/存储

单独为每个用户读取和存储服务器的注册信息。

远程读取

读取远程服务器的注册信息。

服务器名称

指定存储注册信息的远程服务器名称。

全部重置

重置此对话框中的所有选项。

请参见

如何设置对您显示的服务器和组的访问（企业管理器）

如何设置轮询间隔（企业管理器）

如何建立服务器注册信息的中央存储（企业管理器）


SQL Server 企业管理器属性（高级选项卡）

使用此选项卡查看或指定下列选项。

选项

登录超时（秒）

指定从失败的远程登录尝试返回实例之前等待的秒数。

查询超时（秒）

指定处理远程查询时在查询超时之前必须经过的秒数。默认值为 0，允许无限等待。

数据包的大小（字节）

指定表格格式数据流 (TDS) 包的大小。TDS 包的默认大小为 4 千字节 (KB)。

执行字符数据的转换

在不同的客户端和服务器代码页之间执行字符数据的转换。此选项只影响存储在 Microsoft® SQL Server™ 的 char、varchar 和 text 列中的数据。

将控制台树打开到上一个活动节点

指定启动后，SQL Server 企业管理器中的控制台树立即打开到上一个活动节点。

全部重置

重置此选项卡上的所有选项。

请参见

如何配置数据包的大小（企业管理器）


SQL Server 属性（常规选项卡）

使用此选项卡查看或指定下列选项。

选项

名称

查看 Microsoft® SQL Server™ 实例的名称。

产品

查看产品的名称。

操作系统

查看服务器运行的操作系统。

产品版本

查看 SQL Server 实例的版本。

语言

查看产品的默认语言。

平台

查看产品运行的平台。

操作系统内存

查看可用的操作系统内存。

处理器

查看处理器的个数。

根目录

查看根目录。

服务器排序规则

查看 SQL Server 实例正使用的排序规则类型。

自动启动 SQL Server

Microsoft Windows NT® 4.0 或 Windows® 2000 启动时自动启动 SQL Server 实例。

自动启动 SQL Server 代理

Windows NT 4.0 或 Windows 2000 启动时自动启动 SQL Server 代理程序。

自动启动 MSDTC

Windows NT 4.0 或 Windows 2000 启动时自动启动 Microsoft 分布式事务处理协调器 (MS DTC)。

启动参数

显示"服务器参数"对话框。

网络配置

启动 SQL Server 网络实用工具。

请参见

自动启动 SQL Server

使用启动选项

SQL Server 网络实用工具


启动参数

使用此对话框查看或指定下列选项。

选项

参数

指定要添加或删除的服务器参数。

现有参数

查看现有服务器的参数。

添加

添加服务器参数。

删除

删除服务器参数。

请参见

使用启动选项


SQL Server 属性（内存选项卡）

使用此选项卡查看或指定下列选项。

选项

动态配置 SQL Server 内存

指定在更改服务器属性之后立即配置 Microsoft® SQL Server™ 内存。

使用固定的内存大小

为 SQL Server 指定固定的内存大小。

为 SQL Server 保留物理内存

为 SQL Server 保留与内存设置相等的物理内存空间。这意味着 Microsoft Windows NT® 4.0 或 Windows® 2000 不会将 SQL Server 页交换出去，即使当 SQL Server 闲置时可以更容易地使用这些页。

最小查询内存

设置可以分配给每个用户执行查询的最小内存大小。默认为 1024 KB。

配置值

查看或更改此选项卡上的选项的配置值。如果更改了这些值，单击"运行值"查看更改是否已生效。如果没有，必须重新启动 SQL Server 实例才能使更改生效。

运行值

查看此选项卡上的选项的当前运行值。这些值为只读值。

请参见

设置配置选项


SQL Server 属性（处理器选项卡）

使用此选项卡查看或指定下列选项。

选项

处理器

指定希望 Microsoft® SQL Server™ 实例使用的处理器。

最大工作线程

指定 SQL Server 进程可用工作线程的最大数目。

在 Windows 上提升 SQL Server 的优先级

指定 SQL Server 实例是否应当比同一计算机上运行的其它进程具有更高的优先级。默认值为 0，其优先级基数为 7。如果将该选项设置为 1，则 SQL Server 在 Microsoft Windows NT® 4.0 或 Windows® 2000 调度程序中以优先级基数 13 运行。建议只在 SQL Server 专用的 Windows NT 4.0 或 Windows 2000 系统上更改该默认值。

使用 Windows NT 纤程

指定希望 SQL Server 实例使用纤程而非线程。在纤程中，SQL Server 为每个 CPU 分配一个线程，然后为每个并发用户分配一个纤程，直到 max worker threads 值为止。此设置在重新启动服务器后生效。

使用所有可用的处理器

指定希望 SQL Server 将所有可用的处理器都用于并行执行查询。

使用处理器数

指定希望 SQL Server 用于并行执行查询的处理器数。

为允许查询并行执行须满足的最小查询计划阈值

指定 SQL Server 创建和执行并行计划的阈值。只有当同一查询的串行计划的估计执行成本高于此选项的设置值时，SQL Server 才会为该查询创建和执行并行计划。

查看或更改此选项卡上的选项的配置值。如果更改了这些值，单击"运行值"查看更改是否已生效。如果尚未生效，必须重新启动 SQL Server 实例才能使更改生效。

运行值

查看此选项卡上的选项的当前运行值。这些值为只读值。

请参见

设置配置选项


SQL Server 属性（安全选项卡）

使用此选项卡查看或指定下列选项。

选项

SQL Server 和 Windows

指定用户可以使用 SQL Server 身份验证和 Windows 身份验证连接到 Microsoft® SQL Server™ 实例。这种验证为混合模式身份验证。通过 Microsoft Windows NT 4.0 或 Windows 2000 用户帐户连接的用户可以 Windows 身份验证模式或混合模式利用信任连接。当用户通过 Windows NT 4.0 或 windows 2000 用户帐户进行连接时，SQL Server 通过回叫 Windows NT 4.0 或 Windows 2000 请求信息，重新验证帐户名和密码。

仅 Windows

指定用户只能使用 Windows 身份验证连接到 SQL Server 实例。

无

禁用审核。这是此设置的默认值。

成功

审核成功登录尝试。可以记录尝试的用户访问及其它 SQL Server 登录信息，对两种安全模式都启用审核，并且可以记录有关信任和非信任连接的信息。根据 SQL Server 实例的日志记录配置方式，这些事件的日志记录将出现在 Microsoft Windows® 应用程序日志或 SQL Server 错误日志中，也可以同时出现在这两个日志中。

如果选择该选项，则必须停止并重新启动服务器以启用审核。

失败

审核失败登录尝试。可以记录试图的用户访问及其它 SQL Server 登录信息，启用审核用于两种安全模式，并可以记录有关信任和非信任连接的信息。根据 SQL Server 实例日志记录的配置方式，这些事件的日志记录可出现在 Windows 应用程序日志或 SQL Server 错误日志中，也可以同时出现在这两个日志中。

如果选择该选项，则必须停止并重新启动服务器以启用审核。

全部

审核成功和失败的登录操作。可以记录试图的用户访问及其它 SQL Server 登录信息，启用审核用于两种安全模式，并可以记录有关信任和非信任连接的信息。根据 SQL Server 实例日志记录的配置方式，这些事件的日志记录可出现在 Windows 应用程序日志或 SQL Server 错误日志中，也可以在两个日志中同时出现。

如果选择该选项，则必须停止并重新启动服务器以启用审核。

系统帐户

指定 SQL Server 服务帐户的实例为内置的本地系统管理员帐户。

本帐户

指定 SQL Server 服务帐户为 Microsoft Windows NT® 4.0 或 Windows 2000 域帐户。只有在运行 SQL Server 注册实例的计算机上使用有效的 Windows NT 4.0 或 Windows 2000 管理员帐户时才启用此字段。

密码

指定 Windows NT® 4.0 或 Windows 2000 域帐户的密码。只有在运行 SQL Server 注册实例的计算机上使用有效的 Windows NT 4.0 或 Windows 2000 管理员帐户时才启用此字段。

请参见

设置配置选项


SQL Server 属性（连接选项卡）

使用此选项卡查看或指定下列选项。

选项

并发用户连接的最大数目

指定并发用户连接的最大数目。输入零表示可以有无限多个并发用户连接。

默认连接选项

指定选定服务器的默认连接选项。

允许其它 SQL Server 使用 RPC 远程连接到本 SQL Server

允许其它 Microsoft® SQL Server™ 实例使用远程过程调用 (RPC) 远程连接到本服务器。

查询超时（秒）

指定远程查询时在查询超时之前必须经过的秒数。指定零表示对超时时间没有限制。

强制分布式事务处理 (MTS)

通过使用 Microsoft 分布式事务处理协调器 (MS DTC) 协调分布式事务来保护服务器间的过程。

配置值

查看或更改此选项卡上选项的配置值。如果更改了这些值，单击"运行值"查看更改是否已生效。如果尚未生效，必须重新启动 SQL Server 实例才能使更改生效。

运行值

查看此选项卡上选项的当前运行值。这些值为只读值。

请参见

设置配置选项


SQL Server 属性（服务器设置选项卡）

使用此选项卡查看或指定下列选项。

选项

用户的默认语言

指定服务器消息的默认语言。

允许对系统目录直接进行修改

允许对系统目录直接进行修改。

允许激发会激发其它触发器（嵌套触发器）的触发器

允许激发嵌套触发器。

使用查询调控器防止超出指定成本的查询

选择成本查询调控器作为防止查询超出指定成本的工具。

邮件登录名

为邮件客户程序指定有效的邮件登录名。

用两个数字表示年份时，代表下面时间段的年份

指定 Microsoft® SQL Server™ 实例如何解释两位数的年份。若要更改时间跨度，请键入结束年份。默认的时间跨度是 1950 到 2049。开始日期是 1950 年 1 月 1 日，结束日期是 2049 年 12 月 31 日。99 解释为 1999，01 解释为 2001。规则是：小于等于截止年份的最后两位数的年份与截止年份处于同一世纪。大于截止年份的最后两位数的年份处于截止年份的前一个世纪。四位数字的年份不受此选项的影响。如果希望 SQL Server 使用与客户端相同的两位数截止年份，请选择 2030。

配置值

查看或更改此选项卡上的选项的配置值。如果更改了这些值，单击"运行值"查看更改是否已生效。如果尚未生效，必须重新启动 SQL Server 实例才能使更改生效。

运行值

查看此选项卡上的选项的当前运行值。这些值为只读值。

请参见

设置配置选项


SQL Server 属性（数据库设置选项卡）

使用"数据库设置"选项卡查看或指定下列选项。

选项

固定

手工设置默认索引填充因子。索引填充因子决定 Microsoft® SQL Server™ 使用现有数据创建新索引时每页的填满程度。如果清除该选项，则 SQL Server 将选择最佳的性能设置。

无限期等待

指定 DB-Library 必须无限期等待 SQL Server 实例的响应。

试一次后退出

指定 DB-Library 必须试一次连接 SQL Server 实例然后超时。

试...分钟

指定在超时前 DB-Library 必须尝试连接 SQL Server 实例的时间长度（以分钟为单位）。

默认的备份媒体保持期（天）

设置备份用于数据库或事务日志备份之后，保留每一个备份媒体的时间长度的系统范围默认值。

恢复间隔（分钟）

设置 SQL Server 需要用来完成每个数据库的恢复过程的最大分钟数。默认值为每个数据库 0 分钟，这是用于快速恢复的自动配置。

默认数据目录

指定在 SQL Server 中创建新数据库时用于数据文件的默认目录。单击浏览（"..."）按钮搜索现有的数据目录。

默认日志目录

指定在 SQL Server 中创建新数据库时用于日志文件的默认目录。单击浏览（"..."）按钮搜索现有的数据目录。

配置值

查看或更改此选项卡上的选项的配置值。如果更改了这些值，单击"运行值"查看更改是否已生效。如果尚未生效，必须重新启动 SQL Server 实例才能使更改生效。

运行值

查看此选项卡上的选项的当前运行值。这些值为只读值。

请参见

设置配置选项

如何设置固定的填充因子（企业管理器）

如何设置备份保留期（企业管理器）

如何设置恢复间歇（企业管理器）


数据库属性（常规选项卡）

使用此选项卡查看或指定下列选项。

选项

名称

查看选定数据库的名称。

状态

查看选定数据库的状态。

所有者

查看选定数据库的所有者。

创建日期

查看数据库的创建日期和时间。

大小

查看数据库的大小（以兆字节 (MB) 为单位）。

可用空间

查看数据库中的可用空间。

用户数

查看数据库用户数。

上次数据库备份

查看上次数据库备份的日期和时间。

上次事务日志备份

查看上次事务日志备份的日期和时间。

维护计划

查看有关维护计划的详细信息。

排序规则名称

查看数据库排序规则类型。

请参见

查看数据库


数据库属性（事务日志选项卡）

使用此选项卡查看或指定下列选项。

选项

事务日志文件

查看事务日志文件的文件名、位置和分配的空间。

删除

删除选定的事务日志文件。

文件自动增长

指定事务日志文件自动增长。

按兆字节

指定事务日志文件按兆字节 (MB) 自动增长。

按百分比

指定事务日志文件按百分比自动增长。

文件增长不受限制

指定事务日志文件可以无限制增长。

将文件增长限制为 (MB)

指定受限制事务日志文件可增长到的大小（以 MB 为单位）。

请参见

事务日志


数据库属性（选项选项卡）

使用此选项卡查看或指定下列选项。

选项

限制访问

指定只有在下列选项中指出的用户才可以访问数据库。

db_owner、dbcreator 或 sysadmin 的成员

指定只有 db_owner、dbcreator 或 sysadmin 成员才可以访问数据库。

单用户

指定一次只能有一个用户访问数据库。

只读

指定用户可以检索数据库中的数据，但不能修改。

模型

指定数据库的恢复模型类型。有关恢复模型的更多信息，请参见使用恢复模型。

ANSI NULL 默认设置

指定将数据库列默认定义为 NULL 还是 NOT NULL。

递归触发器

启用触发器的递归触发。

select into/bulkcopy

指定可以执行不记录操作。该选项仅当查看 Microsoft® SQL Server™ 7.0 版服务器中的数据库属性时可用。这指定了数据库的恢复模型类型。有关恢复模型的更多信息，请参见使用恢复模型。

在检查点截断日志

指定当检查点进程发生时截断事务日志。该选项仅当您查看 SQL Server 7.0 服务器中的数据库属性时可用。这指定了数据库的恢复模型类型。有关恢复模型的更多信息，请参见使用恢复模型。

残缺页检测

指定可以检测不完整页。

自动关闭

指定数据库资源被释放以及所有用户退出之后关闭数据库。

自动收缩

指定数据库文件可以周期性自动收缩。

自动创建统计信息

指定在优化期间自动生成优化查询所需的任何缺少的统计信息。

自动更新统计信息

指定在优化期间自动生成查询优化所需的过时统计信息。

使用引用的标识符

指定 SQL Server 将强制执行关于引号的 ANSI规则。选择此选项指定双引号只能用于标识符，比如列和表的名称。字符串必须包含在单引号内。

级别

指定数据库兼容性级别。

在 Active Directory 中列出此数据库

指定在 Active Directory 中列出此数据库。Active Directory 是 Microsoft Windows® 2000 操作系统的中心组件，它提供存储有关基于网络的实体（如应用程序、文件、打印机和人员等）信息的空间。只有当数据库位于已被添加到 Active Directory 的服务器上时，此选项才可用。

请参见

设置数据库选项


数据库属性（权限选项卡）

使用此选项卡查看或指定下列选项。

选项

用户/角色

查看用户或角色的名称。

创建表

指定是否授权给每个用户或角色创建表的权限。

创建视图

指定是否授权给每个用户或角色创建视图的权限。

创建 SP

指定是否授权给每个用户或角色创建系统过程的权限。

创建默认设置

指定是否授权给每个用户或角色创建默认值的权限。

创建规则

指定是否授权给每个用户或角色创建规则的权限。

创建函数

指定是否授权给每个用户或角色创建函数的权限。

备份 DB

指定是否授权给每个用户或角色创建备份数据库的权限。

备份日志

指定是否授权给每个用户或角色创建备份日志的权限。

请参见

管理权限


数据库角色属性（常规选项卡）

使用此选项卡查看或指定下列选项。

选项

名称

指定数据库角色的名称。

权限

显示"数据库用户属性"对话框，在其中可指定数据库用户的登录名和用户名。

标准角色

指定如果正创建新数据库角色，则该数据库角色是标准角色。添加和复查现有数据库角色成员。

添加

将用户添加到数据库角色中。

删除

从数据库角色中删除用户。

应用程序角色

指定数据库是应用程序角色，它需要密码。

密码

指定应用程序角色密码。

请参见

数据库角色

查看角色


数据库用户属性（常规选项卡）

使用此选项卡查看或指定下列选项。

选项

登录名

指定数据库用户的登录名。

用户名

指定数据库用户的用户名。

权限

显示"数据库用户属性"对话框，在其中可以指定用户数据库权限。

数据库角色中允许

指定用户所属的数据库角色。

属性

显示"数据库角色属性"对话框，在其中可以将用户添加到角色或从角色中删除用户。

请参见

用户

查看数据库用户


数据库用户属性（权限选项卡）

使用此选项卡查看或指定下列选项。黑色复选标记表示已授予的权限。红色"X"表示拒绝授予的权限。

选项

数据库用户

指定要显示其权限的用户。

列出全部对象

列出选定数据库的全部对象。单击适当的框以修改数据库用户权限。

仅列出此用户具有权限的对象

仅列出用户对其具有权限的对象。单击适当的框以修改数据库用户权限。

列

显示"列权限"对话框，在其中可以管理每列的权限。

请参见

管理权限


SQL Server 登录属性（常规选项卡）

使用此选项卡查看或指定下列选项。

选项

名称

指定 Microsoft® SQL Server™ 登录的名称。

Windows 身份验证

连接到 SQL Server 实例时使用 Windows 身份验证。为了安全，建议使用该选项，因为通过 Microsoft Windows NT® 4.0 或 Windows® 2000 用户帐户连接的用户可以使用信任连接。信任连接由 Windows NT 4.0 或 Windows 2000 验证的连接。

域

查看 Windows NT 4.0 或 Windows 2000 域。该域帐户提供对域中其它服务器的网络访问。

允许访问

授予对 Windows NT 4.0 或 Windows 2000 帐户的登录访问。

拒绝访问

拒绝对 Windows NT 4.0 或 Windows 2000 帐户的登录访问。

SQL Server 身份验证

连接服务器时使用 SQL Server 身份验证。此选项利用 SQL Server 安全机制对用户进行验证。

密码

指定当使用 SQL Server 身份验证连接服务器时使用的密码。

数据库

查看此登录的默认数据库。

语言

查看此登录的默认语言。

请参见

登录

安全管理


SQL Server 登录属性（服务器角色选项卡）

使用此选项卡查看或指定下列选项。

选项

服务器角色

向登录授予服务器范围内的安全权限。

描述

描述角色的登录权限。

属性

显示"服务器角色属性"对话框，在其中可以给服务器角色授予服务器范围的权限。

请参见

角色

安全管理


SQL Server 登录属性（数据库访问选项卡）

使用此选项卡查看或指定下列选项。

选项

指定此登录可以访问的数据库

指定登录可以访问的数据库。

数据库角色

为每个数据库角色选择权限。

属性

显示"数据库角色属性"对话框，在其中可以将成员添加到数据库角色或从数据库角色中删除成员。

请参见

安全管理


默认属性（常规选项卡）

使用此选项卡查看或指定下列选项。

选项

名称

指定默认值的名称。

值

指定默认值的值。

绑定 UDT

将默认值绑定到用户定义的数据类型。

绑定列

将默认值绑定到列。

请参见

默认值

CREATE DEFAULT


规则属性（常规选项卡）

使用此选项卡查看或指定下列选项。

选项

名称

指定规则的名称

文本

指定规则的文本。

绑定 UDT

将规则绑定到用户定义的数据类型。

绑定列

将规则绑定到列。

请参见

规则

CREATE RULE


存储过程属性（常规选项卡）

使用此选项卡查看或指定下列选项。

选项

名称

指定存储过程的名称。

权限

显示"对象属性"对话框，在其中可以指定存储过程权限。

所有者

查看存储过程的所有者。

创建日期

查看存储过程的创建日期。

文本

查看存储过程中出现的文本。如果希望缩进由 SQL Server 企业管理器创建的存储过程中的 Transact-SQL 语句，请按 CTRL+Tab 组合键。

检查语法

检查用于创建存储过程的 Transact-SQL 脚本语法。

请参见

存储过程


用户定义的数据类型属性（常规选项卡）

使用此选项卡查看或指定下列选项。

选项

名称

创建用户定义的数据类型名或审阅现有的用户定义的数据类型名。该名称可以在整个数据库内用于表示一种数据类型。

数据类型

指定用户定义的名称代表的数据类型。

长度

查看或更改用户定义的数据类型的长度。

允许 NULL 值

指定数据类型是否可以允许空值。

规则

指定与用户定义的数据类型相关的规则。

默认值

指定用户定义的数据类型的默认值。

使用位置

查看使用用户定义的数据类型的位置。

请参见

创建用户定义的数据类型


扩展存储过程属性（常规选项卡）

使用此选项卡查看或指定下列选项。

选项

名称

指定扩展存储过程的名称。

权限

显示"对象属性"对话框，在其中可以指定扩展存储过程的权限。

路径

指定扩展存储过程的位置。单击浏览（"..."）按钮搜索扩展存储过程。

请参见

扩展存储过程


远程服务器属性（常规选项卡）

使用此选项卡查看或指定下列选项。

选项

名称

指定远程服务器的名称。

RPC

使远程服务器得以利用远程过程调用 (RPC) 执行本地服务器上的存储过程。

将所有远程登录都映射为

指定所有远程登录必须用来访问本地服务器的登录 ID 。默认情况下选择该选项。

检查密码

远程登录连接到本地服务器时检查其密码。

将远程登录映射为不同的本地登录

对从远程服务器上连接到本地服务器的用户，将每个远程登录 ID 映射为特定的本地登录 ID 。

请参见

配置远程服务器


链接服务器属性（常规选项卡）

使用此选项卡查看或指定下列选项。

选项

链接服务器

指定链接服务器的名称。

SQL Server

将链接服务器标识为 Microsoft® SQL Server™ 实例。如果使用这种方法定义 SQL Server 链接服务器，那么在"链接服务器"中指定的名称必须是服务器的网络名称。而且，任何从该服务器上检索的表都来自该链接服务器上为登录所定义的默认数据库。

其它数据源

通过任何可用的 OLE DB 提供程序（包括 SQL Server）且指定下列选项定义链接服务器。

提供程序名称
指定 OLE DB 提供程序的名称，该提供程序管理对指定链接服务器的访问。
提供程序选项
显示"提供程序选项"对话框，在其中查看链接服务器的各种特性。
产品名称
指定要作为链接服务器添加的 OLE DB 数据源的产品名称。
数据源
指定与链接服务器对应的 OLE DB 数据源属性。
提供程序字符串
指定与链接服务器对应的 OLE DB 提供程序字符串属性。
位置
指定与链接服务器对应的 OLE DB 位置属性。
目录
指定与链接服务器对应的 OLE DB 目录属性。

请参见

配置链接服务器


链接服务器属性（安全选项卡）

使用此选项卡查看或指定下列选项。

选项

本地登录

指定可以连接链接服务器的本地登录 ID。

模拟

指定用来连接链接服务器的本地登录 ID。如果确信本地登录 ID 与在链接服务器上拥有足够权限的登录 ID 正好匹配，请选择此选项。

远程用户

使用远程用户映射"本地登录"中没有定义的用户。

远程密码

指定用于映射"本地登录"中没有定义的用户的密码。

不进行

指定对于该列表中没有定义的登录，将不进行连接。

不使用安全上下文进行

指定对于该列表中没有定义的登录，将不使用安全上下文进行连接。

用登录的当前安全上下文进行

指定对于该列表中没有定义的登录，将使用登录的当前安全上下文进行连接。

用此安全上下文进行

指定对于该列表中没有定义的登录，将使用在"远程登录"和"使用密码"框中指定的登录和密码进行连接。

请参见

配置链接服务器

建立链接服务器的安全性


数据库维护计划（常规选项卡）

使用此选项卡查看或指定下列选项。

选项

计划名

指定维护计划的名称。

全部数据库

生成对所有 Microsoft® SQL Server™ 实例运行维护任务的维护计划。

全部系统数据库（master、model 及 msdb）

生成对每个 SQL Server 系统数据库运行维护任务的维护计划。对用户创建的数据库不运行维护任务。

全部用户数据库（不仅 master、model 及 msdb）

生成对用户创建的全部数据库运行维护任务的维护计划。对 SQL Server 系统数据库不运行维护任务。

如下数据库

生成只在从列表中选择的数据库上运行维护任务的维护计划。如果选择该选项，则必须选择至少一个数据库。该选项是默认设置。

请参见

数据库维护计划向导


数据库维护计划（优化选项卡）

使用此选项卡重新组织数据和索引页，使查询优化器得以更好地访问执行计划。

选项

重新组织数据和索引页

导致除去数据库中的表索引然后用新的填充因子重新创建。FILLFACTOR 决定索引中的每一页留有多大空间，从而为索引中每个数据页将来的扩充留下一定的可用空间。当数据添加到表中时，由于并不维持 FILLFACTOR，因此将填满可用空间。重新组织数据和索引页可以重新建立可用空间。

使用原有可用空间重新组织页面

除去数据库中的表索引并用第一次创建索引时指定的初始 FILLFACTOR重新创建。

将每页的可用空间百分比更改为

除去索引并用自动重新计算的新的 FILLFACTOR 重新创建，从而在索引页上保留了指定的可用空间量。百分比越高，索引页上保留的可用空间就越多，并且索引增长也就越大。有效值为从 0 到 100。

更新查询优化器使用的统计

重新采样在数据库中的用户表上创建的每个索引的分发统计。Microsoft® SQL Server™ 使用分布统计在处理 Transact-SQL 语句时优化表间的导航。为了自动建立分布统计，SQL Server 定期地从每个索引所对应的表中采样一定百分比的数据。该百分比率根据表中的行数和数据修改的频率而定。可以使用此选项利用表中指定百分比的数据执行另一次采样。

数据库的采样百分比

指定用于生成分发统计的表中数据的采样百分比。随着百分比增加，统计的正确率也相应提高。但是，采样所用的时间也随之增加。如果所指定值未生成满足需要的样本，则 SQL Server 将自动确定足够的采样大小。有效值从 1 到 100。

从数据库文件中删除未使用的空间

删除数据库中未用的空间，以减少数据文件的大小。

当数据库大于以下数量时收缩该数据库
仅当数据库超过指定的大小（以 MB 为单位）时，才从数据库中删除未使用的空间。
收缩后剩余的可用空间大小
确定数据库收缩后数据库内剩余的未使用空间大小。百分比越大，数据库可收缩的量越小。该数值基于数据库中实际数据所占的百分比。例如，如果要收缩包含 60 MB 数据和 40 MB 可用空间的 100 MB 数据库，其中可用空间百分比为 50%，则将有 60 MB 数据和 30 MB 可用空间。只有数据库中的过剩的空间才会被删除。有效值从 0 到 100。

调度

设置数据优化任务（使用 SQL Server 代理程序调度）的执行频率。默认为每星期日的午夜 12 点。

更改

显示"编辑反复出现的作业调度"对话框，在此对话框中可以更改默认调度。

请参见

数据库维护计划向导

数据库性能优化概述


数据库维护计划（完整性选项卡）

使用"完整性"选项卡运行数据完整性测试，以检测损坏的数据。损坏有时可能由硬件或软件错误造成。

选项

检查数据库完整性

检查数据库中数据页的分配。

包含索引
测试数据库完整性时，检查索引和数据页的分配。
尝试修复所有小问题
在内部数据完整性测试过程中，尝试自动纠正检测到的所有小问题。推荐选择该选项。

排除索引

测试数据库完整性时，只检查数据页的分配。使用该测试比用索引测试数据库要快，因为检查的页少。

在备份数据库或事务日志之前执行测试

在备份数据库或事务日志前，执行数据库或内部数据完整性测试。如果完整性测试检测到不一致，将不备份后续的数据库或事务日志备份。

调度

设置数据完整性任务（使用 SQL Server 代理程序调度）的执行频率。默认为每星期日午夜 12 点。

更改

显示"编辑反复出现的作业调度"对话框，在此对话框中可以更改默认调度。

请参见

数据库维护计划向导

数据完整性

数据库完整性检查


数据库维护计划（完整备份选项卡）

使用此选项卡制作数据库备份复本，以免故障发生时造成数据丢失。

选项

作为维护计划的一部分来备份数据库

作为常规维护任务的一部分备份整个数据库。备份数据库很重要，因为系统或硬件故障或者用户的误操作都可能损坏数据库，因此，需要制作数据库备份复本以便还原。

完成时验证备份的完整性

执行 Transact-SQL 语句 RESTORE VERIFYONLY 可检查备份集是否完整以及所有卷是否都可以访问。

磁带

将数据库备份到指定的磁带设备。磁带设备连接到包含要备份的 Microsoft® SQL Server™ 数据库的计算机上。

磁盘

将数据库备份到包含要备份的 SQL Server 数据库的计算机的磁盘上。

使用默认备份目录
将数据库备份到包含要备份的 SQL Server 数据库的计算机上的 \Program Files\Microsoft SQL Server\MSSQL\BACKUP 磁盘目录下。
使用此目录
将数据库备份到包含要备份的 SQL Server 数据库的计算机上的指定磁盘目录下。单击浏览（"..."）按钮更改用于备份数据库的默认磁盘目录。只能选择包含要备份的 SQL Server 数据库的计算机上的驱动器。
为每个数据库创建一个子目录
在指定磁盘目录下创建一个子目录，该目录包含正作为维护计划的一部分而备份的每个数据库的数据库备份。
删除早于此时间的文件
自动删除早于指定时期的数据库备份。建议维护数据库备份的历史记录，因为可能必须将数据库还原到比最后执行备份早的即时点。根据实际情况，尽量保留磁盘空间所允许的最多备份，尽量向前扩展备份以供最终还原。

备份文件扩展名

指定包含数据库备份的每个文件的扩展名。默认的文件扩展名是 .bak。

调度

设置数据库备份任务（使用 SQL Server 代理程序调度）的执行频率。默认为每星期日午夜 12 点。

更改

显示"编辑反复出现的作业调度"对话框，在此对话框中可以更改默认调度。

请参见

数据库维护计划向导

备份和还原数据库


数据库维护计划（事务日志备份选项卡）

使用此选项卡制作事务日志备份复本，以免故障发生时造成数据丢失。

选项

作为维护计划的一部分来备份数据库事务日志

作为常规维护任务的一部分备份事务日志。备份事务日志非常重要，因为有可能必须将数据库还原到特定的时间点。选择该选项使下列选项可用。

完成时验证备份的完整性

执行 Transact-SQL 语句 RESTORE VERIFYONLY 可检查备份集是否完整以及所有卷是否都可以访问。

磁带

将事务日志备份到指定的磁带设备。磁带设备连接包含要备份的 Microsoft® SQL Server™ 事务日志的计算机。

磁盘

将事务日志备份到包含要备份的 SQL Server 事务日志的计算机的磁盘上。

使用默认备份目录
将数据库备份到运行要备份的 SQL Server 实例的计算机上的 Program Files\Microsoft SQL Server\MSSQL\BACKUP 磁盘目录下。
使用此目录
将数据库备份到包含要备份的 SQL Server 数据库的计算机上的指定磁盘目录下。单击浏览（"..."）按钮更改用于备份数据库的默认磁盘目录。只能选择包含要备份的 SQL Server 数据库的计算机上的驱动器。
为每个数据库创建子目录
在包含数据库备份的指定磁盘目录下，为作为维护计划一部分的要备份的每个数据库创建子目录。
删除早于此时间的文件
自动删除早于指定时期的数据库备份。建议维护数据库备份的历史记录，因为可能必须将数据库还原到比最后执行备份早的即时点。在磁盘空间允许的情况下，根据实际情况保留尽量多和尽量早的备份以备还原。

备份文件扩展名

指定包含数据库备份的每个文件的扩展名。默认的文件扩展名是 .bak。

调度

设置事务日志备份任务（使用 SQL Server 代理程序调度）的执行频率。默认为除星期日外的每晚 12 点。

更改

显示"编辑反复出现的作业调度"对话框，在此对话框中可以更改默认调度。

请参见

数据库维护计划向导

事务日志备份


数据库维护计划（报表选项卡）

使用此选项卡将 Microsoft® SQL Server™ 所执行的维护活动记录保存在文件中或写入表中。

选项

将报表写入目录中的文本文件

指定将要在其中生成报表的文本文件的完整路径和名称。报表包含维护计划执行步骤的细节，包括任何错误信息。报表通过将日期添加到文件名中来维护版本信息。日期作为文件名的后缀生成，但添加在扩展名之前，其格式为 _YYYYMMDDHHMM（例如，"DB Maintenance Plan10_199804090838.txt"）。

单击浏览（"..."）按钮更改文本文件的默认目录。只能在运行维护计划的 SQL Server 实例上选择目录。

删除早于此时间的文本报表文件
自动删除早于指定时期的文本报表文件。建议维护文本报表文件的历史记录，以便可以根据实际情况，检查尽可能早的已执行维护任务。

通过电子邮件将报表发送至操作员

指定操作员，生成的报告将通过 SQL 邮件发送给该操作员。单击浏览（"..."）按钮指定现有操作员或使用 SQL Server 企业管理器创建新的操作员。

新建

显示"新建操作员属性"对话框，在其中可以创建新的操作员。

将历史记录写入 msdb.dbo.sysdbmaintplan_history 表

将历史记录报表以行的形式写入执行维护计划的服务器上的 msdb.dbo.sysdbmaintplan_history 表中。报表包含维护计划执行的步骤，包括数据库名称、活动、日期、结果（成功或失败）和任何错误信息。每个活动、每个数据库、每个执行日期在表中都占一行。

查看历史记录

显示"数据库维护计划历史记录"对话框，在其中可以查看本地服务器的数据库维护计划历史记录。

将本计划表中的行数限制在

指定表中的最大行数。这些行只表示该计划的历史记录。如果该表中此计划的历史记录行数超出此值，则删除该计划的较早的行（代表最早的历史记录）。设置该值可以防止表变得过大而填满 msdb 数据库（除非允许自动增长）。默认值为 100。

将历史记录写入服务器上的表

将历史记录报表以行的形式写入远程服务器上的 msdb.dbo.sysdbmaintplan_history 表。使用 Windows 身份验证连接到远程服务器。报表包含维护计划执行的步骤，包括数据库名称、活动、日期、结果（成功或失败）和任何错误信息。每个活动、每个数据库、每个执行日期在表中都占一行。

单击浏览（"..."）按钮从网络上的活动服务器列表中指定服务器。

查看历史记录

查看远程服务器的数据库维护计划历史记录。

将本计划表中的行数限制在

指定该表中只代表本计划历史记录的最大行数。如果该表中此计划的历史记录行数超出此值，则删除该计划的较早的行（代表最早的历史记录）。设置该值可以防止表变得过大而填满 msdb 数据库（除非允许自动增长）。默认值为 10.000。

请参见

数据库维护计划向导


数据库维护计划历史记录

使用此对话框查看已成功完成（或失敗）的数据库维护计划历史记录。默认情况下，所有计划的历史记录都会显示。若要查看计划的子集，请指定要查看的计划必须具备的条件。只有当计划匹配所有指定的条件时，才会显示其历史记录。

选项

计划名

指定要查看的数据库维护计划的名称。

服务器名称

指定包含要查看的数据库维护计划历史记录的服务器名称。

数据库

指定要查看其历史记录的数据库名称。

状态

指定要查看其历史记录的计划的状态："成功"或"失败"。如果选择"失败"，可在"消息中的关键字"对话框中输入关键字来进一步缩小所显示的计划历史记录范围。

活动

指定要查看其历史记录的计划的活动："优化"、"完整性检查"、"数据库备份"、"事务日志备份"。

消息中的关键字

指定要查看的历史记录的错误信息关键字，或查看成功备份作业的历史记录。

自动应用筛选

每次更改任一筛选设置时对整套数据库计划应用该组准则。清除该选项，直到对所有的筛选准则设置都满意为止。该选项是默认设置。

属性

显示选定数据库维护计划的属性对话框。

删除

删除选定的维护计划历史记录。

刷新

用最新的数据刷新此对话框。

请参见

数据库维护计划向导


发送消息

使用此对话框将消息发送给连接的用户或计算机。

选项

消息

输入要发送到已连接的计算机或用户的消息文本。

使用用户名

将消息发送到已连接的用户。该用户名为指定的。

使用主机名

将消息发送到已连接的计算机。在对话框中输入另外一个计算机名称，可以把消息发送到另一个计算机。

发送

在网络上传送消息。

请参见

SQL Server 和邮件集成

配置 SQL 邮件


进程详细信息

使用此对话框查看或指定下列选项。

选项

上批 T-SQL 命令

查看由选定进程执行的 Transact-SQL 语句文本的前 255 个字节。

发送消息

将消息发送到已连接的计算机或用户。例如，可以将消息发送给已连接的用户，通知他们服务器将因维护而关闭。然后，用户即可预知服务器的关闭而退出操作并从服务器注销。

取消进程

结束无 forewarnedexit 的进程。当无法以其它方式停止非系统进程时，可使用此功能。必须是 sysadmin 角色成员才可以终止进程。

刷新

在服务器上执行新查询并且重新绘制窗口，以得到对当前活动的精确描述。

请参见

用 SQL Server 企业管理器进行监视


触发器属性

使用此对话框查看或指定下列选项。

选项

名称

指定触发器的名称。

文本

指定定义触发器的 Transact-SQL 语法。

检查语法

检查用于创建触发器的 Transact-SQL 脚本语法。

删除

从数据库中删除触发器。

请参见

用触发器强制执行业务规则


表属性（常规选项卡）

使用此选项卡查看或指定下列选项。

选项

名称

指定表的名称。

权限

显示"对象属性"对话框，在其中可以指定用户表权限。

所有者

查看表所有者的名称。

创建日期

查看在数据库中创建表的日期。

文件组

查看存储表的文件组。

行

查看表中的行数。

键

查看构成主键的表列。

ID

查看具有相关标识的表列。

名称

查看表中每一列的名称。

数据类型

查看与每一表列相关的数据类型。

大小

查看表列的大小（以字节为单位）。

空

查看允许空值的表列。

默认值

查看具有相关默认值的表列。

请参见

表


对象属性（权限选项卡）

使用此选项卡查看或指定下列选项。

选项

对象

指定对象的名称。

列出全部用户/用户定义的数据库角色/public

列出选定数据库的所有用户和数据库角色。单击适当的框以修改对象权限。

仅列出对此对象具有权限的用户/用户定义的数据库角色/public

只列出已在该对象上具有权限的用户或数据库角色。单击适当的框以修改数据库用户权限。

用户/数据库角色/public

查看用户 ID 或数据库角色。

SELECT

授予、废除或拒绝对该对象的 SELECT 权限。

INSERT

授予、废除或拒绝对该对象的 INSERT 权限。

UPDATE

授予、废除或拒绝对该对象的 UPDATE 权限。

DELETE

授予、废除或拒绝对该对象的 DELETE 权限。

EXEC

授予、废除或拒绝对该对象的 EXECUTE 权限。

DRI

授权、废除或拒绝对该对象的声明引用完整性权限。

列

显示"列权限"对话框，在其中可以管理每列的权限。

请参见

管理权限


视图属性（常规选项卡）

使用此选项卡查看或指定下列选项。

选项

名称

查看 Microsoft® SQL Server™ 视图的名称。

权限

显示"对象属性"对话框，在其中可以指定用户视图权限。

所有者

查看视图所有者的名称。

创建日期

查看视图的创建日期。

文本

查看用于创建视图的 Transact-SQL 脚本。

检查语法

检查用于创建视图的 Transact-SQL 脚本语法。

请参见

视图


生成 SQL 脚本（常规选项卡）

使用此选项卡生成 Transact-SQL 语句以创建与数据库中的当前对象相同的对象。如果想使用与原始数据库中对象相同的架构在其它数据库中创建对象，则该选项很有用。

选项

全部显示

查看所有可用于脚本创建的对象。

预览

预览将用选定选项创建的 Transact-SQL 脚本。

编写全部对象脚本

在 Transact-SQL 脚本中包含全部数据库对象。

全部表
在 Transact-SQL 脚本中包含全部数据库表。
全部视图
在 Transact-SQL 脚本中包含全部数据库视图。
全部存储过程
在 Transact-SQL 脚本中包含全部数据库存储过程。
全部默认值
在 Transact-SQL 脚本中包含全部数据库默认值。
全部规则
在 Transact-SQL 脚本中包含全部数据库规则。
全部用户定义数据类型
在 Transact-SQL 脚本中包含全部数据库用户定义数据类型。
全部用户定义函数
在 Transact-SQL 脚本中包含全部数据库用户定义函数。

...上的对象

查看不包含在 Transact-SQL 脚本中的数据库中的对象列表。

将要写入脚本的对象

查看包含在 Transact-SQL 脚本中的数据库中的对象列表。

添加

将数据库对象添加到 Transact-SQL 脚本。

删除

从 Transact-SQL 脚本中删除数据库对象。

请参见

编写数据库文档和脚本


生成 SQL 脚本（设置格式选项卡）

使用此选项卡生成对正在创建的数据库对象进行格式化的 Transact-SQL 语句。若想除去某个数据库中的现有对象，然后使用另一个数据库中相似对象的架构重新创建它，该选项很有用。

选项

为每个对象生成 CREATE <对象> 命令

生成 Transact-SQL 语句创建在"常规"选项卡中选定的每个对象。

为每个对象生成 DROP <对象> 命令

生成 Transact-SQL 语句除去在"常规"选项卡中选定的每个对象。

生成全部相关对象的脚本

生成 Transact-SQL 语句为在"常规"选项卡中选定的每个对象添加相关对象。

在脚本文件中包含说明性的标题

在脚本中每一条 Transact-SQL 语句之前加入解释性标题文本。

包含扩展存储过程

在创建的 SQL 脚本中包含扩展存储过程。

仅为与 7.0 版兼容的功能编写脚本

生成和 Microsoft® SQL Server™ 7.0 版兼容的脚本。如果选择该选项，则将忽略下列 SQL Server 2000 选项：列级排序规则、用户定义函数、扩展属性、表和视图上的 INSTEAD OF 触发器、视图上的索引（索引视图）、计算列上的索引、视图上的引用权限以及降序索引。

脚本模板

查看用此选项卡中所选项生成的 Transact-SQL 脚本模板。

请参见

编写数据库文档和脚本


生成 SQL 脚本（选项选项卡）

使用此选项卡生成可进一步完善创建数据库对象的 Transact-SQL 语句。可以指定安全性、表创建和文件保存选项。

选项

脚本数据库

生成创建现有数据库架构脚本的 Transact-SQL 语句。

编写数据库用户和数据库角色脚本

生成创建可以访问数据库的全部用户和角色的 Transact-SQL 语句。

编写 SQL Server 登录（Windows NT 和 SQL Server 登录）脚本

生成 Transact-SQL 语句创建当前可以访问服务器的全部登录。

编写对象级权限的脚本

生成 Transact-SQL 语句创建"常规"选项卡上所选的每个对象当前存在的全部授权、废除和拒绝权限。

编写索引脚本

生成 Transact-SQL 语句来为任何选定的表创建当前存在的索引。该选项仅当"常规"选项卡上选定了一个或多个表时有用。

编写全文索引脚本

生成创建全文索引的 Transact-SQL 语句。该选项仅当"常规"选项卡上选定了一个或多个表时有用。

编写触发器脚本

生成 Transact-SQL 语句以创建为任何选定的表而存在的触发器。该选项仅当"常规"选项卡上选定了一个或多个表时有用。

编写主键、外键、默认值和检查约束脚本

生成 Transact-SQL 语句创建为任何选定表而存在的主键、外键、默认值和检查约束。该选项仅当"常规"选项卡上选定了一个或多个表时有用。

MS-DOS 文本 (OEM)

用当前 Microsoft® Windows® 系统代码页格式保存 Transact-SQL 脚本。如果想在批处理操作中使用该脚本，并且要使用控制台应用程序（如 Isql.exe）在命令行提示符下执行该操作，请选择此选项。

Windows 文本 (ANSI)

以 ANSI 格式保存 Transact-SQL 脚本。如果脚本将用于 SQL 查询分析器或其它的 Windows 应用程序，则选择该选项。

国际化文本 (Unicode)

以 Unicode 格式保存 Transact-SQL 脚本。如果脚本使用只由 Unicode 字体支持的特殊国际字符，则选择该选项。该格式需要的磁盘空间为当前 Windows 代码页或 ANSI 的两倍。

创建一个文件

保存一个文件，其中包含所选的每个对象的全部 Transact-SQL 语句。

每个对象创建一个文件

为选定的每个非重复对象保存一个文件。

请参见

编写数据库文档和脚本


相关性（常规选项卡）

使用此选项卡查看有关对象相关性关系的信息。

选项

对象

选择要查看其相关性的数据库对象。

依靠<对象>的对象

查看依靠选定对象的全部数据库对象。查看每个对象的所有者和序列。

<对象>依靠的对象

查看选定对象所依靠的全部数据库对象。查看每个对象的所有者和序列。

仅显示第一级相关性

只查看选定对象的第一级相关性。

请参见

sp_depends


备份设备属性（常规选项卡）

使用此选项卡查看和修改备份设备的名称和位置。

选项

名称

指定备份设备的名称。

查看内容

查看存储在设备上的每个备份的名称、服务器、数据库、备份类型、日期、到期日期、大小和描述。

磁带驱动器名

指定备份设备的磁带驱动器名称。

文件名

指定磁盘驱动器的名称和路径。单击浏览（"..."）搜索备份设备。

请参见

备份设备


字体（格式选项卡）

使用此选项卡查看或指定下列选项。

选项

文本

指定字母文本的格式。

文本选定内容

指定选定文本时的格式。

关键字

指定 Transact-SQL 关键字的格式。

存储过程

指定存储过程的格式。

系统表

指定系统表的格式。

全局变量

指定全局变量的格式。

注释

指定在 Transact-SQL 脚本中注释的格式。

数字

指定数字文本的格式。

字符串

指定单引号内包含的字母数字文本的格式。

运算符

指定用于执行列间或者变量间数学计算或比较所用符号的格式。运算符分为算术、位、比较或联接几类。

前景

为"颜色"框中选定的内容类型指定前景字符颜色。

背景

为"颜色"框中选定的内容类型指定背景颜色。

字体

为"颜色"框中选定的内容类型指定字体。

大小

为"颜色"框中选定的内容类型指定字号。

示例

以选定格式查看查询字符。

全部重置

将所有选项重置成各自的初始默认值。


除去对象

使用此对话框查看或指定下列选项。

选项

对象

指定要删除的对象。

所有者

指定要删除的对象所有者。

类型

指定要删除的对象类型。

全部除去

除去全部选定的对象。

显示相关性

查看要删除的选定对象的相关性。

请参见

如何删除用户定义的数据类型（企业管理器）


收缩数据库

使用此对话框查看或指定下列选项。

选项

所分配的空间

查看分配给选定数据库的空间（以兆字节 (MB) 为单位）。

可用空间

查看选定数据库的可用空间（以 MB 和占总空间的百分比为单位）。

收缩后文件中的最大可用空间

指定收缩数据库后数据库文件中的最大可用空间百分比。

在收缩前将页移到文件起始位置

指定在收缩数据库前将页移到文件的起始位置。选择该选项可能会影响性能。

根据调度收缩数据库

指定根据选定的调度收缩数据库，由下列选项决定。

更改
修改用于收缩数据库的调度。

文件

显示"收缩数据库文件"对话框，在其中可以指定要收缩的个别数据库文件。该选项在收缩数据库时提供更精确的控制。

请参见

收缩数据库


SQL Server 备份（常规选项卡）

使用此选项卡查看或指定下列选项。

选项

数据库

指定要备份的数据库。

名称

指定数据库备份的名称。

描述

描述数据库备份。

数据库 – 完整

执行完整数据库备份。

数据库 – 差异

执行差异数据库备份。差异备份仅记录自上次完整数据库备份后对数据库数据所做的更改。

事务日志

备份事务日志。

文件和文件组

指定要备份的文件名和文件组。单击浏览（"..."）按钮搜索文件或文件组。

磁带

将数据库备份到磁带设备。

磁盘

将数据库备份到磁盘设备。

添加

添加备份目的地。

删除

删除选定的备份目的地。

内容

查看选定的磁带或磁盘的内容。

追加到媒体

将备份追加到现有的媒体上。媒体上以前的内容保持不变，新的备份在媒体上上次备份的结尾处写入。

重写现有媒体

指定重写现有媒体。通过重写媒体上的备份，备份媒体的现有内容被新备份重写，因此不再可用。

调度

调度数据库备份。单击浏览（"..."）按钮查看当前的备份调度。

请参见

备份和还原数据库


SQL Server备份（选项选项卡）

使用此选项卡查看或指定下列选项。

选项

完成后验证备份

指定完成后验证备份的媒体完整性。

备份后弹出磁带

备份完成后弹出备份媒体磁带。

删除事务日志中不活动的条目

备份完成时从事务日志中删除所有已完成事务的条目。

检查媒体集名称和备份集到期时间

在重写媒体之前检查媒体集名称和备份集到期时间。

媒体集名称

指定在重写媒体之前媒体必须具有的媒体集名称。

备份集到期时间

设置备份集到期条件。Microsoft® SQL Server™ 仅利用媒体上第一次备份集的备份到期信息来决定是否重写整个媒体。

晚于

指定从备份完成之后到重写媒体之前的天数。

日期

指定可以重写媒体的日期。

初始化并标识媒体

将 Microsoft 磁带格式 (MSTF) 标题写入媒体的起始处。这将抹去所有内容和任何以前的媒体标题信息。初始化媒体时，不检验备份集到期时间和媒体集名称。

媒体集名称

将媒体名作为 MTF 标题的一部分写入媒体。

媒体集描述

将媒体描述作为 MTF 标题的一部分写入媒体。该描述一般应为媒体的用途和存储位置。

请参见

备份和还原数据库


还原数据库（常规选项卡）

使用此选项卡查看或指定下列选项。

选项

还原为数据库

指定要还原的数据库。

数据库

还原选定的数据库。

文件组或文件

还原文件组或文件。

从设备

从设备还原。

显示数据库备份

显示选定数据库的备份。

要还原的第一个备份

指定第一个要还原的备份。只在还原数据库时才显示该选项。

时点还原

从选定的即时点还原备份。只在还原数据库时才显示该选项。单击浏览（"..."）按钮搜索备份。

还原

还原选定的备份。

类型

查看备份类型。

备份集日期

查看备份集的日期。

大小

查看备份集的大小。

还原自

查看备份集的文件位置。

备份集名称

查看备份集的名称。

属性

查看备份集的属性。

请参见

备份和还原数据库


还原数据库（选项选项卡）

使用此选项卡查看或指定下列选项。

选项

在还原每个备份后均弹出磁带（如果有）

在还原每个备份后均弹出磁带。

在还原每个备份前提示

还原每个备份前提示用户以防用户无意中还原备份。

在现有数据库上强制还原

在现有数据库上强制还原。

将数据库文件还原为

指定将要还原的数据库文件的名称和位置。

使数据库可以继续运行，但无法还原其它事务日志

使数据库可以继续运行，这意味着无法还原其它事务日志。

使数据库不再运行，但能还原其它事务日志

使数据库可以继续运行，但允许还原其它事务日志。

使数据库为只读，但能还原其它事务日志。

使数据库为只读，并且允许还原事务日志。

撤消文件

指定要撤消的文件的名称。单击浏览（"..."）按钮搜索要撤消的文件。

请参见

备份和还原数据库


提供程序选项

使用此对话框查看或指定下列选项。

选项

提供程序选项

显示"链接服务器属性"对话框，在其中可以查看在"提供程序名称"框中选定的提供程序的选项。

使用此提供程序的链接服务器

显示"链接服务器属性"对话框，在其中可以查看使用在"提供程序名称"框中选定的提供程序的所有链接服务器。

请参见

配置链接服务器


服务器角色属性（权限选项卡）

使用此选项卡查看或指定下列选项。

选项

此服务器角色可执行下列命令

查看选定的服务器角色可以执行的命令。

请参见

管理权限


服务器角色属性（常规选项卡）

使用此选项卡查看或指定下列选项。

选项

名称

查看服务器角色的名称。

指定哪些登录属于此安全性角色的成员

查看选定的服务器角色成员登录的列表。

添加

将登录添加到选定的服务器角色。

删除

从选定的服务器角色中删除登录。

请参见

角色


外部工具

使用此对话框获得对诸如 Windows 系统监视器等工具的便捷访问。

选项

添加

显示"添加外部工具"对话框，在此对话框中可以将外部工具添加到当前工具列表。

更改

提交对当前选定工具的"菜单文本"、"命令"和"参数"所做的更改。

删除

删除选定的当前工具。

菜单文本

指定描述工具的文本，这些工具出现在当前工具列表和"工具"菜单中。

命令

指定外部工具的完全合法路径，包括工具的可执行文件名。

参数

指定希望外部工具启动时使用的参数。可以添加占位符 [SRV] 和 [DBN] 以替代基于左边或右边的窗格中当前服务器和数据库的上下文。

请参见

如何将外部工具添加到工具菜单（企业管理器）


添加外部工具

使用此对话框查看或指定下列选项。

选项

命令

指定外部工具的完全合法路径，包括工具的可执行文件名。

浏览

搜索要添加的外部工具。

参数

指定希望外部工具启动时使用的参数。可以添加占位符 [SRV] 和 [DBN] 以替代基于左边或右边的窗格中当前服务器和数据库的上下文。

请参见

如何将外部工具添加到工具菜单（企业管理器）


SQL Server 属性（复制选项卡）

使用此选项卡查看或指定下列选项。

选项

配置

指定要在此服务器上配置发布和分发。选择该选项将启动配置发布和分发向导或显示发布服务器和分发服务器属性。

禁用

指定要在此服务器上禁用发布和分发。选择该选项将启动禁用发布和分发向导。

复制监视器组

如果服务器被配置为分发服务器，则将服务器添加到复制监视器组。

请参见

执行复制（企业管理器）


属性（数据文件选项卡）

使用此选项卡查看或指定下列选项。

选项

数据库文件

指定选定数据文件的文件名、位置、分配的空间和文件组。

删除

删除选定的数据文件。

文件自动增长

指定数据文件自动按下列选项所指定的大小增长。

按兆字节
指定数据文件增长所基于的兆字节数。
按百分比
指定希望数据文件自动增长所基于的百分比。
文件增长不受限制
指定数据文件增长不受限制。
将文件增长限制为 (MB)
指定受限制的数据文件可以增长到的大小 (MB)。

请参见

文件和文件组


属性（文件组选项卡）

使用此选项卡查看或指定下列选项。

选项

文件组

查看或指定文件组的名称、文件数和文件组的状态。

删除

删除选定的文件组。只有当已删除文件组中包含的所有文件后才能删除文件组。

请参见

文件和文件组


用户定义函数属性（常规选项卡）

使用此对话框查看或指定下列选项。

选项

名称

查看用户定义函数的名称。

权限

显示"对象属性"对话框，在其中可以指定用户定义函数的权限。

所有者

查看用户定义函数的所有者。

创建日期

查看用户定义函数的创建日期。

文本

查看用户定义函数的语法。

检查语法

检查用于创建用户定义函数的 Transact-SQL 脚本语法。

另存为模板

将用户定义函数文本保存为模板。

请参见

用户定义函数


链接服务器属性（服务器选项选项卡）

使用此选项卡查看或指定下列选项。

选项

选项名

查看每个链接服务器的选项。

值

指定与每个链接服务器相关的选项值。例如，查看连接超时值或链接服务器是否与排序规则兼容。

请参见

配置链接服务器


编辑 SQL Server 消息

使用此对话框查看或指定下列选项。

选项

错误号

指定错误信息号。

严重度

指定错误信息的严重度。

消息文本

指定错误信息的消息文本。

语言

指定错误信息文本所使用的语言。

始终写入 Windows NT 事件日志

指定始终将错误信息写入 Microsoft® Windows® 事件日志。

请参见

管理 SQL Server 消息


收缩数据库文件

使用此对话框查看或指定下列选项。

选项

数据库文件

指定要收缩的数据库文件。

文件组名称

查看选定数据库文件的文件组名称。

文件 ID

查看选定数据库文件的文件 ID。

文件类型

查看选定数据库文件的文件类型（例如，数据文件或日志文件）。

位置

查看选定数据库文件的位置。

当前大小

查看选定数据库文件的当前大小（以兆字节为单位）。

已用空间

查看选定数据库文件的已用空间（以兆字节为单位）。

压缩页，然后截断文件中的可用空间

压缩数据库页，然后截断由压缩页所产生的可用空间。

从文件结尾截断可用空间

从文件结尾处截断可用空间。

清空文件（数据将迁移到文件组中的其它文件）

清空选定的数据库文件。当前文件中的数据将移动到文件组中的其它文件中。

收缩文件至

收缩文件至指定的大小（以兆字节为单位）。

在此时间收缩文件

在指定的日期和时间收缩文件。

日期

指定收缩数据库文件的日期。

时间

指定收缩数据库文件的时间。

请参见

收缩数据库


分离数据库

使用此对话框查看或指定下列选项。

选项

清除

清除与选定数据库的任何连接。

使用本数据库的连接

查看与选定数据库的连接数。用户正在连接时不能分离数据库。

要复制的数据库

查看是否正在复制数据库。正在复制数据库时不能分离数据库。

状态

查看数据库的状态。这将基于前几个选项中的准则，告诉您数据库是否已准备好分离。

在分离前更新统计信息

在分离数据库前更新数据库统计信息。

请参见

如何附加和分离数据库（企业管理器）


添加/编辑目的数据库（常规选项卡）

使用此选项卡查看或指定下列选项。

选项

服务器名称

指定要添加到日志传送定义中的辅助数据库。包含该数据库的服务器必须注册且运行出现在列表中的 Microsoft® SQL Server™ 2000 企业版。如果正在编辑目的数据库，则"服务器名称"是只读的。

目录

指定日志将要备份到的事务日志目的目录。单击浏览（"..."）按钮搜索现有的目录。

请参见

日志传送


添加目的数据库（初始化选项卡）

使用此选项卡查看或指定下列选项。

选项

无恢复模式

指定使辅助数据库不可用。作为 RESTORE LOG 操作或 RESTORE WITH NORECOVERY 操作的结果，辅助数据库被置于 NORECOVERY 模式。

备用模式

指定使辅助数据库可用，但为只读模式。作为 RESTORE LOG 操作或 RESTORE DATABASE WITH STANDBY 操作的结果，辅助数据库被置于 STANDBY 模式。

终止数据库中的用户（推荐）

从数据库断开所有用户。如果有任何用户连接到为日志传送配置的辅助数据库，则日志传送将无效。

立即提取完全数据库备份

立即提取完整数据库备份，而不使用现有的备份文件。

使用最新备份文件

指定用于初始化目的数据库的最新备份文件。单击浏览（"..."）按钮搜索最新的备份文件。

复制频率

设置希望目的服务器从源服务器备份事务日志的频率（以分钟为单位）。

装载频率

设置希望目的服务器从源服务器还原事务日志的频率（以分钟为单位）。

请参见

日志传送


添加目的数据库（阈值选项卡）

使用此选项卡查看或指定下列选项。

选项

不同步阈值

指定源服务器上的上次事务日志备份与目的服务器上的上次事务日志还原之间的最长时间间隔。

装载时间延迟

设置希望目的服务器从源服务器还原事务日志之前延迟的时间。该选项的默认值为 0 分钟，表示目的服务器应立即还原所有事务日志备份。更改时间延迟可在源服务器出错时提供缓冲时间，从而使您得以在损坏的日志还原到目的服务器上之前纠正问题。

文件保持期

指定在删除事务日志之前等待的时间。

历史记录保持期

指定在删除事务日志历史记录之前等待的时间。

请参见

日志传送


编辑目的数据库（阈值选项卡）

使用此选项卡查看或指定下列选项。

选项

不同步阈值

指定源服务器上的上次事务日志备份与目的服务器上的上次事务日志还原之间的最长时间间隔。

装载时间延迟

设置希望目的服务器从源服务器还原事务日志之前延迟的时间。该选项的默认值为 0 分钟，表示目的服务器应立即还原所有事务日志备份。更改时间延迟可在源服务器出错时提供缓冲时间，从而使您得以在损坏的日志还原到目的服务器上之前纠正问题。

文件保持期

指定在删除事务日志之前等待的时间。

历史记录保持期

指定在从 log_shipping_plan_history 表中删除事务日志历史记录之前等待的时间。

请参见

日志传送


数据库维护计划（日志传送选项卡）

使用此选项卡查看或指定下列选项。

选项

监视服务器

查看指定数据库维护计划的监视服务器。

目的服务器信息

查看指定数据库维护计划的目的服务器信息，包括所有目的服务器的名称、目的数据库和同步阈值。

添加

显示"添加目的数据库"对话框，在其中可以添加新的目的数据库。

删除

删除目的数据库。这将停止向选定的目的数据库进行日志传送。

编辑

显示"编辑目的"对话框，在其中可以编辑现有的目的数据库。

删除日志传送

删除和选定的维护计划关联的数据库的日志传送。

日志传送


将规则/默认值绑定到用户定义数据类型

使用此对话框查看或指定下列选项。

选项

规则

查看希望绑定到用户定义的数据类型的规则名。当绑定到列或用户定义数据类型时，规则将指定可以插入到列中的可接受的值。规则是一种向后兼容的功能，执行一些与检查约束相同的功能。CHECK 约束是使用 ALTER 或 CREATE TABLE 的 CHECK 关键字创建的，是对列中的值进行限制的首选标准方法（可以对一列或多列定义多个约束）。列或用户定义数据类型只能有一个绑定的规则。但是，列可以同时具有规则和一个或多个与其关联的检查约束。在这种情况下，将检查所有限制。有关规则的更多信息，请参见 CREATE RULE。

名称

查看用户定义的数据类型的名称和数据类型。通过选中"绑定"框选择要绑定的每个规则。选择"仅将来"框会防止现有用户定义数据类型列继承新规则。如果选定"仅将来"框，新规则将绑定到当前没有规则或使用现有用户定义数据类型规则的任何用户定义数据类型列。有关绑定规则的更多信息，请参见 sp_bindrule。

请参见

创建用户定义的数据类型


将规则/默认值绑定到列

使用此对话框查看或指定下列选项。

选项

规则

查看希望绑定到列的规则名。当绑定到列或用户定义数据类型时，规则将指定可以插入到列中的可接受的值。

作为一种向后兼容的功能，规则执行一些与检查约束相同的功能。使用 ALTER 或 CREATE TABLE 的 CHECK 关键字创建的 CHECK 约束是推荐使用的限制列中值的标准方法。规则和检查约束之间的一个主要差别是：虽然可以在一列或多列上定义多个约束，但是只有一规则可以绑定到列或用户定义的数据类型上。不过，列可以同时具有规则和一个或多个关联的检查约束。在这种情况下，将检查所有限制。有关规则的更多信息，请参见 CREATE RULE。

表

选择希望规则绑定到的列所在的表。

未绑定的列

查看选定表中未绑定的列的名称和数据类型。

绑定列

查看选定表中绑定列的名称和数据类型。

添加

将规则绑定到列。在单击"添加"之前，必须先从"未绑定的列"列表中选择未绑定的列。

删除

从列解除规则绑定。在单击"删除"之前，必须先从"绑定列"列表中选择绑定的列。

请参见

创建用户定义的数据类型


辅助服务器日志传送历史记录

使用此对话框查看或指定下列选项。

选项

显示历史记录

指定希望查看其日志传送历史记录的数据库。可以为选定的辅助服务器选择个别的数据库或所有的数据库。历史记录显示每个活动的状态，如复制、装载和完成时间。

消息

查看关于指定辅助服务器的日志传送的所有消息。

请参见

日志传送


日志传送对属性（状态选项卡）

使用此选项卡查看或指定下列选项。

选项

状态

查看日志传送服务器的状态。例如，辅助服务器可能不同步或处于正常状态。

当前日期时间/在监视服务器上

查看监视服务器上的当前日期和时间。

上次备份的文件

查看上次的源服务器备份。

更新的

查看上次更新备份文件的日期和时间。

备份增量

查看数据库备份之间的时间。

上次复制的文件

查看上次从源服务器复制的文件。

更新的

查看上次从源服务器复制文件的日期和时间。

复制增量

查看文件复本之间的时间。

上次装载的文件

查看上次还原到目的服务器上的文件。

更新的

查看上次还原到目的服务器上的备份文件的日期和时间。

装载增量

查看数据库还原之间的时间。

请参见

日志传送


日志传送对属性（源选项卡）

使用此选项卡查看或指定下列选项。

选项

源

查看日志传送对的源服务器。

警报阈值

指定生成警报的阈值。在该选项中指定的值设置自从上次在源服务器上进行事务日志备份后经过的最长时间。一旦时间超过此指定阈值，监视服务器将生成警报。

警报号

指定超过阈值时生成的警报号。

启用

启用警报。

开始时间

指定开始时间，从这个时间开始即使超过警报阈值也不生成警报。

结束时间

指定结束时间，在这个时间之前即使超过警报阈值也不生成警报。

有效天数

指定开始和结束时间之间的天数，在这段时间内即使超过警报阈值也不生成警报。

查看备份调度

显示"调度"对话框，在其中可以查看备份的频率。

请参见

日志传送


日志传送对属性（目的选项卡）

使用此选项卡查看或指定下列选项。

选项

源

查看日志传送对的目的服务器。

警报阈值

指定警报生成前的阈值。在该选项中指定的值是距离源服务器上次事务日志备份时间的最长期限。一旦时间超过此指定阈值，监视服务器将生成警报。

警报号

指定超过阈值时生成的警报号。

启用

启用警报。

开始时间

指定开始时间，从这个时间开始即使超过警报阈值也不生成警报。

结束时间

指定结束时间，在这个时间之前即使超过警报阈值也不生成警报。

有效天数

指定开始和结束时间之间的天数，在这段时间内即使超过警报阈值也不生成警报。

查看复制调度

显示"调度"对话框，在其中可以查看复制数据库的频率。

已启用复制

启用数据库复制。

查看装载调度

显示"调度"对话框，在其中可以查看还原数据库的频率。

已启用装载

启用还原数据库。

请参见

日志传送


调度

使用此对话框查看下列选项。

选项

调度

查看选定日志传送事件的调度，包括数据库备份、复本或还原。显示选定事件的频率。

请参见

日志传送


SQL Server 登录属性 - 新登录

使用此对话框查看或指定下列选项。

选项

名称

指定新登录的名称。

Windows 身份验证

连接到 Microsoft® SQL Server™ 实例时使用 Windows 身份验证。为了安全，建议使用该选项，因为通过 Microsoft Windows NT® 4.0 或 Windows® 2000 用户帐户连接的用户可以使用信任连接。信任连接由 Windows NT 4.0 或 Windows 2000 验证的连接。

域
指定用于验证登录的网络安全特性的域。SQL Server 通过使用网络用户的安全特性控制登录访问，以实现与 Windows NT 4.0 的登录安全集成。用户的网络安全特性在网络登录时建立，并通过 Windows 域控制器进行验证。
允许访问
授予对登录的访问。
拒绝访问
拒绝对登录的访问。

SQL Server 身份验证

使用 SQL Server 身份验证进行连接。当用户用指定的登录名称和密码从非信任连接进行连接时，SQL Server 通过检查是否已设置 SQL Server 登录帐户，以及指定的密码是否与以前记录的密码匹配，自己进行身份验证。如果 SQL Server 未设置登录帐户，身份验证就失败，用户收到错误信息。有关 SQL Server 身份验证的更多信息，请参见身份验证模式。

密码
指定当使用 SQL Server 身份验证连接服务器时使用的密码。

数据库

指定选定登录的默认数据库。

语言

指定选定登录的默认语言。

请参见

添加 SQL Server 登录


数据库角色属性（权限选项卡）

使用此选项卡查看或指定下列选项。

选项

数据库角色

选择要查看或修改其权限的数据库角色。

列出全部对象

列出数据库中的所有对象。单击适当的框以修改角色权限。

仅列出具有此用户权限的对象

仅为具有数据库权限的对象指定权限。单击适当的框以修改角色权限。这在有很多对象且只需要查看或修改具有选定角色权限的对象时很有用。

对象

指定选定对象的权限。可以授予或删除执行 SELECT、INSERT、UPDATE、DELETE、EXEC 语句的权限。还可以授予或删除执行声明引用完整性 (DRI) 约束的权限。有关声明引用完整性约束的更多信息，请参见数据库各组成部分。

列

显示"列权限"对话框，此对话框允许逐列管理对象的权限。

请参见

创建用户定义的 SQL Server 数据库角色


附加数据库

使用此对话框查看或指定下列选项。

选项

要附加数据库的 MDF 文件

指定要附加的数据库的 MDF（master 数据文件）名称。最多可以指定 16 个文件名。如果指定 16 个以上的文件，则 Microsoft® SQL Server™ 不能附加数据库。有关附加数据库的更多信息，请参见 sp_attach_db。

单击浏览（"..."）按钮搜索要附加数据库的 MDF。

验证

验证指定的 MDF 是否正确。

原文件名

查看要附加的数据库中的所有文件。这包括数据文件和日志文件。

当前文件位置

查看或编辑所有当前的文件名和路径。MDF 文件的当前位置必须在列中才能使附加起作用，如果 SQL Server 在指定的位置找不到 MDF 文件，附加将失败。例如，如果在附加文件前已更改了文件的默认位置，则必须指定当前位置才能使附加成功。

附加为

指定正在附加的数据库的名称。数据库名称不能和任何现有的数据库名匹配。

指定数据库所有者

指定数据库所有者。

请参见

如何附加和分离数据库（企业管理器）


启动作业

使用此对话框查看或指定下列选项。

选项

作业名

查看要启动的作业名。

开始执行的步骤

选择开始执行作业的步骤。还可以查看步骤 ID、步骤名称和步骤类型。

请参见

运行作业


数据库维护计划（服务器选项卡）

使用此选项卡查看或指定下列选项。

选项

服务器

选择将要执行数据库维护计划的服务器。

请参见

数据库维护计划向导


日志传送详细信息

使用此对话框查看或指定下列选项。此对话框仅当有一个辅助数据库处于备用模式时才可用。

选项

SQL Server

查看监视服务器名称。

使用 Windows 身份验证

连接到 Microsoft® SQL Server™ 实例时使用 Windows 身份验证。为了安全，建议使用该选项，因为通过 Microsoft Windows NT® 4.0 或 Windows® 2000 用户帐户连接的用户可以使用信任连接。信任连接由 Windows NT 4.0 或 Windows 2000 验证的连接。

使用 SQL Server 身份验证

使用 SQL Server 身份验证连接监视服务器。当用户用指定的登录名称和密码从非信任连接进行连接时，SQL Server 通过检查是否已设置 SQL Server 登录帐户，以及指定的密码是否与以前记录的密码匹配，自己进行身份验证。如果 SQL Server 未设置登录帐户，身份验证就失败，用户收到错误信息。有关 SQL Server 身份验证的更多信息，请参见身份验证模式。

登录名

如果服务器使用 SQL Server 身份验证连接，则查看监视服务器的登录名。

密码

如果服务器使用 SQL Server 身份验证连接，则查看或指定监视服务器的密码。

日志传送角色

查看有关监视服务器角色的信息。

请参见

日志传送


配置 SQL Server 错误日志

使用此对话框查看或指定下列选项。

选项

错误日志文件更新前允许的最大错误日志文件数。

若选中此选项，将限制在错误日志更新前可以创建的错误日志数。每次启动 Microsoft® SQL Server™ 实例时都创建新的错误日志。通常情况下，SQL Server 保留最后六个日志的备份，除非选中该选项并在下面指定不同的最大错误日志文件数。

最大错误日志文件数。

指定错误日志文件更新前允许的最大错误日志文件数。默认值是六个，这是 SQL Server 在更新备份日志前保留的最后的备份日志数。

请参见

使用 SQL Server 代理程序错误日志


SQL Server 属性（Active Directory 选项卡）

使用此选项卡查看或指定下列选项。

选项

添加

将选定的服务器添加到 Active Directory。Active Directory 是 Microsoft Windows® 2000 操作系统的中心组件，它提供存储有关基于网络的实体（如应用程序、文件、打印机和人员等）信息的空间。将服务器添加到 Active Directory 要求在服务器上有本地管理员特权。

刷新

刷新 Active Directory 中选定服务器的特性。

删除

从 Active Directory 中删除选定的服务器。删除此服务器还将从 Active Directory 中删除该服务器的数据库和发布。


警报属性（常规选项卡）

使用此选项卡查看或指定下列选项。

选项

名称

查看或指定警报名称。该名称的长度不能超过 128 个字符。

ID

查看 Microsoft® SQL Server™ 为警报生成的 ID。创建新警报时会出现"新建"。

类型

指定警报定义的类型。

启用

启用警报。默认情况下启用警报。

错误号

指定触发警报的错误号。单击浏览（"..."）按钮显示"管理服务器消息"对话框，在该对话框中可按错误号查看警报。仅当选择 SQL Server 事件警报时这些选项才可用。

严重度

指定触发警报的严重度。仅当选择 SQL Server 事件警报时可用。

数据库名称

指定在其中发生错误必定触发警报的数据库。仅当选择 SQL Server 事件警报时可用。

错误信息包含此文本

仅将警报限制为那些包含在错误信息中指定文本的事件。仅当选择 SQL Server 事件警报时可用。

上一次发生的日期

查看上一次发生警报的日期和时间。

上一次响应的日期

查看警报上一次发生响应的日期和时间。

发生计数

查看上次重置计数后发生警报的次数。

重置计数

重置警报计数。

请参见

定义警报


警报属性（响应选项卡）

使用此选项卡查看或指定下列选项。

选项

执行作业

指定发生警报时要执行的作业。单击编辑（"..."）按钮更改选定作业的属性。

新建操作员

打开"新建操作员属性"对话框，在该对话框中可添加响应警报的操作员。

操作员名称

查看响应警报的操作员列表。

电子邮件

通过电子邮件通知操作员有关此警报的信息。复选框右边的图标表示那个操作员有一个定义的电子邮件地址。

呼叫程序

通过呼叫程序通知操作员有关该警报的信息。复选框右边的图标表示那个操作员有一个定义的呼叫地址。

网络发送

通过"网络发送"通知操作员有关该警报的信息。复选框右边的图标表示那个操作员有一个定义的网络发送地址。

在电子邮件中包含警报错误文本

在电子邮件通知中包括错误信息文本。

在呼叫提示中包含警报错误文本

在呼叫提示通知中包括错误信息文本。

在网络发送中包含警报错误文本

在"网络发送"通知中包括错误信息文本。

要发送的其它通知消息

指定要发送给操作员的其它通知消息。

两次响应之间的延迟

指定反复出现的警报之间的延迟（以分和秒为单位）。

请参见

定义警报


操作员属性（常规选项卡）

使用此选项卡查看或指定下列选项。

选项

名称

指定操作员名称。该名称的长度不能超过 128 个字符。

ID

显示 Microsoft® SQL Server&trade 为操作员生成的 ID。创建新的操作员时出现"新建"。

电子邮件名称

指定操作员的电子邮件地址。如果显示名称或别名不明确，则指定一个完全合法的电子邮件名称，并用方括号括上。例如，可以使用 [SMTP:myfriend@mycompany.com]。单击浏览（"..."）按钮搜索 SQL Server 通讯簿。

呼叫程序电子邮件名称

指定操作员的呼叫程序地址。如果显示名称或别名不明确，则指定一个完全合法的电子邮件名称，并用方括号括上。例如，可以使用 [SMTP:myfriend@mycompany.com]。单击浏览（"..."）按钮搜索 SQL Server 通讯簿。

测试

发送测试电子邮件、呼叫程序或"网络发送"通知。

网络发送地址

指定操作员的"网络发送"地址。

值班呼叫调度

指定操作员可以接收呼叫提示通知的日期。

工作日开始

指定一个时间，在此时间之后操作员可以接收呼叫提示通知。

工作日结束

指定一个时间，在此时间之后操作员将不能接收呼叫提示通知。

请参见

定义操作员


操作员属性（通知选项卡）

使用此选项卡查看或指定下列选项。

选项

通知送达该操作员的方式：

指定通过警报或作业查看发送到此操作员的通知。

警报名称

查看警报名称，可以创建一个负责该警报的操作员。

电子邮件

指定操作员通过电子邮件接收通知。

呼叫程序

指定操作员通过呼叫程序接收通知。

网络发送

指定操作员通过"网络发送"接收通知。

操作员可以接收通知

指定操作员可以接收通知。

发送电子邮件

生成电子邮件，其中详细描述操作员的警报职责。

通过电子邮件

查看最近发送给操作员的电子邮件通知的日期和时间。

通过呼叫程序

查看最近发送给操作员的呼叫提示通知的日期和时间。

通过网络发送

查看最近发送给操作员的"网络发送"通知的日期和时间。

请参见

定义操作员


作业属性（常规选项卡）

使用此选项卡查看或指定下列选项。

选项

名称

指定作业名称。该名称限制为 128 个字符。仅当作业产生自同一个服务器时，作业的名称才必须是唯一的。在目标服务器上本地创建的作业和从主服务器下载的作业可以共享同一个名称。

源

查看最初发起作业的服务器。默认为本地，表示作业是在为本地服务器的 Microsoft® SQL Server™ 实例上创建的。

创建于

查看作业的创建日期和时间。如果正在创建一个新作业，则出现"尚未创建"。

启用

启用作业。对于新作业和现有作业，默认情况下选定该选项。被禁用的作业仅当用户显式启动它后才运行。

以本地服务器为目标

将作业定义为本地作业，也就是仅在本地服务器上运行的作业。

以多个服务器为目标

将作业定义为多服务器作业，也就是在多个远程服务器上运行的作业。仅在主服务器上启用该选项。

分类

选择作业分类。使用作业分类组织作业，以便易于筛选和分组。默认情况下，本地作业被分配到［未分类（本地）］作业分类中。单击列表（"..."）按钮查看选定的作业所属的同一分类中的其它作业。

所有者

选择作业所有者。当用户是系统管理员时启用该选项。系统管理员可将作业重新分配给另一所有者。默认情况下，所有者列表包含作业创建者的 SQL Server 登录 ID。

描述

最多使用 512 个字符描述作业。描述可以帮助本地和远程计算机上的其他用户了解作业的用途。

上次修改日期

显示上次修改作业的日期。如果正在创建一个新作业，则出现"暂缺"。

更改

显示"更改作业目标服务器"对话框，在该对话框中可以更改作业的目标服务器。仅适用于多服务器作业。

请参见

创建作业


作业属性（步骤选项卡）

使用此选项卡查看或指定下列选项。

选项

ID

查看步骤标识号。

步骤名称

查看步骤名称。

类型

查看步骤类型。

成功后

如果步骤成功则显示控制流操作。

失败后

如果步骤失败则显示控制流操作。

移动步骤

修改执行步骤的顺序。

开始步骤

选择开始执行作业的步骤。

新建

显示"新建作业步骤"对话框，在该对话框中可以配置要在现有步骤列表的最后插入的新步骤。

插入

显示"新建作业步骤"对话框，在该对话框中可以配置要在当前选定步骤之上插入的新步骤。

编辑

显示"编辑作业步骤"对话框，在该对话框中可以更改当前选定步骤的配置。

删除

删除当前选定的步骤。

请参见

创建作业

创建作业步骤

处理多个作业步骤


作业属性（调度选项卡）

使用此选项卡查看或指定下列选项。

选项

注意

查看目标服务器上的当前日期和时间。

ID

查看警报或调度标识号。

名称

查看调度或警报的名称。

启用

查看所选调度或警报的启用状态。

描述

查看调度或警报的描述。

新建调度

显示"新建作业调度"对话框，在该对话框中可以配置新的作业调度。

新建警报

显示"新建警报属性"对话框，在该对话框中可以配置新警报。

编辑

显示"编辑作业调度"对话框，在该对话框中可以更改当前选定的调度或警报的配置。

删除

删除当前所选的调度或警报。

请参见

创建作业

调度作业


作业属性（通知选项卡）

使用此选项卡查看或指定下列选项。

选项

电子邮件操作员

指定当 Microsoft® SQL Server™ 事件完成时通过电子邮件通知操作员。选择要通过电子邮件通知的操作员名称，或者单击浏览（"..."）按钮以添加新的操作员或编辑现有操作员的属性。还应选择通知操作员的完成状态。

呼叫操作员

指定当 SQL Server 事件完成时通过呼叫程序通知操作员。选择要通过呼叫程序通知的操作员名称，或者单击浏览（"..."）按钮以添加新的操作员或编辑现有操作员的属性。还应选择通知操作员的完成状态。

网络发送操作员

指定当 SQL Server 事件完成时通过"网络发送"通知操作员。选择要通过"网络发送"通知的操作员名称，或者单击浏览（"...")按钮以添加新的操作员或编辑现有操作员的属性。还应选择通知操作员的完成状态。

写入 Windows 应用程序事件日志

当作业完成时，将作业完成事件写入 Microsoft Windows® 应用程序日志。还应选择写入事件日志的完成状态。

自动删除作业

当作业完成、成功或失败时，自动删除该作业。这取决于选择的完成状态。

请参见

创建作业

指定作业响应


作业分类属性（常规选项卡）

使用此选项卡查看或指定下列选项。

选项

名称

查看要查看的作业分类名称。如果正在创建一个新的作业分类，请指定一个名称。

此分类中的作业

查看属于该作业分类的所有定义的作业。

请参见

创建作业


作业调度属性

使用此对话框查看或指定下列选项。

选项

名称

指定调度的名称。该名称的长度不能超过 128 个字符。作业中的每个调度名称都必须是唯一的。

启用

启用新作业调度。

启动 SQL Server 代理时自动启动

SQL Server 代理启动时自动启动作业。

每当 CPU 闲置时就启动

只要 CPU 闲置就启动作业。在"SQL Server 代理属性"对话框的"高级"选项卡上指定 CPU 闲置时间。

一次

在指定的日期和时间启动作业一次。

日期
指定希望启动作业的日期。
时间
指定希望启动作业的时间。

反复出现

按照所显示的反复出现的调度启动作业。

更改

显示"编辑反复出现的作业调度"对话框，在该对话框中可以更改当前反复出现的作业调度。

请参见

调度作业


编辑反复出现作业调度

使用此对话框查看或指定下列选项。

选项

作业名

查看要为其设置反复出现调度的作业名称。

每天

设置作业每天发生。

每周

设置作业每周发生。

每月

设置作业每月发生。

每周

以周为增量指定作业频率。

星期一

设置作业在星期一发生。

星期二

设置作业在星期二发生。

星期三

设置作业在星期三发生。

星期四

设置作业在星期四发生。

星期五

设置作业在星期五发生。

星期六

设置作业在星期六发生。

星期日

设置作业在星期日发生。

一次发生于

设置作业每天发生一次的时间。

发生周期

设置作业两次发生之间的时间间隔（小时数或分钟数）。

起始于
设置每天作业频率的开始时间。
终止于
设置每天作业频率结束的时间。

开始日期

设置该调度开始生效的日期。

结束日期

设置该调度失效的日期。

无结束日期

指定调度无限期有效。

请参见

调度作业


作业步骤（常规选项卡）

使用此选项卡查看或指定下列选项。

选项

步骤名称

指定要添加的作业步骤名称。该名称限制为 128 个字符。作业中的每个步骤名称必须唯一。

类型

指定作业步骤类型。

数据库

指定当使用 Transact-SQL 或复制队列读取器作业步骤时所使用的数据库。

成功命令的进程退出代码

执行命令行解释器进程的作业步骤依赖进程退出代码来确定该作业步骤的成功或失败。将该选项设置为命令行解释器进程的成功返回代码，以根据该作业步骤的成功或失败来启用逻辑和通知。仅当使用操作系统命令 (CmdExec) 作业步骤时才可使用该选项。

命令

指定适用于选定类型的过程或命令。

打开

打开 Transact-SQL 或 Microsoft® ActiveX® 脚本文件。仅当在"类型"列表中单击"Transact-SQL"时才可使用该选项。

分析

检查 Transact-SQL 或 ActiveX 脚本命令的语法。仅当在"类型"列表中单击"Transact-SQL"时才可使用该选项。

下一页

移动到下一个作业步骤。

上一页

移动到上一个作业步骤。

请参见

创建作业步骤

处理多个作业步骤


作业步骤（高级选项卡）

使用此选项卡查看或指定下列选项。

选项

成功时的操作

指定步骤成功时要执行的操作。

重试次数

指定步骤失败后重试尝试的次数。

重试间隔（分钟）

指定重试步骤之前等待的时间间隔（以分钟计）。

失败时的操作

指定步骤失败时（执行所有重试后）要执行的操作。

输出文件

指定存储 Transact-SQL 或 CmdExec 作业步骤结果的文件。单击浏览（"..."）按钮以搜索存储输出文件的目录。

视图

显示选定的输出文件。

重写

用新结果重写现有文件。

追加

将结果添加到现有文件的末尾。

将输出追加到步骤的历史记录

将 Transact-SQL 作业步骤的结果添加到该步骤的历史记录项中。

作为用户运行

允许系统管理员以另一数据库用户的身份运行 Transact-SQL 作业步骤。

下一页

移动到下一个步骤。

上一页

移动到上一个步骤。

请参见

创建作业步骤

处理多个作业步骤


SQL Server 代理程序属性（常规选项卡）

使用此选项卡查看或指定下列选项。

选项

系统帐户

在系统帐户下运行 SQL Server 代理服务。

本帐户

指定运行 SQL Server 代理服务的 Microsoft® Windows NT® 4.0 或 Windows® 2000 帐户。

密码

指定 Windows NT 4.0 或 Windows 2000 帐户密码。

邮件配置文件

为 SQL Server 代理服务启动帐户指定一个已经过配置和测试的有效 MAPI 配置文件名。

测试

使用指定的配置文件（在服务器上）启动和停止 MAPI 会话。

在已发送的邮件文件夹中保存发送邮件复本

指定将所有已发送邮件的复本保存在 Microsoft Outlook®、Microsoft Exchange 客户程序或适用的 MAPI-1 电子邮件客户程序中的"已发送的邮件"文件夹中。

文件名称

指定 SQL Server 代理日志文件名。默认为 C:\Program Files\Microsoft SQL Server\MSSQL\LOG\SQLAGENT.OUT。单击浏览（"..."）按钮搜索错误日志目录。

视图

查看 SQL Server 代理错误日志。

包含执行跟踪消息

错误日志中包含附加的执行跟踪消息。应该仅在执行具体的 SQL Server 代理问题调查时才选定此选项。

编写 OEM 文件

允许将 Sqlagent.out 文件（错误日志文件）编写为非 Unicode 文件。这将节省磁盘空间，特别是选定"包含执行跟踪消息"复选框时。

网络发送接收者

指定将收到错误（SQL Server 代理将该错误写入其错误日志）的网络弹出通知的接受者姓名。

请参见

SQL Server 代理

如何更改 SQL Server 服务登录帐户信息（企业管理器）


SQL Server 代理程序属性（高级选项卡）

使用此选项卡查看或指定下列选项。

选项

如果 SQL Server 意外停止，它会自动重新启动

如果 Microsoft® SQL Server™ 服务意外终止，则自动重新启动它。

如果 SQL Server 代理程序意外停止，它会自动重新启动

如果 SQL Server 代理服务意外终止，则自动重新启动它。

向另一个服务器转发事件

将 Microsoft® Windows® 应用程序日志中的新 SQL Server 事件转发给指定的服务器。

服务器
指定要向其转发事件的服务器。
未处理的事件
仅转发本地未处理的事件。
全部事件
转发所有事件，即使是本地已处理的事件也要转发。

如果错误具有等于或高于以下值的严重度：

指定将事件转发到所选服务器的严重度级别。该值大于或等于所选的严重度级别。

CPU 的平均使用低于

按百分比指定 CPU 闲置的条件。闲置是指在指定秒数内 CPU 平均使用低于所选的百分比。

并且保持低于此级别

按秒指定 CPU 闲置的条件。闲置是指在指定秒数内 CPU 的平均使用低于选定的百分比。

请参见

如何自动启动 SQL Server 代理程序（企业管理器）

如何指派事件转发服务器（企业管理器）

如何设置 CPU 空闲时间和持续时间（企业管理器）


SQL Server 代理程序属性（警报系统选项卡）

使用此选项卡查看或指定下列选项。

选项

收件人

为"收件人："行指定呼叫程序地址前缀和/或后缀。

抄送

为"抄送："行指定呼叫程序地址前缀和/或后缀。

呼叫程序地址

指定是否将操作员的呼叫程序地址包含在"收件人："或"抄送："行中。

主题

在警报呼叫主题行中，可在警报名称前面键入最多 100 个字符的文本。呼叫主题的格式为 <前缀><警报名称><后缀>。

后缀

指定在警报呼叫主题行中位于警报名称之后的文本。呼叫主题的格式为 <前缀><警报名称><后缀>。

在通知页中包含电子邮件的正文部分

在通知页中包含电子邮件的正文。清除此复选框以缩短发送的页面。

操作员

指定要向其发送防故障通知的操作员。

电子邮件

通过电子邮件通知防故障操作员。

呼叫程序

通过呼叫程序通知防故障操作员。

网络发送

通过"网络发送"通知防故障操作员。

请参见

如何指派防故障操作员（企业管理器）

如何设置呼叫程序地址的格式（企业管理器）


SQL Server 代理程序属性（作业系统选项卡）

使用此选项卡查看或指定下列选项。

选项

限制作业历史记录日志的大小

对作业历史记录日志的大小进行限制，以避免填满 msdb。

最大的作业历史记录日志大小（行）

指定作业历史记录日志的最大大小（以行为单位）。

每个作业历史记录的最大行数

指定每个作业的作业历史记录的最大行数。

当前作业历史记录日志的大小（行）

查看作业历史记录日志的当前大小（以行为单位）。

清除日志

清除作业的历史记录日志。

关闭超时间隔（秒）

指定 SQL Server 代理关闭之前等待作业完成执行的最大秒数。

主 SQLServerAgent (MSX) 服务器

显示正作为该服务器的主 SQL Server 代理程序运行的 Microsoft® SQL Server™ 实例。

只有具有系统管理员特权的用户才能执行 CmdExec 和 ActiveScripting 作业步骤

指定只有 sysadmin 角色的成员才能执行 CmdExec 或 Microsoft ActiveX® 脚本作业步骤。如果用户不是 sysadmin 角色的成员，却试图运行包括这些类型作业步骤的作业，则 CmdExec 或 ActiveScripting 作业步骤将失败。

重置代理帐户

编辑 SQL Server 代理所使用的用户帐户的用户名、密码和域，SQL Server 代理使用该帐户执行非系统管理员所拥有的作业。

重置代理密码

仅当管理 SQL Server 7.0 实例时该选项才为可用的。

请参见

如何重置 SQLAgentCmdExec 权限（企业管理器）

如何调整作业历史记录日志的大小（企业管理器）

如何设置作业执行关闭（企业管理器）

如何设置作业历史记录日志（企业管理器）


SQL Server 代理程序属性（连接选项卡）

使用此选项卡查看或指定下列选项。

选项

使用 Windows 身份验证

使用 Windows 身份验证将 SQL Server 代理程序连接到 Microsoft® SQL Server™ 实例。如果选定了此选项，则指定作为 SQL Server 代理服务启动帐户的 Microsoft Windows NT® 4.0 和 Microsoft Windows 2000® 用户帐户必须是 SQL Server 中的 sysadmin 角色成员。

使用 SQL Server 身份验证

使用 SQL Server 身份验证将 SQL Server 代理程序连接到 SQL Server 实例。

SysAdmin 登录 ID

指定系统管理员的登录 ID。

密码

指定系统管理员的密码。

登录超时

指定 SQL Server 代理程序等待与 SQL Server 实例建立连接的最长时间（以秒为单位）。

本地主机服务器

指定作为本地服务器的 SQL Server 实例的别名，以满足自定义连接的需要。使用客户端网络实用工具修改可用的选择。

请参见

如何设置 SQL Server 别名（企业管理器）

如何设置 SQL Server 连接（企业管理器）


SQL Server 代理错误日志

使用此对话框查看或指定下列选项。

选项

类型

指定要从 SQL Server 代理错误日志查看的项目类型。

包含文本

将所显示的日志条目限制为仅包括含有指定文本的条目。搜索是区分大小写的。

应用筛选

根据指定的筛选参数刷新显示。

类型

查看日志条目的类型。

日期/时间

查看写入日志条目的日期和时间。

消息

查看日志条目的文本。双击消息以查看全部消息文本。

请参见

使用 SQL Server 代理程序错误日志


SQL 邮件配置（常规选项卡）

使用此选项卡查看或指定下列选项。

选项

配置文件名

指定已为 Microsoft® SQL Server™ 服务启动帐户进行配置和测试的有效 MAPI 配置文件名。SQL 邮件只支持扩展 MAPI。

测试

使用指定的配置文件启动和停止 SQL Server 实例上的 MAPI 会话。

SQL Server 启动时自动启动 SQL 邮件

SQL Server 启动时自动启动 SQL 邮件。只能在 Microsoft Windows NT® 4.0 和 Microsoft Windows® 2000 中使用该功能。

请参见

配置 SQL 邮件


管理 SQL Server 消息（搜索选项卡）

使用此选项卡查看或指定下列选项。

选项

消息文本包含

指定要在消息中搜索的文本。

查找

查找满足指定条件的消息。

错误号

指定要在消息中搜索的错误号。

严重度

指定要在消息中搜索的严重度。

仅包含已记录的消息

仅包含始终写入 Microsoft® Windows® 应用程序日志的消息。

仅包含用户定义的消息

仅包含已由用户创建的消息。

请参见

管理 SQL Server 消息

如何查找 SQL Server 消息（企业管理器）


SQL Server 消息

使用此对话框查看或指定下列选项。

选项

错误号

指定用户定义的错误信息号。用户定义的错误信息号必须大于 50,000。

严重度

指定 Microsoft® SQL Server™ 消息的严重度。严重度在 1 到 25 之间。

消息文本

指定消息的文本。最大字符数为 255。

语言

指定消息的语言。必须先创建英语版的消息，然后才能创建其它语言的消息。

始终写入 Windows 事件日志

指定将此消息写入 Microsoft Windows® 应用程序日志。如果希望通过 SQL Server 代理监视用户定义的消息（出于警报目的），则必须选择此选项。

请参见

管理 SQL Server 消息


管理 SQL Server 消息（消息选项卡）

使用此选项卡查看或指定下列选项。

选项

错误

查看消息的错误号。

严重度

查看消息的严重度。

语言

查看消息的语言。

是否记录

查看是否始终将错误写入 Microsoft® Windows® 应用程序日志。

消息文本

查看错误信息的文本。

新建

显示"新建 SQL Server 消息"对话框，在该对话框中可以添加新的服务器消息。

编辑

显示"新建 SQL Server 消息"对话框，在该对话框中可以编辑服务器消息。还可通过双击消息来编辑它。

删除

删除服务器消息。只能删除编号大于 50,000 的用户定义消息。

请参见

管理 SQL Server 消息


更改作业的目标服务器（可用的服务器选项卡）

使用此选项卡查看或指定下列选项。

选项

可用的服务器

查看可用于运行作业的目标服务器。

属性

显示"目标服务器属性"对话框，在该对话框中可以执行以下操作：

>
将一个或多个目标服务器添加到将要运行作业的目标服务器的列表中。或者双击可用的服务器。
<
从将要运行作业的目标服务器的列表中删除一个或多个目标服务器。或者双击选定的目标服务器。

选定的目标服务器

查看将要运行作业的目标服务器。

请参见

创建作业

多服务器管理


更改作业的目标服务器（全部服务器组选项卡）

使用此选项卡查看或指定下列选项。

选项

名称

查看目标服务器组的名称。

选定数

查看将要运行作业的服务器组中的服务器数。

选定的目标服务器

查看将要运行作业的目标服务器。

添加

添加新的目标服务器组。

删除

删除目标服务器组。分配给该组的单个目标服务器不会被删除。

属性

查看与目标服务器组相关的属性。

>

将所选组的成员服务器添加到将要运行作业的目标服务器列表中。

请参见

创建作业

多服务器管理


目标服务器属性

使用此对话框查看或指定下列选项。

选项

名称

查看目标服务器的名称。

位置

指定目标服务器的物理位置和/或描述。

时区

查看目标服务器所在的时区。

当地时间

查看目标服务器在其时区内的当前日期和时间。所显示的值不是实时进行更新。

登记日期

查看目标服务器登记的本地日期和时间。

上一次轮询

查看目标服务器上一次轮询主服务器的本地日期和时间。

轮询间隔

查看目标服务器轮询主服务器的时间间隔。

未读指令

查看有多少主服务器的指令尚未被目标服务器读取。

服务器所属目标服务器组

查看目标服务器所属的目标服务器组。

请参见

创建作业

多服务器管理


目标服务器（目标服务器状态选项卡）

使用此选项卡查看或指定下列选项。

选项

目标服务器

查看目标服务器的名称。如果右击此服务器，可以查看服务器的属性、检查 SQL Server 代理的状态和查看 SQL Server 代理错误日志。

当地时间

查看目标服务器在其时区内的当前日期和时间。

上一次轮询

查看目标服务器上一次轮询主服务器的本地日期和时间。

未读指令

查看有多少主服务器的指令尚未被目标服务器读取。

状态

查看目标服务器的状态：已阻塞的、良好或脱机。脱机表示选定的目标服务器在最后三个轮询间隔内还未轮询主服务器。

强制轮询

强制选定的目标服务器轮询主服务器。

强制脱离

强制选定的目标服务器从主服务器脱离。

发布指令

为一个或多个目标服务器发布指令。

请参见

多服务器管理

如何查看主 SQL Server 代理错误日志（企业管理器）


目标服务器（下载指令选项卡）

使用此选项卡查看或指定下列选项。

选项

目标服务器

由目标服务器筛选下载指令。

作业

由作业筛选下载指令。

目标服务器

查看将应用下载指令的目标服务器。

操作

查看下载指令要执行的操作。

对象名

查看将受下载指令影响的对象的名称。

发布日期

查看发布指令的本地日期和时间。

下载日期

查看目标服务器下载指令的本地日期和时间。如果目标服务器下载指令时遇到问题，则显示一个错误。

指令下载状态

查看选定的下载指令的最近状态。

删除

删除选定的下载指令。使用此选项时需要特别小心，因为指令的顺序通常很重要。

清除

清除下载指令的状态，从而允许目标服务器再次尝试下载。

请参见

多服务器管理


发布下载指令

使用此对话框查看或指定下列选项。

选项

指令类型

指定要发布的指令类型。

描述

描述指令将导致目标服务器执行什么操作。

全部目标服务器

指定所有目标服务器都将接收指令。

部分目标服务器

指定仅选定的目标服务器将接收指令。

目标服务器

查看目标服务器的名称。

当地时间

查看目标服务器在其时区内的当前日期和时间。

轮询间隔

查看目标服务器轮询主服务器的时间间隔（以秒为单位）。

选择

指定目标服务器将接收下载指令。

请参见

多服务器管理

如何启动作业（企业管理器）


在此 MSX 中登记已注册的服务器

使用此对话框查看或指定下列选项。

选项

服务器名称

查看已注册但还没有登记为此主服务器的目标服务器的服务器名称。只显示在 Microsoft Windows NT® 4.0 或 Windows® 2000 上运行的 Microsoft® SQL Server™ 实例。

已知凭据

查看服务器的注册信息是否包含连接信息。如果未包含连接信息，则必须提供该信息才能登记服务器。

属性

查看与选定的服务器关联的属性。

登记

将所有选中的服务器登记到主服务器中。

请参见

多服务器管理

如何从主服务器中登记目标服务器（企业管理器）


多服务器作业执行状态

使用此对话框查看或指定下列选项。

选项

作业

按作业查看作业执行状态。

服务器

按服务器查看作业执行状态。

作业名

如果已选择按作业显示作业执行状态，请指定要查看的作业名称。

名称

如果已选择按作业显示作业执行状态，则查看服务器名称。如果已选择按服务器显示作业执行状态，则查看作业名称。

上次运行时间

查看目标服务器对选定作业执行最后一次上载时作业执行的开始日期和时间。通过查看远程作业历史记录，可获得有关作业执行历史记录的最新及全面信息。

上次运行状态

查看目标服务器对选定作业执行最后一次上载时的作业结果状态。通过查看远程作业历史记录，可获得有关作业执行历史记录的最新及全面信息。

上次运行消息

查看目标服务器对选定作业执行最后一次上载时的作业结果消息。通过查看远程作业历史记录，可获得有关作业执行历史记录的最新及全面信息。

查看远程作业历史记录

连接到目标服务器并远程查看作业历史记录信息。

目标服务器状态

查看目标服务器的状态。

同步作业

如果已选择按服务器显示作业执行状态，请重新同步目标服务器上所有的多服务器作业。如果已选择按作业显示作业执行状态，请重新同步执行指定作业的所有目标服务器上的作业。

请参见

多服务器管理

如何查看作业历史记录（企业管理器）


生成 SQL 脚本

使用此对话框查看或指定下列选项。

选项

文件名称

指定该 SQL 脚本的文件名。单击浏览（"..."）按钮选择用于保存 SQL 脚本的文件名。

MS-DOS 文本 (OEM)

将脚本保存为当前 Microsoft® Windows® 系统代码页的格式。如果要在批处理操作中使用该脚本并从命令提示执行该脚本，则选择此选项。

Windows 文本 (ANSI)

以 ANSI 格式保存 Transact-SQL 脚本。如果要在 SQL 查询分析器中或其它的 Windows 应用程序中使用该脚本，则选择此选项。

国际化文本 (Unicode)

以 Unicode 格式保存 Transact-SQL 脚本。如果脚本使用仅在 Unicode 字体中受支持的特殊国际化字符，则选择此选项。该格式需要的磁盘空间为当前 Windows 代码页或 ANSI 的两倍。

如果警报存在，将其替换

指定如果警报已存在，用脚本代码替换它。

包含通过警报发送到操作员的通知

在脚本中包含通过警报发送给操作员的所有通知。

包含通过警报执行的作业名

在脚本中包含通过警报执行的作业名。

TSQL 批处理分隔符

指定用于在脚本中分隔 Transact-SQL 批处理命令的词。

预览

查看将要创建的 Transact-SQL 脚本。

请参见

将操作员或警报复制到其它服务器


生成 SQL 脚本

使用此对话框查看或指定下列选项。

选项

文件名称

指定该 SQL 脚本的文件名。单击浏览（"..."）按钮选择用于保存 SQL 脚本的文件名。

MS-DOS 文本 (OEM)

将脚本保存为当前 Microsoft® Windows® 系统代码页的格式。如果要在批处理操作中使用该脚本并从命令提示执行该脚本，则选择此选项。

Windows 文本 (ANSI)

以 ANSI 格式保存 Transact-SQL 脚本。如果要在 SQL 查询分析器或其它的 Windows 应用程序中使用该脚本，则选择此选项。

国际化文本 (Unicode)

以 Unicode 格式保存 Transact-SQL 脚本。如果脚本使用仅在 Unicode 字体中受支持的特殊国际化字符，则选择此选项。该格式需要的磁盘空间为当前 Windows 代码页或 ANSI 的两倍。

如果操作员存在，将其替换

指定如果操作员已存在，用脚本代码替换它。

包含通过警报发送到操作员的通知

在脚本中包含通过警报发送到操作员的所有通知。

TSQL 批处理分隔符

指定用于在脚本中分隔 Transact-SQL 批处理命令的词。

预览

查看将要创建的 Transact-SQL 脚本。

请参见

将操作员或警报复制到其它服务器


生成 SQL 脚本

使用此对话框查看或指定下列选项。

选项

文件名称

指定该 SQL 脚本的文件名。单击浏览（"..."）按钮选择用于保存 SQL 脚本的文件名

MS-DOS 文本 (OEM)

将脚本保存为当前 Microsoft® Windows® 系统代码页的格式。如果要在批处理操作中使用该脚本并从命令提示执行该脚本，则选择此选项。

Windows 文本 (ANSI)

以 ANSI 格式保存 Transact-SQL 脚本。如果要在 SQL 查询分析器或其它的 Windows 应用程序中使用该脚本，则选择此选项。

国际化文本 (Unicode)

以 Unicode 格式保存 Transact-SQL 脚本。如果脚本使用仅在 Unicode 字体中受支持的特殊国际化字符，则选择此选项。该格式需要的磁盘空间为当前 Windows 代码页或 ANSI 的两倍。

如果作业已存在，将其替换

指定如果作业已存在，用脚本代码替换它。

TSQL 批处理分隔符

指定用于在脚本中分隔 Transact-SQL 批处理命令的词。这在 Transact-SQL 作业步骤已包含 GO 命令分隔符的情况下很有用。

预览

查看将要创建的 Transact-SQL 脚本。

请参见

使用 Transact-SQL 编写作业脚本


查看作业分类属性（常规选项卡）

使用此选项卡查看或指定下列选项。

选项

名称

查看所选作业分类的名称。

此分类中的作业

查看所选作业分类中的作业列表。

请参见

创建作业


连接属性

使用此对话框指定连接（会话），如果数据提供程序支持，还可指定导入元数据的数据库（目录）。必须制定这些规范以将元数据（例如表和列信息、主键和外键、索引）导入 Microsoft® SQL Server™ 2000 Meta Data Services。若要能够进行元数据的导入，指定的数据提供程序必须支持 OLE DB 架构行集。

建立连接后，数据转换服务 (DTS) 将元数据信息从指定的连接读入 Meta Data Services。随后，当启用"扫描选项"保存数据转换服务 (DTS) 包时，包中的任务将与导入的元数据建立关系。

如果选择"导入元数据"，则仅从一个数据库（目录）读取元数据；如果选择"扫描选项"对话框中的"扫描所有引用目录"，则包中所引用的所有数据库中的元数据均将保存到 Meta Data Services。

下列定义的选项并非都能用于所有提供程序。根据所选的提供程序，将显示选项的子集。

选项

源

选择与源数据的数据存储格式相匹配的数据专用驱动程序。

文件名

指定保存导入数据的数据库路径和文件名（例如，C:\MyData.xls 或 \\Sales\Database\Northwind.mdb）。

用户名

为数据库连接指定用户名。

密码

为数据库连接指定密码。

高级

显示"高级属性"对话框，可在其中输入自定义设置。有关 OLE DB 提供程序属性的更多信息，请在Microsoft Web 站点 MSDN® Library 的 Platform SDK 章节中搜索。

UDL 文件名

指定包含连接字符串的 Microsoft 数据链接 (.udl) 文件的名称。

总是从 UDL 文件读取属性

指定包每次执行时都从指定的数据链接 (.udl) 文件搜索并读取连接字符串。包各次执行期间，数据链接文件的更改将包含在下一次运行中。如果选择此复选框，则需要为包部署 .udl 文件，以使包能够找到并读取该文件。如果不选择此复选框，则将连接字符串从 .udl 文件复制到包中，而不再引用该文件。以后只有通过直接编辑 DTS 包才能修改连接更改。

属性

显示"数据链接属性"对话框，在此对话框中可以配置数据链接连接。在此对话框中所做的更改将包含于当前会话期间创建的包中，而不会更改数据链接文件。

用户/系统 DSN

指定指向数据源的现有用户或系统数据源名称 (DSN) 的名称。

新建

显示"创建新数据源"对话框，在其中可创建 ODBC DSN。有关创建 ODBC 数据源的更多信息，请在Microsoft Web 站点 MSDN Library 的 Platform SDK 章节中搜索。

文件 DSN

指定指向数据源的现有文件 DSN 的名称。

服务器

指定存放数据源的服务器名称。

使用 Windows 身份验证

指定包使用 Windows 身份验证登录到 SQL Server 数据库。

使用 SQL Server 身份验证

指定包使用 SQL Server 身份验证登录到 SQL Server 数据库。

数据库

列出指定 SQL Server 实例上的数据库。

刷新

使得在运行 Microsoft Windows® 98 的计算机上填充数据库列表。

请参见

DTS 连接

共享元数据


DTS 包版本

使用此对话框显示选定数据转换服务 (DTS) 包的版本历史记录，并且编辑或删除选定包的版本。

可用的选项取决于如何保存包：

  • 可以编辑和删除保存到 Microsoft® SQL Server 中的包版本

  • 可以编辑保存到 SQL Server 2000 Meta Data Services 中的包版本；但是不能删除包版本。

若要编辑或删除包，单击"版本"选项，然后单击"编辑"或"删除"按钮。

请参见

删除 DTS 包

将 DTS 包保存到 SQL Server

将 DTS 包保存到 Meta Data Services


包属性

使用此对话框设置数据转换服务 (DTS) 应用程序的选项。

选项

启用高速缓存

在运行 Microsoft® Windows® 2000 的计算机上使用 DTS 设计器时优化 DTS 应用程序的性能。在此环境中，选择该复选框将明显缩短打开 DTS 包所需的时间。

刷新高速缓存

使 DTS 应用程序识别出自上次刷新高速缓存后新添加的脚本语言、自定义转换、OLE DB 提供程序和自定义任务。该选项仅当选定了"启用高速缓存"复选框时才可用。在 DTS 设计器中注册新任务将刷新任务的高速缓存，但是直到刷新高速缓存时，DTS 应用程序中才会出现新添加的 OLE DB 提供程序。

通常在安装完新的 Microsoft SQL Server™ 2000 实例、注册新的 DTS 对象或添加的新 OLE DB 提供程序后单击"刷新高速缓存"。

在 DTS 设计器中显示多阶段抽取

在 DTS 设计器的转换任务中显示多阶段数据抽取选项。当在"转换数据任务"或"数据驱动的查询任务"中配置转换时，访问多阶段数据抽取选项。

启用实时调试

使用与那些产品一起提供的脚本调试程序调试 Microsoft ActiveX® 脚本。该选项仅当已安装 Windows 2000、Microsoft Visual InterDev® 6.0 或 Microsoft Windows NT® 4.0 Option Pack 后才可用。

请参见

多阶段数据抽取功能

调试 ActiveX 脚本


DTS 包日志

使用此对话框选择存储在服务器上的数据转换服务 (DTS) 包日志并查看包执行的事件和详细信息。

选项

服务器 <服务器名> 上可用的 DTS 包

选择想要显示其日志的包。

DTS 包版本和日志树

查看默认显示，以显示已为其创建了日志的包的所有版本。展开树，查看每次执行该包版本并请求生成日志时所创建的所有日志。将列出这些日志，其中最旧的日志显示在最上面。

打开日志

显示"日志详细信息"对话框，在该对话框中可以查看选定日志的执行步骤的详细信息。

删除

显示"删除包日志"对话框，在该对话框中可以选择要删除的包日志。

请参见

使用 DTS 包日志


删除包日志

使用此对话框删除数据转换服务 (DTS) 包日志。删除包日志的主要目的是从系统中删除最早的日志并保留新的、更相关的日志。若要强制该功能删除版本中最新的日志，唯一的方法是选择"删除最新日志"复选框。

选项

服务器 <服务器名> 上可用的 DTS 包

指定要在树中查看其日志的包。

删除在 <mm/dd/yy hh:mm:ss AM/PM> 上创建的选定版本 <x 版> 的所有日志

指定将删除突出显示的版本中除最新日志外的所有日志。若要无一例外地删除选定版本中的所有日志，还必须选择"删除最新日志"复选框。

删除包的所有日志：<包名称>

指定将删除已选定的包的所有日志（最新日志和最新版本除外）。如果还选择了"删除最新日志"复选框，则删除所有的包日志和版本。

删除最新日志

指定将只删除选定版本的最新日志。默认情况下选择该选项。


日志详细信息

使用此对话框复查有关数据转换服务 (DTS) 包步骤的详细执行信息。

选项

状态

查看表示步骤成功或失败的符号。绿色的选中标志表示该步骤已成功完成，而红色的"X"表示在该步骤中发生了错误。任何没有运行的步骤都不会记入日志，也不会显示在"日志详细信息"对话框中。

步骤名称

查看包中的步骤。它指出日志的该行中的其余列所引用的步骤。

运行状态

查看表示步骤状态的代码。状态代码为：

  • 步骤正在等待 = 1

  • 步骤正在进行 = 2

  • 步骤不是活动的 = 3

  • 步骤已完成 = 4

有关更多信息，请参见 DTSStepExecStatus。

开始时间

查看步骤开始的日期和时间。日期和时间的格式为 yyyy-mm-dd hh:mm:ss:ms。

结束时间

查看步骤完成的日期和时间。日期和时间的格式为 yyyy-mm-dd hh:mm:ss:ms。

运行时间

查看执行步骤所用的时间。即"开始时间"字段和"结束时间"字段之差。

错误代码

查看错误代码。如果步骤已成功执行，则该列中输入的错误代码将是零。如果此步骤没有成功执行，则该列中将输入指出步骤失败原因的错误代码。

错误描述

查看对所发生错误的简短文本描述。

更多信息

展开"日志详细信息"对话框以显示"任务详细信息"部分。

较少信息

从"日志详细信息"对话框中删除"任务详细信息"部分。

查看错误

显示"查看包日志错误描述"对话框，在此对话框中可查看对"错误描述"列中信息的详细描述。

任务详细信息

显示 DTS 任务的实时日志记录详细信息。虽然在 Microsoft® SQL Server™ 中提供的 DTS 任务不提供这些日志记录详细信息，但是可以编写提供日志记录详细信息的 DTS 自定义任务。有关更多信息，请参见 WriteTaskRecord 方法。

状态

查看任务状态。绿色的选中标志表示该步骤已成功完成。红色的"X"表示该步骤已失败。

描述

查看对任务的详细描述。

错误代码

如果发生错误，查看错误信息号。Ok 表示没有遇到错误。