选择数据源

使用此对话框指定要复制的数据源。下列定义的选项并非都能用于所有提供程序。根据所选的提供程序，将显示下列选项的子集。

选项

数据源

选择与源数据的数据存储格式相匹配的数据专用驱动程序。

文件名

指定保存导入数据的数据库路径和文件名（例如，C:\MyData.xls, \\Sales\Database\Northwind.mdb）。

用户名

为数据库连接指定用户名。

密码

为数据库连接指定密码。

高级

显示"高级属性"对话框，在其中可输入自定义设置。有关 OLE DB 提供程序属性的更多信息，请在 Microsoft Web 站点 MSDN® Library 的 Platform SDK 章节中搜索。

UDL 文件名

指定包含连接字符串的数据链接 (.udl) 文件的名称。

总是从 UDL 文件读取属性

请求包每次执行时都从指定的数据链接 (.udl) 文件搜索并读取连接字符串。包各次执行期间，数据链接文件的更改将包含在下一次运行中。如果选择此复选框，则需要为包部署 .udl 文件，以使包能够找到并读取该文件。如果不选择此复选框，则将连接字符串从 .udl 文件复制到包中，而不再引用该文件。以后只有通过直接编辑数据转换服务 (DTS) 包才能修改连接更改。

属性

显示"数据链接属性"对话框，在其中可配置数据链接连接。在此对话框中所做的更改将包含于当前会话期间创建的包中，而不会更改数据链接文件。

用户/系统 DSN

指定现有用户的名称或指定指向数据源的系统数据源名称 (DSN)。

新建

显示"创建新数据源"对话框，在其中可创建 ODBC DSN。有关创建新 ODBC 数据源的更多信息，请在 Microsoft Web 站点 MSDN Library 的 Platform SDK 章节中搜索。

文件 DSN

指定指向数据源的现有文件 DSN 的名称。

服务器

指定存放数据源的服务器名称。

使用 Windows 身份验证

指定包使用 Windows 身份验证登录到 Microsoft® SQL Server™ 数据库。

使用 SQL Server 身份验证

指定包使用 SQL Server 身份验证登录到 Microsoft SQL Server 数据库。

数据库

列出指定 SQL Server 实例上的数据库。

刷新

使得在 Microsoft Windows® 98 计算机填充数据库列表。

请参见

DTS 连接


选择目的

使用此对话框指定所复制数据的目的。下列定义的选项并非都能用于所有提供程序。根据所选的提供程序，将显示下列选项的子集。

选项

目的

选择与目的数据存储格式相匹配的数据专用驱动程序。

文件名

指定存储导入数据的路径和文件名（例如，C:\MyData.xls, \\Sales\Database\Northwind.mdb）。

用户名

为数据库连接指定用户名。

密码

为数据库连接指定密码。

高级

显示"高级属性"对话框，在其中可输入自定义设置。有关 OLE DB 提供程序属性的更多信息，请在 Microsoft Web 站点 MSDN® Library 的 Platform SDK 章节中搜索。

UDL 文件名

指定包含连接字符串的数据链接 (.udl) 文件的名称。

总是从 UDL 文件读取属性

请求包每次执行时都从指定的数据链接 (.udl) 文件搜索并读取连接字符串。包各次执行期间，数据链接文件的更改将包含在下一次运行中。如果选择此复选框，则需要为包部署 .udl 文件，以使包能够找到并读取该文件。如果不选择此复选框，则将连接字符串从 .udl 文件复制到包中，而不再引用该文件。以后只有通过直接编辑数据转换服务 (DTS) 包才能修改连接更改。

属性

显示"数据链接属性"对话框，在其中可配置数据链接连接。在此对话框中所做的更改将包含于当前会话期间创建的包中，而不会更改数据链接文件。

用户/系统 DSN

指定现有用户的名称或指定指向数据源的系统数据源名称 (DSN)。

新建

显示"创建新数据源"对话框，在其中可创建 ODBC DSN。有关创建新 ODBC 数据源的更多信息，请在 Microsoft Web 站点 MSDN Library 的 Platform SDK 章节中搜索。

文件 DSN

指定指向数据源的现有文件 DSN 的名称。

服务器

指定存储数据的服务器名称。

使用 Windows 身份验证

指定包使用 Windows 身份验证登录到 Microsoft® SQL Server™ 数据库。

使用 SQL Server 身份验证

指定包使用 SQL Server 身份验证登录到 Microsoft SQL Server 数据库。

数据库

列出指定的 SQL Server 上的数据库。

刷新

使得在 Microsoft Windows® 98 计算机填充数据库列表。

请参见

DTS 连接


高级连接属性

使用此对话框为某些 OLE DB 初始化属性设置自定义值。具体哪些 OLE DB 高级属性可以自定义，取决于特定提供程序所支持的属性。有关更多信息，请参见各 OLE DB 提供程序的编程文档。

若要更改 OLE DB 属性值，请在"值"下单击所需单元，然后输入新值。

说明 如果您的工作更接近 OLE DB 级，OLE DB 软件开发工具包 (SKD) 附带的 OLE DB 行集查看器将提供一种查看和操作 OLE DB 行集的简单方法。它还新增了通过任何 OLE DB 提供程序所支持的数据源、会话、命令、行集、事务和提示对象调用和操作其它 OLE DB 方法的能力。

请参见

DTS 连接


创建数据库

使用此对话框为数据源连接定义新的数据库。仅当通过用于 SQL Server 的 Microsoft OLE DB 提供程序或用于 ODBC 的 Microsoft OLE DB 提供程序连接到 Microsoft® SQL Server™ 实例上时，才能定义新的数据库。该数据库文件将放置到与 master 数据库文件相同的位置上。如果无法新建数据库，请确认自己的登录是否有相应的权限。

此对话框提供了可用于创建数据库的选项子集。若要在创建数据库时访问所有的选项，请在 SQL Server 企业管理器中右击"数据库"节点，然后单击"新建数据库"命令。

确保遵从 SQL Server 的数据库命名规则，并适当设置新数据库的数据文件大小和日志文件大小。有关更多信息，请参见 SQL Server 2000 实例命名规则。

请参见

创建数据库


选择文件格式

使用此对话框指定源或目的文本文件的格式。文本文件中的行或列的长度可以是固定的，也可以用特殊的字符分隔。

说明 注意如果从 Microsoft® SQL Server™ 实例导入到文本文件，则列的大小可能默认为 2 GB。如果需要调整列的大小设置，请单击"选择目的文件格式"对话框中的"转换"按钮来修改列。当将数据从文本文件复制到新的 SQL Server 表时，列的大小可能默认为 varchar (255)。

选项

带分隔符

指定数据在文件内按字段对齐，每个字段均由相同的终止符分隔。

固定字段

指定数据在文件内以等宽按字段对齐。文件内的字段对所有数据行宽度都相等。然而在同一行中各字段宽度都可以不同。

文件类型

通过单击"ANSI"、"OEM"或"Unicode"指定文件类型，具体取决于文件中数据的类型。如果单击"ANSI"或"OEM"，数据将解释为属于执行包的计算机上的当前代码页。

行分隔符

指定文件中各行以某种字符序列彼此分离。单击下列分隔符之一："{CR}"（回车）；"{LF}"（换行符）；";"（分号）；","（逗号）；"制表符"；"|"（垂直条）。也可以键入字符，用作行分隔符。如果文件是固定字段文件，也可以单击"<无>"。

文本限定符

指定在分隔的数据文件中用来限定文本的字符标记。单击下列文本限定符之一："双引号 {"}"；"单引号 {'}"；"<无>"。也可以键入字符，用作文本限定符。如果文本没有被分隔，而文件不是"固定字段"文件，则该属性可能设置为默认值"双引号 {"}"或更改为"<无>"。

跳过行

指定从文件开头起不想复制的行数。该字段与"第一行含有列名称"字段一起使用。如果没有选定"第一行含有列名称"复选框，则跳过的行数等于这里键入的数字。如果选中了"第一行含有列名称"复选框，则跳过的行数从已对列标题的第一行计数后开始算起。

第一行含有列名称

指定文本文件的第一行含有列标题而非数据。

转换

显示"列映射和转换"对话框，在其中可自定义列映射并将转换添加到已复制的数据。


定义行宽

使用此对话框定义当文本文件不包含分隔符时该文件中的数据行宽。若要显示此对话框，在配置文件格式时必须单击"行分隔符"列表中的"无"。

若要指定一行中的字符数（显示在"值"框中），请选定红线并拖动它。或者可单击"值"框旁的箭头来设置行宽。


指定表复制或查询

使用此对话框指定想要做简单数据复本还是较复杂的数据复本，后者将要求使用 SQL 语句收集和选择要复制的适当行。

选项

从源数据库复制表和视图

显示"选择源表和视图"对话框，在此对话框中可以将字段从源中的选定表和视图复制到指定的目的。将不筛选或排列记录。

用一条查询指定要传输的数据

显示"键入 SQL 语句"对话框，在其中可生成用于检索选定行的 SQL 语句。只有符合选择条件的行才可用于复制。

在 SQL Server 数据库之间复制对象和数据

显示"选择要传输的对象"对话框，如果数据的源和目的都是 Microsoft® SQL Server™ 数据库，则在此对话框中可以指定要复制的对象和数据。可传输的对象包括表、视图、存储过程、默认值、规则、约束、用户定义的数据类型、登录、用户、角色和索引。对象只能在多个 SQL Server 7.0 版实例间传输，从 SQL Server 7.0 实例传输到 SQL Server 2000 实例，和在多个 SQL Server 2000 实例间传输。


键入 SQL 语句

使用此对话框键入 SQL 语句，以从数据源生成要向目的复制的所需数据。

选项

查询生成器

显示"选择列"对话框，在其中可确定选择要复制的表、列和行。

分析

检查查询语句文本区域中 SQL 语句的语法有效性。此选项不允许验证数据域或表和视图的存在。

浏览

显示"选择文件"对话框，在此对话框中可选择文件。选择文件后，将向 Query 语句文本区域复制该文件的文本。


选择要复制的对象

使用此对话框指定要在 Microsoft® SQL Server™ 实例之间传输的对象。对象只能在多个 SQL Server 7.0 版实例间传输，从 SQL Server 7.0 实例传输到 SQL Server 2000 实例，和在多个 SQL Server 2000 实例间传输。

选项

创建目的对象

为所有要传输的对象创建目的对象（包括表、视图、存储过程、默认值、规则、约束、用户定义的数据类型、登录、用户、角色和索引）。启用下列选项：

首先丢弃目的对象
创建新目的对象之前，丢弃所有相应的目的对象。
包括所有相关对象
在数据传输中包括所有相关对象，例如支持视图的表。
包括所有扩展属性
包括所有扩展属性，这些属性是用户在数据库中的不同对象上提供的定义。有关更多信息，请参见在数据库对象上使用扩展属性。

复制数据

启用从源向目的复制 SQL Server 数据以及下列复制选项：

替换现有数据
用指定的源中的新数据改写目的对象中现有数据。
追加数据
保留目的对象的现有数据，并从指定的源追加新数据。

使用排序规则

使得能够在不同的排序规则间复制数据。有关在数据转换服务 (DTS) 中使用不同排序规则的更多信息，请参见数据变换和转换注意事项。

复制所有对象

传输所有与指定的数据源关联的对象。

使用默认选项

将各高级传输选项设置为默认值。

选择对象

显示"选择对象"对话框，在其中可选择要传输的个别对象。清除"传输所有对象"复选框以使此选项可用。

选项

显示"高级传输选项"对话框，在其中可以进一步指定登录和表的传输，以及指定在生成的 SQL 脚本中是否使用被引用的标识符。清除"使用默认选项"复选框以使此选项可用。

脚本文件目录

指定脚本文件和日志文件写入的目录。

每个选定对象的 SQL 和数据文件都将脚本文件写入某个目录，该目录必须位于任务所在的同一台计算机上。这些脚本文件于是在目的数据库上运行。

该目录中的脚本和日志文件一直可被访问，直到下次执行包时。这时，文件由新信息重写。由于脚本文件以这种方式执行，因此从同一个源数据库同时运行多个转换时，需要更改存储其中一个转换的脚本文件的目录。如果没有更改该脚本文件目录，其中一个进程将因文件正在使用而不能访问该文件。

请参见

复制 SQL Server 对象任务


选择对象

使用此对话框指定要传输到新数据库的对象。

说明 选择下列选项之一后，并不会自动标记要传输的对象，而只会使对象出现在"对象"表中。然后可从该表中选择要传输的对象。

选项

显示所有表

在"对象"表中查看数据库中所有的表。

显示所有视图

在"对象"表中显示数据库中所有的视图。

显示所有存储过程

在"对象"表中显示数据库中所有的存储过程。

显示所有用户定义函数

在"对象"表中显示所有用户定义函数。

显示所有默认值

在"对象"表中显示所有数据库默认值。

显示所有规则

在"对象"表中显示所有数据库规则。

显示用户定义的数据类型

在"对象"表中显示数据库中所有的用户定义的数据类型。

对象表

逐个选择项目以将它们包括在转换中，或单击下列选项：

全选
选择数据库中所有能够传输到新数据库中的对象。
检查
选择一个或多个数据库对象。
取消选中
从选择的数据库对象中删除一个或多个数据库对象。

请参见

复制 SQL Server 对象任务


高级复制选项

使用此对话框指定要在 Microsoft® SQL Server™ 实例间复制的对象。

选项

复制数据库用户和数据库角色

复制所有数据库用户和角色。

复制 SQL Server 登录（Windows NT 和 SQL Server 登录）

复制所有 SQL Server 登录。

复制对象级权限

复制所有对象级权限。

复制索引

如果适用，为所有已复制的表复制索引。

传输触发器

如果适用，为所有已复制的表复制触发器。

复制全文索引

如果适用，为所有已复制的表复制全文索引。

复制 PRIMARY 键和 FOREIGN 键

为所有复制的表复制主键和外键定义。

生成 Unicode 形式的脚本

按 Unicode 形式复制数据。如果源数据包含 nchar 数据类型或双字节字符集 (DBCS) 数据，该选项很有用。有关 Unicode 的更多信息，请参见 Unicode 数据。

复制对象时使用被引用的标识符

用引号括起所有对象名。

请参见

复制 SQL Server 对象任务


选择列

使用此对话框指定要向目的复制的表、视图和列，并对目的表中的列排序。

选项

源表

查看要复制的表。若要将所有的列移动到"选定列"文本区域以便复制到目的地，请选择表并单击">"按钮，或双击表名。还可以选择和移动个别的列。若要查看个别的列，请展开列所在的表。

选定列

查看要复制的列。这些列按创建时的顺序列出。

上移

将所选列的顺序上移。

下移

将所选列的顺序下移。


指定排列顺序

使用此对话框将记录按照它们在目的表中的顺序放置。

选项

选定列

查看要复制到目的表的列。若要查看"排序"表中的列，请突出显示某行并双击，或单击">"按钮。

排序

查看将要用于排序条件的列。将从所选列中生成 ORDER BY 子句。ORDER BY 子句后面有"排序"表中显示的列名称，其中第一列为外部排序字段，下一列为内部排序，依此类推。于是记录将按照指定次序放置在目的表中。排序过程不会生成聚集索引或对索引造成影响。


指定查询条件

使用此对话框指定是否要用 WHERE 子句筛选出数据行。如果要使用筛选，请使用"列"、"运算符"和"值/列"字段的组合编写谓词。如果需要三个以上的条件，单击"下一步"按钮，在显示的"键入 SQL 语句"对话框中键入其它条件；或者单击"后退"回到前一个对话框直接键入 SQL 语句。

如果输入多个与不同的逻辑运算符 (AND、OR) 组合使用的条件，那么为数据库管理系统 (DBMS) 定义的优先规则将适用。在大多数 DBMS 安装中，首先执行 AND 条件。

选项

全部行

不加约束地从源中选择所有行。不追加 WHERE 子句到 SQL 语句。

只有满足条件的行

启用"列"、"运算符"和"值/列"字段以便能够定义下列选择条件：

列
选择将要应用约束的列。
运算符
选择用于比较的关系运算符。可用值有 =、<、>、<>、<=、>=。
值/列
选择与"列"列表中的字段进行比较的另一列或值。单击浏览（"…"）按钮，为在"列"列表中显示的列列出存储在表中的值。从该列表中选择的值将成为比较值。


选择源表和视图

使用此对话框指定要向目的复制的表和视图。

选项

表和视图

查看可向目的复制的表和视图。如果选择了源而不执行其它操作，将从源不加更改地复制架构和数据。

...

显示"列映射和转换"对话框，在其中可指定接收源数据的目的列、编辑对记录级传输进行自定义的脚本代码、以及编辑创建目的表所需的 SQL 代码。

预览

运行数据转换服务 (DTS) 包前，预览源数据以对其进行验证。单击"上一步"返回前一个对话框，在此对话框中可以做更正以产生正确数据。


列映射和转换

使用此对话框指定源列和目的列之间的映射，并且如果数据在移动到目的时需经过转换，指定使用何种转换。如果能够进行有效的数据转换，还可以更改数据的数据类型。

列映射选项卡

使用此选项卡指定如何处理目的表，并指定任何新创建的表上的列特性。

选项

创建目的表

复制源数据之前创建目的表。如果指定的目的表不存在，这将是默认选项。如果选定了该选项且目的表已经存在，除非选择"除去并重新创建目的表"复选框，否则将发生错误。

编辑 SQL

自定义用于创建目的表的 Transact-SQL CREATE TABLE 语句。

删除目的表中的行

复制源数据之前删除目的表中的所有行。仅当目的表已存在时此选项才可用。此选项不影响目的表上的现有索引和约束。

在目的表中追加行

将源数据插入目的表。仅当表已存在时此选项才可用。目的表上的现有数据、索引和约束不受影响。然而，行却不必要地追加到目的表的末尾。只要目的表上有聚集索引，就可确定要将行插入何处。

丢弃并重新创建目的表

将数据移动到目的表之前，丢弃该目的表并重新创建该表。将破坏所有目的表中现有数据和全部索引。

启用标识插入

允许将显式值插入表的标识列（仅限于 Microsoft® SQL Server™）。仅当检测到标识列时此选项才可用。标识列被定义为含有 bigint、decimal、integer、numeric、smallint 或 tinyint 数据类型的列，并且该列的 Identity 属性设置为是。

映射表

编辑表中的单元格。表中不列出目的列出现的顺序，而是在映射的每个源列旁列出每个目的列。

对于"映射"表中的每一列，可以设置下列属性：

源
选择要向目的复制的源表的列名。在源列名上单击"<忽略>"按钮，将某个新表的目的列设置为 NULL。如果该表已存在，允许的情况下数据将为 NULL，或者如果已定义了默认值，则设置为默认值。如果将目的定义为 NOT NULL，但没有为目的列指定 DEFAULT 值，那么当执行包时，在源列中单击"<忽略>"按钮将导致错误。

如果复制定义为标识列的源列，只有选定"启用标识插入"复选框才能复制数据。

如果将定义为用户定义数据类型的源列复制到新表中，则目的列的数据类型是与用户定义数据类型相对应的系统定义数据类型。

只有在创建新目的表时，才可以更改下列属性。

目的
选择目的表的列名以接收源数据。单击"<忽略>"按钮以防创建新表时在目的表中创建源列。如果要从现有表中删除列，则必须在目的列中单击"<忽略>"按钮，但还要在此对话框中选择"除去并重新创建目的表"复选框。这将重新创建含有指定列的表。该表中的现有数据和索引将丢失。

timestamp 列不能由数据转换服务 (DTS) 导入/导出向导复制。如果目的列是 timestamp 列，则该字段中的值将是指出何时插入行的新时间戳，而不是源表的时间戳数据复本。

类型
为目的列选择数据类型。默认设置将匹配目的列的数据类型与源列的数据类型。

说明 当默认转换设置允许所有可能的转换时，可以指定无效的数据转换而不导致错误。例如，将 int 数据类型转换为 tinyint 数据类型将发生数据截断，但转换仍将继续。

可以为空
指定目的是否允许空值。
大小
按与数据类型对应的单位指定 Destination 列的长度。该值仅可用于 char、varchar、nchar、nvarchar、binary 和 varbinary 数据类型。指定的大小小于源的长度会导致数据截断。
精度
输入十进制最大位数，该数字可以安置在小数点的左侧和右侧。此选项仅适用于 decimal 和 numeric 数据类型。
小数位数
输入小数点右边存储的十进制最大位数。该数字必须小于或等于"精度"列中的数字。此选项仅适用于 decimal 和 numeric 数据类型。
转换选项卡

使用此选项卡指定是否必须写入唯一转换代码。文本区域中显示的代码反映了在"列映射"选项卡中设置的列映射。

选项

将源列直接复制到目的列

将源列复制到目的表，而不更改数据或源和目的映射。

在将信息复制到目的时对其进行转换

在文本区域编辑脚本，以便在将列从源复制到目的之前自定义这些列。对于复杂的转换，可考虑使用 DTS 设计器，它支持 Microsoft ActiveX® 脚本。

语言

选择脚本编写语言。默认语言是 Microsoft Visual Basic® Scripting Edition (VBScript)。可用语言为 VBScript 或 JScript。

浏览

显示"选择文件"对话框，如果已经编写代码并将其保存到 .txt、.vbs 或 .bas 文件，则在此对话框中可选择包含以前编写的转换代码的文件。选择文件后，将向 Query 语句文本区域复制该文件的文本。

请参见

ActiveX 脚本转换

在 DTS 中使用 ActiveX 脚本


保存、调度和复制包

使用此对话框将源、目的和转换属性保存为数据转换服务 (DTS) 包。

选项

立即运行

当向导结束后，立即运行转换并创建目的数据。

用复制方法发布目的数据

将目的表用于复制。单击"用复制方法发布目的数据"选项时，DTS 导入/导出向导结束运行后将启动创建发布向导。

调度 DTS 包以后执行

将数据转换服务 (DTS) 包保存到 Microsoft® SQL Server™ msdb 数据库、SQL Server 2000 Meta Data Services、COM 结构化存储文件或 Microsoft Visual Basic® 文件，并调度该文件按预定义的时间间隔运行。单击浏览（"…"）按钮显示"编辑反复出现的作业调度"对话框，在其中可调度包的执行。如果没有修改调度，默认为每天午夜 12:00 运行包。

保存 DTS 包

指定要将 DTS 包按下列格式之一保存：

SQL Server
将包保存到 SQL Server 中，存储在 msdb 数据库的 sysdtspackages 表中。
SQL Server Meta Data Services
将包保存到 Meta Data Services。若打算追踪 Meta Data Services 的包版本、元数据和数据沿袭信息，请使用此选项。
结构化存储文件
将包保存为 COM 结构化存储文件。
Visual Basic 文件
将包保存为 Visual Basic 文件。

请参见

复制简介

保存 DTS 包


保存 DTS 包

使用此对话框保存数据转换服务 (DTS) 包。

选项

名称

为包指定唯一名称。

描述

为包指定描述。

所有者密码

为包指定密码以防止未经授权的用户看到包内任何敏感的用户名和服务器密码信息。如果保存到 Microsoft® SQL Server™ 2000 Meta Data Services 或 Microsoft Visual Basic® 文件，则该选项不可用。

用户密码

为包用户指定密码。此密码允许用户执行包，但此选项不允许用户查看包定义。设置用户密码时，还必须设置所有者密码。如果保存到 Meta Data Services 或 Visual Basic 文件，则该选项不可用。

服务器名称

指定存储包的 SQL Server 安装的名称。

使用 Windows 身份验证

当将包保存到 SQL Server 实例时使用 Windows 身份验证。使用的 Windows 身份验证将是创建包的开发人员的 Microsoft Windows® 登录。如果通过 SQL Server 代理程序调度包，则 SQL Server 代理服务帐户必须在拥有访问全部资源权限的帐户下运行。

使用 SQL Server 身份验证

当将包保存到 SQL Server 实例时使用 SQL Server 身份验证。如果通过 SQL Server 代理程序调度包，则 SQL Server 代理服务帐户必须有权访问包所需的全部资源。

用户名

如果单击"使用 SQL Server 身份验证"，指定连接到 SQL Server 实例所使用的登录。

密码

如果单击"使用 SQL Server 身份验证"，指定与用户名相关联的密码。

扫描

显示"扫描选项"对话框，在此对话框中可以指定如何将包所引用的对象扫描到 Meta Data Services 中。此功能使您得以将包中的源对象和目的对象与存储在 Meta Data Services 中的数据库元数据（例如表中的主键和外键、索引、数据类型等列信息）相关联。

将包保存为 COM 结构化存储文件或 Visual Basic 文件时，可使用下面的选项：

名称
为包指定唯一名称。
描述
为包指定描述。
文件名称
指定包源代码文件名和路径。单击浏览（"…"）按钮显示"另存为"对话框。

请参见

保存 DTS 包


查看数据

使用此对话框检查在数据复制操作中将要使用的源数据。只显示数据的前 100 行。


字体

使用此对话框格式化查询框中的 Transact-SQL 代码。

选项

颜色

指定为其指派颜色编码和格式的 Transact-SQL 内容元素。

前景
为选定的内容元素指派颜色。
背景
为选定的查询元素指派背景色。

字体

为选定的 Transact-SQL 内容元素指派字体。

大小

为选定的 Transact-SQL 内容元素指派字体大小。

示例

查看具有指派字体特性的选定 Transact-SQL 内容元素的示例。

全部重置

将所有选项重置成各自的初始默认值。


扫描选项

使用此对话框从 OLE DB 数据源导入数据库架构信息，并填充 Microsoft® SQL Server™ 2000 Meta Data Services 中的数据库信息模型 (DBM) 实例。传递给该扫描程序一个 OLE DB 提供程序，该扫描程序然后检查架构，并使用 DBM 和数据转换服务 (DTS) Meta Data Services 信息模型，在 Meta Data Services 中创建一组相应的实例对象。

如果将 DTS 包保存到 Meta Data Services 中，可以设置包引用的对象与扫描到 Meta Data Service 中的 SQL Server 目录元数据如何相关。这方面的元数据是指如下信息：

  • 主键和外键。

  • 列的类型、大小、精度、小数位数和为空性。

  • 索引。
选项

将包引用解析为已扫描的目录元数据

启用扫描选项，以将包链接到 Meta Data Services 中的元数据。

如果知识库中存在已扫描的目录，则使用这些目录

如果元数据已保存（即通过导入元数据或通过先前的扫描），则使包与 Meta Data Services 中的元数据相关。如果数据库架构没有更改，Meta Data Services 中的元数据已经存在并且出于节省时间的考虑，该选项很有用。如果在列或元数据信息已经更改的情况下使用该选项，将包引用到 Meta Data Services 中的元数据可能没有意义。

将所有引用的目录扫描到知识库中

将有关数据库的所有信息（所有的表、列和元数据信息）扫描到 Meta Data Services 中，即使不使用这些信息。该选项比前一个选项安全，但在时间和性能方面的开销更大。

如果知识库中没有目录，则扫描目录

如果某个数据库在 Meta Data Services 中不存在，则添加该数据库。如果启用扫描选项，则这是默认选择。

始终扫描目录

将数据库扫描到 Meta Data Services 中，即使该数据库已经存在。

请参见

在 DTS 中导入和保存元数据

在 DTS 中记录数据沿袭