DTS 运行

使用此对话框选择要运行的数据转换服务 (DTS) 包并指定该包的连接设置和调度选项。

选项

位置

选择 DTS 包是存储在 Microsoft® SQL Server™ 或 SQL Server 2000 Meta Data Services 中还是存储在结构化存储文件中。

包名称

选择 SQL Server 或 Meta Data Services 中存储的，或将作为结构化存储文件运行的现有包。如果"位置"选项所指定类型的包只有一个，则指定该包。如果有多个同类型的包，则不指定包，而必须单击浏览（"..."）按钮选择一个包。

高级

显示"高级 DTS 运行"对话框，该对话框可用于生成全局变量、日志记录、加密、命令提示等选项。

日期

查看当前日期和时间。

版本

查看选定包版本的全局唯一标识符 (GUID)。

服务器

指定存储包的服务器名称。此选项仅适用于保存到 SQL Server 和 Meta Data Services 的包。

文件名

指定保存为结构化存储文件的包的名称。

使用 Windows 身份验证

指定对登录使用 Windows 身份验证。只有将包保存到 SQL Server，此选项才可用。

使用 SQL Server 身份验证

指定对登录使用 SQL Server 身份验证。只有将包保存到 SQL Server，此选项才可用。

用户名

指定连接所用的用户名。

密码

指定连接所用的密码。

运行

执行选定的包。

调度

显示"编辑反复出现的作业调度"对话框，该对话框可用于调度包定期执行。

请参见

dtsrun 实用工具

执行 DTS 包

调度 DTS 包的执行


高级 DTS 运行

使用此对话框查看或编辑数据转换服务 (DTS) 全局变量、日志记录和加密设置的各种选项。

选项

变量

添加全局变量或临时更改现有的包全局变量的名称、数据类型和值。所做的任何添加或更改仅在 dtsrun 的运行期间内存在。DTS 运行实用工具关闭后，将不保存对现有全局变量的更改，在 DTS 运行实用工具会话期间添加的全局变量也被废弃。

新建

创建在 DTS 运行实用工具会话期间的新全局变量。

删除

删除在 DTS 运行实用工具会话期间的全局变量。

日志文件

键入包含 DTS 包执行错误信息的文本文件的名称。

浏览

选择包执行日志文件。

将完成状态写入事件日志

在 Microsoft® Windows NT® 应用程序日志中包括包执行的完成状态。

加密命令

根据 SQL Server 2000 加密对 dtsrun 命令提示语句进行加密。单击"生成"按钮以在命令提示框中显示加密文本。显示命令提示开关 /Z，后跟整个命令提示的加密文本。

SQL Server 7.0 格式

根据 SQL Server 7.0 加密方法对 dtsrun 命令提示句进行加密。如果正在 SQL Server 7.0 实例上调度包，则需要选择该选项。单击"生成"按钮以在命令提示框中显示加密文本。只加密参数值；不会加密 dtsrun.exe 命令和命令提示开关。

命令行

显示与 DTS 运行实用工具中选定选项等效的命令行。

生成

生成"命令行"框中显示的文本。如果选择"加密命令"复选框，将加密生成命令中的参数值。如果要从批处理文件或 SQL Server 代理程序中执行 dtsrun，那么生成命令提示很有用。

请参见

dtsrun 实用工具

执行 DTS 包

调度 DTS 包的执行


选择包

使用此对话框在保存到结构化存储文件和保存到 SQL Server 的数据转换服务 (DTS) 包版本之间进行选择。

选择保存到结构化存储文件的包版本

当打开保存到结构化存储文件的包时，如果此文件包含不止一个包或包版本，则出现"选择包"对话框。此对话框包含包版本历史记录的树视图。

  • 在顶端节点有一个文本文件图标和随带的标签，表示包的存储位置。

  • 顶端节点的下方显示包节点。其中每个节点代表不同的包。如果在同一个文件名下保存了不同的包，则该文件下可能会列出多个包节点。

  • 包节点的下方显示具有日期的版本节点，表示包的完整版本历史记录。

双击包图标可装载该包版本的最新版本。双击版本图标可装载特定的包版本。

选择保存到 SQL Server 的包版本

当试图将保存在多个版本中的包装载到 SQL Server 时，出现"选择包"对话框。和具有多个版本的结构化存储文件一样，将显示一个树状的包历史记录视图供您选择。不过，仅显示单个包的各个版本。与对结构化存储文件的处理一样，也不能将多个包保存到单个文件。

展开包图标以查看其版本历史记录，然后双击包图标以装载此包的最新版本，或单击特定的版本装载该版本。

请参见

将 DTS 包保存到结构化存储文件

将 DTS 包保存到 SQL Server

DTS 包执行实用工具


执行 DTS 包

此对话框显示数据转换服务 (DTS) 包的执行进度，同时还显示组成该包的个别任务的执行状态。

若要显示有关任务的错误信息，请双击未正确执行的任务。

选项

步骤

在步骤中执行的任务的名称。

状态

显示步骤的执行进度以及步骤是否成功完成。对于报告处理的行数（显示在括号中）的任务，该数字表示从源读取的总行数，而非成功处理的行数。

请参见

执行 DTS 包