ActiveX 脚本任务属性

使用此对话框指定代码，以执行自定义数据转换服务 (DTS) 包时所需要的功能（例如，跳过一行含有无效数据的源数据）。

选项

描述

指定对 Microsoft® ActiveX® 脚本任务的描述。此描述将作为 DTS 设计器设计表中该任务图标的标签。

语言选项卡

该选项卡用于指定脚本语言和在 ActiveX 脚本中使用的功能。

语言
选择可用的脚本语言。在计算机上安装脚本语言时，该列表将自动更新。默认情况下，可以使用 Microsoft Visual Basic® Scripting Edition (VBScript) 和 Microsoft JScript®。
函数
从脚本语言库中选择将放入"ActiveX 脚本文本框"的函数。双击函数名，将函数代码插入光标处的文本框。
入口函数
指定在脚本运行时将成为入口点的函数名。只能为 ActiveX 脚本任务指定一个入口函数。

浏览器选项卡

查看含有返回代码常量、包全局变量以及可在 ActiveX 脚本中使用的查阅的树。若要将信息复制到"ActiveX 脚本文本框"中，请展开这些节点并双击其中一项。

ActiveX 脚本文本框

写入或粘贴执行所需函数时必需的脚本代码。该脚本编辑器的功能有限。它不具有完成语句或对保留字进行颜色编码这类功能。注释行在任何列中都使用省略符号 (') 字符语法，而且从注释字符到行尾的所有文本都被忽略。

自动生成

如果选定的脚本语言支持，则生成一个函数和一行包含返回代码的代码。

重要 如果"ActiveX 脚本文本框"中存在脚本代码，则单击"自动生成"时将删除该代码。

浏览

显示"选择文件"对话框，在此对话框中可选择包含代码的文件。选择文件时，文件的内容即被复制到"ActiveX 脚本文本框"中。

重要 从"选择文件"对话框打开外部脚本文件的操作将重写"ActiveX 脚本文本框"中的任何现有代码。因此，应始终在将任何其它代码插入该框之前选择代码文件。

分析

检查代码中的语法错误。

保存

显示"另存为"对话框，通过此对话框可以将 ActiveX 脚本文本框内的所有代码存入本地硬盘或任何映射驱动器上的文件中。

撤消

撤消有限次数的文本项操作。无法撤消通过"选择文件"对话框添加代码这样的操作。

请参见

在 DTS 中使用 ActiveX 脚本

在 DTS 包中使用全局变量

调试 ActiveX 脚本

在 DTS 中使用返回代码

ActiveScriptTask 对象


ActiveX 脚本转换属性

使用此对话框定义 Microsoft® ActiveX® 脚本的转换。这样使用 ActiveX 脚本时，将为每个源数据行执行转换。

选项

语言选项卡

该选项卡用于指定脚本语言和在 ActiveX 脚本中使用的功能。

语言
选择可用的脚本语言。在计算机上安装脚本语言时，该列表将自动更新。默认情况下，可以使用 Microsoft Visual Basic® Scripting Edition (VBScript) 和 Microsoft JScript®。
函数
从脚本语言库中选择将放入"ActiveX 脚本文本框"的函数。双击函数名，将函数代码插入光标处的文本框。
入口函数
指定 ActiveX 脚本运行时作为入口点的函数名。如果是为各数据抽取阶段添加函数，这里的函数仅指行转换阶段的入口函数。如果不是为行转换阶段添加函数，则禁用该选项。

浏览器选项卡

查看含有返回代码常量、包全局变量以及可在 ActiveX 脚本中使用的查阅的树。单击节点将节点展开，然后双击某项，将该信息复制到"ActiveX 脚本文本框"中。

阶段选项卡

选择计划向其添加 ActiveX 脚本的数据抽取阶段，然后在相应的阶段名下键入每个函数的名称。对于选定的每个阶段，必须在文本框中包含 ActiveX 脚本函数，脚本框中的函数名必须与在此选项卡中输入的函数名相匹配。

说明 只有当启用了 SQL Server 企业管理器中的多阶段数据抽取功能时，此选项卡才会出现。

ActiveX 脚本文本框

写入或粘贴执行所需函数时必需的脚本代码。该脚本编辑器的功能有限。它不具有完成语句或对保留字进行颜色编码这类功能。注释行在任何列中都使用省略符号 (') 字符语法，而且从注释字符到行尾的所有文本都被忽略。

自动生成

如果选定的脚本语言支持，则生成单个函数和一行包含返回代码的代码。

重要 如果"ActiveX 脚本文本框"中存在脚本代码，则单击"自动生成"时将删除该代码。

浏览

显示"选择文件"对话框，在此对话框中可选择包含代码的文件。选择文件时，文件的内容即被复制到"ActiveX 脚本文本框"中。

重要 从"选择文件"对话框打开外部脚本文件的操作将重写"ActiveX 脚本文本框"中的任何现有代码。因此，应始终在将任何其它代码插入该框之前选择代码文件。

分析

检查 ActiveX 脚本的语法。

保存

显示"另存为"对话框，通过此对话框可将"ActiveX 脚本文本框"内的所有代码存入本地硬盘或任何映射驱动器上的文件中。

撤消

撤消有限次数的文本项操作。无法撤消通过"选择文件"对话框添加代码这样的操作。

测试

可通过在部分源数据上执行转换，然后将结果复制到临时文本文件中进行预览的办法来测试转换。该选项不能用于测试数据驱动的查询任务中的 ActiveX 脚本转换。

由于测试模式是将数据发送到文件而不是实际的目的，可能检测不出由于提供程序、目的或数据类型溢出引起的问题。

请参见

在 DTS 中使用 ActiveX 脚本

映射列转换

在 DTS 包中使用全局变量

调试 ActiveX 脚本

在 DTS 中使用返回代码

多阶段数据抽取功能


添加/编辑赋值

使用此对话框指定将给其动态赋值的属性的源。

选项

源

从列表中选择可用的源。动态属性值的源可以是 .ini 文件、SQL 查询、全局变量、环境变量、常量或数据文件。

源信息

进一步指定析取动态属性值所需的源信息。选择的"源"不同，可用的选项也不同。

文件
对于"INI 文件"源或"数据文件"源，选择要析取其属性值的文件。
章节
对于"INI 文件"源，从列表中选择文件中包含属性值的节。
键
对于"INI 文件"源，从列表中选择包含属性值的键。
预览
查看要给其动态赋值的属性的当前值。
刷新
根据最新的信息重新显示在"预览"框中显示的属性值。
连接
从列表中选择可用的数据转换服务 (DTS) 连接。
查询
键入 SQL 查询，其结果集将被动态指派给选定的属性。在将查询结果指派给 DTS 包属性时，动态属性任务只使用第一行第一列的结果。
分析
检查 SQL 查询的语法。
浏览
显示"选择文件"对话框，从此对话框中可以选择包含要输入"查询"框中的 SQL 查询的 .sql 文件。
变量
从列表中选择全局变量或环境变量。
创建全局变量
创建可用于动态属性赋值选择的全局变量。
常量
键入要赋给选定属性的常量值。
选择
从 DTS 常量列表中选择属性值。

请参见

动态属性任务

DynamicPropertiesTask 对象

在 DTS 包中使用全局变量


高级复制选项

使用此对话框指定要在 Microsoft® SQL Server™ 数据库之间传输的对象。

选项

传输数据库用户和数据库角色

传输所有数据库用户和角色。

传输 SQL Server 登录（Windows 和 SQL Server 登录）

传输所有 SQL Server 登录。

传输对象级权限

传输所有对象级权限。

传输索引

如果可能，为所有已传输的表传输索引。

传输触发器

如果可能，为所有已传输的表传输触发器。

传输全文索引

如果可能，为所有已传输的表传输全文索引。

传输主键和外键

为所有已传输的表传输主键和外键。

生成 Unicode 形式的脚本

按 Unicode 形式传输数据。源数据包含 nchar 数据类型时有用。有关 Unicode 的更多信息，请参见 Unicode 数据。

传输对象时使用引用的标识符

用引号括起所有对象名。

请参见

复制 SQL Server 对象任务

传输对象


高级连接属性

使用此对话框为某些 OLE DB 初始化属性设置自定义值。可用于自定义的 OLE DB 高级属性因特定提供程序所支持的属性而异。

若要更改 OLE DB 属性值，请在"值"下单击某个单元，然后键入新值。

说明 如果需要以更接近 OLE DB 级的方式工作，请使用 OLE DB 行集查看器，该查看器随 OLE DB 软件开发工具包 (SDK) 一起提供。OLE DB 行集查看器提供了查看和操作 OLE DB 行集的简单方法，新增了可从任何 OLE DB 提供程序所支持的数据源、会话、命令、行集、事务和提示对象调用和操作其它 OLE DB 方法的能力。

请参见

DTS 连接


大容量插入任务属性（常规选项卡）

使用此选项卡指定大容量插入任务属性，以便从数据文件中导入数据并将其复制到指定的 Microsoft® SQL Server™ 表或视图中。

大容量插入属性中的参数对应于 Bulk Insert 命令中的大多数参数。有关用户接口中任何选项的更多信息，请参见 BULK INSERT。

选项

描述

描述大容量插入任务。此描述将成为置于数据转换服务 (DTS) 设计器设计表中的任务标签。

现有连接

选择 SQL Server 连接，为数据指定相应的目的数据库。

目的表

指定要将数据复制到的数据库中的 SQL Server 表或视图。

刷新

填充 Microsoft Windows® 98 计算机上的数据库列表。

源数据文件

指定包含要复制数据的文件名。单击浏览（"..."）按钮搜索源数据文件。

使用格式文件

指定格式文件的完整路径和名称。格式文件描述数据文件的内容，是使用 bcp 实用工具创建的。单击浏览（"..."）按钮搜索源数据文件。

指定格式

指定源数据文件中行和列的分隔符，以确保读取时对该文件的分析正确。

行分隔符
指定在源文件中表示每行数据行尾的分隔符。默认情况下使用新行分隔符 {LF}。
列分隔符
指定在源文件中表示每行的列尾的分隔符。默认情况下使用 Tab 键。

生成

显示"选择数据文件和格式文件"对话框，可以在此对话框的本地计算机及所有映射的网络驱动程序上搜索源数据文件及其相关格式文件。在保存或执行大容量插入任务之前显示数据预览。

请参见

大容量插入任务

BulkInsertTask 对象


大容量插入任务属性（选项选项卡）

使用本选项卡指定属性以组织文件。

检查约束

确保在大容量复制操作中检查目的表中的任意约束。默认情况下，将会忽略约束。

启用标识插入

指定数据文件中有用于标识列的值。

排序数据

向任务说明数据文件中的数据已在指定列上进行了排序。所提供的列名必须是目的表中有效的列。

保留 NULL 值

指定任何包含空值的列应保留空值，即使目的表中该列已指定了默认值。

锁定整个表

指定大容量插入操作过程中目的表上的表级锁。

代码页

向任务说明用户的数据文件中存在字符值大于 127 或小于 32 的 char、varchar 或 text 列，并要求用户选择适当的代码页值以便正确分析数据。

数据文件类型

指定数据文件中的数据类型。

插入批处理大小

指定批处理中的行数。默认设置为整个数据文件。

下面的"批处理大小"属性值的效果如下所示：

如果将"批处理大小"设置为零，则数据在单个批处理中装载。第一行装入失败将导致整个装载被取消，操作失败。

如果将"批处理大小"设置为一，则一次装载一行数据。每行失败均计为一行失败。先前装载的行可以提交，或如果该步操作已联接包事务，则临时保留在该事务中等待以后提交或回滚。

如果将"批处理大小"设置为大于一的值，则一次装载一个批处理的数据。该批处理中任何一行失败，则整个批处理失败、装载停止而且该步骤失败。先前装载的批处理中的行可以提交，或如果该步操作已联接包事务，则临时保留在该事务中等待以后提交或回滚。

只复制所选行

指定是否应在一个范围内复制连续范围的行。

从下面的行开始
指定要开始复制的第一行。
于下面的行停止
指定要复制的最后一行。

请参见

BULK INSERT

大容量插入任务

BulkInsertTask 对象


日历名

使用此对话框：

  • 更改代表不同月份、星期几以及 A.M. 和 P.M. 表示法的字符串。

  • 更改用于表示日期和时间数据的语言。
选项

名称

标识月份、日或 A.M. 和 P.M. 表示。

值

查看或更改月份、日或 A.M. 和 P.M. 表示的当前值。

语言

选择用于表示日期和时间数据的语言。

设置默认语言

设置"日期时间字符串"转换中所用数据的默认语言。在"语言"列表中选择某种语言后单击此选项，可以将该语言设置为默认语言。

请参见

日期时间字符串转换

转换类型

映射列转换


列顺序

使用此对话框查看转换中映射的源列和目的列的名称，并更改所包含的源列和目的列。对于转换中的源列数和目的列数不等的情况（如将单个源列复制到多个目的列），可能需要更改列映射的顺序。

选项

列文本框

编辑列映射的方法是：单击一个"源"单元或一个"目的"单元，从列表中选择一个列名或选择 <ignore>，然后重复此步骤以编辑其它"源"单元或"目的"单元。

请参见

映射列转换

复制列转换

转换类型


确认包所有者密码

使用此对话框确认所有者密码。

选项

密码文本框

通过重新键入密码，可以验证在"保存 DTS 包"中键入的所有者密码。如果已经设置了所有者密码，则数据转换服务 (DTS) 包用户需要该密码来编辑或运行该包。

请参见

在 DTS 中处理包安全性


确认包用户密码

使用此对话框确认数据转换服务 (DTS) 包用户密码。

选项

密码文本框

通过重新键入密码，可以验证在"保存 DTS 包"中键入的用户密码。只有拥有此用户密码权限的用户才能运行该程序包。但是，这些用户既不能打开也不能编辑包，除非他们还拥有所有者密码权限。

请参见

在 DTS 中处理包安全性


连接属性

通过此对话框添加与数据源的连接，该连接可以是一个新的连接，也可以是现有连接的复本。下列选项并非都能用于所有提供程序。哪些选项的子集可用，取决于选定的提供程序。

选项

新建连接

命名与数据源的新连接。

现有连接

选择与数据源的现有连接。

数据源

从可用提供程序列表中选择一个 OLE DB 提供程序。默认情况下，选择用于 SQL Server 的 Microsoft® OLE DB 提供程序。如果数据源或数据目的是 Microsoft® SQL Server™ 实例，则建议使用此提供程序，因为它提供了高性能大容量装载数据、复制和转换数据时设置批处理大小等选项。

文件名

指定保存导入数据的数据库路径和文件名（例如，C:\MyData.xls, \\Sales\Database\Northwind.mdb）。

用户名

为数据库连接指定用户名。

密码

为数据库连接指定密码。

UDL 文件名

指定包含连接字符串的数据链接 (.udl) 文件的名称。

总是从 UDL 文件读取属性

指定在运行时数据链接 (.udl) 文件中的包解析信息。如果不选择此复选框，则将连接字符串从 .udl 文件复制到包中，而不再引用该文件。以后只有通过直接编辑数据转换服务 (DTS) 包才能修改连接更改。

属性

显示"数据链接属性"对话框。在此对话框中所做的更改将包含于当前会话期间创建的包中，而不会更改数据链接文件。

用户/系统 DSN

指定现有用户的名称或指定指向数据源的系统数据源名称 (DSN)。

新建

显示创建 ODBC DSN 的"创建新数据源"对话框。有关创建 ODBC 数据源的更多信息，请搜索位于 Microsoft Web 站点 的 MSDN® Library 中的 Platform SDK 节。

文件 DSN

指定指向数据源的现有文件 DSN 的名称。

服务器

指定存放数据源的服务器名称。

使用 Windows 身份验证

指定该包使用 Windows 身份验证登录到 SQL Server 实例上。

使用 SQL Server 身份验证

指定包使用 SQL Server 身份验证登录到 SQL Server 实例。

数据库

列出指定 SQL Server 实例上的数据库。

刷新

使得在 Microsoft Windows® 98 计算机填充数据库列表。

高级

显示"高级连接属性"对话框，在此对话框中可以输入自定义设置。有关 OLE DB 连接属性的更多信息，请搜索位于 Microsoft Web 站点的 MSDN Library 中的 Microsoft OLE DB 节。

请参见

DTS 连接

数据链接连接

转换数据任务


复制 SQL Server 对象任务（源选项卡）

使用此选项卡选择数据的复制源，并提供合适的安全上下文，以使用户能够访问数据库。

选项

描述

指定对"复制 SQL Server 对象"任务的可选描述。该文本将成为数据转换服务 (DTS) 设计器设计表上"复制 SQL Server 对象"任务图标的名称。

服务器

指定包含数据源的服务器名称。

使用 Windows 身份验证

指定包使用 Windows 身份验证登录到 Microsoft® SQL Server™ 数据库。

使用 SQL Server 身份验证

指定包使用 SQL Server 身份验证登录到 SQL Server 数据库。

用户名

为数据库连接指定用户名。

密码

为数据库连接指定密码。

数据库

列出指定的服务器上的数据库。

刷新

使得在运行 Microsoft Windows® 98 的计算机上填充数据库列表。

请参见

复制 SQL Server 对象任务

TransferObjectsTask 对象


复制 SQL Server 对象任务（目的选项卡）

使用此选项卡指定数据的复制目的地，并提供合适的安全上下文，以使用户能够访问数据库。

服务器

指定包含数据源的服务器名称。

使用 Windows 身份验证

指定包使用 Windows 身份验证登录到 Microsoft® SQL Server™ 数据库。

使用 SQL Server 身份验证

指定包使用 SQL Server 身份验证登录到 SQL Server 数据库。

用户名

为数据库连接指定用户名。

密码

为数据库连接指定密码。

数据库

列出指定的服务器上的数据库。

刷新

使得在 Microsoft Windows® 98 计算机填充数据库列表。

请参见

复制 SQL Server 对象任务


复制 SQL Server 对象任务（复制选项卡）

使用此对话框指定要在 Microsoft® SQL Server™ 数据库之间传输的对象。对象传输只能在 SQL Server 7.0 版数据库之间、从 SQL Server 7.0 数据库到 SQL Server 2000 数据库和在 SQL Server 2000 数据库之间进行。

创建目的对象

为所有要传输的对象创建目的对象（包括表、视图、存储过程、默认值、规则、约束、用户定义的数据类型、登录、用户、角色和索引）。指定下列复制选项：

首先丢弃目的对象
创建新目的对象之前，丢弃所有相应的目的对象。
包括所有相关对象
在数据传输中包括所有相关对象，例如支持视图的表。

复制数据

启用将 SQL Server 数据从源复制到目的。指定下列复制选项：

替换现有数据
用指定的源中的新数据改写目的对象中现有数据。
追加数据
保留目的对象的现有数据，并从指定的源追加新数据。

使用排序规则

启用在不同排序规则间复制数据。有关在数据转换服务 (DTS) 中使用不同排序规则的更多信息，请参见数据转换和交换注意事项。

复制所有对象

传输所有与指定的数据源关联的对象。

选择对象

显示"选择对象"对话框，使用此对话框可以在传输进程中选择或删除对象。清除"传输所有对象"复选框启动此选项。

使用默认选项

将各高级传输选项设置为默认值。

选项

显示"高级复制选项"对话框，在此对话框中可以选择或删除要传输的特定对象。清除"使用默认选项"复选框启用此选项。

脚本文件目录

指定脚本文件和日志文件编写到的目录。该脚本文件目录必须存在于任务所运行的计算机上。

请参见

复制 SQL Server 对象任务

TransferObjectsTask2 对象


创建绑定表

使用此对话框为参数化查询所使用的绑定表编写 SQL CREATE TABLE 语句，或者自定义现有的绑定表。默认情况下，数据转换服务 (DTS) 设计器对选定的源表显示 CREATE TABLE 语句。可以编辑表名或任意列的定义。但由于新的绑定表会立即在目的数据库中生成，所以使用时请多加小心。

请参见

生成数据驱动的查询


创建数据库

使用此对话框为数据源连接定义新的数据库。仅当通过用于 SQL Server 的 Microsoft OLE DB 提供程序或用于 ODBC 的 Microsoft OLE DB 提供程序连接到 Microsoft® SQL Server™ 实例上时，才能定义新的数据库。该数据库文件将放置到与 master 数据库文件相同的位置上。如果无法新建数据库，请确认自己的登录是否有相应的权限。

提供此对话框是为了使操作简单方便，它并不包含所有可用于创建数据库的选项。若要能够访问所有选项，请单击 SQL Server 企业管理器中的"新建数据库"。

确保遵从 SQL Server 的数据库命名规则，并适当设置新数据库的数据文件大小和日志文件大小。有关更多信息，请参见 SQL Server 2000 实例命名规则。

请参见

创建数据库


创建目的表

使用此对话框为目的表编写 SQL CREATE TABLE 语句，或自定义现有的目的表。默认情况下，数据转换服务 (DTS) 设计器对选定的源表显示 CREATE TABLE 语句。可以编辑表名或任意列的定义，但由于会在目的数据库中立即创建新表，所以请多加小心。


创建新的转换

使用此对话框从列表中选择一个转换，将其应用于源列和目的列。此列表包括数据转换服务 (DTS) 提供的所有转换类型，以及已经添加和注册的任何自定义转换。

最常用的转换类型是"复制列"和"ActiveX 脚本"。如果只想将数据从源复制到目的而不需要转换数据，则使用"复制列"。如果打算使用脚本代码转换数据，则使用"ActiveX 脚本"。

请参见

映射列转换

转换类型


自定义任务属性

使用此对话框查看数据转换服务 (DTS) 自定义任务的属性。列出所有属性，但并非所有列出的属性都可以编辑（例如，象 image 这样的 BLOB 数据就不能在此对话框中编辑）。如果某个属性可以编辑，则单击"值"列中的相应单元然后键入新值。

请参见

DTS 自定义任务

生成 DTS 自定义任务

CustomTask 属性

CustomTask 对象

CustomTaskUI 对象


自定义转换属性

使用此对话框查看和编辑自定义转换的属性。只有当已将自定义转换装入数据转换服务 (DTS) 设计器并且没有编写用于转换的用户界面时，才出现此对话框。

此对话框中列出的属性专门用于如何编写转换，用于编辑的属性亦如此。若要编辑自定义转换属性值，请在表中单击该行的"值"单元并键入新值。

请参见

生成 DTS 自定义转换


数据驱动的查询任务属性（源选项卡）

使用此选项卡选择表或视图，或者选择作为数据驱动查询的数据源的查询结果。

选项

描述

键入对数据驱动的查询任务的描述。

连接

从列表中选择与数据源的现有连接。

表/视图

从连接上指定的数据源中选择表或视图。行不一定有序。

SQL 查询

指定 SQL 语句从数据源中检索数据。键入 SQL 语句。

参数

将全局变量映射到输入参数。此选项只能在指定包含参数的 SQL 查询（用一个或多个问号作为参数占位符）之后执行。

预览

查看选定的源表或视图中的数据。

说明 如果源连接是 dBase 数据源且指定了 SQL 查询，则源数据可能无法用于查看。

生成查询

使用数据转换服务 (DTS) 查询设计器创建在数据源上执行的 SQL 语句。

浏览

指定要执行的 SQL 查询的位置。

分析查询

在执行 SQL 语句前检查其语法。

请参见

数据驱动的查询任务

在 DTS 中使用参数化查询


数据驱动的查询任务属性（绑定选项卡）

使用此选项卡对数据驱动的查询参数将映射到的绑定进行配置。如果打算在数据驱动的查询任务中使用多个查询，则绑定表必须包含查询中所有参数的列。

选项

连接

选择作为参数绑定表基础的现有数据源连接。

表名

选择用于参数绑定的现有表。确保表包含要定义的查询中所有参数的列。

创建

创建用于参数的新绑定表。必须存在绑定表才能指定转换。

名称

查看列名。

类型

使用 OLE DB 数据类型映射查看目的本机数据类型。

为空性

查看绑定列是否允许空值。默认设置为真。

大小

查看适用的绑定列的宽度。

精度

查看适用的绑定列的精度。

小数位数

查看适用的小数位数中的位数。

请参见

数据驱动的查询任务


数据驱动的查询任务属性（转换选项卡）

使用此选项卡选择并以图形方式映射构成每个转换的源和绑定列。不要求以图形方式映射转换。相反，可使用"转换选项"对话框中的选择框指定转换的源列和目的列。

在此选项卡上，列映射由"源"和"绑定表"框中连接列的箭头表示。默认情况下，数据驱动的查询任务使用单个多对多映射来映射相等数量的匹配源和绑定表列。

重要 除非您是高级用户或有专门的需要，否则不需要更改数据驱动的查询任务的默认列映射。

选项

阶段筛选

选择要添加转换的数据抽取阶段。只有在 SQL Server 企业管理器中选择"在 DTS 设计器中显示多阶段抽取"复选框时，才能使用此高级选项。默认设置为"行转换"阶段。

名称

查看选定转换的名称。必须在映射行上单击才能显示转换的名称。否则显示 <无选定内容>。默认情况下，转换名为 DTS_Transformation_n，n 等于已映射的转换的有序位置。

类型

查看选定映射的列级转换类型。必须在映射行上单击才能显示转换类型。否则显示 <无选定内容>。如果想要创建新转换，则忽略该值。

新建

显示"创建新转换"对话框，在此对话框中选择列级转换类型。

编辑

显示"转换选项"对话框，在此对话框中可以修改现有转换。单击"编辑"前，选择要修改的转换的映射行。

删除

删除选定的转换。单击"删除"前，选择表示要从任务中删除的转换的映射行。

源

以图形方式查看源数据列，并单击转换中包括的一列或多列。

绑定表

以图形方式查看绑定表的列，并单击要包含在转换中的一列或多列。

全选

选择所有源列和目的列。若要创建多对多转换映射类型，请使用"全选"。

全部删除

删除所有转换。单击"删除"前，选择表示要从任务中删除的转换的映射行。

请参见

映射列转换

数据驱动的查询任务

多阶段数据抽取功能


数据驱动的查询任务属性（查询选项卡）

使用此选项卡查询并设置源行集的属性。

选项

查询类型

选择要执行的数据驱动的查询类型。选项包括"插入"、"更新"、"删除"或"用户"（存储过程）。

查询类型标签仅作为建议。可使用"插入"选项的"查询类型"执行"更新"，使用"删除"选项的"查询类型"执行"插入"，等等。为了方便阅读，可能需要使用与打算使用的查询类型相匹配的标签。

生成

使用数据转换服务 (DTS) 查询设计器创建要执行的参数化 SQL 语句。

分析/显示参数

检查 SQL 语句的语法并列出任何映射到"转换"选项卡上的绑定列的参数。

目的

表示映射参数的绑定列。

参数

表示映射到绑定列的相应参数。

请参见

生成数据驱动的查询

数据驱动的查询示例：更改客户帐户


数据驱动的查询任务属性（查找选项卡）

使用此选项卡定义查找查询。在定义查找查询之前，必须首先创建源表、绑定表和查找表的连接，并指定源表和绑定表。有关更多信息，请参见查找查询。

选项

名称

键入查找的名称。

连接

选择要在其上执行查找查询的现有连接。

高速缓存

指定保存在高速缓存中的查找结果的数目。如果要转换的行数很多，并且正在查询查找表中较少的行数，使用高速缓存查找尤其有用。

查询

在数据转换服务 (DTS) 查询设计器中生成查找查询。也可将文本编辑器中的查询粘贴到 SQL 窗格中。

添加

创建新的查找查询，此查询将列为 Lookups 表中的一行。

删除

从 Lookups 表中删除突出显示的查找查询。

请参见

配置简单的查找查询

在 DTS 中使用 ActiveX 脚本


数据驱动的查询任务属性（选项选项卡）

使用此选项卡将行发送到异常错误文件，确定该文件的格式，并设置达到多少错误计数时包应停止执行。异常错误文件存储在本地或映射驱动器上。

选项
异常错误文件区域

名称

指定异常错误记录将写入的文件的路径和名称。如果在运行包时不存在该文件，则创建该文件。未给该文件指派默认扩展名。

单击浏览（"..."）按钮在本地计算机或映射驱动器上查找现有的异常错误文件。如果使用现有异常错误文件，则将追加包的状态和错误信息。

文件类型区域

7.0 格式

指定以 7.0 格式保存异常错误文件。如果为 Microsoft® SQL Server™ 7.0 版异常错误文件编写了异常错误文件语法分析器，则此格式很有用，因为使用此向后兼容格式的异常错误文件仍可用于此语法分析器。

错误文本

指定记录在执行任务过程中遇到的所有错误。如果选择此选项，将记录数据转换服务 (DTS) 包名称、执行的开始和完成时间，以及异常错误日志中的其它数据等信息。

源错误行

指定创建单独的异常错误文件包含源数据中没有写入绑定表的所有行。根据指定的"文件格式属性"格式化该文件。该文件名与在"名称"字段中指定的带 .Source 扩展名的名称相同，并且与异常错误文件位于同一目录中。

目的错误行

创建一个单独的异常错误文件，记录有关尝试写入目的时失败的行的错误信息。该文件名将与在"名称"字段中指定的带 .Dest 扩展名的名称相同，并且与异常错误文件位于同一目录中。

文件格式区域

行分隔符

选择用于分隔异常错误文件数据行的分隔符。默认情况下使用回车符/换行符 {CR}{LF}。

列分隔符

选择用于分隔异常错误文件数据列的分隔符。默认情况下使用垂直条。

文本限定符

指定在分隔的数据文件中用来限定文本的字符标记。从以下几项中选择：双引号 {"}、单引号 {'} 和 <无>。也可以键入字符，用作文本限定符。

数据移动区域

最大错误计数

设置对终止处理任务前所允许的错误数的限制。当超过"最大错误计数"值时，任务执行将终止。默认值为 0，表示发生第一个错误时终止任务。

提取缓冲区大小

设置数据移动过程中在源位置提取的数据行的数目。一般不必调整该值，除非有必要优化数据提供程序的特性。

首行

指定要移动的数据首行。如果首行由列标题组成，或者已复制数据源的第一部分，则此选项很有用；可以将该值设置为更早的数据抽取操作中处理停止时的行数。

末行

指定要移动的数据末行。

请参见

转换数据的任务

数据驱动的查询任务


日期时间字符串转换属性

使用此对话框选择转换中使用的源和目的日期时间数据的格式。可以重新设置日期和时间源数据的格式，并通过任一可用格式将其复制到目的。

选项

源

用这些选项指定源数据格式。

日期格式
从列表中选择可用的日期时间格式。
预览
查看以选定的日期格式表示的当前日期和时间。

目的

用这些选项指定目的数据格式。

日期格式
从列表中选择可用的日期时间格式。
预览
查看以选定的日期格式表示的当前日期和时间。

2000 年截止日期

用于指定代表截止年份的整数，以便将两位数的年份视为四位数的年份。比"2000 年截止日期"的后两位数字小或者与其相等的两位数年份处于"2000 年截止日期"之前的世纪。而比"2000 年截止日期"的后两位数字大的两位数年份与"2000 年截止日期"处于同一个世纪。

命名

当复制转换的日期和时间信息时，重命名日期和时间信息或重新设置所用的语言。

请参见

日期时间字符串转换

转换类型

映射列转换


定义列

当目的为文本文件时，使用此对话框指定列及其特性。

选项

表列

在文本文件中定义列。默认情况下，在源中选定的所有列都被复制到目的。

名称
选择是否 <ignore> 目的中的列。
类型
选择列中的数据是"可引用"还是"不可引用"。
大小
键入选定目的列的列大小。
二进制
选择目的列中的数据是否为二进制。

从源填充

将列架构从源复制到目的，并重写任何更改。在选择此选项后，仍可修改列和列特性。

执行

用在对话框中输入的值定义目的。


定义行宽

当文本文件中不含分隔符时，使用此对话框定义该文件中的数据行宽（必须已对"行分隔符"选择了"无"）。选定红线并拖动它以指定希望行中所含的字符数，字符数如"值"框所示。也可以单击"值"框旁的箭头设置行宽。


DTS 包属性（常规选项卡）

使用此选项卡查看数据转换服务 (DTS) 包的常规属性。

选项

名称

查看包名称。

描述

键入对文本包的描述。

包 GUID

查看包的全局唯一标识符 (GUID)，即一个 128 位的唯一数字。

版本 GUID

查看包版本的全局唯一标识符 (GUID)，即一个 128 位的唯一数字。如果包只有一个版本，则此数字与包 GUID 相同；如果包有多个版本，则版本 GUID 也不同。

创建者姓名

查看创建包的用户的姓名（DTS Package.CreatorName 属性）。在运行 Microsoft® Windows® 98 的计算机上，该字段可能为空；当非空时，它包含域名和用户名。

计算机

查看在其上创建包的计算机名（Microsoft Win32® 计算机名，存储在 Package.CreatorComputerName 属性中）。

日期

查看创建包的日期（Package.CreationDate 属性）。

优先级

指定 Windows 进程的优先级（Package.PackagePriorityClass 属性）。可能的值有"低"、"正常"和"高"。

将并行执行的任务的最大数限制为

指定可以并发执行的最大任务数。可以是任何 32 位的正整数。默认值为 4。

将此值设置过高会减慢包执行的速度，设置过低则会减慢执行并发步骤的速度。

请参见

管理 DTS 包属性


DTS 包属性（全局变量选项卡）

使用此选项卡查看有关全局变量的信息，而全局变量可由数据转换服务 (DTS) 包中的任何 Microsoft® ActiveX® 脚本引用。这些脚本可用于自定义任务、工作流步骤和转换。在此选项卡上定义的全局变量保留在包生命期的作用域中。

在此选项卡中所创建的全局变量的值和包一起保存。还可以在 ActiveX 脚本中动态创建全局变量并在其中使用，例如：

DTSGlobalVariables("NewGlobalVariable").Value = 5

用上述方式创建的全局变量不和包一起保存，且不会出现在"全局变量"选项卡上。

选项

名称

指定全局变量名称。可以编辑现有名称，也可单击"新建"后在单元格中键入一个新名称。

类型

从列表中指定全局变量的数据类型。

值

指定指派给变量的初始值。

显式全局变量

指定在 ActiveX 脚本中使用的全局变量在使用前必须在该对话框中或"执行 SQL 任务"对话框中定义。通过设置"显式全局变量"，将强制声明每个全局变量，正如在打开"选项显式"时在 Microsoft Visual Basic® 中所做的一样。

新建

在包中添加全局变量。单击"新建"在 Variables 表中插入一个空行。

删除

从包中删除选定的全局变量。

请参见

在 DTS 包中使用全局变量


DTS 包属性（日志记录选项卡）

使用此选项卡保存有关数据转换服务 (DTS) 包执行的信息。可以指定想要保存包错误的位置，并决定如果遇到错误时包是否停止运行。也可将包执行的状态保存到 Microsoft® SQL Server™，并指定如果日志文件遇到问题则停止运行包。

选项

将包记录执行日志记录到 SQL Server

指定想要将包和步骤执行数据保存到 msdb 数据库。有关包的信息将保存到 sysdtspackagelog 文件，有关包中每个步骤的信息将保存到 sysdtssteplog。在日志中不存储有关未执行的步骤的信息。

服务器

指定其 msdb 数据库将成为日志记录信息存储区的服务器名。

使用 Windows 身份验证

指定使用 Windows 身份验证登录到 msdb 数据库所驻留的 SQL Server 实例。

使用 SQL Server 身份验证

指定使用 SQL Server 身份验证登录到 msdb 数据库所驻留的 SQL Server 数据库。

用户名

指定用于 msdb 数据库连接的用户名。

密码

指定用于 msdb 数据库连接的密码。

出现日志错误时使包失败

指定对服务器日志的写入失败将停止进一步执行包。事件日志缓冲区过小，或重命名服务器日志表会导致日志错误。

删除日志

指定想要从 msdb 数据库中立即删除该包所保存的所有日志。

错误文件

指定包和步骤状态以及错误信息写入的文件名。除了已执行的步骤及其结果外，该文件还包含未执行的步骤列表。该文件可位于本地驱动器或映射驱动器上。如果在运行包时不存在该文件，则创建该文件。该文件没有指派的默认扩展名；必须将扩展名放到文件名中。最常见的扩展名是 .txt。

浏览

显示"选择文件"对话框，在该对话框中可搜索本地计算机或映射驱动器查找现有的错误文件。如果使用现有错误文件，将追加包的状态和错误信息。

第一次出错时使包失败

指定第一步失败将停止运行整个包。剩下的任何步骤或任务都不运行。如果没有选定该选项，则不管任何步骤中的任何失败，包都将继续运行。包将以成功状态完成。

将完成状态写入事件日志

指定想要将包执行状态写入 Microsoft Windows® 应用程序日志。该选项仅在运行 Windows NT 4.0 和 Windows 2000 的计算机上可用。有关更多信息，请参见如何查看 Windows 应用程序日志 (Windows)。

请参见

使用 DTS 包日志


DTS 包属性（高级选项卡）

使用此选项卡指定数据沿袭属性、Microsoft® SQL Server™ 2000 Meta Data Services 扫描选项和数据转换服务 (DTS) 的事务设置。这使您得以做下列事情：

  • DTS 的数据沿袭功能使您得以确定应用于数据的任何数据块和转换的源。

  • Meta Data Services 扫描选项是使包所引用的对象与 Meta Data Services 中的目录元数据相关联的设置。

  • DTS 还提供事务功能，使您得以将工作流中的任务指派给事务，并根据事务单元是成功还是失败来提交或回滚个别步骤。"高级"选项卡上的设置使您得以打开事务功能，并设置这些功能的提交模式和隔离级别。

    说明 并非所有的 OLE DB 提供程序都支持事务或特定事务功能。有关更多信息，请参见个别提供程序的文档。

如果正将 DTS 包保存到 Meta Data Services 中，则只能使用这些选项的前两组。如果在单击任何这些选项后试图将包保存到任何其它位置或格式，DTS 设计器会提示您将该包保存到 Meta Data Services。

选项

名称

查看包名称。

将沿袭变量显示为源列

将全局数据沿袭变量添加到包中，但不将它们写入 Meta Data Services。如果需要创建自定义任务以编写沿袭跟踪和审核信息，则由该选项单击其本身会非常有用。

将沿袭变量写入知识库

指定在保存包时始终将数据沿袭变量写入知识数据库。

选项

设置包的 Meta Data Services扫描选项。

使用事务

允许定义和使用包中工作的事务单元。

成功完成包时提交

指定每个 SQL 语句都是一个事务。如果语句成功完成，则自动提交事务；如果语句有错误，则回滚该语句（OLE DB 的默认设置）。

当清除此设置时，DTS 连接以隐性事务模式进行操作。（第一条 SQL 语句所开始的事务在 DTS 提交或回滚之前将一直有效。由下一条 SQL 语句开始的新事务在提交或回滚之后开始执行。）

事务隔离级别

从下列级别中进行选择：

  • 混沌。可以看到由其它事务所做的未提交更改，但更新锁未保持到事务的结束。不支持回滚。SQL Server 不支持此隔离级别。

  • 提交读。在提交其它事务之前，无法看到这些事务所做的更改。

  • 未提交读。可以看到其它事务所作的未提交更改。

  • 可重复读。在已经读取的值中保证看不到由其它事务所做的任何更改。

  • 可串行读。保证所有并发事务之间的交互作用只与全部逐个执行每个事务时产生的效果相同。

使用 OLE DB 服务组件

如果选择该选项，则使用 OLE DB 服务组件 IDataInitialize::CreateDBInstance（默认设置）实例化 OLE DB 提供程序数据源对象；如果清除该选项，则用 CoCreateInstance 直接实例化数据源对象。

OLE DB 服务组件提供类似会话池和 IRowsetChange 的服务，某些 OLE DB 提供程序可能不支持这些服务。DTS 提供程序（PackageDSO、RowQueue、FlatFile）和用于 SQL Server 的 Microsoft OLE DB 提供程序忽略该设置。

请参见

将事务并入 DTS 包

在 DTS 中记录数据沿袭

管理 DTS 包属性


数据转换服务查询设计器

使用数据转换服务 (DTS) 查询设计器的简单图形界面生成 SQL 命令。

DTS 查询设计器包含一个选择要连接的服务器的选择框以及几个同步窗格，在这些窗格中可以图形方式操作数据和输入生成查询的 SQL 命令文本。

选项

链接服务器

选择要连接的数据库所在的服务器。在数据转换服务 (DTS) 中连接的任何服务器都可用，包括任何已定义的链接服务器。

DTS 查询设计器窗格

DTS 查询设计器包含"表/视图列表"窗格、"关系图"窗格、"网格"窗格、"SQL"窗格和"结果"窗格：

表/视图列表窗格
此窗格显示连接数据库中的表或视图列表。当更改服务器时，表和视图列表将刷新。若要使用此窗格生成查询，请选择一个表或视图并将它拖至"关系图"窗格上。
关系图窗格
此窗格显示正在查询的表和其它表结构化对象。每个矩形都代表一个表或表结构化对象，并显示可用的数据列以及表示每列如何用于查询的图标。矩形之间的联接用线表示。
网格窗格
此窗格包含一个类似电子表格的网格，可以在其中指定选项，如要显示的数据列、要选择的行、行的分组方式等等。有关更多信息，请参见网格窗格。
SQL 窗格
此窗格显示用于查询或视图的 SQL 语句。可以编辑 DTS 查询设计器所创建的 SQL 语句，也可以输入 SQL 语句。对于不能用"关系图"窗格和"网格"窗格创建的 SQL 语句（如 Union 查询），键入这条语句尤其有用。有关更多信息，请参见 SQL 窗格。
结果窗格
此窗格显示含有由查询或视图检索的数据的网格。在 DTS 查询设计器中，该窗格显示最近执行的 Select 查询的结果。可以通过编辑该网格单元中的值对数据库进行修改，而且可以添加或删除行。有关更多信息，请参见结果窗格。在视图设计器中，结果窗格显示视图的内容。

可以在任意窗格内进行操作以创建查询或视图：可以通过在"关系图"窗格中选择某列，将该列输入到"网格"窗格中，或者使其成为"SQL"窗格中 SQL 语句的一部分等方法，指定要显示的列。"关系图"窗格、"网格"窗格和"SQL"窗格是同步的。当在某一窗格中进行更改时，其它窗格自动反映此更改。

请参见

关系图窗格

网格窗格

在查询设计器中浏览

结果窗格

SQL 窗格


动态属性任务属性

使用此选项卡查看将在数据转换服务 (DTS) 包运行时指派的包属性。

描述

键入对动态属性任务的描述。此描述出现在 DTS 设计器设计表中。

目的属性

查看将在运行时给其赋值的包属性名。

源类型

选择下列外部源之一，将为这些外部源指派属性值：

一个 .ini 文件

一个数据文件

一个查询

一个全局变量

一个环境变量

一个常量

源值

查看属性的当前值，该值在每次运行包时都会更改。

添加

显示"包属性"对话框，可以在其中选择要给其动态赋值的新包属性。

编辑

单击此命令以更改"更改"列表中所选属性的动态赋值。

删除

单击此命令以永久删除"更改"列表中的动态属性赋值。

请参见

动态属性任务


动态属性任务：包属性

使用此对话框查看并选择要动态设置的属性。

左窗格显示数据转换服务 (DTS) 包属性的树视图。展开适当的节点以导航到要为其动态赋值的属性所在的组。

右窗格列出属于左窗格中所选属性组的属性的名称和默认值。

选项

添加

从右窗格中选择属性后，单击此命令以显示"添加/编辑赋值"对话框，并用此对话框对属性赋值。

关闭

返回"动态属性任务属性"对话框。

添加设置之后，将此对话框保持为打开状态

一次对多个属性进行赋值。如果清除此框，则在添加设置后，"添加/编辑指派值"对话框将关闭，并显示"动态属性任务属性"对话框。

请参见

动态属性任务


编辑所有包属性

使用此对话框选择要查看或修改其值的数据转换服务 (DTS) 包属性。无法修改所有包属性。

"编辑所有包属性"对话框分为左右两个窗格：

  • 左窗格包含当前包中所有属性组的可扩展树视图。若要表现属性，请单击加号图标展开树视图的分支。在表现包含要查看或修改的属性的属性组之后，通过单击属性名选择属性。

  • 右窗格包含左窗格中选定节点的属性列表。此窗格用于选择要查看或修改其值的个别属性。
选项

编辑

在右窗格中选择完属性后，查看或编辑属性值。

关闭

保存更改并关闭对话框。

请参见

用脱接编辑来编辑 DTS 包属性


编辑属性

用此对话框查看或更改选定的属性。如果无法编辑某个属性，可查看数据，但"类型"框和"值"框是被禁用的。

选项

名称

查看在"编辑所有包属性"对话框中选定的属性名称。

类型

从列表中选择属性的数据类型。

警告 并非所有的数据类型对于选定的属性都有效，而且数据转换服务 (DTS) 设计器不执行任何验证检查。确定所做的任何数据类型更改都有效，或者可以禁用 DTS 包。

值

查看或更改属性值。

请参见

用脱接编辑来编辑 DTS 包属性


执行包任务属性（常规选项卡）

使用执行包任务指定另一个数据转换服务 (DTS) 包作为包执行的一部分运行，并将包含在父包全局变量中的信息传递到子包。

选项

描述

键入执行包任务的文本标签，该标签将出现在数据转换服务 (DTS) 设计器的设计工作表中。

位置

指定将由执行包任务运行的包的保存方式：

保存到 Microsoft® SQL Server™

保存到 SQL Server 2000 Meta Data Services

保存到结构化存储文件

包名称

键入任务将要运行的包名称，或浏览以查找该包。

说明 如果在"选择包"对话框中选择将要运行的特定版本的包，则将始终执行包的那个版本。如果在"选择包"对话框中选择包节点，则将始终运行选定包的最新版本。

密码

如果任务将要运行的包有密码，则键入密码。

包 ID

查看与将要运行的包相关联的全局唯一标识符 (GUID)。

服务器

从可用服务器列表中选择包含将要运行的外部包的服务器名称（仅适用于 SQL Server 和 SQL Server Meta Data Services）。

使用 Windows 身份验证

指定登录时使用 Windows 身份验证（仅适用于 SQL Server 和 Meta Data Services）。

使用 SQL Server 身份验证

指定登录时使用 SQL Server 身份验证（仅适用于 SQL Server 和 Meta Data Services）。

用户名

指定新连接的用户名（仅适用于 SQL Server 和 Meta Data Services）。

密码

指定新连接的密码（仅适用于SQL Server 和 Meta Data Services）。

请参见

执行包任务


执行包任务属性（子包全局变量选项卡）

使用此选项卡指定将传递给数据转换服务 (DTS) 包执行的全局变量信息。确保子包包含在此指定的全局变量的定义，否则执行包任务将会失败。

有关全局变量的信息在 Variables 表的各行上显示。该表底部的按钮控制全局变量的增加和删除。可以选择表中的单元格输入或更改信息。

选项

名称

指定全局变量名称。可以编辑现有名称，也可单击"新建"后在单元格中键入新名称。

类型

从列表中指定全局变量的数据类型。

Value

指定指派给变量的初始值。

新建

在包中添加全局变量。单击"新建"在 Variables 表中插入空行。

删除

从包中删除选定的全局变量。

请参见

执行包任务

在 DTS 包中使用全局变量


执行包任务（父包全局变量选项卡）

使用此选项卡选择父包中将把信息传递给子包的全局变量。可使用现有的全局变量或创建新的全局变量。该对话框中所定义的全局变量在运行时创建并执行。也可在"DTS 包属性"对话框中定义全局变量。

选项

名称

指定全局变量名称。可以编辑现有名称，也可单击"新建"后在单元格中键入新名称。

新建

在包中添加全局变量。单击"新建"在 Variables 表中插入空行。

删除

从父包全局变量列表中删除选定的全局变量。

请参见

执行包任务

在 DTS 包中使用全局变量


执行进程任务属性

使用此选项卡指定将可执行程序或批处理文件作为任务运行的属性。

选项

描述

键入对执行进程任务的描述。此描述成为数据转换服务 (DTS) 设计器设计表上的标签。

Win32 进程

指定将要运行的可执行文件 (.exe) 或批处理文件 (.bat) 的名称。

浏览

显示"选择文件"对话框，在该对话框中可以搜索本地计算机和映射驱动器查找可执行文件或批处理文件。

参数

指定可执行文件或批处理文件所要求的任何命令提示参数。多个参数之间用空格分隔。

返回代码

指定成功执行进程时所需要的返回代码。

超时

指定在一段时间内将进程视为成功执行的秒数。0 是指不使用超时值，进程在完成和遇到错误之前将一直运行。

超时后终止进程

一旦达到超时期限，便终止进程。

请参见

执行进程任务

CreateProcessTask 对象

CreateProcessTask2 对象


执行 SQL 任务属性

使用此对话框命名任务、指定数据连接、指定要执行的 SQL 语句和设置连接超时。

选项

描述

键入对执行 SQL 任务的描述。此描述成为数据转换服务 (DTS) 设计器设计表上的标签。

现有连接

选择与想要对其运行 SQL 语句的适当数据的连接。

命令超时

指定一个值以确定执行在超时前可以保持的最大秒数。零值表示保持的时间无限。

SQL 语句

指定要执行的 SQL 语句。可使用 GO 语句将多个查询分开。

参数

显示"参数映射"对话框，在此对话框中可以将全局变量映射为 SQL 语句的输入参数，或作为包含查询结果的输出参数。如果使用参数标记创建 SQL 语句且未启用"参数"按钮，则选定的提供程序不支持参数化查询。

分析查询

检查 SQL 语句的语法。OLE DB 提供程序提供对标准 SQL 语法的语法检查。语法检查将不会捕获复杂表达式中的错误，也不支持使用不标准的 SQL 构造，如参数标记和注释。应该验证与不正确的语法相关的错误信息，并且如果发现 SQL 语句有效则可将其忽略。

生成查询

使用图形查询生成工具 DTS 查询设计器创建要执行的 SQL 语句。

浏览

显示"选定的文件"对话框，在此对话框中可选择包含预编写 SQL 语句的文件。选定文件后，将向 SQL 语句文本区复制该文件所包含的 SQL。

请参见

执行 SQL 任务

ExecuteSQLTask 对象


执行 DTS 包

使用此对话框查看整个数据转换服务 (DTS) 包的执行进度，以及组成该包的个别任务的执行状态。

要显示有关任务的错误信息，双击未正确执行的任务。

选项

步骤

查看在步骤中执行的任务名。

状态

查看步骤的执行进度以及步骤是成功完成还是失败。对于报告已处理行数（显示在括号中）的任务，该行数表示从源中读取的总行数，而不是成功处理的行数。

请参见

执行 DTS 包


文件传输协议任务属性（位置选项卡）

使用此选项卡指定和配置下载数据的远程服务器或 Internet 位置。

选项

描述

键入文件传输协议 (FTP) 任务的文本标签。

源

选择是从网络中的"目录"位置还是从"Internet 站点"下载数据。可用的选项因所做的选择而异。

目录路径

如果选择从"目录"位置下载数据，则输入目录路径。单击浏览("...")按钮搜索下载数据的目录。

FTP 站点

如果选择从"Internet 站点"位置下载数据，则输入源数据的 FTP 地址。

用户名

键入访问 FTP 站点所需的用户名。

密码

键入访问 FTP 站点所需的密码。

重试次数

指定尝试的连接次数（如果第一次连接失败）。

目的

指定有关 FTP 数据目的地的信息。

目录路径
键入目的文件的 FTP 站点位置。

请参见

文件传输协议任务


文件传输协议任务属性（文件选项卡）

使用此选项卡选择在文件传输协议 (FTP) 站点之间复制的文件。

选项

源

查看有关源文件的信息并选择要复制的文件。双击某个文件即可将它移到"目的"列表中。

目的

查看有关目的文件的信息并选择不想复制的文件。双击某个文件即可将它从"目的"列表中删除。

>

将选定的文件从"源"列表移到"目的"列表中。

>>

将所有文件从"源"列表移到"目的"列表中。

<

从"目的"列表中删除选定的文件。

<<

从"目的"列表中删除所有文件。

刷新

如果已将文件添加到指定位置或已从指定位置删除，则重新显示文件列表。

重写

当进行文件复制时，选择是用相同的名称重写现有文件还是创建新的文件。

请参见

文件传输协议任务


字体

使用此对话框格式化查询框中的 Transact-SQL 代码。

选项

颜色

指定要为其指派颜色代码和格式的 Transact-SQL 内容元素。

前景
为选定内容元素指派颜色。
背景
为选定的查询元素指派背景颜色。

字体

为选定的 Transact-SQL 内容元素指派字体。

大小

为选定的 Transact-SQL 内容元素指派字体大小。

示例

查看已为其指派了字体特性的选定的 Transact-SQL 内容元素示例。

全部重置

将所有选项重置成各自的初始默认值。


全局变量

使用此对话框查看或更改有关数据转换服务 (DTS) 包中的全局变量信息。在此对话框中定义的全局变量与包一起保存，并可在任何在任务、步骤和列映射级编写的转换脚本中使用这些全局变量。也可在"DTS 包属性"对话框中定义全局变量。

有关全局变量的信息在 Variables 表的各行上显示。该表底部的按钮控制全局变量的增加和删除。可以选择表中的单元格输入或更改信息。

选项

名称

指定全局变量名称。可以编辑现有名称，也可单击"新建"后在单元格中键入新名称。

类型

从列表中指定全局变量的数据类型。

值

指定指派给变量的初始值。

新建

在包中添加全局变量。单击"新建"在 Variables 表中插入空行。

删除

从包中删除选定的全局变量。

请参见

在 DTS 包中使用全局变量


消息队列消息属性

使用此对话框定义将发送给消息队列的消息的类型和内容。

选项

消息类型

从列表中选择下列消息类型：

字符串消息，包含指定的文本字符串。

数据文件消息，包含数据转换服务 (DTS) 包 ID、版本 ID 以及数据文件的名称和内容。

全局变量消息，包含 DTS 包 ID、版本 ID、名称、类型以及一个或多个变量的值。

消息

选择是否希望消息队列任务给其它包"发送消息"或从其它包"接收消息"。

字符串消息

如果选择"字符串消息"的"消息类型"，请键入消息文本。

文件名

键入包含包信息的数据文件的路径和名称。

全局变量

显示将发送给消息队列的包全局变量的列表。

名称
单击"新建"按钮后，从可用包全局变量列表中选择一个全局变量包括在消息中。
类型
查看所选包全局变量的数据类型。
值
查看所选包全局变量的初始值。

创建全局变量

创建可包括在消息队列任务中的新的包全局变量。

新建

创建包括在消息中的全局变量条目。

删除

删除全局变量条目。删除全局变量条目不会从包中删除全局变量的定义。

全局变量

显示将发送给消息队列的全局变量列表。

请参见

消息队列任务

消息类型


消息队列任务属性

使用此对话框配置消息队列任务，该任务使您得以使用消息排队服务在数据转换服务 (DTS) 包之间发送和接收消息。

选项

描述

键入消息队列任务的文本名。

消息

选择希望消息队列任务"发送消息"还是"接收消息"。

队列

指定将从中发送或接收消息的队列。队列的格式为：computer_name\queue_type$\queue name，其中 queue_type 可以是 Outgoing、Public、Private 或 System。

发送消息选项

如果在"消息"框中选择"发送消息"，则下列选项可用：

要发送的消息
显示为该消息队列任务定义的每条消息的信息。

数字

查看自动生成的、用以指出消息创建顺序的数字。

消息类型

查看消息是由数据文件、全局变量还是字符串组成。

添加

定义添加到消息队列任务的新消息。

编辑

编辑消息队列任务中的现有消息。

接收消息选项

如果在"消息"框中选择"接收消息"，则可用的选项因所选的"消息类型"而异：

消息类型
从列表中选择下列消息类型之一：

字符串消息，包含指定的文本字符串。

数据文件消息，包含 DTS 包 ID、版本 ID 以及数据文件的名称和内容。

全局变量消息，包含 DTS 包 ID、版本 ID、名称、类型以及一个或多个变量的值。

仅接收来自特定包或版本的消息
使您得以筛选消息队列任务可以接收的可能消息：

无筛选，选择该选项关闭对任务进行消息筛选。

从包，选择该选项指定用作筛选的包。只接收来自指定包的各版本的消息。

从版本，选择该选项指定用作筛选的包版本。只接收来自具有特定版本标识符的包的消息。

标识符，查看用作筛选的包或包版本的全局唯一标识符 (GUID)。

... 浏览用作消息接收筛选的包或版本。

将文件另存为
通过键入文件路径和文件名，或通过浏览用于保存数据文件消息内容的文件，将数据文件消息内容保存到指定的文件中。
比较
指定接收字符串消息时使用的筛选。只有当字符串消息与筛选匹配时，消息队列任务才接收字符串消息。从下列选项中选择：

无，指定无筛选。

完全匹配，指定消息内容必须与"比较字符串"框中输入的字符串完全匹配。

忽略大小写，指定消息内容必须与"比较字符串"框中输入的字符串内容相匹配，但不区分大小写。

包含，指定消息内容必须包含"比较字符串"框中输入的字符串。

比较字符串
键入评估字符串消息时用作筛选的字符串。
重写
若选择此选项，在保存数据文件消息内容时将重写现有文件中的数据。

在

选择此选项以指定接收消息的超时长度。

请参见

消息队列任务

消息类型


字符串中间部分转换属性

使用此对话框从源列中复制子字符串，转换该字符串，然后将结果复制到目的列中。通过提供起始位置和所要包含的最多字符个数来指定子字符串。其它选项可用于去掉字符串中的空格和更改大小写。

选项

子字符串选项

使用以下选项定位要复制的子字符串。

起始位置（基于 1）
定义子字符串复制的起始字符位置（索引从数字 1 开始）。
将字符个数限制为
指定要复制的字符数。默认情况下，复制字符串中的所有字符，包括起始位置的字符（默认值为 0）。

剪裁选项

选择从字符串中的什么位置删除空格。

剪裁起始空格
删除字符串数据第一个字符前的任何空格。
剪裁尾随空格
删除字符串数据最后一个字符后的任何空格。
剪裁嵌入空格
删除字符串数据第一个和最后一个字符之间的任何空格。

大小写选项

选择是否更改字符串数据的大小写作为转换的一部分。

不更改大小写
执行任何剪裁操作后，保持字符串数据的大小写不变。
全部大写
执行任何剪裁操作后，将字符串数据的小写字母均改为大写。
全部小写
执行任何剪裁操作后，将字符串数据的大写字母均改为小写。

请参见

字符串中间部分转换

剪裁字符串转换


参数映射（输入参数选项卡）

使用此选项卡指定指派给 SQL 语句参数的全局变量。这些参数在 SQL 语句中用问号表示，分析顺序为从左到右，在 Parameters 列中分别用 Parameter1、Parameter2 等表示。

选项

输入全局变量

选择要用其值在运行时替换参数标记的全局变量。

参数

查看 SQL 语句中的参数标记的只读列表。

创建全局变量

显示"全局变量"对话框，可在该对话框中创建新的数据转换服务 (DTS) 包全局变量。

请参见

在 DTS 中使用参数化查询

执行 SQL 任务

在 DTS 包中使用全局变量


参数映射（输出参数选项卡）

使用此选项卡指定将包含查询所返回数据的全局变量。

选项

输出参数类型区

无
指定不从查询返回任何数据，如果正在返回数据，则指定不在全局变量中存储任何数据。
行值
指定从查询返回的每一列存储在一个单独的全局变量中。网格将以结果集中相应数目的列填充。这些列将按照 Parameter1、Parameter2 等等的顺序列出。到现有全局变量的自动映射按有序的方式完成。如果不想保存正在返回的列值，请在"输出全局变量"字段中键入 <none>。若要更改哪个全局变量中存储哪列，请使用"输出全局变量"单元中的列表，选择应包含该数据的全局变量。如果想要使用的全局变量不存在，请单击"创建全局变量"按钮。创建全局变量后，就可以在参数映射中使用它了。
行集
指定要将查询所返回的数据存储在单个全局变量中。该全局变量将包含整个行集。该全局变量可在随后的任务中作为脱接的 Microsoft® ActiveX® 数据对象 (ADO) 记录集来使用。如果查询未返回任何数据，则全局变量为空。如果想要使用的全局变量不存在，请单击"创建全局变量"按钮。创建全局变量后，就可以在参数映射中使用它了。
行集列表
指定将包含行集的全局变量名。

参数映射区

参数
显示正从 SQL 语句返回的列的只读列表（如果适用）。
输出全局变量
指定包含列中正作为行值返回的数据的全局变量。
创建全局变量
显示"全局变量"对话框，在此对话框中可以为数据转换服务 (DTS) 包键入新的全局变量。

请参见

在 DTS 中使用参数化查询

执行 SQL 任务

在 DTS 包中使用全局变量


读取文件转换属性

使用此对话框将源列指定的整个文件内容复制到目的列中。

选项

目录

键入想要从中读取数据的文件的目录位置。运行时，源列中的所有条目都附加到该目录名中以构成读取路径。如果那个位置存在一个文件，则此文件将被打开，其中的内容（可能已转换）被复制到目的列。目录名可以从磁盘驱动器或通用命名规则 (UNC) 开始。

也可以通过浏览选定包含要从中读取数据的文件的目录位置。

文件类型

选择转换从中读取数据的文件是 ANSI、Unicode 还是 OEM。

没有找到文件时显示错误信息

若选择此选项，当在目录位置未找到源列中指定的文件时，将停止处理并使读取文件转换操作失败。

请参见

读取文件转换


注册自定义任务

使用此对话框注册自定义任务。自定义任务用 Microsoft® Visual Basic® 或 Microsoft Visual C++® 这类语言编写。创建自定义任务后，可以注册该任务并将其包含在数据转换服务 (DTS) 设计器用户界面中。这样一来，在使用 DTS 设计器创建包时就可以使用自定义任务。

选项

任务描述

键入对自定义任务的描述。

任务位置

键入自定义任务动态链接库（.dll 文件）的路径和文件名，或浏览并选定该库的位置。

图标位置

键入自定义任务图标的路径和文件名，或通过浏览选定该图标的位置。

刷新

清除框中的数据。

选择图标

选择自定义任务的图标。

请参见

DTS 自定义任务

生成 DTS 自定义任务


保存 DTS 包

使用此对话框将数据转换服务 (DTS) 包保存到 Microsoft® SQL Server™ msdb 数据库、SQL Server 2000 Meta Data Services、COM 结构化存储文件或 Microsoft Visual Basic® 文件中。还可在此对话框中设置包身份验证信息和密码。

选项

保存包时，可以使用下列选项：

包名称

为包指定唯一名称。msdb 表将此名称用作主键。

所有者密码

为包指定密码以防止未经授权的用户看到包内任何敏感的用户名和服务器密码信息。如果包有所有者密码，则使用标准加密 API 加密该数据。只有保存到 SQL Server 的包或作为结构化存储文件的包可以使用此选项。

用户密码

为包用户设置密码。该密码允许用户执行包，但不允许用户查看包定义。设置用户密码时，还必须设置所有者密码。只有保存到 SQL Server 的包或作为结构化存储文件的包可以使用此选项。

位置

指定已保存包的格式和位置。可以保存到 SQL Server msdb 数据库、Meta Data Services、结构化存储文件或 Visual Basic 文件。

当将包保存到 SQL Server 或 Meta Data Services 时，会遇到下列选项：

服务器名称

指定存储包的 SQL Server 安装的名称。

使用 Windows 身份验证

指定用于连接到 SQL Server 的安全模式。使用的 Windows 身份验证将是创建包的用户的 Microsoft Windows® 登录。

使用 SQL Server 身份验证

指定用于连接到 SQL Server 实例的安全模式。

用户名

指定用于连接到 SQL Server 实例的用户名。

密码

指定用于连接到 SQL Server 实例的密码。

将包保存到 Meta Data Services 时，会遇到以下附加选项：

扫描

显示"扫描选项"对话框，在该对话框中指定如何将包所引用的对象扫描到 Meta Data Services 中。此功能使您得以将包中的源对象和目的对象与存储在 Meta Data Services 中的数据库元数据（例如表中的主键和外键、索引、数据类型等列信息）联系起来。

将包保存为 COM 结构化存储文件或 Visual Basic 文件时，会遇到下面的选项：

文件名

指定包文件的名称和路径。如果包是结构化存储文件，应使用 .dts 扩展名存储。如果包是 Visual Basic 文件，则应使用 .bas 扩展名存储。

浏览（"..."）

显示"另存为"对话框，在该对话框中可以指定文件名、扩展名和存储位置。

请参见

保存 DTS 包


扫描选项

使用用于 Microsoft® SQL Server™ 2000 Meta Data Services 的 OLE DB 扫描程序，从 OLE DB 数据源导入数据库架构信息，并填充 Meta Data Services 中的数据库信息模型 (DBM) 实例。扫描程序被传递给 OLE DB 提供程序、检查架构，并使用 DBM 和数据转换服务 (DTS) Meta Data Services 信息模型在 Meta Data Services 中创建一组相应的实例对象。

如果将 DTS 包保存到 Meta Data Services 中，可以设置包引用的对象与扫描到 Meta Data Services 中的 SQL Server 目录元数据如何相关。这方面的元数据是指如下信息：

  • 主键和外键。

  • 列的类型、大小、精度、小数位数和为空性。

  • 索引
选项

将包引用解析到所扫描的目录元数据

启用扫描选项，以将包链接到 Meta Data Services 中的元数据。

如果 Meta Data Services 中存在已扫描的目录，则使用这些目录

如果元数据已保存（即通过导入元数据或通过先前的扫描），将包链接到 Meta Data Services 中的元数据。如果数据库架构没有更改，Meta Data Services 中的元数据已经存在并且出于节省时间的考虑，该选项很有用。如果在列或元数据信息已经更改的情况下使用该选项，将包引用到 Meta Data Services 中的元数据可能没有意义。

将所有引用的目录扫描到 Meta Data Services 中

将有关数据库的所有信息（所有的表、列和元数据信息）扫描到 Meta Data Services 中，即使不使用这些信息。该选项比前一个选项安全，但在时间和性能方面的开销更大。

如果 Meta Data Services 中没有目录，则扫描目录

如果在 Meta Data Services 中不存在数据库，则添加该数据库。（如果启用扫描选项，这是默认选择。）

总是扫描目录

将数据库扫描到 Meta Data Services 中，即使该数据库已经存在。

请参见

在 DTS 中导入和保存元数据

在 DTS 中记录数据沿袭


选择对象

使用此对话框选择要传输到新数据库的对象。

说明 选择复选框并不能自动标记要传输的相应对象。出现的对象位于"对象"列表中，从该列表中可选择要传输的对象。

选项

显示所有表

在"对象"表中显示数据库中所有的表。

显示所有视图

在"对象"表中显示数据库中所有的视图。

显示所有存储过程

在"对象"表中显示数据库中所有的存储过程。

显示所有默认值

在"对象"表中显示数据库中所有的默认值。

显示所有规则

在"对象"表中显示数据库中所有的规则。

显示用户定义的数据类型

在"对象"表中显示数据库中所有的用户定义的数据类型。

全选

选择数据库中所有能够传输到新数据库中的对象。

选中

在所有选定的对象旁添加选中标记。

取消选中

取消所有选定对象的选中标记。

请参见

复制 SQL Server 对象任务


选择包

使用此对话框在保存到结构化存储文件和保存到 Microsoft® SQL Server™ 的数据转换服务 (DTS) 包版本之间进行选择。

选择保存到结构化存储文件的包版本

当打开保存到结构化存储文件的包时，如果该文件包含多个包或包版本，将出现"选择包"对话框。此对话框包含包版本历史记录的树视图。

  • 在顶端节点有一个文本文件图标和随带的标签，表示包的存储位置。

  • 顶端节点的下方显示包节点。其中每个节点代表不同的包。如果在同一个文件名下保存了不同的包，则该文件下可能会列出多个包节点。

  • 包节点的下方显示具有日期的版本节点，表示包的完整版本历史记录。

双击一个包图标将装载那个包版本的最新版本，双击一个版本图标将装载那个包版本。

选择保存到 SQL Server 的包版本

当试图装载保存到具有多个版本的 SQL Server 的包时，将出现"选择包"对话框。和具有多个版本的结构化存储文件一样，将显示树型的包历史记录视图供您选择。不过，只显示单个包的各个版本。与结构化存储文件的情况一样，也不能将多个包保存到单个文件。

展开包图标以查看其版本历史记录，然后双击包图标以装载那个包的最新版本，或在特定的版本上单击以装载那个版本。

请参见

将 DTS 包保存为结构化存储文件

将 DTS 包保存到 SQL Server

DTS 包执行实用工具


发送邮件任务属性

使用此选项卡指定将消息发送到适当收件人的属性。发送邮件任务允许将附件和消息一起发送。

选项

描述

键入对发送邮件任务的描述。此描述将成为数据转换服务 (DTS) 设计器设计表上的标签。

配置文件名

通过从包含所有本地定义的 MAPI 配置文件的"配置文件名"列表中选择适当的配置文件，指定电子邮件配置文件名。

密码

键入配置文件密码。

收件人

指定电子邮件收件人的姓名。单击浏览（"..."）按钮显示"<配置文件> 上的通讯簿"对话框，在该对话框中选择包含收件人姓名的通讯簿。

抄送

指定任何应接收此电子邮件抄送复本的收件人姓名。单击浏览（"..."）按钮显示"<配置文件> 上的通讯簿"对话框，在该对话框中选择包含收件人姓名的通讯簿。从姓名列表中选择要将抄送复本发送到的收件人。

主题

指定电子邮件的主题。

消息

键入电子邮件消息。

附件

指定要附加到电子邮件中的文件。

添加

显示"选择文件"对话框，在该对话框中可以选择打算附加到电子邮件上的文件。

请参见

发送邮件任务


文本文件属性

使用此对话框设置源文本文件或目的文本文件的数据格式。有两种数据格式可供选择：带分隔符的字段和固定字段。

选项

带分隔符

指定源文本文件或目的文本文件使用分隔符表示列。

固定字段

指定源文本文件或目的文本文件中的数据排列在等宽的列中。

跳过行

指定文本文件中要跳过的行数。此选项只有在文本文件用于源数据时才起作用。

第一行含有列名称

表示指定文件中的第一行由列名组成。

文件类型

指定数据文件是 ANSI（默认设置）、Unicode 还是 OEM。

行分隔符

指定数据文件中行的分隔符是回车符/换行符 {CR}{LF}（默认设置）、回车符 {CR} 还是换行符 {LF}。也可以键入其它字符。

文本限定符

指定在数据文件中是否使用引号限定文本。


任务引用

使用此对话框更改已经映射的转换中使用的源连接或目的连接。

任务名

显示所有与源或目的相关的已修改任务。

清除转换

在源字段和目的字段间映射转换，并为每一对映射设置默认的复制列转换，或者清除默认的复制列转换以使先前定义的转换保持原样。

取消

原样保留先前定义的转换。

重要 应用程序不验证字段对选定的新源或新目的是否有效，而只是将选定的操作应用到最初进行转换时已经存在的字段。

请参见

映射列转换

转换类型

复制列转换


测试转换

使用此对话框查看选定的 Microsoft® ActiveX® 脚本转换的执行进度。

在源数据上运行转换，并将结果复制到临时文本文件。不影响目的表。由于测试模式是将数据发送到文件而不是实际的目的地，所以，可能检测不出由提供程序、目的地或数据类型溢出而引起的问题。

选项

执行进度

查看正在测试的转换的进度。

执行状态

查看关于未正确执行的转换的错误信息。双击该步骤。

完成

显示"ActiveX 脚本转换属性"对话框，在该框中可更改 ActiveX 脚本。

查看结果

显示"查看数据"对话框，在此对话框中可以查看包含测试转换结果的临时文件的内容。

请参见

在 DTS 中使用 ActiveX 脚本

转换数据的任务

转换数据任务


转换数据任务属性（源选项卡）

使用此选项卡设置源数据属性并查询源数据。

选项

描述

键入对此转换数据任务的描述。

表/视图

从连接所指定的数据源中选择表或视图。行不一定有序。

SQL 查询

指定 SQL 语句从数据源中检索数据。键入 SQL 语句。

参数

通过指定包含参数（使用一个或多个问号作为参数占位符）的 SQL 查询，将全局变量映射到输入参数。

预览

查看选定源表中的数据。

说明 如果源连接指连接 dBase 数据源并指定 SQL 查询，则源数据可能不能用于查看。

生成查询

使用数据转换服务 (DTS) 查询设计器这一可视化查询生成工具，创建要执行的 SQL 语句。

浏览

指定要执行的 SQL 查询的位置。

分析查询

执行 SQL 语句前验证其语法。

请参见

转换数据任务

DTS 连接

在 DTS 中使用参数化查询


转换数据任务属性（目的选项卡）

使用此选项卡为任务结果配置目的表或存储位置。要配置的属性因目的数据源的特性而异。

选项

表名

从列表中选择数据转换的目的。

创建

指定应创建新表作为目的表。必须存在目的表或存储区域才能指定转换。

名称

查看目的列的名称。

类型

使用 OLE DB 数据类型映射查看目的本机数据类型。

为空性

查看目的列是否允许空值。默认设置为 true。

大小

查看适用的目的列的宽度。

精度

查看适用的目的列的精度。

小数位数

查看适用的小数位数中的位数。

请参见

转换数据任务

DTS 连接


转换数据任务属性（转换选项卡）

使用此选项卡选择并以图形方式映射组成每个转换的源和目的列。不要求以图形方式映射转换。也可以使用"转换选项"对话框中的选择框映射转换。

在此选项卡上，列映射由连接"源"和"目的"框中的列的箭头表示。默认情况下，转换数据任务使用一对一列映射来映射所有列。

选项

阶段筛选

选择要添加转换的数据抽取阶段。只有选定"包属性"对话框中的"在 DTS 设计器中显示多阶段抽取"复选框，此高级选项才可用。默认设置为"行转换"阶段。

名称

查看选定转换的名称。必须单击映射行才能显示转换的名称；否则显示〈无选定内容〉。默认情况下，转换名为 DTS_Transformation_n，n 等于已映射的转换的有序位置。

类型

查看选定映射的列级转换类型。必须单击映射行才能显示转换类型；否则显示〈无选定内容〉。如果想创建新转换，则忽略该值。

新建

显示"创建新转换"对话框，在此对话框中选择列级转换类型。

编辑

显示"转换选项"对话框，在此对话框中可以修改现有转换。单击"编辑"前，选择要修改的转换的映射行。

删除

删除选定的转换。单击"删除"前，选择表示要从任务中删除的转换的映射行。

源

以图形方式查看源数据列，并单击转换中包括的一列或多列。

目的

以图形方式查看目的数据列，并单击转换中包括的一列或多列。

测试

运行选定的转换。单击"测试"前，选择表示要运行的转换的映射行。转换的结果被发送到文本文件，用户于是可以查看该数据。测试转换时，对目的数据所做的更改都不是永久性的。

全选

选择所有源列和目的列。若要创建多对多转换映射类型，请使用"全选"。

全部删除

删除所有转换。单击"删除"前，选择表示要从任务中删除的转换的映射行。

请参见

映射列转换

转换数据的任务

转换数据任务

多阶段数据抽取功能


转换数据任务属性（查找选项卡）

使用此选项卡定义查找查询。在定义查找查询之前，必须首先创建源表、绑定表和查找表的连接，并指定源表和绑定表。

选项

名称

键入查找的名称。

连接

从即将在其中执行查找查询的列表中选择现有连接。

高速缓存

键入或查看高速缓存中保存的查找结果数。如果要转换的行很多，并且正在查询查找表中较少的行数，使用高速缓存会特别有用。

查询

在数据转换服务 (DTS) 查询设计器中生成查找查询。也可将文本编辑器中的查询粘贴到 SQL 窗格中。

添加

创建新的查找查询，该查询将作为新行列在 Lookups 表中。

删除

从 Lookups 表中删除突出显示的查找查询。

请参见

查找查询

配置简单的查找查询

在 DTS 中使用 ActiveX 脚本


转换数据任务属性（选项选项卡）

使用此选项卡将行发送到异常错误文件，确定该文件的格式，并设置达到多少错误计数时包应停止执行。异常错误文件存储在本地或映射驱动器上。还可以指定如快速装载、表锁定属性、移动数据时是否检查约束等项目。

选项

异常错误文件属性区

名称
指定异常错误记录将写入的文件的路径和名称。如果在运行包时不存在该文件，则创建该文件。未给该文件指派默认扩展名。
浏览
显示"选择文件"对话框，在该对话框可为现有异常错误文件搜索本地计算机或映射驱动器。如果使用现有异常错误文件，则将追加包的状态和错误信息。

文件类型属性区

7.0 格式
指定以 7.0 格式保存异常错误文件。如果为 Microsoft® SQL Server™ 7.0 版异常错误文件编写了异常错误文件语法分析器，则此格式很有用，因为使用此向后兼容格式的异常错误文件仍可用于语法分析器。
错误文本
指定记录在执行任务过程中遇到的所有错误。包名称、执行开始时间和完成时间等信息以及其它数据都输入异常错误日志中。
源错误行
指定创建单独的异常错误文件来包含源数据中未写入目的的所有行。根据指定的"文件格式属性"格式化文件。文件名与"名称"字段中指定的文件名相同，并追加了 .Source 扩展名。
目的错误行
指定创建单独的异常错误文件来包含源文件中被拒绝的记录。文件名与"名称"字段中指定的文件名相同，并追加了 .Dest 扩展名。

文件格式属性区

行分隔符
选择用于分隔异常错误文件数据行的分隔符。默认情况下，使用回车符/换行符 {CR}{LF}。
列分隔符
选择用于分隔异常错误文件数据列的分隔符。默认情况下使用垂直条。
文本限定符
指定在分隔的数据文件中用来限定文本的字符标记。从以下几项中选择：双引号 {"}；单引号 {'}；<无>。也可以键入用作文本限定符的字符。

数据移动属性区

最大错误计数
设置终止处理任务前所允许的错误个数的限制。如果选择了 SQL Server 快速装载选项，则错误或是对应于转换数据任务检测到的行级失败，或是对应于批处理失败。"最大错误计数"值包括转换数据任务检测到的行级错误数和批处理失败数。当超过"最大错误计数"值时，任务执行将终止。默认值为 0，表示发生第一个错误时终止任务。
提取缓冲区大小
设置数据移动过程中在源位置提取的数据行的数目。一般不必调整该值，除非有必要优化数据提供程序的特性。
首行
指定要移动的数据首行。如果首行由列标题组成，或者如果已复制了数据源的首部，则此选项很有用。可以将该值设置为在前面的数据抽取操作中处理停止时所在的行号。
末行
指定要移动的数据末行。

SQL Server 属性区

使用快速装载
指定要使用高速大容量复制处理。只有当目的连接是用于 SQL Server 的 Microsoft OLE DB 提供程序时，才可以使用快速装载选项。启用此选项时，数据抽取可以接受成批的转换数据。批处理大小由该区域中的"插入批处理大小"选项控制。
保留 NULL 值
指定要将 NULL 值保留在目的列中，即使目的表是使用为列指定的默认值创建的。此选项只有在启用"使用快速装载"时才可用。
检查约束
指定是否在装载过程中检查目的表上的约束。默认情况下，将会忽略约束。这将提高性能，但是也允许将违反现有约束的数据插入到表中。此选项只有在启用"使用快速装载"时才可用。
表锁
指定在使用表的过程中如何锁定表。如果不使用"使用快速装载"属性和"表锁"，则使用行级锁锁定表。如果使用"表锁"，则使用表级锁锁定表。如果已打开"使用快速装载"属性，且不使用"表锁"，则使用行级锁锁定表。如果使用"表锁"，则使用表级锁锁定表。此选项只有在启用"使用快速装载"时才可用。
启用标识插入
允许将显式值插入表的标识列中（仅限于 SQL Server）。此选项仅当检测到标识列时才可用。标识列是指数据类型为 bigint、decimal、integer、numeric、smallint 或 tinyint，列的"标识"属性设置为"是"的列。此选项只有在启用"使用快速装载"时才可用。
总是提交最后的批处理
选择提交在错误发生前成功处理的最后批处理中的所有行。当在处理最后批处理的过程中发生转换或插入错误时，应用此属性，这样不必再次处理错误发生前批处理中的所有行。此设置对于大型批处理很有用。此选项只有在启用"使用快速装载"时才可用。
插入批处理大小
指定批处理中的行数。此选项只有在启用"使用快速装载"时才可用。

"批处理大小"的值按如下方式工作：

如果将批处理大小设置为 0，则数据将载入一个批处理中，失败的第一行将导致取消整个装载，且该步骤失败。此值为默认设置。

如果将批处理大小设置为 1，则一次装载一行数据。每个失败的行记为一次批处理失败，"最大错误计数"值增加 1。先前装载的行可以提交，或如果该步操作已联接包事务，则保留在该事务中等待以后提交或回滚。

如果将批处理大小设置为大于 1 的值，则一次装载一个批处理的数据。该批处理中第一行失败，将导致整个批处理失败；装载停止且该步骤失败。先前装载的批处理中的行可以提交，或如果该步操作已联接包事务，则保留在该事务中等待以后提交或回滚。

请参见

转换数据的任务

转换数据任务


转换标志

使用此对话框自定义源列和目的列之间的数据转换，并强制对数据类型转换进行某种严格程度的限制。此对话框中可用的转换标志与 DTSTransformFlags 对象类成员的子集相对应。

选项

默认转换标志

允许所有可能的数据转换。此为限制最不严格的数据转换设置。此设置对应于 DTSTransformFlag_Default 常量。

要求在源和目的之间完全匹配

强制源列和目的列中的数据类型完全匹配。未完全匹配时会生成错误。使用"数据转换属性"对话框中的"高级"选项卡处理错误。此设置对应于 DTSTransformFlag_RequireExactType 常量。

自定义转换标志

允许从下列选项中列出的三个转换标志设置中选择。

允许数据类型升级
允许数据类型从 16 位整型升级到 32 位整型数字。此设置对应于 DTSTransformFlag_AllowPromotion 常量。
允许数据类型降级
允许数据类型从 32 位整型降级为 16 位整型数字。此设置对应于 DTSTransformFlag_AllowDemotion 常量。
允许 NULL 转换
允许数据从允许 NULL 值的列转换到不允许 NULL 值的列。此设置对应于 DTSTransformFlag_AllowNullChange 常量。

请参见

TransformFlags 属性


转换选项（常规选项卡）

使用此选项卡命名要创建的转换，查看有关转换类型的信息，并显示转换的属性对话框。

当使用"转换选项"对话框中的其它选项卡时，单击"属性"查看或配置转换属性前必须返回到"常规"选项卡。

选项

名称

键入转换的名称，或使用默认名称。默认名称为"DTSTransformation_n"，n 等于为任务所定义的转换数目。

类型

查看在"创建新转换"对话框上选定的列转换类型。

属性

配置选定转换的属性。

序列

查看创建和执行当前转换的次序。在由多个转换写入同一目的列的转换中，保存上一个转换（由序号指定）的结果。

转换描述

查看对选定转换类型的概括性描述。

请参见

映射列转换

转换类型

转换数据的任务


转换选项（源列选项卡）

使用此选项卡选择和排序将在转换中使用的源列。如果曾经使用转换数据任务或数据驱动的查询任务的"转换"选项卡上的映射行来定义转换，则"选中的列"列表中将出现那些映射的源列。

选项

可用的列

查看创建转换时可选择的源列。

选中的列

查看将用于转换的源列。

>

将从"可用的列"列表中选取的列复制到"选中的列"列表中。

>>

将"可用的列"列表中的所有列复制到"选中的列"列表。

<

从"选中的列"列表中删除选定列。

<<

从"选中的列"列表和转换中删除所有列。

请参见

映射列转换

转换类型

转换数据的任务


转换选项（目的列选项卡）

使用此选项卡选择并排序将在转换中使用的可用目的列。如果曾经使用转换数据任务或数据驱动的查询任务的"转换"选项卡上的映射行来定义转换，则"选中的列"列表中将出现那些映射的目的列。

选项

可用的列

查看创建转换时可选择的目的列。

选中的列

查看将用于转换的目的列。

>

将从"可用的列"列表中选取的列复制到"选中的列"列表中。

>>

将"可用的列"列表中的所有列复制到"选中的列"列表。

<

从"选中的列"列表中删除选定列。

>>

从"选中的列"列表和转换中删除所有列。

请参见

映射列转换

转换类型

转换数据的任务


转换选项（阶段选项卡）

使用此选项卡选择将通过提供并注册 COM 对象实现的转换阶段。如果提供 Microsoft® ActiveX® 脚本函数实现多阶段数据抽取功能，则不必使用此选项卡。

选项

源数据函数前

在首次提取源数据前调用函数。为源转换前阶段创建主要用于将标题行写入目的的函数。

行转换函数

为复制和转换数据调用默认转换函数。创建只用于此转换阶段的函数相当于不使用多阶段数据抽取功能。

行转换函数后

指定在数据抽取的行转换阶段之后执行行转换后函数。只能为一行调用下列行转换后函数之一："插入成功时"、"插入失败时"、"转换失败时"。

插入成功时

创建在插入操作（如果转换是数据驱动的查询任务的组成部分，则为插入查询）成功时调用的函数。无法在已返回状态下指定任何目的操作。

插入失败时

创建在插入操作（如果转换是数据驱动的查询任务的组成部分，则为插入查询）失败时调用的函数。无法在已返回状态下指定任何目的操作。

转换失败时

创建正常转换阶段（行转换返回 DTSTransformStat_Error 或 DTSTransformStat_ExceptionRow）失败时调用的函数。编写用于此转换阶段的函数使您得以处理转换错误（如类型不匹配），以替代转换返回的值并继续执行。

批处理完成时

创建批处理或者行成功或失败时调用的函数，由转换数据任务的"选项"选项卡中的"插入批处理大小"中指定的值定义。只能通过编程的方式设置数据驱动的查询任务或并行数据抽取任务的批处理大小。因此，若要为这些任务中的任意一个任务编写"批处理完成时"函数，也应通过编程方式完成。

抽取完成时

创建在转换任务结束时（处理完所有的行之后）调用的函数。使用写入"抽取完成时"的函数释放资源，并提交在数据抽取过程中全局变量中含有的数据。无法通过"抽取完成时"函数访问此数据。

源数据函数后

完成任务后，创建用于处理目的数据的函数。和"抽取完成时"函数不一样，写入此阶段的函数允许访问目的数据。源数据函数后常用于将页脚行写入文件、释放资源和提交全局变量中含有的数据。

请参见

多阶段数据抽取功能

映射列转换

转换类型

转换数据的任务


剪裁字符串转换属性

使用此对话框从源列内的字符串中删除起始空格、尾随空格和嵌入空格，并将结果复制到目的列。

选项

剪裁选项

选择从字符串的什么位置删除空格。

剪裁起始空格
删除字符串数据第一个字符前的任何空格。
剪裁尾随空格
删除字符串数据最后一个字符后的任何空格。
剪裁嵌入空格
删除字符串数据第一个和最后一个字符之间的任何空格。

大小写选项

选择是否将更改字符串数据的大小写作为转换的一部分。

不更改大小写
执行任何剪裁操作后，保持字符串数据的大小写不变。
全部大写
执行任何剪裁操作后，将字符串数据的小写字母均改为大写。
全部小写
执行任何剪裁操作后，将字符串数据的大写字母均改为小写。

请参见

剪裁字符串转换

字符串中间部分转换


撤消注册自定义任务

使用此对话框删除所有已注册的自定义任务及其注册表项。

选项

任务描述

选择要从列表中撤消注册的自定义任务。

请参见

DTS 自定义任务

生成 DTS 自定义任务


验证转换

使用此对话框选择当源连接或目的连接已更改以及存在的列映射不再有效时如何处理列映射。

选项

删除无效转换

删除所有列映射。如果选择此选项，则显示"转换"选项卡，可在此选项卡中重新应用适当的列映射和转换。使用此选项可清除所有无效映射，而不必先手工删除所有无效映射后再建立适当的列映射。这样，将使新映射应用更为容易。

更改源表/目的表

修改源表或目的表。如果选择此选项，则显示转换任务"源"选项卡，可在此选项卡中更改源表，或显示"目的"选项卡修改目的表。

删除所有转换并重新进行自动映射

删除所有原始列映射并使用新字段重新应用列映射。如果选择此选项，则显示"转换"选项卡，在此选项卡中可检查并应用适当的列映射和转换。此选项自动映射每一列。必须删除任何不正确的映射，然后适当地重新应用。

请参见

映射列转换


查看数据

使用此对话框检查将用于转换任务的源数据，或者检查对转换运行的测试结果。

在测试转换后使用"查看数据"对话框时，此对话框允许查看包含转换结果的临时文本文件。可以检查此数据以确保转换产生的结果与预期的相同。

由于测试模式是将数据发送到文件而不是实际的目的，可能检测不出由于提供程序、目的或数据类型溢出引起的问题。因此，在某些情况下，测试结果不能准确表现出转换任务的性能。


工作流 ActiveX 脚本属性

使用此对话框指定脚本代码，以执行自定义数据转换服务 (DTS) 包步骤（如重试连接）所需的函数。

选项

语言选项卡

此选项卡包含功能列表，这些功能可在"语言"列表中选择的语言中使用。

语言
选择可用的脚本语言。在计算机上安装脚本语言时，该列表将自动更新。默认情况下，Microsoft Visual Basic® Scripting Edition (VBScript) 和 Microsoft JScript® 可用。
函数
从脚本语言库中选择将放入"ActiveX 脚本文本框"的函数。双击函数名可将函数代码插入游标位置处的文本框。
入口函数
指定在脚本运行时将成为入口点的函数名。只能为工作流 Microsoft ActiveX® 脚本指定一个入口函数。

浏览器选项卡

查看可在工作流 ActiveX 脚本中用作返回代码、包全局变量和查找的可用常量。单击某个选项卡以显示可供选择的信息，然后双击某项将信息复制到"ActiveX 脚本文本框"。

ActiveX 脚本文本框

键入或粘贴执行所需函数时必需的脚本代码。脚本编辑器的功能有限，不包括如语句完成或对保留字进行颜色编码这样的功能。注释行在任何列中都使用省略符号 (') 字符语法，而且从注释字符到行尾的所有文本都被忽略。

自动生成

用选定的脚本语言生成单个函数占位符。此选项可能不是对所有已安装的脚本引擎都有效。

重要 如果"ActiveX 脚本文本区"中有脚本代码，单击"自动生成"时将删除此代码。

浏览

显示"选择文件"对话框，在此对话框中可选择包含代码的文件。选定一个文件时，该文件的内容将复制到"ActiveX 脚本文本框"。

重要 从此对话框打开外部脚本文件的操作将重写"ActiveX 脚本任务文本框"中所有现有代码。因此，应始终先执行该任务。

分析

检查代码语法错误。

保存

显示"另存为"对话框，通过此对话框可将"ActiveX 脚本文本框"内的所有代码存入本地硬盘驱动器或其它映射驱动器上的文件中。

撤消

撤消有限次数的文本项操作。无法撤消如通过"选择文件"对话框添加代码这类操作。

请参见

在 DTS 工作流中使用 ActiveX 脚本

在 DTS 中使用 ActiveX 脚本

在 DTS 包中使用全局变量

调试 ActiveX 脚本

在 DTS 中使用返回代码


工作流属性（优先选项卡）

使用此选项卡查看并配置任务、转换和优先约束之间的关系。

  • 如果正在配置优先约束的属性，则此选项卡显示从源表到目的表履行约束所须完成的步骤。还可使用此选项卡将另外的约束添加到前面的步骤、删除那些步骤上的约束或重新定义那些步骤上的现有约束。

  • 如果正在配置转换数据任务的工作流，则此选项卡在目标转换之前显示源优先约束。还可使用此选项卡将另外的约束添加到工作流、删除约束或重新定义现有的约束。

约束的顺序不重要。默认情况下，每个步骤都可以立即执行。

选项

源步骤

从列表中选择可用的源步骤。

优先

根据"完成时"、"成功时"或"失败时"的状态指定任务执行。还可以选择 <无> 以终止"源步骤"和"目的步骤"之间的现有关系。

目的步骤

从列表中选择可用的目的步骤。

新建

在两个步骤之间添加新约束，然后对其进行配置。

删除

删除两个步骤之间的现有约束。

请参见

DTS 包工作流


工作流属性（选项选项卡）

使用此选项卡自定义关于事务行为、执行选项和 Microsoft® ActiveX® 脚本使用的转换数据任务的工作流属性。

选项

描述

查看转换数据任务的名称。

有事务时联接

如果选择此选项且已启用事务，则此步骤将联接数据转换服务 (DTS) 包事务。更新将不断积累，直到提交或回滚。如果清除该复选框，则根据请求将每次执行一次更新。

成功完成此步骤时提交事务

如果选择此选项，则成功完成步骤时将触发事务提交。使未完成的更新成为永久更新。如果清除该复选框，则所有更新都保留在事务中，直到下一次提交或回滚。

失败时回滚事务

如果选中该选项，步骤失败将触发回滚包事务。未完成的更新将被废弃。如果清除该复选框，则所有更新都保留在事务中，直到下一次提交或回滚。

在主包线程中执行

强制与此步骤相关联的任务在主包线程而不是衍生的线程上执行。如果正在数据提供程序上执行任务，且此提供程序没有可用的线程且不支持并行执行任务，则选择此选项。

重要 如果在不支持并行执行的提供程序上尝试并行执行，可能会导致严重的错误。与 DTS 设计器一起使用且不支持并行执行的某些数据提供程序包括用于 Jet 的 Microsoft OLE DB 提供程序和用于 Microsoft Excel、dBase、Paradox 和 HTML 源文件的提供程序。如果多个操作与这些提供程序一起使用，则使用"在主包线程中执行"选项。

完成时关闭连接

如果任务与连接有关，则完成包后关闭连接。是否使用此选项取决于数据提供程序；如果连接没有保持打开，某些提供程序的性能会更好。是否选择此选项的另一个考虑因素是可用连接数以及与维护打开的连接相关的费用。有关更多信息，请参见 OLE DB 提供程序文档。

步骤失败时使包失败

若选择此选项，则在步骤发生故障时将终止对 DTS 包的处理。

DSO 行集提供程序

对外部使用者表现此步骤获取的 OLE DB 行集数据。这允许查询包，还允许将步骤获取的数据用作其它包的源。

禁用此步骤

当执行包时禁用此工作流步骤。

步骤优先级

为步骤设置 Microsoft Windows NT® 4.0 线程优先级。默认设置是"普通"。

使用 ActiveX 脚本

执行步骤时包括 ActiveX 脚本。

属性

如果选择了"使用 ActiveX 脚本"，则显示"ActiveX 脚本属性"对话框。

请参见

DTS 包工作流

配置 DTS 事务属性

在 DTS 工作流中使用 ActiveX 脚本


写入文件转换属性

使用此对话框将源列（数据列）的内容复制到由第二个源列（文件名列）指定路径的文件中。

选项

目录

键入文件名列指定的文件所在的目录，或者浏览并选定目录。运行时，文件名列中的所有条目都附加到该目录名下以创建保存路径。如果该位置没有文件存在，则将创建一个文件并用数据列的内容对其进行初始化。

文件类型

选择转换将数据写入的文件是 ANSI、Unicode 还是 OEM。

文件名列

选择包含列表中的文件名列表的列。

处理现有文件

选择当写入数据的文件已存在时的处理办法。

有文件存在时重写
用新内容替换现有文件内容（默认选择）。
有文件存在时追加
保留文件原有内容并在文件末尾添加新内容。
文件存在时显示错误
如果文件已存在，则终止处理并使写入文件转换失败。

请参见

写入文件转换