选择服务器

使用"选择服务器"屏幕选择要为其创建数据库维护计划的数据库所在的一台或多台服务器。只列出本地 MSX（主）服务器可向其发送作业的服务器，而不是网络上可用的全部服务器。

（本地）服务器是 MSX（主）服务器。

所有其它服务器均为 TSX（目标）服务器。


选择数据库

使用"选择数据库"屏幕查看或指定下列选项。

选项

全部数据库

生成在所有 Microsoft® SQL Server™ 数据库上运行维护任务的维护计划。

所有系统数据库（master、model 和 msdb）

生成对每个 SQL Server 系统数据库运行维护任务的维护计划。对用户创建的数据库不运行维护任务。

所有用户数据库（除 master、model 和 msdb 之外的所有数据库）

生成对用户创建的全部数据库运行维护任务的维护计划。对 SQL Server 系统数据库不运行维护任务。

如下数据库

生成只运行所选数据库维护任务的维护计划。如果选择本选项，则至少必须选择列表中的一个数据库。

将事务日志传送到其它 SQL Server（日志传送）

将日志传送设置为该维护计划的一部分。有关更多信息，请参见日志传送。

说明 此功能仅在 SQL Server 2000 企业版和开发版中可用。


更新数据优化信息

使用"更新数据优化信息"屏幕查看或指定下列选项。

选项

重新组织数据和索引页

导致除去数据库表中的索引，并用新的 FILLFACTOR 重新创建。FILLFACTOR 决定为索引中的每一页留下多少空间，从而为索引中每个数据页将来的扩充保留一定的可用空间。随着向表中添加数据，由于 FILLFACTOR 没有维持，可用空间逐渐填满。重新组织数据和索引页可以重新建立可用空间。

使用原有可用空间重新组织页面

除去数据库中表的索引，并用创建索引时所指定的原 FILLFACTOR 重新创建。

将每页可用空间的百分比更改为

导致除去数据库表中的索引，并用最新自动计算过的 FILLFACTOR 重新创建，从而在索引页上保留指定大小的可用空间。百分比越高，索引页上保留的可用空间就越多，并且索引增长也就越大。有效值为 0 到 100。

更新查询优化器所用统计

导致对数据库中用户表上创建的每个索引的分布统计重新采样。Microsoft® SQL Server™ 使用分布统计在处理 Transact-SQL 语句时优化表间的导航。为了自动建立分布统计，SQL Server 将按百分比定期采样与每项索引相关的表中数据。该百分比率根据表中的行数和数据修改的频率而定。可以使用此选项利用表中指定百分比的数据执行附加采样。

采样数据库的 %

通过对表中数据按指定百分比进行采样生成分发统计。此百分比越高，统计就越准确，但采样需要的时间就越长。如果所指定值未生成满足需要的样本，则 SQL Server 将自动确定足够的采样大小。有效值的范围为 1 到 100。

从数据库文件中删除未使用的空间

删除数据库文件中不用的空间，以减少数据文件的大小。

当其超过

仅当数据库超过指定的大小（以 MB 为单位）时，才从数据库中删除未使用的空间。

收缩后保留的可用空间量为

确定数据库收缩后保留在数据库中的未使用空间量（该百分比越大，数据库可收缩的量越小）。该数值基于数据库中实际数据的百分比。例如，某个 100 MB 数据库包含 60 MB 的数据和 40 MB 的可用空间，当可用空间百分比为 50% 时，将生成 60 MB 的数据和 30 MB 的可用空间（因为 60 MB 的 50% 是 30 MB）。只有数据库中的过剩的空间才会被删除。有效值为 0 到 100。

调度

设置数据优化任务（使用 SQL Server 代理调度）的执行频率。默认为每星期日凌晨 01:00:00 点。

更改

更改默认调度。


检查数据库完整性

使用"检查数据库完整性"屏幕查看或指定下列选项。

选项

检查数据库完整性

通过运行 DBCC CHECKDB Transact-SQL 语句，检查数据库中用户和系统表及索引的分配及结构完整性。以确保数据库中的任何完整性问题均能得到报告，以便系统管理员或数据库所有者在以后加以解决。

包含索引

在完整性测试时检查数据库中的数据页和索引页。

尝试修复所有小问题

在数据库完整性测试过程中自动尝试修复所检测到的任何小故障。如果选择了此选项，维护计划每次运行时都将数据库置于单用户模式。建议选择本选项。

排除索引

在完整性测试时只检查数据库中的数据页。而不检查索引。由于数据库中要检查的页数较少，所以本选项执行速度比单击"包含索引"快。

备份前执行测试

导致在备份数据库或事务日志之前执行数据库和/或内部数据的完整性测试。如果完整性测试检测到不一致，将不进行随后的数据库或事务日志备份。

调度

设置数据完整性任务（使用 SQL Server 代理来调度）的执行频率。默认为每星期日晚 12 点。

更改

更改默认调度。


指定数据库备份计划

使用"指定数据库备份计划"屏幕查看或指定下列选项。

选项

作为维护计划的一部分来备份数据库

导致备份整个数据库成为维护任务的一部分。备份数据库非常重要，当发生系统或硬件故障（或用户错误）而造成数据库的某种破坏时，就要求用备份副本来还原数据。

备份完成时验证备份的完整性

通过执行 RESTORE VERIFYONLY Transact-SQL 语句检查备份集完整且所有的卷均可以访问。

磁带

将数据库备份到指定的磁带设备。只有连接在数据库所在的计算机上的磁带设备才可用。

磁盘

将数据库备份到磁盘。有关如何指定数据库备份位置的更多信息，请参见指定备份磁盘目录。

调度

设置数据库备份任务（使用 SQL Server 代理来调度）的执行频率。默认为每星期日凌晨 2:00 点。

更改

更改默认调度。


指定备份磁盘目录

使用"指定备份磁盘目录"屏幕查看或指定下列选项。

选项

使用默认备份目录

将数据库备份到该数据库所在计算机上的默认备份磁盘目录下。Microsoft® SQL Server™ 2000 默认实例的目录是 \MSSQL\BACKUP，而 SQL Server 2000 命名实例的目录是 \MSSQL$instancename\BACKUP。

使用此目录

将数据库备份到指定的磁盘目录。只能使用与数据库位于同一台计算机上的磁盘。单击浏览（"..."）按钮可更改用于备份数据库的默认目录。只能选择正在备份的 SQL Server 数据库所在计算机中的驱动器。

为每个数据库创建子目录

在包含数据库备份的指定磁盘目录下，为作为维护计划一部分而备份的各数据库创建子目录。

删除早于此时间的文件

自动删除早于指定时期的数据库备份。应保留数据库备份的历史记录，以应付必须将数据库还原到上次执行备份前的某一时间点的情况。在磁盘空间允许范围内尽可能多地保留备份，并根据需要保留过去尽可能长时间的备份。

备份文件扩展名

定义包含数据库备份的各个文件所用的文件扩展名。默认的文件扩展名为 .bak。

说明 将自动生成磁盘备份文件名（例如 pubs_tlog_199803120203.bak，其中 199803120203 是时间戳）。


指定事务日志的备份磁盘目录

使用"指定事务日志的备份磁盘目录"屏幕查看或指定下列选项。

选项

使用默认备份目录

将事务日志备份到该事务日志所在计算机上的默认备份磁盘目录下。Microsoft® SQL Server™ 2000 默认实例的目录是 \MSSQL\BACKUP，而 SQL Server 2000 命名实例的目录是 \MSSQL$instancename\BACKUP。

使用此目录

将 SQL Server 事务日志备份到该事务日志所在的计算机上的指定磁盘目录。单击浏览（"..."）按钮更改用于备份事务日志的默认磁盘目录。只能选择指定 SQL Server 事务日志所在的计算机上的驱动器。

为每个数据库创建子目录

在事务日志备份的指定磁盘目录下，为作为维护计划一部分而备份的各数据库创建子目录。

删除早于此时间的文件

自动删除早于指定时期的事务日志备份。当需要将数据库恢复到时间上的一特定点时，应保存事务日志备份的历史记录。在磁盘空间允许范围内尽可能多地保留备份，并根据需要保留过去尽可能长时间的备份。

备份文件扩展名

指定包含事务日志备份的每个文件的文件扩展名。默认的文件扩展名为 trn。

说明 将自动生成磁盘备份文件名（例如 pubs_tlog_199803120203.bak，其中 199803120203 是时间戳）。


指定事务日志备份计划

使用"指定事务日志备份计划"屏幕查看或指定下列选项。

选项

作为维护计划的一部分来备份事务日志

将事务日志作为维护计划的一部分进行备份。事务日志备份对将数据库恢复到故障点是必需的。

备份完成时验证备份的完整性

通过执行 RESTORE VERIFYONLY Transact-SQL 语句，检查备份是否完整且所有卷是否均可被访问。

磁带

将数据库备份到指定的磁带设备。只有连接在数据库所在的计算机上的磁带设备才可用。

磁盘

将数据库备份到磁盘。有关如何指定数据库备份位置的更多信息，请参见指定备份磁盘目录。

调度

设置事务日志备份任务（使用 SQL Server 代理程序调度）的执行频率。默认为每星期一至星期五的午夜 12:00 点。


要生成的报表

使用"要生成的报表"屏幕查看或指定下列选项。

选项

将报表写入目录中的文本文件

指定将要生成报表的文本文件的完整路径和名称。报表包含维护计划执行步骤的细节，包括任何错误信息。报表通过将日期添加到文件名中来维护版本信息。日期作为文件名的后缀，但位于扩展名之前，其格式为 _YYYYMMDDHHMM。例如："DB Maintenance Plan10_199804090838.txt"。

单击浏览（"..."）按钮更改文本文件的默认目录。只能选择运行维护计划的计算机上的目录。

删除早于此时间的文本报表文件

自动删除早于指定时期的文本报表文件。应保存文本报表文件的历史记录，以便检查过去所执行的维护任务。

将电子邮件报表发送给操作员

指定操作员，生成的报告将通过 SQL 邮件发送给该操作员。单击浏览（"..."）按钮可使用 SQL Server 企业管理器更改指定操作员的属性。

新建操作员

使用 SQL Server 企业管理器创建新操作员。


维护计划历史记录

使用"维护计划历史记录"屏幕查看或指定下列选项。

选项

将历史记录写至本服务器上的 msdb.dbo.sysdbmaintplan_history 表中

将报表以行的形式写到执行服务计划的服务器上的该表中。报表包含维护计划所执行操作步骤，包括数据库名称、活动、日期、结果（成功或失败）及任何错误信息。按数据库和执行日期，每个活动一行。

将本计划表中的行数限制在

指定表中表示该计划的历史记录的最大行数。如果该表中此计划的历史记录行数超出此值，则删除该计划的较早的行（代表最早的历史记录）。设置该值可以防止该表过大而填满 msdb 数据库（如果不允许自动增长）。默认值为 10.000。

将历史记录写至服务器

将报表按行写到远程服务器上的 msdb.dbo.sysdbmaintplan_history 表中。使用 Windows 身份验证连接到远程服务器。报表包含维护计划所执行操作步骤，包括数据库名称、活动、日期、结果（成功或失败）及任何错误信息。按数据库和执行日期，每个活动一行。

单击浏览（"..."）按钮可更改报表所写入的远程服务器。只能选择 Microsoft® SQL Server™ 实例。

将本计划表中的行数限制在

指定表中表示该计划的历史记录的最大行数。如果该表中此计划的历史记录行数超出此值，则删除该计划的较早的行（代表最早的历史记录）。设置该值可以防止该表过大而填满 msdb 数据库（如果不允许自动增长）。默认值为 10.000。


指定事务日志共享

使用"指定事务日志共享"屏幕指定要在其中创建事务日志文件的网络共享。

选项

用于 <备份目录> 的网络共享名

指定用于指定的备份目录的网络共享名。单击浏览（"..."）按钮可搜索想要的网络共享。


指定日志传送目的

使用"指定日志传送目的"屏幕选择日志传送的目的服务器。

选项

目的服务器

查看要将事务日志传送到的服务器。

数据库

查看日志传送的数据库安装的名称。

添加

添加新的日志传送目的。

编辑

编辑突出显示的日志传送目的。

删除

删除突出显示的日志传送目的。

请参见

日志传送


添加或编辑目的数据库

使用"添加或编辑目的数据库"屏幕输入日志传送的目的数据库信息。

选项

服务器名称

选择日志传送的目的服务器。

目录

选择目的服务器上用于传送事务日志的目录。单击浏览（"..."）按钮可搜索适当的磁盘目录。

创建并初始化新数据库

在目的服务器上创建用于日志传送的新数据库。

数据库名称

指定要创建的数据库名称。

用于数据

指定目的服务器上用于新数据库文件的目录。单击浏览（"..."）按钮可搜索适当的磁盘目录。

用于日志

指定目的服务器上存储新数据库的日志文件的目录。单击浏览（"..."）按钮可搜索适当的磁盘目录。

使用现有数据库（不初始化）

将目的服务器上的一个现有数据库用于日志传送。

数据库名称

选择用于日志传送的数据库。

不恢复模式

使目的数据库处于不恢复模式。用户无法访问处于不恢复模式的数据库。

备用模式

使目的数据库处于备用模式。

终止数据库中的用户（推荐）

指定是否应自动终止与目的数据库的用户连接。

允许数据库采用主角色

指定应将目的服务器设置为能够作为主服务器运行。

目录

指定当辅助服务器作为主服务器运行时，目的服务器上用于存储数据库事务日志的目录。

请参见

日志传送


初始化目的数据库

使用"初始化目的数据库"屏幕指定是使用完整数据库备份还是使用最近的备份文件。

选项

开始执行完整数据库备份

创建用于日志传送的新的完整数据库备份。

使用最新的备份文件

使用文本框中所指定的最新的备份文件。单击浏览（"..."）按钮可搜索最新的备份文件。如果该文件不在日志传送共享中，将被复制到该位置。

请参见

日志传送


日志传送调度

使用"日志传送调度"屏幕为任何日志传送操作指定调度。

选项

备份调度

查看当前日志备份调度。

更改

显示"编辑反复出现的作业调度"对话框，在该对话框中可以更改当前备份调度。

复制/装载频率

设置装载事务日志备份的频率。

装载延迟

设置事务日志备份在可以被装载之前必须存在的时间。

文件保持期

设置事务日志备份在被删除前所存在的时间。

请参见

日志传送


日志传送阈值

使用"日志传送阈值"屏幕指定日志传送阈值。在超出这些阈值时将生成警报。

选项

备份警报阈值

设置源服务器上的事务日志备份之间的最长时间间隔。如果超出该时间间隔，将生成警报。

不同步警报阈值

设置源服务器上的上一次事务日志备份与目的服务器上的上一次事务日志装载之间的最长时间间隔。如果超出该时间间隔，将生成警报。

请参见

日志传送


指定日志传送监视服务器信息

使用"指定日志传送监视服务器信息"屏幕指定中央服务器（也称为监视服务器）的名称和身份验证信息，将从中央服务器对日志传送进行监视。

选项

SQL Server

选择监视日志传送的 Microsoft® SQL Server™ 实例。

使用 Windows 身份验证

连接到日志传送监视服务器时使用 Windows 身份验证。

使用 SQL Server 身份验证

连接到日志传送监视服务器时使用 SQL Server 身份验证。

登录名

指定用于连接到日志传送监视服务器的登录名。

密码

指定用于连接到日志传送监视服务器的密码。

请参见

日志传送