复制数据库向导帮助

复制数据库向导帮助

复制数据库向导提供一种便利的联机方法以在不同服务器之间移动或复制数据库及其对象，并且可避免服务器停止运行。利用这一向导，可以：

  • 选取源和目的服务器。

  • 选择要移动或复制的数据库。

  • 指定数据库的文件位置。

  • 在目的服务器中创建登录。

  • 复制支持对象、作业、用户定义的存储过程以及错误信息。

  • 调度移动或复制数据库的时间。

重要 若要使复制数据库向导工作，您必须是源服务器和目的服务器上的 sysadmin 固定服务器角色成员。换言之，您不仅必须是数据库将要复制到的服务器上的管理员，还必须是向外复制数据库的服务器上的管理员。

复制数据库向导 DTS 自定义任务

复制数据库向导是作为在目的服务器上运行的数据转换服务 (DTS) 包来生成的。完成该向导屏幕后，Microsoft® SQL Server™ 2000 将自动命名包并将其保存在目的服务器上。无论是否立即运行该包，它都将保存下来，并调度以便在以后某一日期运行或定期反复运行。

DTS 自定义任务也可以作为 DTS 设计器中独立的项目使用，这些任务可以在任何 DTS 包中使用（但不能用于复制数据库向导）。这五项自定义任务为：

  • 数据库移动/复制任务

  • 登录复制任务

  • 作业复制任务

  • Master 数据库存储过程复制任务

  • 错误信息复制任务

请参见

升级 SQL Server 7.0 数据库（复制数据库向导）

DTS 包元素

使用复制数据库向导


选择源服务器

此屏幕用于指定要移动或复制的数据库所在的服务器，并用于输入登录信息。选择身份验证方法并输入登录信息后（按照要求），单击"下一步"按钮即可建立与源服务器的连接。该连接在复制或移动会话期间一直处于打开状态。

选项：

源服务器

选择要移动或复制的一个或多个数据库所在的服务器的名称，或单击浏览 (…) 按钮定位所需的服务器。

使用 Microsoft® Windows® 身份验证

使用 Windows 用户名和密码以验证连接。

使用 SQL Server™ 身份验证

使用 SQL Server 安全性以验证连接。

用户名
如果选择 SQL Server 身份验证，则输入一个有效的 SQL Server 标准登录。
密码
如果选择 SQL Server 身份验证，则输入标准的登录密码。

下一页

开始验证进程。该进程检查用户是否为所选计算机上 sysadmin 固定服务器角色的成员。

请参见

身份验证模式

升级 SQL Server 7.0 数据库（复制数据库向导）


选择目的服务器

此屏幕用于指定要将数据库移动或复制到的服务器。当选择身份验证方法并输入用户信息后，单击"下一步"按钮即可建立与目的服务器的连接并验证服务器和用户信息。

建立连接：

  • 您必须是选定计算机上的 sysadmin 固定服务器角色成员。

  • 目的服务器必须不同于源服务器。

  • 这两种服务器必须符合版本规则。
选项：

目的服务器

选择要将一个或多个数据库移动或复制到的服务器的名称，或单击浏览 (…) 按钮定位目的服务器。

说明 所使用的目的服务器可以是聚集服务器；复制数据库向导将会确保您所选择的只是聚集目的服务器上的共享驱动器。

使用 Microsoft Windows 身份验证

使用 Windows NT 用户名和密码以验证连接。

使用 SQL Server 身份验证

使用 SQL Server 安全性以验证连接。

用户名
如果选择 SQL Server 身份验证，则输入一个有效的 SQL Server 标准登录。
密码
如果选择 SQL Server 身份验证，则输入标准的登录密码。

下一页

开始验证进程，然后转到下一屏幕。

请参见

身份验证模式


选择要移动或复制的数据库

此屏幕用于选择要从源服务器移动或复制到目的服务器的一个或多个数据库。不能移动或复制下列数据库：

  • 目的服务器上的数据库。

  • 系统数据库。

  • 带有复制标记的数据库。

  • 带有"不可访问"、"装载"、"脱机"、"恢复"、"置疑"标记的数据库或处于紧急模式的数据库。
全文目录

移动或复制包含全文目录的数据库时，全文功能将停止，以后必须手工恢复。Microsoft 搜索服务管理全文目录，并在数据库中运行以提供此项服务。全文检索由复制数据库向导停止，因此数据库可被置入单用户模式，而该模式对移动或复制操作是必需的。

如果希望复制含有全文目录的数据库，那么复制操作完成后，源服务器上将无法使用该数据库的全文目录。必须在目的服务器上手工重新填充全文目录。

如果希望移动含有全文目录的数据库，那么移动数据库时，不移动任何相关的全文目录文件。这些文件必须由数据库管理员手工移动。

选项

移动

选择此选项将数据库移动到目的服务器。

复制

选择此选项将数据库复制到目的服务器。

源

显示源服务器上的数据库。

目的

显示目的服务器上源数据库的状态：

确认
可以移动或复制源数据库。
已经存在
源数据库已经存在，因而无法进行复制。
系统数据库
源数据库是系统数据库，无法复制，但可以复制从 master 和 msdb 数据库中选择的对象。
复制数据库
源数据库正参与复制，因而不能复制。
其它
对于特殊情况，将注明源数据库的具体状态。

刷新

刷新数据库列表。

数据和日志文件位置（仅限于 Windows 98 服务器）

将 Microsoft® Windows 98 服务器选为源服务器时，出现该列表。从列表中选择一个位置，即可启用"下一步"按钮。

单击"下一步"按钮后，可以验证选定数据库的所有数据和日志文件在选定位置上是否可用。

下一页

开始验证进程，然后转到下一屏幕。

请参见

升级 SQL Server 7.0 数据库（复制数据库向导）

使用复制数据库向导


数据库文件位置

此屏幕用于概述将要复制或移动的所有数据和日志文件的状态。准备移动或复制的文件在"状态"字段中有一个选中标记。如果存在名称冲突或磁盘空间问题，"状态"字段中就会显示一个红色的 X。

如果有磁盘空间问题或命名冲突，可单击"修改"按钮或"下一步"按钮打开数据库文件对话框，在该对话框中可以解决名称冲突或空间问题。

文件

显示所包括的数据文件和日志文件。

目标驱动器

显示数据文件和日志文件的目的服务器的驱动器名称。该信息使用目的服务器注册表中的数据自动设置。

大小

显示数据或日志文件的大小。

状态

如果文件已经准备好移动或复制，则显示一个绿色的选中标记。

如果存在磁盘空间问题或命名冲突，则显示一个红色的 X。

修改

单击即可打开"数据库文件"对话框。该对话框用于解决命名冲突和/或指定存在磁盘空间问题时所使用的备用驱动器。

刷新

单击即可重新评估磁盘空间和命名冲突。更新在"目的驱动器"和"状态"字段中显示。

说明 在此 Microsoft® SQL Server™ 2000 中，"大小"字段不会更新，即使文件的大小发生了变化。例如，可能已经对选定数据库的列表进行了更新。


数据库文件对话框

此对话框用于解决在移动或复制操作中遇到的冲突。

  • 要解决名称冲突，可在"源文件"字段直接键入一个新的名称。

  • 要解决磁盘空间问题，可单击浏览 (…) 按钮以更改"目的"字段中的位置。

当解决名称或磁盘空间问题后，单击"确定"按钮继续执行向导。

说明 无法用该对话框释放目的磁盘上的磁盘空间。

数据库

显示数据库名称。

目标文件

文件出现在源服务器上时，显示它们的名称。若要解决名称冲突问题，可直接编辑该字段。选择一个文件名，然后键入该文件在目的服务器上的名称。

大小

显示源文件的大小。

目的

显示建议的目的位置。若要更改目的，可直接编辑该字段或单击"浏览"按钮。

（"..."）浏览

单击"浏览"按钮更改数据库在目的服务器上的位置。在"标准文件位置"对话框中，定位想要的文件夹位置，然后输入数据库文件名。可以使用同一个文件名，或者更改数据库名称。

状态

如果文件已经准备好移动或复制，则显示一个绿色的选中标记。

如果存在磁盘空间问题或命名冲突，则显示一个红色的 X。

驱动器

显示驱动器名称。

可用空间

显示各磁盘上可用的可用空间。

所需空间

显示建议的移动或复制操作所需要的磁盘空间。

刷新

单击即可重新评估磁盘空间和命名冲突。更新将在相关字段中显示。

请参见

数据库文件位置


选择相关对象

此屏幕用于修改将在移动或复制操作中包括的对象。

选项

登录（推荐）

在移动或复制操作中包含登录，默认情况下是选中的。

包运行时检测到的所有登录
选择复制源服务器中的所有登录。所复制的登录的列表在运行时确定。
仅由选定数据库使用的登录（可选）
选择只复制由选定数据库使用的登录。

master 数据库中的共享存储过程（可选）

在移动或复制操作中包含 master 数据库中的存储过程，默认情况下是选中的。

说明 扩展存储过程及其相关的 DLL 不符合 Microsoft® SQL Server™ 2000 中的自动复制条件。

包运行时检测到的所有存储过程
选择复制 master 数据库中的所有 dbo（数据库所有者）存储过程（有名称冲突的数据库除外）。
用户选定的存储过程
选择启用"从 master 数据库中选择存储过程"屏幕，该屏幕详细提供了从 master 数据库中选择的存储过程。

msdb 中的作业（可选）

在移动或复制操作中包含 msdb 数据库中的作业，默认情况下是选中的。

包运行时检测到的所有作业
选择复制 msdb 数据库中的所有作业（有名称冲突或参与复制的数据库除外）。
用户选定的作业
选择启用"选择 msdb 中的对象"屏幕，该屏幕详细显示从 msdb 数据库中选择的作业。

用户定义的错误信息（可选）

在移动或复制操作中包含用户定义的错误信息，默认情况下是选中的。

包运行时检测到的所有错误信息
选择移动或复制所有消息（有 ID 冲突的消息除外）。
用户定义的错误信息（可选）
选择启用"选择用户定义的错误信息"屏幕，该屏幕详细地显示了用户选择的错误信息。


从 master 数据库中选择存储过程（可选）

此屏幕用于指定要在移动或复制操作中包含的存储过程。当在"选择相关对象"屏幕上选择"用户选定的存储过程"后，将会显示此屏幕。

选项

源对象

显示 master 数据库中所有用户创建的存储过程。无法复制目的服务器上的存储过程；这些存储过程虽然列出，但却无法在列表上启用。

所有者名称

显示对象的所有者，如特殊用户 dbo（数据库所有者）。

类型

显示数据库对象的类型。存储过程是所使用的唯一类型。

目的

显示目的服务器上源对象的状态。

确认
可以移动或复制该对象。
已经存在
源对象已经存在，因而无法进行复制。

全选

单击即可选择"源"字段中列出的所有对象。

全部清除

单击即可清除"源"字段中的所有已选对象。

存储过程复制选项

包运行时检测到的所有存储过程

使用该选项复制包运行时检测到的所有存储过程。

选定的存储过程

使用该选项复制所有存储过程。


从 msdb 中选择作业（可选）

此屏幕用于指定要在移动或复制操作中包含的作业。当在"选择相关对象"屏幕上选择"用户选定的作业"后，将会显示此屏幕。

选项

源

显示 msdb 数据库中的可用的源作业。

类型

在 Microsoft® SQL Server™ 2000 中，作业是可从 msdb 数据库复制的唯一对象类型。

目的

显示目的服务器上的源作业状态。

全选

单击即可选择列出的所有源作业。

全部清除

单击即可清除所有选定的源作业。

作业复制选项

包运行时检测到的所有作业

使用该选项复制包运行时检测到的所有作业。

选定的作业

使用该选项复制所有选定的作业。


选择用户定义的错误信息

此屏幕用于指定要在移动或复制操作中包含的消息。当在"选择相关对象"屏幕上选择"用户选定的消息"后，将会显示此屏幕。

列表中将显示所有用户定义的错误信息。在下列情况下无法复制消息：

  • 目的服务器上已经存在该消息。

  • 消息 ID 数字存在冲突。

  • 错误信息 ID 和语言 ID 有冲突。例如，如果 (MessageId1, msglangid1) =(MessageId2, msglangid2)，那么就会发生冲突。

  • 目的服务器上没有安装编写该消息所用的语言。
选项

错误

显示错误信息编号。

严重度

显示消息的严重度。

消息

显示消息的文本。

语言 ID

显示消息文本的语言标识符。

状态

显示目的服务器上错误信息的状态。

确认
可以移动或复制该对象。
已经存在
源对象已经存在，因而无法进行复制。

全选

单击即可选择列出的所有消息。

全部清除

单击即可清除所有选定的消息。

错误信息复制选项

包运行时检测到的所有错误信息

使用该选项复制包运行时检测到的所有信息。

选定的错误信息

使用该选项复制所有选定的信息。

请参见

错误信息格式


调度 DTS 包

此屏幕用于指定需要开始移动或复制操作的时间。

选项

包属性

显示 DTS 包的名称。

名称
显示将要运行的 DTS 包的名称。该名称自动生成。

时间

指定要运行 DTS 包的时间

立即运行
如果需要移动或复制操作在单击"下一步"按钮后执行，应选择此选项。
运行一次
如果希望只运行一次移动或复制操作，请选择该选项，然后使用"日期"或"时间"编辑框指定时间。
调度 DTS 包以后运行
如果需要调度移动或复制操作在以后执行，应选择此选项。当前的调度设置显示在描述框中。若要更改这些调度设置，请单击浏览 (…) 按钮以打开"编辑反复出现的作业调度"对话框。


完成复制数据库向导

此屏幕用于概述您已经做出的选择，其中包括：

  • 选定的数据库以及它们是否将被移动或复制。

  • 各数据库的文件位置。

  • 将包括的登录。

  • 从 master 数据库中选择的所有对象。

  • 从 msdb 数据库中选择的所有作业。

重要 使用复制数据库向导将 Microsoft® SQL Server™ 7.0 版数据库升级到 SQL Server 2000 时，管理员需对目的服务器上的数据库运行 sp_updatestats（更新统计）。这对于优化所复制的数据库的性能很重要。

后退

单击"后退"按钮即可查看或更改所作的选择。

完成

单击"完成"按钮即可运行移动或复制操作并在"日志详细信息"屏幕上查看其进度。

请参见

sp_updatestats


日志详细信息屏幕

如果立即运行移动或复制操作，则将显示"日志详细信息"屏幕。该状态屏幕显示操作中各主要步骤正在进行的进度，以及开始时间、结束时间和各步骤运行的总时间。扩展屏幕后即可查看各步骤的详细信息。

步骤详细信息

状态

显示绿色选中标记时表示步骤已经成功完成。

显示红色 X 时表示步骤已经失败。

步骤名称

显示复制数据库向导为进程中各步骤指定的名称。例如，CDW Master Task Step 表示传输 master 数据库中的对象信息这一步骤。

运行状态

显示数字代码以表示操作中各步骤的状态。

1
该步骤正在等待处理。
2
该步骤当前正在运行（执行）。
3
该步骤当前处于非活动状态（执行未激活）。
4
该步骤已经完成运行（完成执行）。

开始时间

显示移动或复制操作开始的时间。

结束时间

显示移动或复制操作结束的时间。

运行时间

显示操作所用的总时间。

错误代码

当出现错误时显示错误信息编号。

错误描述

显示对所遇到的错误信息的描述。

更多信息

扩展对话框以显示各主要步骤的任务详细信息。

较少信息

折叠对话框以隐藏各主要步骤的任务详细信息。

查看错误

显示对错误描述字段内信息的详细描述。

任务详细信息

状态

显示绿色选中标记时表示步骤已经成功完成。

显示红色 X 时表示步骤已经失败。

描述

显示对任务的详细描述。

错误代码

当出现错误时显示错误信息编号。Ok 表示没有遇到错误。