Microsoft SQL Server 2000 的新特性

Microsoft® SQL Server™ 2000 扩展了 Microsoft SQL Server 7.0 版的性能、可靠性、质量和易用性。Microsoft SQL Server 2000 增加了几种新的功能，由此成为大规模联机事务处理 (OLTP)、数据仓库和电子商务应用程序的优秀数据库平台。

SQL Server 7.0 版中提供的 OLAP 服务功能现在称为 SQL Server 2000 Analysis Services。术语"OLAP 服务"已被术语"Analysis Services"取代。Analysis Services 还包括一个新的数据挖掘组件。有关更多信息，请参见 Analysis Services 的新特性。

SQL Server 7.0 版中包含的知识库组件现在称为 Microsoft SQL Server 2000 Meta Data Services。现在提及该组件时使用术语"Meta Data Services"。"知识库"这个术语只在谈及 Meta Data Services中的知识库引擎时才使用。有关更多信息，请参见 Meta Data Services 的新特性。

"新特性"主题包括对新特性的简要概述，以及与提供更详细信息的相关概念性主题的链接。这些概念性主题提供与描述使用这些功能所需的命令和语句的主题的链接。


关系数据库增强

Microsoft® SQL Server™ 2000 对服务器进行了一些改进并增加了几种新的功能：

XML 支持

关系数据库引擎可以返回扩展标记语言 (XML) 文档格式的数据。另外，XML 还可用于在数据库中插入值以及更新和删除数据库中的值。有关更多信息，请参见 SQL Server 和 XML 支持与 XML 和 Internet 支持概述。

联合数据库服务器

SQL Server 2000 支持分布式分区视图增强，使您得以在多台服务器间对表进行水平区分。还可以从一台数据库服务器扩大到一组数据库服务器，使服务器相互合作，提供与数据库服务器群集相同的性能级别。此数据库服务器组（或数据库服务器联合体）可以支持最大型的 Web 站点和企业数据处理系统的数据存储要求。有关更多信息，请参见联合 SQL Server 2000 服务器。

SQL Server 2000 为虚拟接口构架 (VIA) 系统范围的网络引入了 Net-Library 支持，从而在服务器之间（例如在应用程序服务器和数据库服务器之间）提供了高速连接。有关更多信息，请参见通讯组件。

用户定义函数

可以通过创建自己的 Transact-SQL 函数来扩展 Transact-SQL 的可编程性。用户定义函数可返回标量值也可返回表。有关更多信息，请参见 SQL 用户定义函数。

索引视图

当应用程序中包含需要经常执行联接或聚合操作的查询时，利用索引视图可显著提高查询性能。索引视图允许在视图中创建索引，在数据库中存储视图的结果集并编制索引。不必为了利用索引视图所带来的性能改进而修改现有的应用程序。有关更多信息，请参见 SQL 视图。

新数据类型

SQL Server 2000 引入了三种新的数据类型：bigint 是 8 字节的整型类型，sql_variant 类型允许存储不同数据类型的数据值，table 类型允许应用程序临时存储结果供以后使用。table 类型可用于变量，并可作为用户定义函数的返回数据类型。有关更多信息，请参见数据类型和表结构。

INSTEAD OF 和 AFTER 触发器

执行 INSTEAD OF 触发器代替执行触发操作（例如 INSERT、UPDATE 和 DELETE）。这些触发器同样可在视图中定义，这样可以大大扩展视图所能支持的更新操作类型。AFTER 触发器在触发操作完成后激发。SQL Server 2000 还增加了指定 AFTER 触发器激发的先后顺序的功能。有关更多信息，请参见触发器。

级联引用完整性约束

在尝试更新或删除现有外键所指向的键时，可以控制 SQL Server 2000 采取的操作。这由 CREATE TABLE 和 ALTER TABLE 语句的 REFERENCES 子句中新的 ON DELETE 和 ON UPDATE 子句控制。有关更多信息，请参见约束。

排序规则增强

SQL Server 2000 用排序规则代替代码页和排序次序。SQL Server 2000 支持 SQL Server 早期版本所支持的大部分排序规则，并在 Windows 排序规则的基础上增加了一套新的排序规则。现在，用户可以在数据库级别或列级别上指定排序规则。以前，只能在服务器级上指定代码页和排序次序，然后应用于服务器上的所有数据库。有关更多信息，请参见排序规则。

排序规则支持代码页转换。现在支持 char 和 varchar 操作数具有不同代码页的操作。对于 text 操作数，不支持代码页转换。可以使用 ALTER DATABASE 更改数据库的默认排序规则。有关更多信息，请参见 SQL Server 排序规则基础知识和 ALTER DATABASE。

全文检索增强

全文检索现在包括更改跟踪和图像筛选。更改跟踪维护记录着全文索引数据所有更改的日志。若要使全文索引更新为新的内容，可根据调度手工刷新日志，也可以使用后台更新索引选项，在更改一发生时便更新。图像筛选功能允许为存储在 image 列中的文档创建索引并执行查询。如果某个文档以文件的形式存储在文件系统中，则用户可在包含该文档应具有的文件扩展名的列中提供文档类型。使用该信息，全文检索可以装载相应的文档筛选以提取文本化信息进行索引。有关更多信息，请参见 Microsoft 搜索服务。

多个 SQL Server 实例

SQL Server 2000 支持在同一台计算机上运行多个关系数据库引擎的实例。每一台计算机都可以从 SQL Server 6.5 或 7.0 版中运行一个关系数据库引擎实例，同时从 SQL Server 2000 中运行一个或多个数据库引擎的实例。每一个实例都有自己的一套系统和用户数据库。应用程序可以连接计算机上的任一个实例，连接方式类似于连接运行在其它计算机上的 SQL Server 实例。SQL Server 2000 实用工具和管理工具已得到增强，可以处理多个实例。有关更多信息，请参见多个 SQL Server 实例。

索引增强

现在可以在计算列上创建索引。可指定以升序还是降序生成索引，以及数据库引擎是否应在索引创建过程中使用并行扫描和排序。有关更多信息，请参见表索引和创建索引的并行操作。

CREATE INDEX 语句现在可以将 tempdb 数据库用作生成索引所需的排序的工作区域。这将改进索引创建步骤中读写磁盘的模式，使索引页更有可能分配在邻接条带中。另外，创建索引的完整过程不仅适用于初始表扫描，还适用于并行操作。有关更多信息，请参见 tempdb 和索引创建、创建索引的并行操作和 CREATE INDEX。

故障转移群集增强

故障转移群集的管理已得到很大改进，使安装、配置和维护 Microsoft SQL Server 2000 故障转移群集变得非常容易。其它增强功能还包括：对 SQL Server 2000 群集中任意节点进行故障转移和故障回复，在 SQL Server 2000 安装过程中向群集中添加或从中删除任意节点，在重新安装或重建群集中任意节点中的群集实例时不影响其它群集节点实例。SQL Server 2000 实用工具和管理工具已被增强为可处理故障转移群集。有关更多信息，请参见故障转移群集构架。

Net-Library 增强

SQL Server 2000 Net-Library 已重新编写，使得在连接 SQL Server 2000 客户端与 SQL Server 2000 实例时，不必管理客户端计算机上的 Net-Library 配置。新的 Net-Library 还支持连接同一台计算机上的多个 SQL Server 实例，并支持在所有 Net-Library 上进行安全套接字层加密。SQL Server 2000 为虚拟接口构架 (VIA) 系统范围的网络引入了 Net-Library 支持，从而在服务器之间（例如在应用程序服务器和数据库服务器之间）提供了高速连接。有关更多信息，请参见通讯组件。

64-GB 内存支持

Microsoft SQL Server 2000 企业版可以使用 Microsoft Windows 2000 Advanced Windows Extension (AWE) API，支持计算机上有多达 64 GB 的物理内存（RAM)。有关更多信息，请参见使用 Windows 2000 上的 AWE 内存。

分布式查询增强

SQL Server 2000 引入了新的 OPENROWSET 函数，用于在分布式查询中指定特殊的连接信息。SQL Server 2000 还指定了一些方法，OLE DB 提供程序通过这些方法报告它所支持的 SQL 语法的级别，以及数据源中键值分布的统计数据。然后，分布式查询优化器可使用这些信息减少必须从 OLE DB 数据源中发送的数据量。比起早期版本的 SQL Server，SQL Server 2000 委派给 OLE DB 数据源更多的 SQL 操作。分布式查询还支持在 SQL Server 2000 中增加的其它功能，例如支持多个实例、允许在结果集中混合不同排序规则的列、支持新的 bigint 和 sql_variant 数据类型。有关更多信息，请参见分布式查询构架。

SQL Server 2000 分布式查询增加了对用于 Exchange 的 OLE DB 提供程序和用于 Microsoft Directory 服务的 Microsoft OLE DB 提供程序的支持。有关更多信息，请参见用于 Microsoft 目录服务的 OLE DB 提供程序和用于 Exchange 的 OLE DB 提供程序。

可更新的分布式分区视图

SQL Server 2000 引入了分布式分区视图的功能。用户可以跨多个服务器水平分区表，并在每个成员服务器上定义一个分布式分区视图，看起来就好象在每台服务器上存储了原始表的一个完整复本。以这种分区方式相互协作的 SQL Server 服务器组称为服务器联合体。使用 SQL Server 2000 数据库生成的数据库联合体能支持最大型 Web 站点或企业级数据库的处理要求。有关更多信息，请参见创建分区视图。

Kerberos 和安全委托

SQL Server 2000 使用 Kerberos 支持客户端和服务器间的相互身份验证，并支持在计算机间传递客户端的安全凭据，使远程服务器上的工作得以利用模拟客户端凭据继续进行。在 Microsoft Windows® 2000 环境中，SQL Server 2000 使用 Kerberos 和委托支持集成的身份验证以及 SQL Server 登录。有关更多信息，请参见安全帐户委托。

备份和还原增强

SQL Server 2000 增加了一种全新的、更易于理解的模型来指定备份和还原选项。这种新模型使用户能够更加清楚地针对不同计划的性能和日志空间要求，权衡增加或降低工作损失的风险。SQL Server 2000 通过在事务日志中使用命名日志标记，增加了对恢复到特定工作点的支持，并支持进行部分数据库还原。有关更多信息，请参见备份/还原构架。

用户可以为备份集和媒体集设定密码，以防止未经授权的用户访问 SQL Server 备份。有关更多信息，请参见 BACKUP。

实用工具操作可伸缩性增强

SQL Server 2000 中实用工具操作的增强功能包括：更快速的差异备份、并行数据库控制台命令检查 (DBCC) 和并行扫描。现在完成差异备份所需的时间与自最后一次完整备份以来所改动的数据量成正比。运行 DBCC 时，无须为扫描表而获取共享表锁，因此，DBCC 可以与表上的更新活动并发运行。另外，DBCC 现在可利用多个处理器，因此，可以获得与 CPU 数量成近似线性关系的性能增益（假设 I/O 不是瓶颈）。有关更多信息，请参见数据完整性验证和差异备份和还原。

Text in Row 数据

SQL Server 2000 支持新的 text in row 表选项，用来指定将小的 text、ntext 和 image 值直接放入数据行而非单独的页中。这将减少用于存储小的 text、ntext 和 image 数据值的空间，并减少处理这些值所需的磁盘 I/O 量。有关更多信息，请参见 text、ntext 和 image 数据。


关系数据的 XML 集成

Microsoft® SQL Server™ 2000 关系数据库引擎生来支持可扩展标记语言 (XML)。

现在可以使用统一资源定位器 (URL) 通过 HTTP 访问 SQL Server 2000。可以在 Microsoft Internet 信息服务器 (IIS) 上定义一个虚拟根，该服务器赋予用户访问 SQL Server 2000 的数据和 XML 功能的 HTTP 权限。

可以使用 HTTP、ADO 或 OLE DB 处理 SQL Server 2000 的 XML 功能：

  • 可以通过在简化 XML-Data (XDR) 架构中进行批注来定义 SQL Server 2000 数据库的 XML 视图，以映射与架构的元素及特性相关联的表、视图和列。这样就可以在 XPath 查询中引用 XML 视图。XPath 查询从数据库中检索结果并将结果以 XML 文档的形式返回。

  • SELECT 语句的结果可以 XML 文档的形式返回。SQL Server 2000 Transact-SQL SELECT 语句支持 FOR XML 子句，该子句指定以 XML 文档的形式而不是关系结果集的形式返回语句结果。复杂查询或用户希望具有安全性的查询都可以模板的形式存储在一个 IIS 虚拟根下，并可以通过引用模板名来执行。

  • 可以使用新的 OPENXML 行集函数将 XML 文档中的数据表现为关系行集的形式。只要是在 Transact-SQL 语句中可使用行集函数的地方，例如在 FROM 子句中引用表或视图的位置，都可以使用 OPENXML。这使您得以使用 XML 文档中的数据插入、更新或删除数据库表中的数据，包括在单个操作中修改多个表中的多行。

请参见

SQL Server 和 XML 支持

XML 和 Internet 支持概述


图形管理增强

Microsoft® SQL Server™ 2000 改进并增加了以下新的图形管理功能：

日志传送

日志传送功能允许连续备份源数据库中的事务日志，并将这些日志装入另一台服务器上的目标数据库中。这对于维护备用服务器或将查询处理负载从源服务器移到一台只读目的服务器上非常有用。有关更多信息，请参见日志传送。

SQL 事件探查器增强

SQL 事件探查器现在支持基于大小和基于时间的跟踪，并包括"数据文件自动增长"、"数据文件自动压缩"、"日志文件自动增长"、"日志文件自动压缩"、"显示全部计划"、"显示计划统计"和"显示计划文本"中的新事件。

增强后的事件探查器提供审核 SQL Server 活动的功能，审核级别可达到由美国政府确定的 C2 安全级别要求。有关更多信息，请参见审核 SQL Server 活动和使用 SQL 事件探查器进行监视。

SQL 查询分析器增强

SQL 查询分析器现在包括对象浏览器，允许用户随意浏览和获取有关数据库对象，包括用户和系统表、视图、存储过程、扩展存储过程和函数的信息（如参数和相关性）。对象浏览器还支持生成脚本以执行或创建对象。其它增强功能还包括服务器跟踪和客户端统计数据，以显示服务器端和客户端受给定查询影响的有关信息。

SQL 查询分析器包括一个存储过程调试器。此外，它还包括可用作开始创建对象（如数据库、表、视图和存储过程）时的模板。有关更多信息，请参见 SQL 查询分析器和 SQL 查询分析器概述。

复制数据库向导

用户可以运行复制数据库向导，将 SQL Server 7.0 版数据库升级到 SQL Server 2000 数据库。还可用此向导在 SQL Server 2000 实例间复制完整的数据库。有关更多信息，请参见将数据库复制到其它服务器和升级 SQL Server 7.0 数据库（复制数据库向导）。


复制增强

Microsoft® SQL Server™ 2000 改进并增加了以下复制功能：

执行复制

SQL Server 2000 的快照复制、事务复制和合并复制通过增加以下功能得到增强：
  • 备用快照位置，为将初始快照应用于订阅服务器提供了更加方便和灵活的方法。用户可以将快照文件保存（或压缩）到某个网络位置或可移动媒体上，然后，不通过网络即可将这些文件传送到订阅服务器。

  • 可连接的订阅数据库，允许用户将包含已复制数据的数据库以及一个或多个订阅从一台订阅服务器传送到另一台 SQL Server 上。当此数据库被附加到新的订阅服务器后，新的订阅服务器上的订阅数据库将自动接收自己对指定发布服务器上发布的请求订阅。

  • 对发布数据库的架构进行了更改，允许用户添加或除去发布表上的列，并将那些更改传播到订阅服务器。

  • 请求式脚本执行，允许用户粘贴将在所有订阅服务器上执行的常规 SQL 脚本。

  • 快照前和快照后脚本，允许用户在订阅服务器上应用快照之前或之后运行脚本。

  • 远程代理程序激活，允许用户通过在一台计算机上运行分发代理程序或合并代理程序，同时从另一台计算机上激活此代理程序的方式，减少分发服务器或订阅服务器上的处理量。可以将远程代理程序激活功能用于强制订阅或请求订阅。

  • 支持新的 SQL Server 功能，包括用户定义函数、索引视图、新数据类型和多个 SQL Server 实例。

  • ActiveX 快照控制，使得更容易通过编程方式生成快照。

  • 更多的快照脚本选项，支持向订阅服务器传送索引、扩展属性和约束。

合并复制

合并复制是从发布服务器向订阅服务器分发数据的过程，允许发布服务器和订阅服务器在相连或未相连时进行更新，然后在相连时合并站点间的所有更改。合并复制增强功能包括：
  • 对于改进后的服务器间性能，合并代理程序具有更大的并行度。

  • 确定与订阅服务器上某一分区相关的数据更改的优化功能。

  • 动态快照在使用动态筛选时能更有效地应用初始快照。

  • 合并发布的垂直筛选。

  • 用户定义函数具有更强大的动态筛选功能。

  • 能够在同步数据时使用备用的同步伙伴。通过使用备用的同步伙伴，合并发布的订阅服务器可以与任何拥有与原始发布服务器相同数据的指定服务器同步。

  • 自动管理标识范围。在合并复制拓扑中，如果某个发布包含一个 identity 列，并且可以在订阅服务器上插入新行时，订阅服务器上的自动管理标识范围将确保不会将同一个标识值指派给插入不同订阅数据库的行，也不会发生违反主键约束的行为。当排队更新与快照或事务复制一起使用时，也可以使用此功能。

  • 支持发布表中的 timestamp 列。

  • 对管理合并跟踪数据增长进行了改进。

  • 增加了几个新的合并复制冲突解决程序，包括为即时、手工解决冲突，基于列值、最小/最大值获胜、第一个/最后一个更改获胜、累积/平均值的优先级，和通过追加不同的文本值进行合并提供用户界面的交互式冲突解决程序。

  • 增加了用于验证订阅服务器是否有权将更改上载到发布服务器的新选项 (check_permissions)，并增强了安全性，包括 Microsoft SQL Server 2000 附带的冲突解决程序的代码签名。

  • 增加了新的 COM 接口，支持在 SQL Server 复制拓扑内将异类数据源作为发布服务器。

  • 验证每次订阅的复制数据或发布范围内的复制数据。还可以通过 SQL Server 企业管理器使用验证。

  • 重新初始化允许在应用新快照之前上载订阅服务器的更改。

有关更多信息，请参见合并复制和复制选项。

事务复制

通过事务复制，在订阅服务器上应用数据的初始快照，然后，当发布服务器上发生数据修改时，捕获个别的事务并传播到订阅服务器。事务复制增强功能包括：
  • 并发快照处理，允许在生成初始快照的同时在发布表上继续修改数据。

  • 改进了处理错误方式，能够跳过指定错误继续复制。

  • 在订阅服务器上验证复制数据，包括在垂直分区上验证。还可以通过 SQL Server 企业管理器使用验证。

  • 将索引视图以表的形式发布。

  • 将订阅服务器上所做的数据修改存储到队列的选项（排队更新）。

  • 在数据发布到订阅服务器时转换数据的选项（转换已发布数据）。

  • 不必重新初始化订阅或禁用和重新配置发布和分发，即可还原事务复制数据库。还可以设置事务复制与日志传送一同使用，使用户能将故障转移到备用服务器，而不必重新配置复制。有关更多信息，请参见事务复制的备份和还原策略。

有关更多信息，请参见事务复制。

排队更新

排队更新允许快照复制和事务复制订阅服务器不必与发布服务器建立活动的网络连接，即可修改已发布的数据。

当通过启用排队更新选项来创建发布，且订阅服务器在已发布数据上执行 INSERT、UPDATE 或 DELETE 语句时，更改将存储在一个队列中。当网络连接恢复后，在发布服务器上经过排队的事务将进行异步应用。

由于更新异步传播至发布服务器，所以发布服务器或另一台订阅服务器有可能更新同一数据，而在应用更新时会发生冲突。将自动检测这些冲突，此外还提供了几个解决冲突的选项。

有关更多信息，请参见排队更新。

转换已发布的数据

转换订阅（可用于快照复制或事务复制）可调节数据转换服务（DTS）的数据移动、转换映射和筛选功能。

通过在复制拓扑中使用可转换的订阅，使用户得以根据各个订阅器的要求自定义和发送已发布的数据，包括在发布数据时执行数据类型映射、列操作、字符串操作以及使用函数。

有关更多信息，请参见转换已发布的数据。

复制可用性

SQL Server 企业管理器经过多方改进，使实施、监视和管理复制变得更加容易。复制可用性的增强功能包括：
  • 在 SQL Server 企业管理器树中增加了一个集中复制文件夹，用于在正在管理的服务器上组织所有订阅和发布。

  • 能够使用 Windows Active Directory 浏览和订阅发布（当被授权时）。

  • 能够在 SQL Server 企业管理器的单个监视节点中查看多个分发服务器。

  • 创建发布向导、创建强制订阅向导和创建请求订阅向导中的标准和高级复制选项被分开。用户可以选择是否在每个向导的欢迎页上显示向导中的高级选项。

  • 增加了两个新向导：为使用动态筛选的合并发布创建动态快照作业的创建动态快照作业向导，和在快照复制或事务复制中转换已发布数据的转换已发布数据向导。


数据转换服务增强

Microsoft® SQL Server™ 2000 增强并增加了以下数据转换服务 (DTS) 功能：

新的自定义任务

新的 DTS 自定义任务（可通过 DTS 设计器或 DTS 对象模型获得）使您得以创建 DTS 包，以便根据运行时环境的属性执行任务或设置变量。使用这些任务可以：
  • 从 Internet 和文件传输协议 (FTP) 站点导入数据，以及向它们发送数据和完整的包。

  • 异步运行包。

  • 生成相互发送消息的包。

  • 生成执行其它包的包。

  • 联接多个包执行，作为事务的一部分。

有关更多信息，请参见生成 DTS 自定义任务。

增强的日志设备

DTS 包日志保存每次包执行的信息，从而可以维护一个完整的执行历史记录。也可以查看任务内的个别进程的执行信息。

可以生成转换任务的异常错误文件。记入异常错误文件后，就可以通过 DTS OLE DB 文本文件提供程序，将源错误行和目的错误行保存到文件中，然后重新处理错误行。

将 DTS 包保存到 Visual Basic 文件

现在 DTS 包可以保存到 Microsoft® Visual Basic® 文件。这允许将 DTS 导入/导出向导或 DTS 设计器创建的包并入 Visual Basic 程序，或者由需要引用 DTS 对象模型组件的 Visual Basic 开发人员作为原型使用。有关更多信息，请参见保存 DTS 包。

使用多阶段数据抽取

新的多阶段数据抽取允许高级用户在数据抽取操作的不同阶段自定义数据抽取操作。可以将全局变量用作查询的输入和输出参数。有关更多信息，请参见多阶段数据抽取功能。

使用参数化查询

现在可以在 DTS 转换任务和执行 SQL 任务中使用参数化源查询。另外，DTS 还包括一个将参数化查询的结果保存到全局变量的选项，这使您得以执行类似将脱接的 Microsoft ActiveX® 数据对象 (ADO) 记录集保存到 DTS 中这样的功能。有关更多信息，请参见在 DTS 中使用参数化查询。

使用全局变量在 DTS 包之间传递信息

现在可以使用执行包任务来将全局变量的值动态地从父包赋给子包。当各个包执行不同的工作项目时，使用全局变量在包之间传递信息。例如，使用一个包每夜下载数据，对数据进行汇总，将汇总数据值赋给全局变量，然后将这些值传递给另一个包，由该包来进一步处理数据。


Analysis Services 增强

Microsoft® SQL Server™ 2000 Analysis Services 包括以前的 OLAP 服务。并增加了新的数据挖掘组件。有关数据挖掘和其它 Analysis Services 新特性的更多信息，请参见 Analysis Services 的新特性。


Meta Data Services 增强

Microsoft® SQL Server™ 2000 Meta Data Services 包括以前的 Microsoft 知识库。有关 Meta Data Services 新特性的更多信息，请参见 Meta Data Services 的新特性。


English Query 增强

English Query 引入了以下几种新特性：

  • 与 Microsoft® Visual Studio®、Analysis Services 和全文检索的集成更加紧密。

  • 为 English Query 创作增加了图形用户界面。

  • 增加了 SQL 项目向导。

  • 增加了用于保持 English Query 模型信息的基于 XML 的语言。

有关更多信息，请参见 English Query 的新特性。


文档增强

Microsoft® SQL Server™ 2000 的文档有如下增强和新特性：

F1 帮助和 SQL Server 联机丛书集成

SQL Server 2000 的 F1 帮助已经与 SQL Server 联机丛书集成。当选择 F1 帮助时，SQL Server 联机丛书中的相关主题就会显示出来。

SQL Server 联机丛书支持子集

SQL Server 联机丛书允许用户定义整个 SQL Server 联机丛书的子集并对子集执行搜索。用户可以定义自己的子集；不过还需提供一组默认的子集。子集面向特定的用户，并且每个子集涵盖多个主题。子集通过将搜索点击次数减到最少，使搜索与活动有关的信息变得更容易。

缩略图艺术

SQL Server 联机丛书中的某些关系图显示为关系图缩图。单击"增大关系图"可查看完整的关系图。打印主题时显示完整的关系图。

词汇表改进

词汇表术语显示为带下划线的彩色文本。单击术语时，将出现一个弹出式窗口，显示术语定义。

访问相关主题更加容易

很多主题的结尾处都有相关主题的列表，称为"参阅"。SQL Server 联机丛书新增了一个"参阅"图标，单击该图标会显示相关主题的列表。