首页.1

Powered By Gisun http://www.gisun.com

1 安装要求... 2

2 安装顺序... 2

2.1 服务器端安装顺序... 2

2.2 客户端安装顺序... 2

3 服务器端安装... 3

3.1 安装Dotnetfx35.exe. 3

3.2 执行SQL2008安装必备中的Setup.exe. 4

3.3 安装SQLEXPRADV_x86_CHS.exe. 4

3.3.1 安装SQL Server 2008. 4

3.3.2 检测数据库是否安装成功... 13

3.4 开启数据库SA用户、配置SQL Server网络配置... 13

3.4.1 开启数据库SA用户... 13

3.4.2 配置SQL Server网络配置... 17

3.5 安装仓库程序所需程序... 19

3.5.1 安装IIS. 19

3.5.2 安装ASPAJAXExtSetup.msi. 21

3.5.3 安装WebFormDWCLTRT25.msi. 21

3.6 执行希望之星安装中的Setup.exe. 21

4 客户端安装... 24

4.1 执行希望之星安装中的Setup.exe. 24

5 ★常见问题处理★... 25

5.1 安装数据库的常见问题... 25

5.2 安装希望之星的常见问题... 25

5.3 登录仓库常见问题... 25

5.4 Reporting Services异常... 28

5.5 附加Sunrise数据库... 30

6 Windows XP安装... 31

6.1 安装要求... 31

6.2 服务器端安装... 31

6.3 WindowsXP安装说明... 32


1安装要求.14267

1 安装要求

l 安装前注意事项

n 安装时使用Administrator登录系统

n 修改计算机名称，安装完数据库后再修改会导致数据库无法使用，且计算机名称不能超过10位，如名为Server

l 软件要求

n 服务器端使用Windows2003+SP2操作系统，客户端可使用Windows2003或WindowsXp操作系统

n 电脑操作系统尽量使用安装版操作系统，Ghost系统版本较多，有的版本不能使用，会导致程序安装失败

n 尽量使用干净的操作系统，即重做系统

l 硬件要求

n CPU：2GHz以上

n 内存：至少1.5GB，建议2GB

n 硬盘：80GB，至少有C、D盘符

n 显示器分辨率：1024*768


2安装顺序.18838

2 安装顺序


2.1服务器端安装顺序.19259

2.1 服务器端安装顺序

l 安装Dotnetfx35.exe

l 执行SQL2008安装必备中的Setup.exe

n 自动安装WindowsServer2003-KB942288-v4-x86-msi_45.exe并重启电脑

n 自动安装Windows补丁WindowsServer2003-KB936059-x86-CHS.exe

n 自动安装Windows PowerShell

l 安装SQLEXPRADV_x86_CHS.exe

l 开启数据库SA用户、配置SQL Server网络配置

l 安装仓库程序所需程序

n 注：如果不安装仓库管理模块，可以不安装以下程序

n 安装IIS（必须根据系统版本安装对应的IIS）

n 安装ASPAJAXExtSetup.msi

n 安装WebFormDWCLTRT25.msi

l 执行希望之星安装中的Setup.exe

n 自动安装.NET 2.0

n 安装希望之星

n 自动安装消息队列


2.2客户端安装顺序.25799

2.2 客户端安装顺序

l 执行希望之星Setup.exe

n 自动安装Microsoft .NET Framework 2.0及中文包

n 安装希望之星

n 自动安装消息队列


3服务器端安装.27585

3 服务器端安装


3.1安装Dotnetfx35.exe.28010

3.1 安装Dotnetfx35.exe

l 双击程序安装，打开安装窗口，接受条款，点“安装”按钮；

l 进入下载窗口，如果电脑可以上网，安装程序会自动到微软网址上下载最新的.net Framework程序，下载非常慢且不需要下载最新的程序，所以在安装此程序时将电脑网络断开或禁用本地连接，安装程序经过5次连接服务器失败后会继续往下安装。安装完.net Framework后可再将网络连上；

l 安装程序可能要等几分钟，请耐心等待；

l 安装成功后点“退出”按钮。


3.2执行SQL2008安装必备中的Setup.exe.30534

3.2 执行SQL2008安装必备中的Setup.exe

l 自动安装WindowsServer2003-KB942288-v4-x86-msi_45.exe并重启电脑

l 自动安装Windows补丁WindowsServer2003-KB936059-x86-CHS.exe

l 自动安装Windows PowerShell

l 注：安装过程比较简单，按照提示进行安装


3.3安装SQLEXPRADV_x86_CHS.exe.32518

3.3 安装SQLEXPRADV_x86_CHS.exe


3.3.1安装SQLServer2008.33056

3.3.1 安装SQL Server 2008

l 双击程序安装，打开“SQL Server安装中心”；

l 安装前可检查系统配置是否符合标准，点“系统配置检查器”，打开检查窗口对当前系统进行检测，全部通过点“确定”关闭检查窗口；

l 左侧选择“安装”，右侧选择“全新SQL Server独立安装或向所有安装添加功能”，检查安装程序所需条件，全部通过点“确定”按钮开始安装；

l 打开“安装程序支持文件”窗口。

l “产品密钥”，点“下一步”；

l 接受许可条款，点“下一步”；

l “安装程序支持文件”窗口，点“安装”按钮安装程序支持文件；

l 打开“安装程序支持规则”窗口进行检查，全部通过点“下一步”，

l “功能选择”窗口，选择“数据库引擎服务”，“SQL Server复制”，“Reporting Services”，“管理工具-基本”，“SQL 客户端连接SDK”，选择安装以上几项就可以，其余不用安装，如下图，点“下一步”；

l “实例配置”窗口，使用默认，如下图，点“下一步”；

l “磁盘空间要求”窗口，显示安装程序所需磁盘空间大小，点“下一步”；

l “服务器配置”窗口，点“对所有SQL Server服务使用相同的的帐户”，打开窗口，“帐户名”下拉框选择“NT AUTHORITY\NETWORD SERVICE”,点“确定”按钮，所有服务使用此帐户名；

l 下侧“SQL Server Browser”选择“自动”，点“下一步”

l “数据库引擎配置”窗口，默认“Windows身份验证模式”，可以选择“混合模式（SQL Server身份验证和Windows身份验证”，但必须输入SA的密码。点“添加当前用户”按钮，将当前用户指定为SQL Server管理员。“数据目录”和“FILESTREAM”Tab页使用默认即可，点“下一步”；

l “Reporting Services配置”窗口，使用默认的“安装本机模式默认配置”，点“下一步”；

l “错误和使用情况报告”窗口，使用默认，不用选择选项，点“下一步”；

l “安装规则”窗口，检测系统，全部通过点“下一步”按钮；

l “准备安装”窗口，显示前面设置的安装信息，点“安装”；

l “安装进度”窗口，开始安装程序；

l 安装过程所需时间较长，请耐心等待；

l 所有功能安装成，安装完毕，点“下一步”；

l “完成”窗口，点“关闭”按钮，SQL Server 2008安装完毕；

l 关闭“SQL Server安装中心”。


3.3.2检测数据库是否安装成功.45079

3.3.2 检测数据库是否安装成功

l 打开‘开始-程序-Microsoft SQL Server 2008’，如图所示数据库组件安装完整。

l 打开浏览器，输入“http://服务器名/ReportServer_SQLExpress”，如下图所示说明报表服务器安装成功。


3.4开启数据库SA用户、配置SQLServer网络配置.46742

3.4 开启数据库SA用户、配置SQL Server网络配置


3.4.1开启数据库SA用户.47276

3.4.1 开启数据库SA用户

l “开始-程序-Microsoft SQL Server 2008-SQL Server Management Studio”,打开数据库引擎， “连接到服务器”点连接按钮；

l 右击服务器名，选择“属性”，“安全”中服务器身份验证选择“SQL Server和Windows身份验证模式”，点确定按钮；

l 打开“安全性-登入名-sa-属性-状态”，登录设置为启用，点确定按钮；

l 打开“安全性-登入名-sa-属性-常规”，如果Sa不需要设置密码，去掉“强制实施密码策略”，同时清除密码；

l 设置完后重新启动Sql server服务，SA开启成功；

l 注：开启sa时需要按说明的顺序执行，如先去掉“强制实施密码策略”再设置“登录”为启用，确定时出错不允许修改。需要再选中“强制实施密码策略”并设置一个密码，再按顺序进行设置。


3.4.2配置SQLServer网络配置.51807

3.4.2 配置SQL Server网络配置

l 因为需要用到报表服务器和远程访问数据库，需要配置远程服务器；

l “开始-程序-Microsoft SQL Server 2008-配置工具-SQL Server配置管理器”，选择“SQLEXPRESS的协议”，右侧“Named Pipes”右击属性或直接双击，打开“Named Pipes”窗口，“已启用”选择“是”，点“确定”，需要重启SQL Server服务；

l 右侧“TCP\IP”右击属性或直接双击，打开“TCP\IP属性”窗口，“已启用”选择“是”，点“确定”，需要重启SQL Server服务；

l 选择“SQL Server服务”，右侧“SQL Server（SQLEXPRESS）”右击“重新启动”。


3.5安装仓库程序所需程序.54780

3.5 安装仓库程序所需程序


3.5.1安装IIS.55290

3.5.1 安装IIS

l IIS属于Windows操作系统的组件，需要手工单独安装；

l Windows2003+Sp2有各自的IIS组件，安装时先要确认操作系统及Sp版本，然后在希望之星光盘中选择相对应的IIS组件。一定要选择相对应的IIS组件，否则安装失败。

l 打开Windows2003的“开始 - 控制面板 - 添加或删除程序”，点击左侧“添加/删除Windows组件”，窗口内双击“应用程序服务器”选中“Internet信息服务IIS”，系统自动选中“启用网络COM+访问”，再选择“ASP.NET”，点击“确定”按钮；

l 点击“下一步”，系统开始安装IIS。安装过程中先后会出现几次选择所需文件窗口，点“浏览”按钮选择对应的IIS组件下的文件即可。

l 点击“完成”，IIS安装完毕。


3.5.2安装ASPAJAXExtSetup.msi.58830

3.5.2 安装ASPAJAXExtSetup.msi

l 安装过程比较简单，按照提示进行安装


3.5.3安装WebFormDWCLTRT25.msi.59666

3.5.3 安装WebFormDWCLTRT25.msi

l 安装过程比较简单，按照提示进行安装


3.6执行希望之星安装中的Setup.exe.60503

3.6 执行希望之星安装中的Setup.exe

l 双击“Setup.exe”文件，自动安装.Net2.0，安装完毕打开希望之星酒店管理系统安装窗口，选中“我接受许可协议中的条款”，点“下一步”；输入“姓名”和“单位”，可以为空，点“下一步”；选中“安装服务器端”，点“下一步”；

l 数据库服务器名称是“计算机名称（或IP）+‘\Sqlexpress’”，名称输入错误会导致程序安装失败，如“Server\sqlexpress”，点击“下一步”；

l 报表服务器Web服务URL：输入“http://服务器名/ReportServer_Sqlexpress”

l 报表管理器URL：输入“http://服务器名/ReportS_Sqlexpress”

l 打开选择安装窗口。默认典型安装，即安装基本信息、餐厅预顶、前台收银、客房管理、客户管理、报表中心；

l 点击“自定义”按钮打开自定义安装窗口。默认显示的就是典型安装的内容，根据自己的需要选择性安装模块功能；

l 默认安装位置是“C:\Program Files\Hopesoft\”,可以修改安装位置；

l 重置按钮可以将安装置为默认，即典型安装；

l 选择安装的模块后点“下一步”，点“安装”按钮开始安装；

l 注：当安装程序检查到系统安装了IIS，则自定义安装中会有“仓库管理”模块，否则自定义安装中将“仓库管理”隐藏；

l 程序安装可能需要几分钟，请耐心等待；

l 安装完毕，提示“已完成 希望之星酒店管理系统安装向导”，说明程序安装成功，点“完成”按钮；

l 如提示“希望之星酒店管理系统 安装向导过早结束”，说明程序安装失败，检查失败原因，并卸载后重新安装。


4客户端安装.67628

4 客户端安装


4.1执行希望之星安装中的Setup.exe.68051

4.1 执行希望之星安装中的Setup.exe

l 自动安装Microsoft .NET Framework 2.0及中文包

l 手工安装希望之星

n 安装客户端程序与服务器端基本一样。有以下两点区别：

n 1.安装时选择“安装客户端”；

n 2.客户端没有“报表服务器连接设置”窗口

n 注：安装客户端程序前需要将服务器数据库SA用户开启

l 自动安装消息队列


5★常见问题处理★.70987

5 ★常见问题处理★


5.1安装数据库的常见问题.71472

5.1 安装数据库的常见问题

l 服务器以前安装过SQL Server 2008，并且安装了Reporting service，再重新安装SQL Server 2008前到添加删除程序中卸载SQL Server 2008的所有程序，将C:\Program Files\Microsoft SQL Server\MSSQL10.SQLEXPRESS\MSSQL \DATA目录下的数据库文件（后缀为.mdf和.LDF）删除，否则安装失败。


5.2安装希望之星的常见问题.72915

5.2 安装希望之星的常见问题

l 第一次安装希望之星程序时会自动生成数据库，如果已经存在数据库则不再安装。如果SQL Server 2008是重新安装的，在安装希望之星程序前需要先手工附加已经存在的数据库，数据库文件默认在D:\hopestar目录下，数据库文件不能删除，否则数据库丢失，数据无法恢复，数据库名为Sunrise。详见附加数据库。


5.3登录仓库常见问题.74126

5.3 登录仓库常见问题

l 登录仓库时提示需要输入用户名和密码，当密码为空时不能登录，需要为操作员设置一个密码；

l 解决方法：打开“管理工具-计算机管理-服务和应用程序-Internet信息服务-网站-默认网站”，右击选择“属性”，选择“目录安全性”页，“身份验证和访问控制”部分选择“编辑”，打开“身份验证方法”窗口，选择“启用匿名访问-浏览-高级-立即查找”，搜索结果中选择“Administrator”，点确定返回“身份验证方法”窗口，密码输入框输入超级用户的密码，再次输入一遍密码。点确定后先后出现两次继承覆盖窗口，全选后确定。

l 安装完仓库程序登录有如下提示，是因为SA用户没有开启，详见开启SA用户。

l 进入仓库有如下两种提示，需要到数据中心模块将身份验证方式改为“SQL身份登录”。出现该问题是因为安装程序在开启sa用户之前，如果先开启sa用户，再安装程序生成数据库就不会出现这个问题。

l 打开仓库报表出现如下错误，需要到数据中心模块将身份验证方式改为“SQL身份登录”，再次登录仓库。

l 打开仓库出现如下错误，解决方法：“开始-运行”，输入cmd回车打开dos窗口，输入“cd C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727”，回车，输入“aspnet_regiis -i”，回车。

l 打开仓库出现如下错误，是因为没有安装装ASPAJAXExtSetup.msi、WebFormDWCLTRT25.msi，安装后重新登录。


5.4ReportingServices异常.80315

5.4 Reporting Services异常

l 报表无法打开，提示“报表服务器无法解密用于访问报表服务器数据库中的敏感数据或加密数据的对称密钥”类似错误；

l 打开“Reporting Service配置-加密密钥”，点删除按钮；

l 输入“http://服务器名/Reports_sqlexpress”，打开如下界面；

l 选择‘HsHotelReports’，打开报表列表选择‘dbhoteldb’，显示如下图所示；

l “连接字符串”录入一下内容，修改相应的服务器名和数据库名。选择“Windows集成安全性”，点“应用”按钮。


5.5附加Sunrise数据库.83880

5.5 附加Sunrise数据库

l 打开“开始-程序-Microsoft SQL Server 2008-SQL Server Management Studio Express”，右击数据库选择附加，打开附加数据库窗口，点“添加”按钮，选择“Sunrise.mdf”文件进行附加。“Sunrise.mdf”文件默认在“D:\hopestar”目录下。

l 注：必须重新安装希望之星程序，否则报表无法使用。


6WindowsXP安装.85753

6 Windows XP安装


6.1安装要求.86247

6.1 安装要求

l 服务器端使用WindowsXP+SP2或以上版本操作系统


6.2服务器端安装.87049

6.2 服务器端安装

l 安装Dotnetfx35.exe

l 打开sql2008安装必备

n 安装“WS-Management v1.1”- “windowsxp-kb936059-v2-x86-chs.exe”

n 安装“WindowsInstaller4_5”-“WindowsXP-KB942288-v3-x86.exe”，并重启电脑

n 安装“Windows PowerShell”-“powershell_setup_x86.msi”

n 注：以上三个程序需按顺序手工安装，不能执行Setup.exe

l 安装SQLEXPRADV_x86_CHS.exe

l 开启数据库SA用户、配置SQL Server网络配置

l 安装仓库程序所需程序

n 注：如果不安装仓库管理模块，不用安装以下程序

n 安装IIS（必须根据系统版本安装对应的IIS）

n 安装ASPAJAXExtSetup.msi

n 安装WebFormDWCLTRT25.msi

l 执行希望之星安装中的Setup.exe

n 自动安装.NET 2.0

n 安装希望之星

u 报表服务器Web服务URL：“http://服务器名：8080/ ReportServer_Sqlexpress”；

u 报表管理器URL：“http://服务器名：8080/ReportS_Sqlexpress”；

u 注：服务器名后需要加“：8080”，与Windows2003不同

n 自动安装消息队列


6.3WindowsXP安装说明.95383

6.3 WindowsXP安装说明

l 以上是WindowsXP系统的安装顺序，粗斜体部分是与Windows2003不同的地方，其它安装请参照Windows2003安装

l WindowsXP系统上服务器端安装只作为自用、演示及测试使用，实际酒店客户服务器端必须使用Windows2003系统，否则后果自负